Jump to content
Sign in to follow this  
wasson65

EasyPopulate 2.4, now with Froogle support!

Recommended Posts

I have been using Easypopulate very effectively for some time. But after installing the Category Description contribution something strange happens. I have suppose 250 item file which I upload to my site, some of the items within this file goes to top level category although appropriate category values are present. If I took one these fault items and prepare a single item file and upload, then this time goes to correct category. I am totally confused???

 

If the category description contrib changed the categories_description table or the products_to_categories table, then easypopulate will need to be modded to handle it.

 

Why one record would work, and more would not, is odd. Sorry I don't have more info. I've got a store with the category description in it, I'll take a look sometime in the next couple days and see if my EP is working. Sorry I can't promise anything more, I'm kinda stacked up at this time.

 

Tim

Share this post


Link to post
Share on other sites

I am using EP with category descriptions on Ian's loaded 4 version and don't have a problem. I haven't tried it with ms1 and loaded 5 yet.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
I think I may have found a problem.

 

catagories are in reverse order

 

It's not a bug, but it's not a feature either. It was a shortcut - it was easier to program it that way. I've got a version of EP that changes this to the top-down order, and also adds product_url. It's getting beta tested now, and will get released soon. The reverse-ish ordering is discussed in the docs, but it's been a thorn in my side since day one, and pretty soon it won't be a thorn any more!

 

Tim

 

Tim: Did you ever release a version that has the categories in proper order? And if not, what would you think about posting that part of the code or at least pointing me in right direction? Thanks for all your work.

 

Sorry for the delay, been busy busy busy. Anyway, I'm scheduled to spend some time on EP this week, hopefully with a release of whatever I'm able to get pulled together. It will include the "category in the right order" fix as well as additional fields for up and download.

 

Tim

 

Hi Tim: Any updates on the category order fix? I read in another post that you were hurting for time, so perhaps you have not had a chance to do an update. Just curious, because I am getting close to turning over a project and would like to have this in there. If you won't get to it for awhile I will probably just use the old version. Thanks again.

Share this post


Link to post
Share on other sites

I began getting the following error after upgrading to php 4.3.1 Is this related with the php.ini or any other configuration?

 

Fatal error: Maximum execution time of 30 seconds exceeded in D:INETPUB484admineasypopulate.php on line 4

Share this post


Link to post
Share on other sites

Easy Populate 2.53 - Default Language : Dutch(4)

 

File uploaded.

Temporary filename: C:DOCUME~1CeasarLOCALS~1TempphpCA.tmp

User filename: EP2003Mar27-2008.txt

Size: 26342

| BB230 | bbholland. | Beets Brot | Alexander | | Beets Brot | Alexander | | 16.81 | 1.00 | | 8-3-2003 1 | 5 | | CD | Beets Brot | | | | | | BTW | Active Updated

1054 - Onbekende kolom 'products_mimage' in field list

 

UPDATE products SET products_price="16.81" ,products_image="bbholland.jpg" ,products_mimage="" ,products_bimage="" ,products_subimage1="" ,products_bsubimage1="" ,products_subimage2="" ,products_bsubimage2="" ,products_subimage3="" ,products_bsubimage3="" ,products_weight="1.00" ,products_tax_class_id="2" ,products_date_available= CURRENT_TIMESTAMP ,products_date_added= "8-3-2003 17:15" ,products_last_modified=CURRENT_TIMESTAMP ,products_quantity="5" ,manufacturers_id=NULL , products_status=1 WHERE (products_id = "1")

 

[TEP STOP]

 

This looks real strange. What could be the problem ?

Share this post


Link to post
Share on other sites

'comment these lines if you are running the image mods'

 

Not all of them where commented. Now it works :o

Share this post


Link to post
Share on other sites

Sorted this myself ;)

 

WOuld still like to see some kind of crossover with the attribute mod so that downloadable-only products can be added without a two stage process :twisted:


Apples...why did they have to be apples?

Share this post


Link to post
Share on other sites

File uploaded.

Temporary filename: /tmp/phpT1w21x

User filename: 88.txt

Size: 7756

| 45099 | | 00-01 | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | B&M ShortS | Engine/Tra | | | | | | | | | 45099 | | 00-01 | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | B&M ShortS | Engine/Tra | | | | | | | | | 45091 | | 93-98 Twin | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | B&M ShortS | Engine/Tra | | | | | | | | | 80743 | | | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | B&M Shiftk | | | | | | | | | | 80744 | | | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | B&M Shiftk | | | | | | | | | | 80745 | | | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | B&M Shiftk | | | | | | | | | | 80746 | | | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | B&M Shiftk | | | | | | | | | | 80537 | | | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | B&M Shiftk | | | | | | | | | | 80738 | | | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | B&M Shiftk | | | | | | | | | | 80739 | | | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | B&M Shiftk | | | | | | | | | | 80743 | | | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | B&M Shiftk | | | | | | | | | | 54687 | hr.gif | 90-98 Non | | | 275 | 0 | 3/25/2003 | 3/24/2003 | | H&R | Suspension | Springs | Toyota | Celica | H&R | | | --none-- | Active Updated

1054 - Unknown column 'products_mimage' in 'field list'

 

UPDATE products SET products_price="275" ,products_image="" ,products_mimage="" ,products_bimage="" ,products_subimage1="" ,products_bsubimage1="" ,products_subimage2="" ,products_bsubimage2="" ,products_subimage3="" ,products_bsubimage3="" ,products_weight="0" ,products_tax_class_id="" ,products_date_available= "3/25/2003 3:05" ,products_date_added= "3/24/2003 3:05" ,products_last_modified=CURRENT_TIMESTAMP ,products_quantity="1000" ,manufacturers_id=16 , products_status=1 WHERE (products_id = "67")

 

[TEP STOP]

 

 

 

 

 

 

 

 

thats the error i get when i try to upload my products.

Share this post


Link to post
Share on other sites

Do you have the loaded 5 from Ian or any of the additional images contributions installed?


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

i ahve the same prob as Quickenterprises.

running OS2.2 MS1 , easy populate 2.53

 

Clean install of OScommerce, only mod is the image proportion code change.

 

here's my error

File uploaded.  

Temporary filename: C:DOCUME~1ADMINI~1LOCALS~1Tempphp4612.tmp

User filename: EP2003Apr02-1301.txt

Size: 16209

| 10152 | | 128M 144-P | 128M 144-P | www.transc | | | | | | | $78.93 | | | | | Transcend | Memory | | | | | | | 1 | Active Updated

1054 - Unknown column 'products_mimage' in 'field list'

 

UPDATE products SET products_price="$78.93" ,products_image="" ,products_mimage="" ,products_bimage="" ,products_subimage1="" ,products_bsubimage1="" ,products_subimage2="" ,products_bsubimage2="" ,products_subimage3="" ,products_bsubimage3="" ,products_weight="" ,products_tax_class_id="2" ,products_date_available= CURRENT_TIMESTAMP ,products_date_added= CURRENT_TIMESTAMP ,products_last_modified=CURRENT_TIMESTAMP ,products_quantity="1000" ,manufacturers_id=23 , products_status=1 WHERE (products_id = "249")

 

Thanx for any fix ideas :)

Share this post


Link to post
Share on other sites

here's a snippet from my txt file in excell if it helps.

 

v_products_model v_products_image v_products_name_1 v_products_description_1 v_products_url_1 v_products_name_2 v_products_description_2 v_products_url_2 v_products_name_3 v_products_description_3 v_products_url_3 v_products_price v_products_weight v_date_avail v_date_added v_products_quantity v_manufacturers_name v_categories_name_1 v_categories_name_2 v_categories_name_3 v_categories_name_4 v_categories_name_5 v_categories_name_6 v_categories_name_7 v_tax_class_title v_status EOREOR

10152  128M 144-Pin PC-100 SD, 16Mx8 CL2, 8 chips 128M 144-Pin PC-100 SD, 16Mx8 CL2, 8 chips www.transcendusa.com       $78.93     Transcend Memory       1 Active EOREOR

10153  128M 144-Pin PC-133 SD, 16Mx8 CL3, 8 chips 128M 144-Pin PC-133 SD, 16Mx8 CL3, 8 chips www.transcendusa.com       $82.18     Transcend Memory       1 Active EOREOR

10154  128M 144-Pin PC-133 SD, CL3, 16Mx16, 4 chips 128M 144-Pin PC-133 SD, CL3, 16Mx16, 4 chips www.transcendusa.com       $65.20     Transcend Memory       1 Active EOREOR

 

 

thanx heaps, this will save me hours or work when its working :)

Share this post


Link to post
Share on other sites

There's two big chunks of code that you have to ensure are commented out - search for the string "'products_mimage" and ensure that any code around it (should be obvious) is commented out :D


Apples...why did they have to be apples?

Share this post


Link to post
Share on other sites

Thank you your help fast freddy

I did as you suggested and discovered that i had to comment out these lines 1569 - 1577

 

// $query .=

   // '" ,products_mimage="'.$v_products_mimage.

   // '" ,products_bimage="'.$v_products_bimage.

   // '" ,products_subimage1="'.$v_products_subimage1.

   // '" ,products_bsubimage1="'.$v_products_bsubimage1.

   // '" ,products_subimage2="'.$v_products_subimage2.

   // '" ,products_bsubimage2="'.$v_products_bsubimage2.

   // '" ,products_subimage3="'.$v_products_subimage3.

   // '" ,products_bsubimage3="'.$v_products_bsubimage3;

 

Then i had a another error but i removed the "$" from my txt file on the prices and all was good :)

 

Once again, many thanx

Many thanx to the contribution author as well

Share this post


Link to post
Share on other sites
Thank you your help fast freddy

I did as you suggested and discovered that i had to comment out these lines 1569 - 1577  

 

// $query .=

   // '" ,products_mimage="'.$v_products_mimage.

   // '" ,products_bimage="'.$v_products_bimage.

   // '" ,products_subimage1="'.$v_products_subimage1.

   // '" ,products_bsubimage1="'.$v_products_bsubimage1.

   // '" ,products_subimage2="'.$v_products_subimage2.

   // '" ,products_bsubimage2="'.$v_products_bsubimage2.

   // '" ,products_subimage3="'.$v_products_subimage3.

   // '" ,products_bsubimage3="'.$v_products_bsubimage3;

 

Then i had a another error but i removed the "$" from my txt file on the prices and all was good :)

 

Once again, many thanx

Many thanx to the contribution author as well

 

worked.. thanks

Share this post


Link to post
Share on other sites

Hi all,

 

I'm quite near to make EP work. just few things:

 

Now I get this error:

File uploaded.  

Temporary filename: /tmp/phpPEF6Rr

User filename: EP1.xls

Size: 3828

| CFP48.jpg | Necklace | Nice "Y | | | | | Necklace | Nice "Y | | | | | 23 | 4 | | 21/11/2002 | 99 | | 18 Kt. Gol | Necklaces | | | 0 | | | | | | Taxable Go | Active | Updated

| GIFT10 | manufactur | Gift Vouch | e-Gift Vou | | | | | Gift Vouch | e-Gift Vou | | | | | 10 | 0 | 0000-00-00 | 0000-00-00 | 1000 | | Gift Vouch | | | | 0 | | | | | | None | Inactive Updated

| qvc bracel | 9K. Diamon | Nice yello | | | | | | | | | | | 40 | 5,4 | | 29/12/2002 | 98 | | 9 Kt. Gold | | | | 0 | | | | | | Taxable Go | Active | !New Product!

1136 - Column count doesn't match value count at row 1

 

INSERT INTO products ( products_image, products_mimage, products_bimage, #products_subimage1, #products_bsubimage1, #products_subimage2, #products_bsubimage2, #products_subimage3, #products_bsubimage3, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, products_stones, products_color, products_carat, manufacturers_id) VALUES ( '9K. Diamond cut Bracelet', 'qvc bracelet.jpg', '5,4', '1', CURRENT_TIMESTAMP, "98", "29/12/2002 17.54", '', '', '1000', '11')  

 

[TEP STOP]

 

In fact I think all this image mods are causing the problem. I use a loaded version ( don't remember which one ) and I have just 3 images to load ( normal, medium and big )

any idea on how to change easypopulate.php to match my needs ?

 

Thanks.

Since no DB is equal to another one, wouldn't it be possible to specify in the script ( or in a joint script ) which fields in which table/s are to be considered for downloading ?

Wouldn't it be really useful for anyone using OSC ?

 

Thanks

Franco


Outside links in signatures are not allowed!

Share this post


Link to post
Share on other sites

tomcat i dont know how to help you but i know that every time I upload a database i save it in .txt format (from excel).

 

i have a problem.when i grab the database form the server i want to add a field, and that is product_id.because my first product ID is 57, when i upload a database it creates duplicate products, because the first product in excel is with ID 1 and my first product from the database beggins with ID 57.

 

please tell me where to edit the source code.

thanks


Serban Ghita - my blog

Share this post


Link to post
Share on other sites

Hi Zamo...

 

Don't really know about the duplicate problem...

One thing is for sure: you can't create new fields in the Excel file without creating the field itself in the table products fisrt.

 

Try to clear all your data in the DB with phpmyadmin and then upload the file again, that should work

 

hope this helps


Outside links in signatures are not allowed!

Share this post


Link to post
Share on other sites

:roll:

well i know that after a clean install all works fine, but i allready started the shop and i have a lot of comment made by users on products.if i change the id of the product than a certain comment would appear at another product.

i wonder if i insert a column named 'product_id' and i set the product id there, what code should i insert in easypopulate.php to work? :oops:

 

i dont understand what thunderbird said, i`ll try to read again the whole thread.

 

 

zam


Serban Ghita - my blog

Share this post


Link to post
Share on other sites

wasson65/Tim,

 

Any chance you could enhance this MOD to include adding Attributes automatically for products?

 

:D


Apples...why did they have to be apples?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×