Jump to content
Sign in to follow this  
wasson65

EasyPopulate 2.4, now with Froogle support!

Recommended Posts

Hello All-

 

I've done a search on the boards and haven't seen an answer, so here goes...

 

I'm using Easy Populate 2.41beta7 on a new install of OSC. It seems to work great!! When I visit my admin page, all categories, sub-categories and items are present. I am very impressed at the ease of use here - obviously a lot of work has gone into this!

 

However, I take a look at my online catalog, and none of the items are showing up. Hmmmm... curious? In fact - the demo store items are still there - even though I've deleted them all in my admin pages?

 

Now, I'm aware this could be something mind-numbingly simple - as I've been awake and working on this for more hours than I can currently count. :?

 

Does anyone know why this would occur? The catalog can be viewed at www.apcdesigns.com/catalog/default.php This is only a testing server - no sense in trying to accomplish something until I learn more about this program.

 

Thanks in advance

 

-Adam

Share this post


Link to post
Share on other sites

I am using the latest version of EP and have a problem:

 

After uploading I get the English files without any problem going, the German ones are not there.

 

I have tried all day, made a small file with 5 items, add the language files and nothing, German won't appear.

 

Any idea, its me stupid or is this a bug?

 

I have set English as default and the files are sorted that way, first English, then German. When I download the file with EP from a recent back-up I get the German files, but getting them up seems impossible......

 

Helpless

 

rainbow007


Besser heute als morgen......

Share this post


Link to post
Share on other sites

Hello All-

 

I have found the pesky problem - seems there was a faulty user installed(me) :oops:

 

I had two databases going and that really fouled things up. I cleaned everything up and reloaded using Easy Populate and guess what?

 

It worked perfectly! Thanks for this unbelievable mod - looking forward to more fun with OSC - Carry on!

 

-Adam

Share this post


Link to post
Share on other sites
Hello,

I have the latest version of EP installed.  

 

Froogle sent me this regarding my feed:

 

 

 

* Remove the quotation marks in the Name and Description fields

 

The categories in the data feed need to be separated by a ">" plus a

space on each side, thusly " > "

 

An example of a correct category field is:

 

Home & Garden > Kitchen > Appliances

 

 

Is there anyway for me to get the categories as they have requested?

 

Also, I have tried everything to get rid of quotes in my name and description field and I can't. I followed the directions to the letter.

 

Hmm, I thought I'd laid the ghosts to rest with respect to froogle, but it appears my confidence was premature....alas...

 

Can you send me your file? I'd like to take a look at it. We might need to do some stripping of quotes from the descriptions.

 

wasson65@nc.rr.com

 

thanks,

 

Tim

Share this post


Link to post
Share on other sites
I already modified the code to upload and download products with the bimage, I just can't get the froogle file to have the bimage when it downloads. I've tried changing the froogle variables to bimage, but this just gives a blank. My photos are setup to show the thumb unless you click on the "click to enlarge" this is where the java pop-up comes in.

 

Look in easypopulate.php where it creates the filelayout array. Find in the code

switch( $dltype ){

and a few lines below that:

case 'froogle':

and below that:

$filelayout_sql = "SELECT

p.products_id as v_products_id,

p.products_model as v_products_model,

p.products_image as v_products_image,

p.products_price as v_products_price,

p.products_weight as v_products_weight,

p.products_date_added as v_date_avail,

p.products_tax_class_id as v_tax_class_id,

p.products_quantity as v_products_quantity,

p.manufacturers_id as v_manufacturers_id,

subc.categories_id as v_categories_id

FROM

products as p,

categories as subc,

products_to_categories as ptoc

WHERE

p.products_id = ptoc.products_id AND

ptoc.categories_id = subc.categories_id

";

break;

Add the bimage field to the query.

 

The poster above did the bimage query and filelayout changes to the "full" section of the filelayout, you'll need to mimic those changes in the "froogle" section.

Share this post


Link to post
Share on other sites
I am using the latest version of EP and have a problem:

 

After uploading I get the English files without any problem going, the German ones are not there.

 

I have tried all day, made a small file with 5 items, add the language files and nothing, German won't appear.  

 

Any idea, its me stupid or is this a bug?

 

I have set English as default and the files are sorted that way, first English, then German. When I download the file with EP from a recent back-up I get the German files, but getting them up seems impossible......

 

Helpless

 

rainbow007

 

OK, a few questions to clarify the problem and narrow down the issue:

1. if you have a product with eng and german descriptions and you do a dl with EP, does it include the german descriptions?

2. If you re-upload the file you just downloaded without editing it at all, and you check the descriptions, do the eng and german descriptions still show up correctly?

3. If you download and change the english and german descriptions, then upload, does it change both, one but not the other, or neither?

 

Tim

Share this post


Link to post
Share on other sites

Tim,

 

thanks for your answer.

 

If I download both are there, the German and the English descriptions and when I upload the same file without changing anything, the German descriptions and categories are gone.

 

If I change anything, it will be only changed in the English part.

 

I am using the snapshot from 1 Nov 2002, and the header looks like this:

 

v_products_model v_products_image v_products_name_1 v_products_description_1 v_products_name_2 v_products_description_2 v_products_price v_products_weight v_date_avail v_date_added v_products_quantity v_manufacturers_name v_categories_name_1 v_categories_name_2 v_categories_name_3 v_categories_name_4 v_categories_name_5 v_categories_name_6 v_categories_name_7 v_tax_class_title v_status EOREOR

 

Could you please have a look, perhaps there is something wrong, but I couldn't find it yet. I have tried to change the product name and description numbers from 1,2 to 2,1 which resulted that I had the English descriptions in the German part, but no German in the English.

 

Thanks in advance

 

rainbow007


Besser heute als morgen......

Share this post


Link to post
Share on other sites
Tim,

 

thanks for your answer.

 

If I download both are there, the German and the English descriptions and when I upload the same file without changing anything, the German descriptions and categories are gone.

 

If I change anything, it will be only changed in the English part.

 

I am using the snapshot from 1 Nov 2002, and the header looks like this:

 

v_products_model v_products_image v_products_name_1 v_products_description_1 v_products_name_2 v_products_description_2 v_products_price v_products_weight v_date_avail v_date_added v_products_quantity v_manufacturers_name v_categories_name_1 v_categories_name_2 v_categories_name_3 v_categories_name_4 v_categories_name_5 v_categories_name_6 v_categories_name_7 v_tax_class_title v_status EOREOR

 

Could you please have a look, perhaps there is something wrong, but I couldn't find it yet. I have tried to change the product name and description numbers from 1,2 to 2,1 which resulted that I had the English descriptions in the German part, but no German in the English.

 

Thanks in advance

 

rainbow007

 

The fact that uploading the unedited file removes the german descriptions is helpful... I'll try to get this troubleshot this weekend.

 

Tim

Share this post


Link to post
Share on other sites

This is a great contrib. Thank you :)

I have it working well..

I would like to be able to pull customer information from the DB, but have no idea where to start.

 

I have copied the priceqty function from easypopulate.php and renamed it to customer. I added a link on the admin page which pulls this information. It works well.

 

However, I cannot figure out how to pull customer information from the databse...

 

  case 'customer':

 $iii = 0;

 // uncomment the customer_price and customer_group to support multi-price per product contrib

 $filelayout = array(

	 'v_products_model'  => $iii++,

	 'v_products_price'  => $iii++,

	 'v_products_quantity'  => $iii++,

   );

 $filelayout_sql = "SELECT

	 p.products_id as v_products_id,

	 p.products_model as v_products_model,

	 p.products_price as v_products_price,

	 p.products_quantity as v_products_quantity

	 FROM

	 products as p

	 ";



 break;

 

What do I need to change to pull customer information?

 

Much appreciated.

 

Tracy


If life begins at 40..... What ends at 39????

Share this post


Link to post
Share on other sites

iam using june snapshot, i tried 2.41 beta 7 but it did'nt work so i tried beta 6 that too did'nt work, in fact none of the 2.4 snapshot worked, but 2.3 worked, but i had problems with it, its updating the products and categories wrongly. the products i have specfied in one category is getting linked to another category. so thats why i thought i'll upgrade to newer snapshot, but its not working

 

any help will be greatly appreciated

Share this post


Link to post
Share on other sites

iam using june snapshot, i tried 2.41 beta 7 but it did'nt work so i tried beta 6 that too did'nt work, in fact none of the 2.4 snapshot worked, but 2.3 worked, but i had problems with it, its updating the products and categories wrongly. the products i have specfied in one category is getting linked to another category. so thats why i thought i'll upgrade to newer snapshot, but its not working

 

any help will be greatly appreciated

Share this post


Link to post
Share on other sites

The instructions for adding additional fields make for a relatively easy modification of EP.

 

What I would LOVE to see would be an EP Admin function that would allow the user to 1) add additional fields into the database and 2) add all necessary calls into EP for import.

 

Thanks for the great contribution.

Share this post


Link to post
Share on other sites

Regarnig the following info on Easypopulate documentation;

 

EasyPo ulate requires the use of the  roduct_model field (model number).  It won't work without the

model number.  The model numbers you assign must be unique, i.e. you can't give all your  roducts

a  roduct_model of "test".

 

I understand from this statement that the product model field will be used as an unique identifier for each record. I am going to build an online bookstore with over 10000+ items. Do I have to set the product_model field unique, let's say "autonumber" fnction in access, I would appreciate if someone clarifies this for me.

Cheers

Ugur

Share this post


Link to post
Share on other sites
Regarnig the following info on Easypopulate documentation;

 

EasyPo ulate requires the use of the  roduct_model field (model number).  It won't work without the

model number.  The model numbers you assign must be unique, i.e. you can't give all your  roducts

a  roduct_model of "test".

 

I understand from this statement that the product model field will be used as an unique identifier for each record. I am going to build an online bookstore with over 10000+ items. Do I have to set the product_model field unique, let's say "autonumber" fnction in access, I would appreciate if someone clarifies this for me.

Cheers

Ugur

 

EP needs a way to know if the record you are uploading is an update of an existing product or a totally new product. That's what it uses the product_model for. EP doesn't care what it is, just as long as it's unique for each item.

 

So yes, "autonumber" should work in access.

 

Tim

Share this post


Link to post
Share on other sites
EP needs a way to know if the record you are uploading is an update of an existing product or a totally new product. That's what it uses the product_model for. EP doesn't care what it is, just as long as it's unique for each item.  

 

Just one more question. Suppose I want to update the prices in the future. Is it enough to use the model value and updtaed price and leave the other fields blank for a bulk update. Thanks in advance

Ugur

Share this post


Link to post
Share on other sites

EP needs a way to know if the record you are uploading is an update of an existing product or a totally new product. That's what it uses the product_model for. EP doesn't care what it is, just as long as it's unique for each item.  

 

Just one more question. Suppose I want to update the prices in the future. Is it enough to use the model value and updtaed price and leave the other fields blank for a bulk update. Thanks in advance

Ugur

 

If you include a field, you must provide data. Otherwise EP thinks you're updating your time to have a blank description. You should experiment with the other types of downloads from EP - there is one that pulls just product_model and a couple other fields. Test it first - As far as I know it works, but it would be good to do a test with just one product first to make sure it works and that you know how it works.

 

Tim

Share this post


Link to post
Share on other sites

I think I may have found a problem.

 

catagories are in reverse order

 

Example:

 

Easy Populate output for catagoy:

Signature Series > Pearl > Snares

 

It should be:

Snares > Pearl > Signature Series


<>< <>< <>< <>< <>< <><

<><

<>< Tony Pros - tony@funksmith.com

<><

<>< <>< <>< <>< <>< <><

 

I've learned that if someone says something unkind about me, I must live so that no one will believe it.

Share this post


Link to post
Share on other sites
I think I may have found a problem.  

 

catagories are in reverse order

 

Example:  

 

Easy Populate output for catagoy:

Signature Series > Pearl > Snares

 

It should be:

Snares > Pearl > Signature Series

 

But if the category order gets changed now, those of us already using it will have to rearrange all of our categories. As long as you understand the way it works, it shouldn't be a problem.

 

Snares is the main category, but it is Category 3 field in the file for the products that go 3 deep.

 

Pearl is the second category, Category 2 in any case.

 

Signature series is the 3rd deep category, and it is in Category 1 field in the file.

 

At least that is how I am using it and it works for me.

 

Debbie


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

Sorry, I meant to say, just follow how it is in the first EP file that you download of your current products to see how to set up an import file :)


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
I think I may have found a problem.

 

catagories are in reverse order

 

Example:

 

Easy Populate output for catagoy:

Signature Series > Pearl > Snares

 

It should be:

Snares > Pearl > Signature Series

 

It's not a bug, but it's not a feature either. It was a shortcut - it was easier to program it that way. I've got a version of EP that changes this to the top-down order, and also adds product_url. It's getting beta tested now, and will get released soon. The reverse-ish ordering is discussed in the docs, but it's been a thorn in my side since day one, and pretty soon it won't be a thorn any more!

 

Tim

Share this post


Link to post
Share on other sites

Tim...Any chance that a delete function is on the way, to remove products from the database ??

 

Thanks..

 

Jason

Share this post


Link to post
Share on other sites

Thanks for posting this, I was about to attempt adding fields for mo-pics, now I'll wait for your next release :)

 

If you need help with testing, etc, I have some sites that aren't online yet that I am using to test various setups etc.

 

Debbie


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

Is there a way in EP to strip the quotes from the description and name fields?

 

Just point me in the direction of what I need to change or modify.

 

Thank You

 

PS: This is a great contribution. :D

Share this post


Link to post
Share on other sites
Is there a way in EP to strip the quotes from the description and name fields?

 

Just point me in the direction of what I need to change or modify.

 

Thank You

 

PS: This is a great contribution. :D

 

What's your email? I've got a doctored up version of EP that will have a config var for this.

 

I'll send it and you can test it out.

 

Tim

wasson65@nc.rr.com

Share this post


Link to post
Share on other sites

I don't yet have the new version. I modded the old one to handle extra database entries and strange things in my DB. It was relatively straight forward for a nonprogrammer like me to do it. I can't wait to upgrade to Froogle support.

 

BTW, Tim you've done more than enough with this great add-on. It is really superb. Some mods are less than professional, but this is really a top notch addition and you really stand behind it.

 

Thanks,

 

Dave :bigups:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×