Jump to content
Sign in to follow this  
stankovski

[contribution] "Live Customer Support"

Recommended Posts

Sorry, I couldn't help with the questions to my contrib, since I was away. I will try to update the contribution and get rid of all the bugs.

Thanks to everybody for debugging.

 

Denis

 

Thanks denis

 

I have it working now but I cant get the ICQ part of it working fully although it does page me . I cant get the images to display and the ones I did see in ICQ did not look like yours can ICQ be skinned and have better graphics?? I like yours they look slick BUT ICQ and those stupid flowers are ...well....errr...girlie!! <grin>

Share this post


Link to post
Share on other sites

It worked like a charm for me!

 

8)

 

It is nice too that it isn't totally integrated into OS Commerce. Other programs can then use it too.

 

-Dave

 

:wink:

Share this post


Link to post
Share on other sites
It worked like a charm for me!

 

8)

 

It is nice too that it isn't totally integrated into OS Commerce. Other programs can then use it too.

 

-Dave

 

:wink:

 

have you got a URL for us to see it in action as it were??

 

Did you manage to get it working without edits??

Share this post


Link to post
Share on other sites

There are still a fw fixes. If you follow this thread and do the things people have done, you should be okay. I am having trouble with the JS pop-up, but I think that can be rectified.

 

However, it did work when I visited the links directly and used it outside of OS Commerce. There is one more thing that I have had to do that I haven't seen here and I've noticed this issue with other things. Before it queries the new chat DB that you must create, you should do the following:

 

tep_db_close();

 

then once your DB queries are complete...

 

tep_db_connect();

 

I did this is Status.php which is called by the chat box in the program. I have yet to see if more of those need to be added.

 

Anytime you query another SQL database, OSCommerce wants you to do those things otherwise it can get confused. It's no big deal if it happens though. You'll just get an error or it won't finish drawing all the HTML.

 

 

-Dave

Share this post


Link to post
Share on other sites

Okay... I have everything working as it written. However, I have noticed that there is a logic error even on Dennis's site. When offline it is supposed to say, "Click here to leave a message." Instead it still tries to connect to a chat. Has anyone fixed this problem? Dennis's own site http://www.harmoniouslifestyles.com/catalog/ does have a nice indicator that works and gets around the problem a bit. I'd also be interested in how that works since it isn't part of the distributed module.

 

 

-Dave

 

:wink:

Share this post


Link to post
Share on other sites

Everything is cool. Just be sure to logout of the admin window. Otherwise it still thinks you're online and funny things happen.

 

-Dave

 

:stupid:

Share this post


Link to post
Share on other sites
Okay... I have everything working as it written. However, I have noticed that there is a logic error even on Dennis's site. When offline it is supposed to say, "Click here to leave a message." Instead it still tries to connect to a chat. Has anyone fixed this problem? Dennis's own site http://www.harmoniouslifestyles.com/catalog/ does have a nice indicator that works and gets around the problem a bit. I'd also be interested in how that works since it isn't part of the distributed module.

 

 

-Dave

 

:wink:

 

AH ok so its not just me. I have spoken to dennis when he first released this contrib and he does indeed have what I need as the live chat on the site I am working on will be off line more than it is online but I thought a much better way of getting people to leave a message.

 

so dennis can you confirm how you get this part to work. I will email denis now anyway to see if we can find out how he does it.

 

I know its to do with ICQ snd he has mentioned using img=7 instead of the flowers but I am not sure if thats in the code or in ICQ in fact I am quite confused with some of your posts as I am PHP dyxlexic if you know what I mean. <smile>

Share this post


Link to post
Share on other sites

Hi,

 

All right, about the status indicator. Since I use ICQ I use their status indicator which is NOT tied any way to the chat. In other words I can not modify PHP to check whether this indicator shows ON or OFF.

To use this method you can (as I did) make a box where you'll have a words like: this is a chat and than an image from ICQ site:

<img src="https://web.icq.com/whitepages/online?icq=162729639&img=7" border="0">

where icq=xxxxxxxxxx is the ICQ number.

 

By the way, there is a way to leave messages when you are offline. To do that you have to remeber to click "Offline" and "Online" in the admin window. Later on, you can just check from PHP:

SELECT status FROM `chat_user` WHERE id=1

You'll have to do some PHP modifications though.

 

However, now I'm doing an updated chat and hopefuly will post it noting all the remarks from this forum.

 

Denis


Denis Stankovski

----------------------

http://www.harmoniouslifestyles.com

Share this post


Link to post
Share on other sites

Hi, Denis;

 

I just went to your site to try the Live Support interface from a customer's perspective, as I am looking at adding your contribution to my site.

 

Just an observation, perhaps you're already aware of and working on a fix:

 

The graphic makes it appear as if someone is available (ie: no 'Offline' indication), I clicked to open it, signed in with no problem, got the 'Waiting for operator' screen and then waited through about 15 refreshes with no change before I closed it down. Are you working on something that will automagically go to an email option if an operator doesn't respond after, say 4-5 refreshes?


... if you want to REALLY see something that doesn't set up right out of the box without some tweaking,

try being a Foster Parent!

Share this post


Link to post
Share on other sites

just installed the latest verison and i receive the following error in the admin panel when i click on live support in tools:

 

1146 - Table 'fwdepot.TABLE_LS_VARIABLES' doesn't exist

select v.color, a.ls_variable_option from TABLE_LS_VARIABLES v, TABLE_LS_ATTRIBUTES a where v.color = a.ls_attributes_id

 

in the sql file included with the contribution i see it creates 3 tables, the above not being one of them:

 

# Table structure for table `ls_conversations`

#

 

CREATE TABLE ls_conversations (

id int(11) NOT NULL auto_increment,

guest varchar(255) NOT NULL default '',

tech varchar(255) NOT NULL default '',

session_id varchar(255) NOT NULL default '',

message varchar(255) NOT NULL default '',

tech_reply tinyint(1) NOT NULL default '0',

PRIMARY KEY (id)

) TYPE=MyISAM;

 

#

# Dumping data for table `ls_conversations`

#

 

# --------------------------------------------------------

 

#

# Table structure for table `ls_techs`

#

 

CREATE TABLE ls_techs (

tech_id int(11) NOT NULL auto_increment,

support_tech varchar(20) NOT NULL default '',

password varchar(25) NOT NULL default '',

support_group varchar(255) NOT NULL default '',

status varchar(10) default NULL,

helping varchar(255) NOT NULL default '',

PRIMARY KEY (tech_id),

UNIQUE KEY yech_id (tech_id)

) TYPE=MyISAM;

 

#

# Dumping data for table `ls_techs`

#

 

INSERT INTO ls_techs VALUES (1, 'Sales', '', 'Sales', 'no', '');

 

CREATE TABLE ls_status (

id int(255) NOT NULL auto_increment,

session_id varchar(255) NOT NULL default '',

status tinyint(1) NOT NULL default '1',

PRIMARY KEY (id)

) TYPE=MyISAM;


Reading is beneficial - Searching is enlightening

find answers at wiki.oscommerce.com/top

Share this post


Link to post
Share on other sites

Regarding waiting. I think that that's a good idea of sending people to leave email message after 5 reloads, I never thought of that... I'll try to work on that.

 

About Admin and Tables. Since I deceided to change the logic and make installation easier, now "Chat Admin" is not connected to "OsCommerce Admin". So to access it you have to either open it manualy from chat2.0/admin or link it to osC manually.

 

Now Important part!!!

Being an empty headed dummy I am, I forgot to include one more instruction for installation!!!

After you unzip and install everything go to file: chat2.0/login/login_page.html and somewhere on the line 69 where it says <!-- Enter ICQ Number Here --> change value of

<input type="hidden" name="to" value="xxxxxxx">

to what your ICQ number is.

 

Please make a note of that!!!


Denis Stankovski

----------------------

http://www.harmoniouslifestyles.com

Share this post


Link to post
Share on other sites
Regarding waiting. I think that that's a good idea of sending people to leave email message after 5 reloads, I never thought of that... I'll try to work on that.

 

Thats superb idea as I said via the Chat Dennis.

 

To those of you thinking of installing go ahead its a massive improvement on the previous version and that was good anyway.

 

I think this has a big potential so perhaps we could get some clever person to help Denis out with fixes maybe?? Two heads better than one etc......no good me trying I am PHP challenged as they say...

 

I can test though but once again a really really useful contrib that allows external paging to notify operator BUT does not require an external applet to be installed which most people find off putting.

 

When denis has finally solved the online and offline problems this will be one son of a mother that has massive uses outside of OS etc if people wish to set up a secure chat between a few people. I am assuming you can have more than one person logged in at the same time I have not got round to testing that part yet :)

 

Great work Denis Thanks

Share this post


Link to post
Share on other sites

Thanks Andy, nice to be praised once in a while (doesn't happen too often with my wife :))

I've found a way to check ICQ status through XML. Hurray!!!

(http://magik.dk/services/icq/xml/?uin=162729639)

This would allow us to have online and offline images.

The only problem is that I'm not too good in XML decoding so if anyone could have helped me, it would have been greatly appreciated.

 

Any way, at this time, I'm going to start reading PHP manuals.

 

Denis


Denis Stankovski

----------------------

http://www.harmoniouslifestyles.com

Share this post


Link to post
Share on other sites

Dennis

 

I have everthing installed and ready to go however i get the following error:

 

Warning: Failed opening 'configure.php' for inclusion (include_path='') in /home/stsadmin/public_html/new/chat/main/chat.php on line 13

Could not select database

 

now this is weird because my database is setup and working...( i loaded the tables into my catalog sql.)

 

any ideas??

Share this post


Link to post
Share on other sites
Dennis

 

I have everthing installed and ready to go however i get the following error:

 

Warning: Failed opening 'configure.php' for inclusion (include_path='') in /home/stsadmin/public_html/new/chat/main/chat.php on line 13

Could not select database

 

now this is weird because my database is setup and working...( i loaded the tables into my catalog sql.)

 

any ideas??

 

Hi,

 

Which file are you opening when you get that message? Make sure that there is chat2.0/main/configure.php file you refer to and that you have it modified.


Denis Stankovski

----------------------

http://www.harmoniouslifestyles.com

Share this post


Link to post
Share on other sites
Dennis

 

I have everthing installed and ready to go however i get the following error:

 

Warning: Failed opening 'configure.php' for inclusion (include_path='') in /home/stsadmin/public_html/new/chat/main/chat.php on line 13

Could not select database

 

now this is weird because my database is setup and working...( i loaded the tables into my catalog sql.)

 

any ideas??

 

Hi,

 

Which file are you opening when you get that message? Make sure that there is chat2.0/main/configure.php file you refer to and that you have it modified.

 

HAve you got it working yet Steve??

 

Dennis have you manged to solve the on line of line leave a mesage yet. I have been suffereing with a major problem with shipping but I have now fixed this and am about to re-install this new mod. But desperatly need leave a message even above the live chat which will be used dporadically but will be used more later when he gets broadband in the shop!.

Share this post


Link to post
Share on other sites

I've just uploaded a fix for Chat 2.0. It fixes the problems with scrolling and most important allows users to leave messages if the operator is offline.

Try it out at http://www.oscommerce.com/community/contributions,872

Please do not forget that if you have an older version installed, it's better to update ALL files.

 

Denis


Denis Stankovski

----------------------

http://www.harmoniouslifestyles.com

Share this post


Link to post
Share on other sites

Denis,

 

This is looking good, but I'm having some trouble getting started!

 

The most recent contribution didn't have chat.sql, so I got it out of a previous installation. Is there a more recent one that I should be using?

 

As it is, I can get onto the admin page and change my info, but not log in. Also, users don't see that I am online. If I try to manually enter chat2.0/index.php I get this error:

Warning: Failed opening 'configure.php' for inclusion (include_path='') in /home/dzi/public_html/stage/chat2.0/main/chat.php on line 13

Could not select database

 

If I change line 13 to an absolute path, I simply get a Query Failed error.

 

Any ideas?

 

Thanks,

 

Greg

Share this post


Link to post
Share on other sites

Hi Greg,

 

No the SQL is the same. Thanks for the comments by the way. I've uploaded a fixed one just now. Do not forget to update column_right.php.

 

About Online/Offline the ICQ has some problems today, so everyone is shown as Offline. But that should be fixed soon.


Denis Stankovski

----------------------

http://www.harmoniouslifestyles.com

Share this post


Link to post
Share on other sites

Well, then, I look forward to seeing it in action soon!

 

Thanks again for the great contribution! You should defintitely release this to the rest of the world.

 

We're considering adding it to our recent Support System, which noiw includes Support Tickets, Announcements, and FAQ. Will keep you posted.

 

Thanks,

 

Greg

Share this post


Link to post
Share on other sites

I can?t Log In & Log out because this options not ready in admin page.

 

Please, help me.

 

:(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×