Jump to content
Sign in to follow this  
webtrek

PayPal sudden Fatal Error, need advice

Recommended Posts

My PayPal gateway works great and has for several years. I got the follow error in the Admin panel when acessing PayPal IPN. This is a sudden error that is new to me. I looked at line 27 and didn't see the problem but I have a beginner understanding of PHP syntax.

 

Nothing was changed, I am not sure where to start looking on this one and no threads in the Paypal forum. Error is below. Thanks much.

 

 

<Error begin>

 

Fatal error: Cannot use object of type PayPal_Page as array in /public_html/ecommerce/os/catalog/includes/modules/payment/paypal/templates/osC_Admin.tpl.php on line 27.

 

</Error End>

Share this post


Link to post
Share on other sites
My PayPal gateway works great and has for several years. I got the follow error in the Admin panel when acessing PayPal IPN. This is a sudden error that is new to me. I looked at line 27 and didn't see the problem but I have a beginner understanding of PHP syntax.

 

Nothing was changed, I am not sure where to start looking on this one and no threads in the Paypal forum. Error is below. Thanks much.

 

 

<Error begin>

 

Fatal error: Cannot use object of type PayPal_Page as array in /public_html/ecommerce/os/catalog/includes/modules/payment/paypal/templates/osC_Admin.tpl.php on line 27.

 

</Error End>

and line 27 says?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

osC_Admin.tpl.php paste its 20 to 30 line.


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites

I have this same problem, my line 27 looks like this:

 

<body margin width="0" marg inheight="0" topmargin="0" bottom margin="0" leftmargin="0" right margin="0" bgcolor="#FFFFFF" onLoad="<?php echo $page['onLoad']; ?>">

 

Anyone?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×