Jump to content
Sign in to follow this  
oarenj

Hate to post but I been searching since Sunday. USPS METHOD ISSUE

Recommended Posts

I am doing a fresh install of OSC due to a bunch of add ons over the years, etc and the only things I have on the new site are the latest OSC and the latest USPS methods. My international shipping is fine, no issues but when I do anything in the US I get the following;

 

United States Postal Service United States Postal Service

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

 

My Zip code is correct, and I have fresh installed teh USPS methods multiple times - why do my USA/Domestic shipping calculations work?

Share this post


Link to post
Share on other sites

Whoops! The last line should read;

 

My Zip code is correct, and I have fresh installed teh USPS methods multiple times - why do my USA/Domestic shipping calculations not work?

Share this post


Link to post
Share on other sites

This is the error I get back when I change the email address to mine

 

<Error><Number>-2147219085</Number><Source>Rate_Respond.;SOLServerRates.RateV3_Respond</Source><Description>Invalid XML Element cannot be empty according to the DTD/Schema.

line= 0 pos= 1159</Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error>

Share this post


Link to post
Share on other sites

Got it.

 

The latest USPS methods did not work for me, I want back a couple versions and EVERYTHING worked flawlessly.

Share this post


Link to post
Share on other sites
Got it.

 

The latest USPS methods did not work for me, I want back a couple versions and EVERYTHING worked flawlessly.

 

 

any other way to fix this problem? i dont even know how to go "back" a couple versions..

 

mine has the same error as stated in this thread..

 

the shipping calculation error...

Share this post


Link to post
Share on other sites
This is currently the only shipping method available to use on this order.

United States Postal Service

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

 

 

 

here's my config:

 

 

 

United States Postal Service

You will need to have registered an account with USPS at http://www.uspsprioritymail.com/et_regcert.html to use this module

USPS expects you to use pounds as weight measure for your products. 

Enable USPS Shipping
True

Enter the USPS User ID
************

Enter the USPS Password
************
Which server to use
production

Handling Fee
1.25

Tax Class
Taxable Goods

Shipping Zone
Alabama

Sort Order
0

Share this post


Link to post
Share on other sites
here's my config:

 

 

 

United States Postal Service

You will need to have registered an account with USPS at http://www.uspsprioritymail.com/et_regcert.html to use this module

USPS expects you to use pounds as weight measure for your products. 

Enable USPS Shipping
True

Enter the USPS User ID
************

Enter the USPS Password
************
Which server to use
production

Handling Fee
1.25

Tax Class
Taxable Goods

Shipping Zone
Alabama

Sort Order
0

 

 

Check in includes/modules/shipping/usps.php

This should be your methods stated. I got the same error because the - DASH was missing from first class.

 

 

$this->types = array('Express Mail' => 'Express Mail',

'First-Class Mail' => 'First Class Mail',

'Priority Mail' => 'Priority Mail',

'Priority FltRt Envelope' => 'Priority Mail Flat Rate Envelope',

'Priority FltRt Box' => 'Priority Mail Flat Rate Box',

'Parcel Post' => 'Parcel Post',

'Bound Printed Matter' => 'Bound Printed Matter',

'Media Mail' => 'Media Mail');

Share this post


Link to post
Share on other sites
I am doing a fresh install of OSC due to a bunch of add ons over the years, etc and the only things I have on the new site are the latest OSC and the latest USPS methods. My international shipping is fine, no issues but when I do anything in the US I get the following;

 

United States Postal Service United States Postal Service

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

 

My Zip code is correct, and I have fresh installed teh USPS methods multiple times - why do my USA/Domestic shipping calculations work?

 

I had this problem, I called USPS and had them switch me from the test to the production server and that did the trick. More than likely that is your problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×