Jump to content
dailce

OSC Socializer v1.0

Recommended Posts

Hi

 

Great contribution. Is any one able to help me with two little tweaks?

1. I would like the box to go upwards instead of down

2. What code would I need to add for Kaboodle?

 

Thanks in advance

Share this post


Link to post
Share on other sites

Nice add-on, I like it. However, the only way to close the pop-up as it is, is by clicking the actual "CLOSE" button in the top right. I know somewhere, I've seen coding to make a pop-up close when clicked inside or outside, and of course, we wouldn't want to close this one onClick inside (other than the X), but I would like to make it close if clicked outside the window. I didn't bookmark where I saw that coding, and don't recall where it was, and I'm absolutely not qualified to try coding it myself. I did go ahead and try, and I failed miserably and broke the whole thing. LOL Anyway, what code would I add in what spot, to make the Socializer window close if the user clicks outside the window? Any takers?

 

Namasté,

Russ


One: people are not wearing enough hats. Two: matter is energy. In the universe, there are many energy fields which we cannot normally perceive. Some energies have a spiritual source which act upon a person's soul. However, this soul does not exist ab initio, as orthodox Christianity teaches. It has to be brought into existence by a process of guided self-observation. However, this is rarely achieved, owing to man's unique ability to be distracted from spiritual matters by everyday trivia.

Share this post


Link to post
Share on other sites

I am having a few problems with this mod.

 

First I am using sts, does this work properly with this? I am also using Ultimate SEO? I know I have to put the code in the templates and it is working at that point, assuming i am using the full code in the placement of the button

<img src="social/buttonshare_trans.png" class="socializer" id="social_but" title="MYSITE: <?php echo $product_info['products_name']; ?>" alt="<?php echo tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL'); ?>" />

 

It all comes up, only when you click say to add to facebook, all is ok until you try and add the image it does not come with any images from that page, only from front page, then when its posted it does not come up with the link only www.mydomain.com/-p.html not the full path to the item.

 

Any help appreciated.

Share this post


Link to post
Share on other sites

Well I have managed to get lightbox to work properly but when I try clicking on the share button nothing happens.

 

You can view it here http://www.get-wireless.co.uk/coolermaster...case-p-123.html

 

I upgraded the lightbox .js files to the latest version and also updated mootools-1.2-core.js to mootools-1.2.1-core-nc.js

 

is there a way to get these two to work at all as I dont want to have to go down the route of removing light box and installing something else as it took a long time to get light box and more pics to work together and I wouldnt like ot even start to try and remove light box due to a lot of changes :(

Share this post


Link to post
Share on other sites

(!) If you ran into the problem with mootools conflicting with jquery, I have a simple solution for you! It took an hour to find, and 20 seconds to implement and it works.

 

From http://blog.phil-taylor.com/2007/01/31/usi...thout-conflict/ :

 

The jQuery library, and virtually all of its plugins are constrained within the jQuery namespace. As a general rule, “global” objects are stored inside the jQuery namespace as well, so you shouldn’t get a clash between jQuery and any other library (like Prototype, MooTools, or YUI).

 

That said, there is one caveat: By default, jQuery uses “$” as a shortcut for “jQuery” and so does MooTools!!!

 

However, you can override that default by calling jQuery.noConflict() at any point after jQuery and the other library have both loaded. For example (modified from original):

 

<script src="prototype.js">

 

<script src="moo.js">

 

<script src="jquery.js">

 

<script>

 

jQuery.noConflict();

 

// Use jQuery via jQuery(...)

 

// Use Prototype/Mootools with $(...), etc.

 

</script>

 

This will revert $ back to its original library. You’ll still be able to use “jQuery” in the rest of your application.

Share this post


Link to post
Share on other sites
I am having a few problems with this mod.

 

First I am using sts, does this work properly with this? I am also using Ultimate SEO? I know I have to put the code in the templates and it is working at that point, assuming i am using the full code in the placement of the button

CODE

<img src="social/buttonshare_trans.png" class="socializer" id="social_but" title="MYSITE: <?php echo $product_info['products_name']; ?>" alt="<?php echo tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL'); ?>" />

 

 

It all comes up, only when you click say to add to facebook, all is ok until you try and add the image it does not come with any images from that page, only from front page, then when its posted it does not come up with the link only www.mydomain.com/-p.html not the full path to the item.

 

Any help appreciated.

 

Any help, someone please ?

Share this post


Link to post
Share on other sites

Hi,

 

Could someone give me a link to their site with this contrib running please as I'd like to see what its like before changing from what I already have.

 

Thanks guy's

 

Steve


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites
Hi,

 

Could someone give me a link to their site with this contrib running please as I'd like to see what its like before changing from what I already have.

 

Thanks guy's

 

Steve

You can look at my site. A few changes, but you will get the idea.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
You can look at my site. A few changes, but you will get the idea.

Hi,

 

I've taken a look at your site and a few others, but I notice no one seems to have an email option, is there a reason for this?

 

Thanks


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites
Hi,

 

I've taken a look at your site and a few others, but I notice no one seems to have an email option, is there a reason for this?

 

Thanks

Don't know about anyone else, I took it out to prevent spam.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Well I have managed to get lightbox to work properly but when I try clicking on the share button nothing happens.

 

You can view it here http://www.get-wireless.co.uk/coolermaster...case-p-123.html

 

I upgraded the lightbox .js files to the latest version and also updated mootools-1.2-core.js to mootools-1.2.1-core-nc.js

 

is there a way to get these two to work at all as I dont want to have to go down the route of removing light box and installing something else as it took a long time to get light box and more pics to work together and I wouldnt like ot even start to try and remove light box due to a lot of changes :(

 

I've done a bit of reading on this and unfortunately Mootools (Socializer) and Scriptaculous (Lightbox) are mutually exclusive, so you can't use them both at the same time.

 

The workaround I have found is to use Slimbox which is a minimalist version of lightbox (looks exactly the same) but uses Mootools rather than Scriptalicious and it works fine.

 

Just download the Mootools version of Slimbox from here and upload to your catalogue root and then use this code to call both socializer and slimbox on your product_info page

 

<script language="javascript" type="text/ecmascript" src="social/js/mootools-1.2-core.js"></script>
<script language="javascript" type="text/ecmascript" src="social/js/socializer.js"></script>
<link href="social/css/socializer.css" rel="stylesheet" type="text/css" />
<script type="text/javascript" src="js/slimbox.js"></script>
<link rel="stylesheet" href="css/slimbox.css" type="text/css" media="screen" />

 

Hope that helps :)

 

Demo here http://www.dirtbikebitz.com/sidi-charger-m...ite-p-2093.html

 

Dave

Edited by stubbsy

Share this post


Link to post
Share on other sites

Nice tip, well done.

 

:)


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Why is it when I add it, It show up on my site but its not clickable? Any help would be great.


Custom PC's, Components, Liquid Cooling, Notebooks and More

Share this post


Link to post
Share on other sites

I am having a few problems with this mod.

 

First I am using sts, does this work properly with this? I am also using Ultimate SEO? I know I have to put the code in the templates and it is working at that point, assuming i am using the full code in the placement of the button

<img src="social/buttonshare_trans.png" class="socializer" id="social_but" title="MYSITE: <?php echo $product_info['products_name']; ?>" alt="<?php echo tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL'); ?>" />

 

It all comes up, only when you click say to add to facebook, all is ok until you try and add the image it does not come with any images from that page, only from front page, then when its posted it does not come up with the link only www.mydomain.com/-p.html not the full path to the item.

 

Any help appreciated.

 

 

I have the same problem. Has anybody solved this problem with STS?

Share this post


Link to post
Share on other sites

v1.5 Multilanguage??

 

Have anyone managed to install this contrib in two languages?

 

I have english and spanish running in my site.

 

The spanish version of the share button should read "Compartir" and some more changes has to be done to the email page.

 

How to do that?

 

thanks for reading :)

Share this post


Link to post
Share on other sites

Hi i got the same problem when i used this osc socializer in my website. This post helps me a lot.

 

Thanks for the solution ........

 

 

 

 

(!) If you ran into the problem with mootools conflicting with jquery, I have a simple solution for you! It took an hour to find, and 20 seconds to implement and it works.

 

From http://blog.phil-taylor.com/2007/01/31/usi...thout-conflict/ :

 

The jQuery library, and virtually all of its plugins are constrained within the jQuery namespace. As a general rule, “global” objects are stored inside the jQuery namespace as well, so you shouldn’t get a clash between jQuery and any other library (like Prototype, MooTools, or YUI).

 

That said, there is one caveat: By default, jQuery uses “$” as a shortcut for “jQuery” and so does MooTools!!!

 

However, you can override that default by calling jQuery.noConflict() at any point after jQuery and the other library have both loaded. For example (modified from original):

 

<script src="prototype.js">

 

<script src="moo.js">

 

<script src="jquery.js">

 

<script>

 

jQuery.noConflict();

 

// Use jQuery via jQuery(...)

 

// Use Prototype/Mootools with $(...), etc.

 

</script>

 

This will revert $ back to its original library. You’ll still be able to use “jQuery” in the rest of your application.

Share this post


Link to post
Share on other sites

Hi,

 

I can not work out how to change the MYSITE: bit at the start of a link. I have tried editing the send_to_friend.php file but I'm not too sure which bit to change.

 

Other than that I have managed to get it working fine :)

 

Many Thanks

 

Ken

Share this post


Link to post
Share on other sites

I'v now sorted it out :blush: I needed to change it in the product info file.

 

Thanks

 

Ken

Share this post


Link to post
Share on other sites

Ok I do have an issue now.

 

Everything is working fine bar the bookmark button option. It adds it ok to firefox as a favourite link, but when you click on the link it comes up at the side and does not display the page. Here is the link it generated.

 

http://www.MYSITE.com/catalog/http%3A%2F%2Fwww.MYSITE.com%2Fcatalog%2Ffull-epson-t0715-compatable-multipack-19ml-p-166.html

 

I'v changed the domain name, but other than that, that is the exact way it links to it.

 

Any Ideas?

 

Kind Regards

 

Ken Wilson

Edited by kenboon

Share this post


Link to post
Share on other sites

How change js/socializer.js to share products with pictures in Facebook?

http://www.facebook.com/share.php?u=PRODUCT&p=PICTURE

Edited by papiga01

Share this post


Link to post
Share on other sites

Really nice addon!

 

But I have a couple of problems..

 

Is it supposed to share the product image on facebook? Because it won't share it for me (Using oscThumb)

 

And when I share a product on facebook, that's in a subcategory in my store, it doesn't share the product information text but just the category names (?!)

 

What's wrong? :P

 

It works fine with products thats not in a subcategory.. Except the image thing.

 

Thank you!

 

d0zzen.

Share this post


Link to post
Share on other sites

How change js/socializer.js to share products with pictures in Facebook?

http://www.facebook.com/share.php?u=PRODUCT&p=PICTURE

 

 

so had anyone succeeded in getting this to work w/ facebook (in the sense of including a product image from product info) ?

 

Ok Mates chill out and check this out i think you will like it, i know it worked for me:

 

in product_info.php add this line to the head:

<?php echo '<link rel="image_src" type="image/jpeg" href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" >'; ?>

 

the only thing you have to do now, is calling the database before the header. For that, move the following code before the first "?>" of the file (before the head):

 

$product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'");  
$product_info = tep_db_fetch_array($product_info_query);

 

This will make this social bookmarks contribution (The best socials contrib available in add-ins) post the product image properly to facebook.

 

This worked for me, i hope will do it for you also.

 

Attention: Appreciation and gratitude to Oliver aka BackyardRacing from Switzerland, who sent me in pm the solution so he has credits. Sorted this bit out and thus delievering more power to this contribution.

 

You can and should change $HTTP_GET_VARS for $_GET if you have Sams cleansing contrib which is recomended for security reasons.

 

I would like someone to update the socializer.js file with all links working (most of them do).

 

Thanks

Francis

Edited by Francys

Share this post


Link to post
Share on other sites

Hello all,

 

Demo works perfect.

I've installed this great contribution even a few times and I'm getting confused because it doesn't work in my shop. "Share" button seems to appear but when I click on it, it doesn't work at all.

 

I've done a bit of reading on this and unfortunately Mootools (Socializer) and Scriptaculous (Lightbox) are mutually exclusive, so you can't use them both at the same time.

 

The workaround I have found is to use Slimbox which is a minimalist version of lightbox (looks exactly the same) but uses Mootools rather than Scriptalicious and it works fine.

 

Just download the Mootools version of Slimbox from here and upload to your catalogue root and then use this code to call both socializer and slimbox on your product_info page

 

<script language="javascript" type="text/ecmascript" src="social/js/mootools-1.2-core.js"></script>
<script language="javascript" type="text/ecmascript" src="social/js/socializer.js"></script>
<link href="social/css/socializer.css" rel="stylesheet" type="text/css" />
<script type="text/javascript" src="js/slimbox.js"></script>
<link rel="stylesheet" href="css/slimbox.css" type="text/css" media="screen" />

 

Hope that helps :)

 

Demo here http://www.dirtbikebitz.com/sidi-charger-m...ite-p-2093.html

 

Dave

 

Well... it still doesn't work, even on your page :'(

 

 

(!) If you ran into the problem with mootools conflicting with jquery, I have a simple solution for you! It took an hour to find, and 20 seconds to implement and it works.

 

From http://blog.phil-taylor.com/2007/01/31/usi...thout-conflict/ :

 

The jQuery library, and virtually all of its plugins are constrained within the jQuery namespace. As a general rule, “global” objects are stored inside the jQuery namespace as well, so you shouldn’t get a clash between jQuery and any other library (like Prototype, MooTools, or YUI).

 

That said, there is one caveat: By default, jQuery uses “$” as a shortcut for “jQuery” and so does MooTools!!!

 

However, you can override that default by calling jQuery.noConflict() at any point after jQuery and the other library have both loaded. For example (modified from original):

 

<script src="prototype.js">

 

<script src="moo.js">

 

<script src="jquery.js">

 

<script>

 

jQuery.noConflict();

 

// Use jQuery via jQuery(...)

 

// Use Prototype/Mootools with $(...), etc.

 

</script>

 

This will revert $ back to its original library. You’ll still be able to use “jQuery” in the rest of your application.

 

I was trying to implement jQuery.noConflict(); but I'm doing something wrong or it also doesn't work on my site.

 

I'm sure that it's all about js conflict because I've got tons of addons. I'm stuck. Any advice, please?

Share this post


Link to post
Share on other sites

Great contribution!!

Little weird placing code somewhere in catalog/products_info.php but I've managed that :)

Thank You !!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×