Jump to content
Sign in to follow this  
spooks

Product Listing Enhancements, Thumbnails & Manufacturer Headings

Recommended Posts

 

 

Thanks for that, it is smthg thats planned for a later release, but I'll look at your implementation for ideas. smile.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Add icons

 

 

The php for this is simple, but the html not so, remember this has many modes so there is much to consider fo any addition

 

You have shown the icons overlaying the pics and aligned to the box edges, if you care to come up with the html for that that works, I sort the php. wink.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Use reviews code

 

 

I don't see anything obvious there, check the product your testing have reviews, also after the data gathering section check data exists with:

 

echo '$pid_string=' . $pid_string;

 

print_r(array_values($review));

 

edit

 

Just spotted it, you added to the function, but dont call it, add product_description($listing['products_id'],$link) where you want the display.

 

Thanks Sam, worked a treat.

Share this post


Link to post
Share on other sites

Thank for the reply Sam, I will try to change the javascrip.

Once agin, thank you for this awsome contrib!

 

2fix4u (Harry),

Kudos to you! I have implemented prettyphoto to my listing, NICE!

 

Thank..........

Share this post


Link to post
Share on other sites

2fix4u (Harry),

Kudos to you! I have implemented prettyphoto to my listing, NICE!

 

Thank..........

 

Glad I could help! :thumbsup:

And Thank you for your ContetGlide Files, looks very NICE too! :thumbsup:

Share this post


Link to post
Share on other sites

I've installed this and it works great. One question, what is the best options type contribution that will work well with this contribution? Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

I've installed this and it works great. One question, what is the best options type contribution that will work well with this contribution? Any help would be greatly appreciated.

 

 

I've never used any of those & there are quite a few, I suspect which one would depend on your precise needs.

 

The attribute display is done through a small function, so any changes needed should be minimal.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Thanks for your reply Sam. I just need to add product attribute checkboxes, radiobuttons and a select function. Nothing crazy. I will look around and see.

Share this post


Link to post
Share on other sites

Sam I found a simple addon that doesn't require much change to the code. One more question, and you can answer if you want to because it has nothing to do with your great contribution, but looking around in the forum, you seem to know a lot about this stuff. Is there any way to call a different product_info page for a particular prouduct? And if there is can you please tell me where the funtion is called. I appreciate your help.

Share this post


Link to post
Share on other sites

My link

 

hello sir sam.. do you happen to know how can i remove the navigation

 

"Displaying 1 to 9 (of 98 products) Result Pages: 1 2 3 4 5 ... [Next >>] "

 

on home page to display only 9 products??

 

and also how can i return my manufaturers into drop down instead

 

heres my manufacturer.php

 

<?php
/*
 $Id: manufacturers.php,v 1.19 2003/06/09 22:17:13 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

 $manufacturers_query = tep_db_query("select manufacturers_id, manufacturers_name from " . TABLE_MANUFACTURERS . " order by manufacturers_name");
 if ($number_of_rows = tep_db_num_rows($manufacturers_query)) {
?>
<!-- manufacturers //-->
<tr><td>         

<?php
   $info_box_contents = array();
   $info_box_contents[] = array('text' => BOX_HEADING_MANUFACTURERS);

   new infoBoxHeading($info_box_contents, false, false);




   if ($number_of_rows <= MAX_DISPLAY_MANUFACTURERS_IN_A_LIST) {
$categories_string = '<ul>';
// Display a list
     $manufacturers_list = '';
     while ($manufacturers = tep_db_fetch_array($manufacturers_query)) {
       $manufacturers_name = ((strlen($manufacturers['manufacturers_name']) > MAX_DISPLAY_MANUFACTURER_NAME_LEN) ? substr($manufacturers['manufacturers_name'], 0, MAX_DISPLAY_MANUFACTURER_NAME_LEN) . '..' : $manufacturers['manufacturers_name']);
       if (isset($HTTP_GET_VARS['manufacturers_id']) && ($HTTP_GET_VARS['manufacturers_id'] == $manufacturers['manufacturers_id'])) $manufacturers_name = '<b>' . $manufacturers_name .'</b>';
       $manufacturers_list .= '<a href="' . tep_href_link(FILENAME_DEFAULT, 'manufacturers_id=' . $manufacturers['manufacturers_id']) . '">' . $manufacturers_name . '</a><br>';
     }

     $manufacturers_list = substr($manufacturers_list, 0, -4);

     $info_box_contents = array();
     $info_box_contents[] = array('text' => $manufacturers_list);
   } else {
// Display a drop-down
     $manufacturers_array = array();
     if (MAX_MANUFACTURERS_LIST < 2) {
       $manufacturers_array[] = array('id' => '', 'text' => PULL_DOWN_DEFAULT);
     }

     while ($manufacturers = tep_db_fetch_array($manufacturers_query)) {
       $manufacturers_name = ((strlen($manufacturers['manufacturers_name']) > MAX_DISPLAY_MANUFACTURER_NAME_LEN) ? substr($manufacturers['manufacturers_name'], 0, MAX_DISPLAY_MANUFACTURER_NAME_LEN) . '..' : $manufacturers['manufacturers_name']);
       $manufacturers_array[] = array('id' => $manufacturers['manufacturers_id'],
                                      'text' => $manufacturers_name);
     }

     $info_box_contents = array();
     $info_box_contents[] = array('form' => tep_draw_form('manufacturers', tep_href_link(FILENAME_DEFAULT, '', 'NONSSL', false), 'get'),
                                  'text' => '
								<table cellpadding="0" cellspacing="0" border="0" style=" width:170px;">
									<tr><td><br style="line-height:1px;"><br style="line-height:3px;">'. 

(isset($_GET['sort']) ? tep_draw_hidden_field('sort', $_GET['sort']) : '') . (isset($_GET['list']) ? tep_draw_hidden_field('list', $_GET['list']) : '') . (isset($_GET['max']) ? tep_draw_hidden_field('max', $_GET['max']) : '')
tep_draw_pull_down_menu('manufacturers_id', $manufacturers_array, (isset($HTTP_GET_VARS['manufacturers_id']) ? $HTTP_GET_VARS['manufacturers_id'] : ''), 'onChange="this.form.submit();" size="' . MAX_MANUFACTURERS_LIST . '" class="jamp" ') . tep_hide_session_id().'</td></tr>						</table>												
								');
   }

   new infoBox($info_box_contents);
?>

     </td></tr>   
<!-- manufacturers_eof //-->
<?php
 }
?>

Share this post


Link to post
Share on other sites

Hi,

 

I am having a few issues after reinstalling the contrib. This was installed on a unmodified cart as I am starting fresh.

 

1.) When uploading an image into a subcategory it duplicates it into the parent category as well.

 

2.) The information is jumbled up on the product listing page. Some things are overlapping others.

 

3.) The quantity: text is showing up when in admin I have it at 0.

 

See image:

 

ProdList.gif

Share this post


Link to post
Share on other sites

I am also noticing that although I have the 'Product Listing Style Switch' set to both... It does not appear on the screen. It is missing.

 

Thanks,

 

Charles

Share this post


Link to post
Share on other sites

fan4chevy. try this:

 

((((((2.) The information is jumbled up on the product listing page. Some things are overlapping others.)))))))

yoursite.com/admin/configuration.php?gID=8&cID=825&action=edit

(product listing height) leve it empty, not 0, but empty.

Or just increase the number untill the jumbled up go's away.

Share this post


Link to post
Share on other sites

 

 

have u set a date limit for new products?

 

you could change:

 

 if ( ($listing_split->number_of_rows > (int)$max_results) && $top_nav ) echo $page_nav;

 

to

 

 if ( ($listing_split->number_of_rows > (int)$max_results) && $top_nav && !$new_mode) echo $page_nav;

 

 

You could use the original manufacturers box!!


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

 

 

Yes, you need to set your admin values as appropriate to your content, see the doc

 

Also adjust your css settings ie in .infoBoxProducts margin-bottom: often needs adjusting (sets gap below thumbnail border)

 

This makes no code changes in admin, so any changes there cannot be blammed on this!! blink.gif

 

Why on earth did u think otherwise!!


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

I guess theres more than one way to skin a chicken, :o

I had the same issue and that't what worked for me B)

 

Of course, there may be better ways.

 

God, what was I thinking? just trying to help. :lol:

 

((Ok, time to give some back to the community!))

 

Here are addon pages to this wonderfull cotribution created by Sam.

 

Best Sellers page

Fearured products page

Coming Soom page

Bundled products page

 

You can download it here:

Addon Pages

 

This link will be active for the next 30 days.

Out of respect for Sam and his hard work, I have not added this

addon package to his contribution. It will be at his discretion wether

he wants to revise the scripts and add them to his contribution him self.

I the event that addon pages are included after 30 days,

I will add this package to oscommerce in a separate contribution

for all to enjoy.

 

Once again, thank you Sam for this wonderfull contribution! :D

Share this post


Link to post
Share on other sites

When I switch views from thumbs to list I get this error:

 

1054 - Unknown column 'mi.manufacturers_description' in 'field list'

 

select distinct m.manufacturers_id, m.manufacturers_name, mi.manufacturers_description from products p, products_to_categories p2c, manufacturers m left join manufacturers_info mi on m.manufacturers_id = mi.manufacturers_id where p.products_status = '1' and p.manufacturers_id = m.manufacturers_id and p.products_id = p2c.products_id and p2c.categories_id = '11' and mi.languages_id = '1' order by m.manufacturers_name

 

[TEP STOP]

 

I imagine I did not install something, any ideas? I don't really use manufacturers in my cart.

 

Thanks,

Charles

Share this post


Link to post
Share on other sites

Hi,

 

Another thing I am noticing is that on the 'New Product' grid that when using the ones from the contrib. it does not say 'New Products' in the title bar. There is no text at all at the top. This is why I was confused in an earlier posting thinking there was duplications to parent cat.

 

If I switch back to the os originals then it says New Products again in the title.

 

Thanks,

 

Charles

Share this post


Link to post
Share on other sites

 

 

Thanks for those, I'll look at adding them though there is the issue of upload limit, its near the limit now & last time I went passed it it took a week b4 I could upload again!! ohmy.gif

 

 

God, what was I thinking? just trying to help.

 

Not sure what your getting upset about there?

 

For your info the Product Listing Box Height setting does limit the box size, its recent change in behaviour is as the box has changed from a table to a div (tables always strech to content) to facilitate the round corners. Spacing around the box is done by the css, so quantity boxes etc, that are outside the box must be seperated that way.

 

 

PS if you use the reply button instead of the add reply button in the forum its clear your post is a reply (& what too), not a random new post!! wink.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

 

 

If your talking of the new products page, the page has the title 'New Products' so no title is added by the listing module, as that would be a repeat, that is also the default behaviour.

 

The title for your new products page is set in your language file.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

If your talking of the new products page, the page has the title 'New Products' so no title is added by the listing module, as that would be a repeat, that is also the default behaviour.

 

The title for your new products page is set in your language file.

 

Hi Sam thanks for your help. Actually here is an image of what it is doing. If I revert back to the original OS files then it shows 'New Products' in the title. The fresh files unmodified cart using the contrib has nothing on the top.

 

newproducts.gif

 

 

Thanks,

 

Charles

Edited by fan4chevy

Share this post


Link to post
Share on other sites

 

 

your talking of the new products module then, please make yourself clear, you said you were swapping a file, but not which!!

 

It will display the contents of TABLE_HEADING_NEW_PRODUCTS, its set in your language files.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

 

 

 

Ooops!! I just realised if your using grid mode without graphic borders then it don't have the titles (as it sorts of messes it) blush.gif

 

to add the titles in grid mode, listing module line 447:

 

 echo $Tborder;$row ++;

 

 

add after:

 

    if (!$gborders && $grid && $title_name) {
     $info_box_heading[0] = array('text' => '<big>'.$title_name.'</big>');
     new infoBoxHeading($info_box_heading, false, false); 
   }     


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Ooops!! I just realised if your using grid mode without graphic borders then it don't have the titles (as it sorts of messes it) blush.gif

 

to add the titles in grid mode, listing module line 447:

 

 echo $Tborder;$row ++;

 

 

add after:

 

    if (!$gborders && $grid && $title_name) {
     $info_box_heading[0] = array('text' => '<big>'.$title_name.'</big>');
     new infoBoxHeading($info_box_heading, false, false); 
   }     

 

Yep, I am using grid without graphics borders. See how wonderfully smart you are? Thanks Spooks, I will try it when I get back.

Charles

Share this post


Link to post
Share on other sites

Spooks, did you have any idea what is causing the error I mentioned:

 

When I switch views from thumbs to list I get this error:

 

1054 - Unknown column 'mi.manufacturers_description' in 'field list'

 

select distinct m.manufacturers_id, m.manufacturers_name, mi.manufacturers_description from products p, products_to_categories p2c, manufacturers m left join manufacturers_info mi on m.manufacturers_id = mi.manufacturers_id where p.products_status = '1' and p.manufacturers_id = m.manufacturers_id and p.products_id = p2c.products_id and p2c.categories_id = '11' and mi.languages_id = '1' order by m.manufacturers_name

 

[TEP STOP]

 

It does it when I am in the listings page and click on switch to 'List View'. I followed install very closely. :blush:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×