Jump to content
Sign in to follow this  
spooks

Product Listing Enhancements, Thumbnails & Manufacturer Headings

Recommended Posts

Installed this today. Can do a few things like turn off buy now column and buttons, but my products are still listed one under another, no matter how many products per row I select. Any help appreciated.

 

BTW, if I want to uninstall, how do I do it?

 

Thanks...

 

Have you tried changing the 'Product Listing Style' & Product Listing Per Row option in admin?

 

You did run the setup??

 

To unistall, just replace the new product_listing.php with the original.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
Installed this today. Can do a few things like turn off buy now column and buttons, but my products are still listed one under another, no matter how many products per row I select. Any help appreciated.

 

BTW, if I want to uninstall, how do I do it?

 

Thanks...

 

 

Have you tried changing listing style?

 

Just put back the original listing file to remove.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
At the point in the page where everything stops, it must be a fatal error or it would continue on to do your right column & footer.

 

You could change the setting for Prev/Next Navigation Bar (1-top, 2-bottom, 3-both) to both, see if it does the first, list must be longer than max though (set in max values, search results)

 

NB you did run the new setup from 1.3 didn't you?

 

Tried changing Prev/Next Navigation Bar to 3, same result (set max results to 3 products aswell so the list is longer). Yes I did run the new setup. I just ran it again and got : Enhanced Product Listing configuration appears to be set up already. Aborted Operation.

Edited by Marker

Share this post


Link to post
Share on other sites

If you get no display with list length set to 3 then its iether a conflict with function or split page_results as said before, nothing else is done at that point. Have you tried downloading a new copy, in-case of corruption.

 

I`ve tested this on ms2 to rc2a with php4 & 5 sql 4 & 5 and see no error.

 

You need to enable errors, so you can see whats the block.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
Installed this today. Can do a few things like turn off buy now column and buttons, but my products are still listed one under another, no matter how many products per row I select. Any help appreciated.

 

BTW, if I want to uninstall, how do I do it?

 

Thanks...

 

am I missing some files? The installation package has catalog/admin/includes/modules directory, but no file there and also catalog/includes/modules directory with no file

Share this post


Link to post
Share on other sites
If you get no display with list length set to 3 then its iether a conflict with function or split page_results as said before, nothing else is done at that point. Have you tried downloading a new copy, in-case of corruption.

 

I`ve tested this on ms2 to rc2a with php4 & 5 sql 4 & 5 and see no error.

 

You need to enable errors, so you can see whats the block.

 

 

How do I enable errors?

Share this post


Link to post
Share on other sites
am I missing some files? The installation package has catalog/admin/includes/modules directory, but no file there and also catalog/includes/modules directory with no file

 

I wonder if the problem was that my stylesheet wasn't writeable, so the new entries didn't get added? Can't re-install because I get error message as it finds stuff in the database and says it's already installed, so what entries does it put in the stylesheet so that I can do it manually?

 

Thanks.

Share this post


Link to post
Share on other sites
I wonder if the problem was that my stylesheet wasn't writeable, so the new entries didn't get added? Can't re-install because I get error message as it finds stuff in the database and says it's already installed, so what entries does it put in the stylesheet so that I can do it manually?

 

Thanks.

 

I'm very confused now...

 

How do I install latest version from scratch with after removing current installation? All of the files don't seem to be in the latest full package and only the fist version 1 has installation instructions with it...

Share this post


Link to post
Share on other sites
I'm very confused now...

 

How do I install latest version from scratch with after removing current installation? All of the files don't seem to be in the latest full package and only the fist version 1 has installation instructions with it...

 

 

When you unzip the package you will find 2 directories, 'Product Listing Enhancements, Thumbnails & Manufacturer Headings V1.2' with all the unchanged stuff in it, and 'Product Listing Enhancements, Thumbnails & Manufacturer Headings V1.3' with all the new stuff in it.

 

The setup makes relavent changes to your dBase, it does not alter your css file, you have to do that yourself following the install instructions.

 

The instructions from V1 are in V1.3 as well.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
I'm very confused now...

 

How do I install latest version from scratch with after removing current installation? All of the files don't seem to be in the latest full package and only the fist version 1 has installation instructions with it...

 

Version 1.3 has install instructions with it. It will tell you how to update from a previous version:

 

"If your upgading from any previous version, run the new setup file, it will make any required changes.

There are some additional css entries with this install too."

Share this post


Link to post
Share on other sites
I'm very confused now...

 

How do I install latest version from scratch with after removing current installation? All of the files don't seem to be in the latest full package and only the fist version 1 has installation instructions with it...

 

 

When you unzip the package you wil;l find 2 directories:

 

Product Listing Enhancements, Thumbnails & Manufacturer Headings V1.2 with all the unchanged stuff in it.

 

Product Listing Enhancements, Thumbnails & Manufacturer Headings V1.3 with all the new stuff in it, instructions are there.

 

The package does not alter your css files, you must do that, follow the instructions.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

I have just re-downloaded V1.3 and uploaded the files to make sure that mine were not corupt and it made no difference.

 

If the problem is with split page results where should I be looking for the problem? I have already uploaded a vanilla (oscommerce-2.2rc2a) spilt page result file and that didn't work.

 

I do recall having some problems with split page result when I originaly installed graphical borders (a few months ago). The problem was that if a category or a search had no products in it the message displaying no. of results would display -1,-2,-3,-4 page links. Doesn't do it any more though because i unistalled graphical boarders and installed easy graphical borders, just wondered if it might be related.

Share this post


Link to post
Share on other sites
I have just re-downloaded V1.3 and uploaded the files to make sure that mine were not corupt and it made no difference.

 

If the problem is with split page results where should I be looking for the problem? I have already uploaded a vanilla (oscommerce-2.2rc2a) spilt page result file and that didn't work.

 

I do recall having some problems with split page result when I originaly installed graphical borders (a few months ago). The problem was that if a category or a search had no products in it the message displaying no. of results would display -1,-2,-3,-4 page links. Doesn't do it any more though because i unistalled graphical boarders and installed easy graphical borders, just wondered if it might be related.

 

 

The old graphical borders does all sorts of stuff, the new one only sets the box borders, so should have less problems.

 

I did make a change, just after calling split page results you have the line

 

 if ( ($listing_split->number_of_rows > 0) && ( (PREV_NEXT_BAR_LOCATION == '1') || (PREV_NEXT_BAR_LOCATION == '3') ) ) {

 

I changed this to:

 

if ( ($listing_split->number_of_rows > MAX_DISPLAY_SEARCH_RESULTS) && ( (PREV_NEXT_BAR_LOCATION == '1') || (PREV_NEXT_BAR_LOCATION == '3') ) ) {

 

as the $listing_split->number_of_rows > 0 will always give true, so pointless, with $listing_split->number_of_rows > MAX_DISPLAY_SEARCH_RESULTS means if you have only one page, you wont get the display.

 

Perhaps your MAX_DISPLAY_SEARCH_RESULTS is set to something illegal for the function, could cause the failure, could set it back to 0 or change to (int)MAX_DISPLAY_SEARCH_RESULTS


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
When you unzip the package you wil;l find 2 directories:

 

Product Listing Enhancements, Thumbnails & Manufacturer Headings V1.2 with all the unchanged stuff in it.

 

Product Listing Enhancements, Thumbnails & Manufacturer Headings V1.3 with all the new stuff in it, instructions are there.

 

The package does not alter your css files, you must do that, follow the instructions.

 

if I want to install version 1.0, having already installed 1.3, can I just do it or do I need to uninstall 1.3. If so, how can I do that?

 

Do installation instructions from ver 1.0 apply for all? I can't find any other instructions?

 

thanks.

Share this post


Link to post
Share on other sites
The old graphical borders does all sorts of stuff, the new one only sets the box borders, so should have less problems.

 

I did make a change, just after calling split page results you have the line

 

 if ( ($listing_split->number_of_rows > 0) && ( (PREV_NEXT_BAR_LOCATION == '1') || (PREV_NEXT_BAR_LOCATION == '3') ) ) {

 

I changed this to:

 

if ( ($listing_split->number_of_rows > MAX_DISPLAY_SEARCH_RESULTS) && ( (PREV_NEXT_BAR_LOCATION == '1') || (PREV_NEXT_BAR_LOCATION == '3') ) ) {

 

as the $listing_split->number_of_rows > 0 will always give true, so pointless, with $listing_split->number_of_rows > MAX_DISPLAY_SEARCH_RESULTS means if you have only one page, you wont get the display.

 

Perhaps your MAX_DISPLAY_SEARCH_RESULTS is set to something illegal for the function, could cause the failure, could set it back to 0 or change to (int)MAX_DISPLAY_SEARCH_RESULTS

 

 

I added:

 

if ( ($listing_split->number_of_rows > MAX_DISPLAY_SEARCH_RESULTS) && ( (PREV_NEXT_BAR_LOCATION == '1') || (PREV_NEXT_BAR_LOCATION == '3') ) ) {

 

into the product_listing that I am running at the moment (the one that works but doesn;t list by manufactuer) and the page loads fine to the problem can;t be with that.

 

If I set the maxiumum search results to 0 in admin>config>max values I get the sql error below. But this normal though isn't it, not a issue?

 

Displaying 0 to 0 (of 4 products)	  Result Pages:  -9  -8  -7  -6  -5  -4  -3  -2  -1  0 
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-0, 0' at line 1

select p.products_image, pd.products_name, pd.products_description,p.products_image, p.products_id, p.manufacturers_id, p.products_price, p.products_tax_class_id, p.products_free_shipping, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price from ((products_description pd, products p) left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c) left join specials s on p.products_id = s.products_id where p.products_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and p2c.categories_id = '254' order by pd.products_name limit -0, 0

[TEP STOP]

Share this post


Link to post
Share on other sites

I am flumaxed as to whats causing your problem, no-one else seems to have it & I cant replicate.

 

Anyway I have a new version I`ll be uploading v-soon, best to try that next & see what that does.

 

I have modified some of the code to make it more efficient (so smaller) so the code layout is somewhat modified.

 

It gives some new options:

 

Block display in list/manufacturer listings, similar to the 'new products' display, except you can choose whats shown & what order.

A grid display option to the thumbnails display.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

I`ve looked into this further, it would appear that if you exceed your allocated memory limit during a sql query that can cause the code to halt silently.

 

So it looks like it is failing with split page results, if you select thumbnails, or list mode the query applied is unchanged, there are only extra ones if you select manufacturer.

 

At the point its failing the only differance to the original is the function I set up, I presume that that is taking you over your limit. On v1.4 I've now put the split page call before the function define, so that may help, but if your catalogue is growing its going to become a bigger problem.

 

You can try setting your limit by adding

ini_set("memory_limit","32M");

at the start of application_top, otherwise you need to speak to your host.

 

;)


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
I`ve looked into this further, it would appear that if you exceed your allocated memory limit during a sql query that can cause the code to halt silently.

 

So it looks like it is failing with split page results, if you select thumbnails, or list mode the query applied is unchanged, there are only extra ones if you select manufacturer.

 

At the point its failing the only differance to the original is the function I set up, I presume that that is taking you over your limit. On v1.4 I've now put the split page call before the function define, so that may help, but if your catalogue is growing its going to become a bigger problem.

 

You can try setting your limit by adding

ini_set("memory_limit","32M");

at the start of application_top, otherwise you need to speak to your host.

 

;)

 

I`ve done some tests of the total memory usage of my scipt, its around 2kb per result (product). So you can calculate your expected usage per query, I`d take maximum possible.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
I`ve done some tests of the total memory usage of my scipt, its around 2kb per result (product). So you can calculate your expected usage per query, I`d take maximum possible.

 

 

Most sub categories only have like 4-8 products so I don't think that would take me over my limit. I tired adding that to application_top and no change.

 

I'll wait for V1.4 and try that, not holding out much hope though because I think there’s something major wrong with my site. V1.1 worked (almost) the product listing displayed as it should but my product search stopped working. Thanks for all the suggestions, really appreciate it. :)

Edited by Marker

Share this post


Link to post
Share on other sites

Uploaded New Version V1.4

 

Modified some of the code to make it more efficient (so smaller) so the code layout is somewhat modified.

Added block display mode in list/manufacturer listings, similar to the 'new products' display, except you can choose whats shown & what order (Standard 'Product Listing' settings apply).

Added a grid display option to the thumbnails display.

Added extra picture test for 'Additional Images'.

Changed files: product_listing.php, product_listing_setup.php css entries.

 

UPGRADING

If your upgading from any previous version, run the new setup file, it will make any required changes.

There are some additional css entries with this install too.

 

B)


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Sam,

thanks for contribution.

I upgraded to version 1.4 and so far is good, except minor thing: when I chose to show weight it shows KG instead of lb. Same thing was in version 1.3. I am not sure where I can change that, I didn't see in admin configuration anything like that. The country is set to US, I'm not sure if it is related to contribution or some setting. Can you give me some light?

 

Thanks


Computers777dotcom

Share this post


Link to post
Share on other sites

I havent made it multi-lingual yet,

 

line 64

 

$weight = 'Weight = '.$products['products_weight'].'Kg<br />';

Edited by spooks

Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
I havent made it multi-lingual yet,

 

line 64

 

$weight = 'Weight = '.$products['products_weight'].'Kg<br />';

 

Oh, I didn't know it hard coded.

It's more about multi-metrical than multi-lingual I think.

I thought that somewhere osCommerce has it stored, probably related to country or something else, cause it shows correct pounds where it should.

Anyway, thanks for that line, it will be easy to me to change.

Thanks!


Computers777dotcom

Share this post


Link to post
Share on other sites
V1.4 didn’t work for me. Same issue. I think its time to throw in the towel on this one.

 

 

OK, out of interest, you could find your memory usage, at the beginning of the file add:

 

echo 'Memory Use: ' . number_format(memory_get_usage(), 0, '.', ',') . " bytes\n";

 

if you have php5 you could also put:

 

echo 'Peak: ' . number_format(memory_get_peak_usage(), 0, '.', ',') . " bytes\n";

 

You can find you current limits in admin/tools/server info


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×