Jump to content
Sign in to follow this  
spooks

Product Listing Enhancements, Thumbnails & Manufacturer Headings

Recommended Posts

1. You havent completed the install, check it again, esp re language files.

 

2. You seem to have modified application_top so its ignoring the action=buy_now, as a workaround for your site, you could go through product_listing.php, search for all cases of action=buy_now and replace with action=add_product

 

3. Oops, missed smthing, trying to do it too quick,

 

before the:

 

if (!strstr(PRODUCT_THUMBNAIL_VIEW, 'list') && LISTING_SWITCH != 'false' && !$empty_list) echo '<br><span class="smalltext"><a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('list')). 'list='.(strstr($thumbnail_view, 'thumbnails') ? 'manufacturer' : 'thumbnails')) . '">' . (strstr($thumbnail_view, 'thumbnails') ? LIST_VIEW : THUMB_VIEW).'</a></span><br />';

 

you added, add:

 

$thumbnail_view = (isset($_GET['list']) ? $_GET['list'] : PRODUCT_THUMBNAIL_VIEW);


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
1. You havent completed the install, check it again, esp re language files.

 

2. You seem to have modified application_top so its ignoring the action=buy_now, as a workaround for your site, you could go through product_listing.php, search for all cases of action=buy_now and replace with action=add_product

 

3. Oops, missed smthing, trying to do it too quick,

 

before the:

 

if (!strstr(PRODUCT_THUMBNAIL_VIEW, 'list') && LISTING_SWITCH != 'false' && !$empty_list) echo '<br><span class="smalltext"><a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('list')). 'list='.(strstr($thumbnail_view, 'thumbnails') ? 'manufacturer' : 'thumbnails')) . '">' . (strstr($thumbnail_view, 'thumbnails') ? LIST_VIEW : THUMB_VIEW).'</a></span><br />';

 

you added, add:

 

$thumbnail_view = (isset($_GET['list']) ? $_GET['list'] : PRODUCT_THUMBNAIL_VIEW);

 

Hi Spooks,

 

Thanks again, the change view link is working fine. I replaced action=buy_now with action=add_product but still no luck. I completed the install.

 

Is there a way to comment out the sort order drop down and move the quantity box right below the price? I may need the sort order at a later date.

 

Your time is much appreciated.

 

Regards,

Joy

Share this post


Link to post
Share on other sites

Sam,

 

I've tried every tip in this thread but I can't get thumbnails view to work. If I set the Product Listing Image Width to 0, the big images display. If I set it to the same as my small image width (125) it squishes down but still widens out to break the site tables.

 

I really want the thumbnail view in the product listings. Can you help?

 

List view works perfectly. I'm stumped.

 

Thanks in advance.


Debora

Breaking code.... one website at a time.

Vibrators: like cute little puppies without the puppy breath. Who can't like a vibrator?

Life Tip: Taking yourself too seriously? Put on a penis hat and look in the mirror every 5 minutes. That should fix it.

"Finally found the ball gag for those damn voices. Now to pull out the whip...." - Me

Member of the CODE BREAKERS CLUB - WE RULE!

Share this post


Link to post
Share on other sites
1. You havent completed the install, check it again, esp re language files.

 

Hi Spooks,

 

I must be missing something. I tried running the setup file again but I got a message that install detected and operation aborted. The sort order drop down has names with underscore. Try as I might, I still cannot get the add to cart button to add items to the shopping cart.

 

Please help me save the last two strands of hair I have left.

 

Regards,

Joy

Share this post


Link to post
Share on other sites

I took a look at the source of both the listing display and the thumbnail display....the listing display is calling product_thumb.php with the right pixels, however the thumbnail display is calling product_thumb.php with larger pixels. Is there something I can change to make this work right?


Debora

Breaking code.... one website at a time.

Vibrators: like cute little puppies without the puppy breath. Who can't like a vibrator?

Life Tip: Taking yourself too seriously? Put on a penis hat and look in the mirror every 5 minutes. That should fix it.

"Finally found the ball gag for those damn voices. Now to pull out the whip...." - Me

Member of the CODE BREAKERS CLUB - WE RULE!

Share this post


Link to post
Share on other sites
I took a look at the source of both the listing display and the thumbnail display....the listing display is calling product_thumb.php with the right pixels, however the thumbnail display is calling product_thumb.php with larger pixels. Is there something I can change to make this work right?

 

 

My file has no & never calls product_thumb.php, perhaps you have some other contrib installed.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
Thanks again, the change view link is working fine. I replaced action=buy_now with action=add_product but still no luck. I completed the install.

 

You still havent done the whole install!!

 

I suspect you are loosing the $_GET, this can be caused by SEF URL functions, try turning that off


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
My file has no & never calls product_thumb.php, perhaps you have some other contrib installed.

I've got OTF Auto Thumbnailer installed. So it's not going to work with the OTF? Or is there a code change I can do to make it work?

 

Thanks Spooks for any help you can provide with this....


Debora

Breaking code.... one website at a time.

Vibrators: like cute little puppies without the puppy breath. Who can't like a vibrator?

Life Tip: Taking yourself too seriously? Put on a penis hat and look in the mirror every 5 minutes. That should fix it.

"Finally found the ball gag for those damn voices. Now to pull out the whip...." - Me

Member of the CODE BREAKERS CLUB - WE RULE!

Share this post


Link to post
Share on other sites

Sorry, I have never touched Auto Thumbnailer, so I cant help with any integration, perhaps it has its own support thread?


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
You still havent done the whole install!!

 

I suspect you are loosing the $_GET, this can be caused by SEF URL functions, try turning that off

 

Hi Spooks,

 

Sorry for being such a baby. How do I turn off the SEF URL functions? I tried reinstalling but previous install is canceling operation.

 

Thanks.

 

Regards,

Joy

Share this post


Link to post
Share on other sites
Sorry, I have never touched Auto Thumbnailer, so I cant help with any integration, perhaps it has its own support thread?

I just realized what you meant. I turned off the SEO URLs and re-ran the installing but I got the same "Aborted Operations" message. Is there a way to delete the directory and then I can re-run the installation again?

 

Regards,

Joy

Share this post


Link to post
Share on other sites

When I said you havent completed the install I did'nt mean run the installer again, that only does the database changes, its the rest you need to do, follow the included instructions.

 

I don't know how to turn off your SEO, look at the instructions for that, I am mearly aware of the possible effects of that type of contrib.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
Sorry, I have never touched Auto Thumbnailer, so I cant help with any integration, perhaps it has its own support thread?

Okay, thanks Sam.


Debora

Breaking code.... one website at a time.

Vibrators: like cute little puppies without the puppy breath. Who can't like a vibrator?

Life Tip: Taking yourself too seriously? Put on a penis hat and look in the mirror every 5 minutes. That should fix it.

"Finally found the ball gag for those damn voices. Now to pull out the whip...." - Me

Member of the CODE BREAKERS CLUB - WE RULE!

Share this post


Link to post
Share on other sites
When I said you havent completed the install I did'nt mean run the installer again, that only does the database changes, its the rest you need to do, follow the included instructions.

 

I don't know how to turn off your SEO, look at the instructions for that, I am mearly aware of the possible effects of that type of contrib.

I turned off SEO and I followed the instructions and double checked it several times but still the items are not going to cart. Sort order still has the underscored names. Love the contribution so I don't want to give up.

 

Thanks much!

Joy

Share this post


Link to post
Share on other sites

thanks for the contrib Spooks. it looks absolutely perfect for the 3 col product listing layout i am after. I have installed V1.8 only missing out the bits about graphical borders, short descriptions and manufacturers descriptions as i dont have these installed. I do have a few contribs and add ons on my site but none that you have mentioned such as SEO URLS etc..

 

my product listings are still displaying exactly as they were before install in rows of single products with the details by the side across the box. please forgive my cluelessness as i'm obviously doing something majorly wrong!! this is my first crack at oscommerce and i'm finding it a bloody steep learning curve indeed!!

 

toywood.co.uk/catalog

 

any help MUCH apprecitated!

 

cheers

Share this post


Link to post
Share on other sites
I turned off SEO and I followed the instructions and double checked it several times but still the items are not going to cart. Sort order still has the underscored names. Love the contribution so I don't want to give up.

 

Thanks much!

Joy

 

COMPLETE THE INSTALL, then names in sort order & Switch will be correct, If its not SEO then its errors in your application top as I stated before, I can see from your site that the BUY_NOW button links are correct, so your error is not in this.

 

If you don`t want to complete this install properly then you can hardly complain when you have issues.!!


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Looking at your site it appears you have not uploaded the new product_listing.php file

 

Also Have you set the settings in admin correctly?

 

Please read through & complete all the instructions required.

Edited by spooks

Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
COMPLETE THE INSTALL, then names in sort order & Switch will be correct, If its not SEO then its errors in your application top as I stated before, I can see from your site that the BUY_NOW button links are correct, so your error is not in this.

 

If you don`t want to complete this install properly then you can hardly complain when you have issues.!!

 

I don't understand your statement that I don't want to complete the install. I have gone through the install several times. Anyway, I will never get this resolved since you view my request for help as a complaint. When I restored my old page, the add to cart worked but when I changed back to your page it does not work. The sort order is not changing no matter what I do.

 

I guess I will never know what is wrong since I don't have the knowledge to fix this myself. Anyway, sorry for wasting your time.

Share this post


Link to post
Share on other sites
Looking at your site it appears you have not uploaded the new product_listing.php file

 

Also Have you set the settings in admin correctly?

 

Please read through & complete all the instructions required.

How do I delete the settings from the database? Thx.

Share this post


Link to post
Share on other sites
How do I delete the settings from the database? Thx.

 

 

Restore your backup, or wait till I`ve time to write a script, or use Total Configuration http://addons.oscommerce.com/info/5040

 

The settings wont effect anything.

 

I note your restored listing is non-standard, are you using a template?


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites
Looking at your site it appears you have not uploaded the new product_listing.php file

 

Also Have you set the settings in admin correctly?

 

Please read through & complete all the instructions required.

 

 

well that works for me :)

thought i had uploaded it, must have got confused with what i had and hadn't done!!

 

thanks for a top top contrib Spooks!

Share this post


Link to post
Share on other sites

Hi Sam,

 

I have this installed and it works really good - thank you... One small change I could need some help with. we have some products that are priced at 0 which are a "request price" item. is there any way to have the "buy now" button hidden for these items?

Share this post


Link to post
Share on other sites

I had this contribution installed for a while and it worked great. Until today when I noticed that the sort pull down box is showing 'Product NameALPHA_ORDER', 'ProductNUM_ORDER', etc. I did install a few other contributions recently but can't tell which one could do this. Can someone shed any light?

 

Any help greatly appreciated. www.partylanes.co.uk

 

Kat

 

!!!!!!! Just went back to look again and it's all back to normal! Great - how can this be? Do I have to check the box every now and then to make sure it's still working?

Edited by katsur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×