Jump to content

Archived

This topic is now archived and is closed to further replies.

darrenultra

Hair pulling osCsid problem

Recommended Posts

Hi,

 

I used to have my oscommerce store in the catalog folder, however I recently decided to move it directly into the root folder. I thought I had made all the necessary changes, however I have just discovered that the osCsid does not disappear from the URL (it always used to when my store was in the catalog folder). This suggests to me that I do not have my cookie settings configured properly anymore.

 

These are my includes>configure.php settings:

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.mywebsite.co.uk'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://sslrelay.com/mywebsite.co.uk'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.mywebsite.co.uk');

define('HTTPS_COOKIE_DOMAIN', 'sslrelay.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/mywebsite.co.uk/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

As far as I can tell these are the right settings for a root folder oscommerce store ...however considering the non-disappearin osCsid I guess they can't be! If anyone has any ideas I would be very grateful.

 

Cheers,

Nick

Share this post


Link to post
Share on other sites

Problem solved!

 

It turned out that my http cookie path should have been '' instead of '/'.

 

Hope this helps anyone having the same problem.

Share this post


Link to post
Share on other sites

×