Jump to content
Sign in to follow this  
Vin?

"Ad Tracker (where did they come from?)"

Recommended Posts

Thank you for your interest.

 

I've installed Mr. Safran's "Ad Tracker (where did they come from?)" contribution, and there are 2 problems i've encountered:

This modification allows you to keep track of where your registered users are coming from.

For anyone running multiple ad banners or paid google-type links, knowing which ads are

effective is pretty nice.

 

In addition, I wanted to capture the entire referring url so I could later see what the

users search string was to get to my link.

 

1. It works fine at default.php?ad=whereicamefrom, but not at any other php (any other php that calls application_top.php). I've tried manufacturers, categories, products... no luck. My (amateur) guess is that it has something to do with the second ? after the .php ...

 

2. It completely fails on a (live) SSL-site!!

 

Can anyone (who also uses or would like to use this contribution) help me out here?

Maybe an update to this contribution?


'Time is a social construction to make the transitoriness manageable'

Share this post


Link to post
Share on other sites

I use this contribution, and I have been meaning to chime in concerning my issues as well.

 

My cart uses SSL. While it does neatly ad the referring URL to the DB, it does not work for me either.

 

It seems that the AD column is never populated.


-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Share this post


Link to post
Share on other sites

I'm also having problems with using the Ad Tracker.

 

I only know of one problem so far so I don't know if it's the only one I'm going to have.

 

Anyway, my problem is that I am faced with a blank screen whenever I try to access my site with http://www.domain.com/?ad=somead or http://www.domain.com/default.php?ad=somead

 

Has anyone else been having this problem?

 

Any solutions?

 

Thanks,

Tony


"The price of success is perseverance. The price of failure comes much cheaper."

Share this post


Link to post
Share on other sites

I've been using this without any problems for quite a while now. Try doing this instead:

 

http://bigredbow.net/default.php?ad=osComm...Forums&cPath=25

 

two ? marks will break it. whenever you are displaying variables in a string you want to separate them with &s not ?s. PHP doesn't care about which order it is being displayed in the URL.

 

I just verified the above and it does work.

 

Hope this helps.

 

David

Share this post


Link to post
Share on other sites

Hi,

 

I'm working on an update to the Ad Tracker and was hoping to see if those original problems where ever resolved. I apologize for not having seen the original posts. I just decided to search for "tracker" today to see if there was any discussion about my contrib.

 

Anyway, I just finished a small admin feature that let's you *see* the results of your ads. :D

 

I'm working on the docs right now and will be posting very soon.

 

Adam Safran

http://MonkeyGoods.com


Adam

--------------------------------

got monkey? We do.

http://www.monkeygoods.com

Share this post


Link to post
Share on other sites
I use this contribution, and I have been meaning to chime in concerning my issues as well.

 

My cart uses SSL. While it does neatly ad the referring URL to the DB, it does not work for me either.

 

It seems that the AD column is never populated.

This is the problem I am having also.

 

It installed fine (of course I have a newer version of OSC so I had to use index.php instead of default.php for my ads.

 

No errors, but when I do a purchase following the ad link... nothing is populated in the admin for orders. Make sense?

Share this post


Link to post
Share on other sites

I added cookies to AdTracker to keep you from loosing the Ad reference if they don't not become a customer the first time they visit your site.

 

In case you are not aware here is the issue. Potential customer visits your site from say a google ad. They bookmark your page but don't become a customer. 3 days later they come back and make a purchase. The Sales $ will not be recorded under your Google Ad.

There will be no reference that the sale came from your Google Ad.

 

Creating a cookie solves this problem.

 

If anyone is interested I'll post the code, it's quite simple.

Share this post


Link to post
Share on other sites

Im working my way through this, and know NOTHING about php, so any ideas are Encouraged and Welcome!

 

Could the problem be in application_top ?

 

The instructions say

Add the following

Place AFTER "tep_session_start();"

// Updated for PHP 3.4.x

//user_tracking modications

  if (!$referer_url) {

  if ($HTTP_SERVER_VARS['HTTP_REFERER']) {

    $referer_url = $HTTP_SERVER_VARS['HTTP_REFERER'];

    tep_session_register('referer_url');

}

  }

 

//user_ad_tracker modification

  if ($ad) {

      $advertiser = $_GET["ad"]; 

      tep_session_register('advertiser');     

  }

 

After closer examination, /catalog/includes/application_top.php has THREE instances of Place AFTER "tep_session_start();". Mine is modified, but I found them on :

 

LINE 179 thru 192 read............

 

if (isset($HTTP_COOKIE_VARS['cookie_test'])) {

tep_session_start();

  } elseif (SESSION_BLOCK_SPIDERS == 'True') {

    $user_agent = strtolower(getenv('HTTP_USER_AGENT'));

    $spider_flag = false;

 

    if (tep_not_null($user_agent)) {

      $spiders = file(DIR_WS_INCLUDES . 'spiders.txt');

 

      for ($i=0, $n=sizeof($spiders); $i<$n; $i++) {

        if (tep_not_null($spiders[$i])) {

          if (is_integer(strpos($user_agent, trim($spiders[$i])))) {

            $spider_flag = true;

            break;

 

 

 

LINES 198 thru 208 read...........

 

if ($spider_flag == false) {

      tep_session_start();

      $session_started = true;

    }

  } else {

    tep_session_start();

    $session_started = true;

  }

 

// set SID once, even if empty

  $SID = (defined('SID') ? SID : ''

Share this post


Link to post
Share on other sites
chris wrote.....If anyone is interested I'll post the code, it's quite simple.

 

Chris, yes please do.

 

I hadnt even thought that far ahead.. LOL I cant even get it to log the sale.

 

I placed an ad, in that ad I used "http://www.discountcelebrityphoto.com/index.php ?ad=fly2net"...(will split so it will show up here in full text)

 

I then went and clicked on the link, which took me to my site, I placed an order, and went through the checkout. Went into the admin to make sure the order was set at "delivered".

 

Went into Ad Tracker and this is what it looks like:

 

ad_tracker_sample.gif

Share this post


Link to post
Share on other sites

This is my code, yours may require some tweaking. I changed mine so it uses ref= instead of ad=

 

File applicaton_top.php

right under

tep_session_start();

 

//user_ad_tracker modification

if ($ref) {

$advertiser = $HTTP_GET_VARS["ref"];

if ($advertiser){

tep_session_register('advertiser');

//register cookie for 180 days

setcookie("yourdomainreferral",$advertiser,time()+60*60*24*180,"/");

}

}

else {

$advertiser = $HTTP_COOKIE_VARS["yourdomainreferral"];

if ($advertiser){

tep_session_register('advertiser');

}

}

 

 

I hope this helps.

Share this post


Link to post
Share on other sites

No thats not right.

 

the yourdomain can be anything you want it ot be.

It just for reference in the cookie.

 

do not change advertiser.

 

You system probably checks for ?ad= on the url line.

my system checks for ?ref= on the url line.

Share this post


Link to post
Share on other sites

I think Im in way over my head on this one. I may have to Uninstall, and try something else...anyone know any other Contributions? What about "OSCaffiliate "?

 

Also, does anyone know how to have your IP excluded from the Visitors stats?

 

Thanks Chris for trying to help, but I do believe this one is way beyond my understanding.

 

Tammy

Share this post


Link to post
Share on other sites

I believe the only way you'll see an ad populate is when someone from another site actually comes to your site and buys a product, when buying a product the website will add it's info on the page, but if they don't buy this time it won't populate till they come back and buy.

Share this post


Link to post
Share on other sites

Talon,

 

I did!

 

previous post:

I placed an ad with Fly2Net, in that ad I used "http://www.discountcelebrityphoto.com/index.php ?ad=fly2net"...(will split so it will show up here in full text) as the listed URL.

 

I then went and clicked on the link, which took me to my site,

I placed an order,

and went through the checkout.

Went into the admin to make sure the order was set at "delivered".

 

Still nothing shows up

Share this post


Link to post
Share on other sites

Humn, what version are you using? I installed this contrib 2 days ago, and it worked only after i completed a test order.

Share this post


Link to post
Share on other sites

Im using Ad Tracker:

Ad Link Tracking

Written by Adam Safran

asafran@amonkey.com

http://www.monkeygoods.com/

Written December 14, 2002

Updated April 27, 2003

 

 

 

With OSC 2.2

 

I uninstalled Ad Tracker (where did they come from). Then I installed OSC Affiliate. Ran the same test purchase with OSC affiliate and it showed everything in the admin as its suppose to. So I suppose I will need to use OSC Affiliate.

 

Thanks

Tammy

Share this post


Link to post
Share on other sites

I don't understand what the author means when in the install text he refers to putting your ad link out of the web like this.

 

http://www.monkeygoods.com/default.php?ad=google.hats

 

I am using OScommerce 2.2. ms 2

 

So using my site would I put in an ad this?

 

http://www.lhsmarkets.chainreactionweb.com....php?ad=candles

 

Could someone explain how this is supposed to work?

 

Second.

 

In my reports box in Admin my instead of saying Ad results mine says BOX_REPORTS_AD_RESULTS.

 

How do I get it just to say Ad Results. I assume there is something wrong in the reports.php file.

 

Could someone help me with this.

 

Thank you.

 

Lee

Share this post


Link to post
Share on other sites
This is my code, yours may require some tweaking.  I changed mine so it uses ref= instead of ad=

 

File applicaton_top.php

right under

tep_session_start();

 

 

These are three reference to tep_session_start():

 

Which one are you referring to?

 

And just to make sure I am following this thread correctly.  This is for capturing the URL from the customer even if they don't make a purcahse.

 

I put this under the first tep_session_start(); reference in the file.

 

 

 

Lee

Share this post


Link to post
Share on other sites
setcookie("yourdomainreferral",$advertiser,time()+60*60*24*180,"/");

 

        $advertiser = $HTTP_COOKIE_VARS["yourdomainreferral"];

      I hope this helps.

 

In these two lines you refer to yourdomainreferral.

 

What is supposed to be there.

 

My site is LHSMarkets.com

 

Would I put lhsmarkets.com/referral?

 

Lee

Share this post


Link to post
Share on other sites

Hi,

I have install ad tracker now but when I go to index.php are that one blank page. This is my code in catalog/includes/application_top.php

 

// start the session
 $session_started = false;
 if (SESSION_FORCE_COOKIE_USE == 'True') {
   tep_setcookie('cookie_test', 'please_accept_for_session', time()+60*60*24*30, $cookie_path, $cookie_domain);

   if (isset($HTTP_COOKIE_VARS['cookie_test'])) {
     tep_session_start();
// Ad Tracker Begin - ADDED BY BENI
//user_tracking modications
 if (!$referer_url) {
	 if ($HTTP_SERVER_VARS['HTTP_REFERER']) {
   $referer_url = $HTTP_SERVER_VARS['HTTP_REFERER'];
   session_register('referer_url'); 
//    tep_session_register('referer_url'); DID NOT WORK
}
 }

//user_ad_tracker modification
 if ($ad) {
     $advertiser = $_GET["ad"];  
     session_register('advertiser'); 
//      tep_session_register('advertiser'); DID NOT WORK
  } 
// Ad Tracker End - ADDED BY BENI
     $session_started = true;
   }
 } elseif (SESSION_BLOCK_SPIDERS == 'True') {
   $user_agent = strtolower(getenv('HTTP_USER_AGENT'));
   $spider_flag = false;

   if (tep_not_null($user_agent)) {
     $spiders = file(DIR_WS_INCLUDES . 'spiders.txt');

     for ($i=0, $n=sizeof($spiders); $i<$n; $i++) {
       if (tep_not_null($spiders[$i])) {
         if (is_integer(strpos($user_agent, trim($spiders[$i])))) {
           $spider_flag = true;
           break;
         }
       }
     }
   }

   if ($spider_flag == false) {
     tep_session_start();

// Ad Tracker Begin - ADDED BY BENI
//user_tracking modications
 if (!$referer_url) {
	 if ($HTTP_SERVER_VARS['HTTP_REFERER']) {
   $referer_url = $HTTP_SERVER_VARS['HTTP_REFERER'];
   session_register('referer_url'); 
//    tep_session_register('referer_url'); DID NOT WORK
}
 }

//user_ad_tracker modification
 if ($ad) {
     $advertiser = $_GET["ad"];  
     session_register('advertiser'); 
//      tep_session_register('advertiser'); DID NOT WORK
  } 
// Ad Tracker End - ADDED BY BENI

     $session_started = true;
   }
 } else {
   tep_session_start();

// Ad Tracker Begin - ADDED BY BENI
//user_tracking modications
 if (!$referer_url) {
	 if ($HTTP_SERVER_VARS['HTTP_REFERER']) {
   $referer_url = $HTTP_SERVER_VARS['HTTP_REFERER'];
   session_register('referer_url'); 
//    tep_session_register('referer_url'); DID NOT WORK
}
 }

//user_ad_tracker modification
 if ($ad) {
     $advertiser = $_GET["ad"];  
     session_register('advertiser'); 
//      tep_session_register('advertiser'); DID NOT WORK
  } 
// Ad Tracker End - ADDED BY BENI

   $session_started = true;
 }

// set SID once, even if empty
 $SID = (defined('SID') ? SID : '');

Share this post


Link to post
Share on other sites

Quick update for Purchase Without Account contribution users:

 

In Step 5 where you update create_account_process.php (or create_account.php), you should also make the same changes to Order_Info_Process.php. If you don't, the referer and ad will not be stored and your stats_ads_results.php in admin will be blank.

Share this post


Link to post
Share on other sites
Quick update for Purchase Without Account contribution users:

 

In Step 5 where you update create_account_process.php (or create_account.php), you should also make the same changes to Order_Info_Process.php. If you don't, the referer and ad will not be stored and your stats_ads_results.php in admin will be blank.

 

Good job! I just figured out the same thing!

 

But I have the "BLANK REPORT" problem too.

It shows the ad in the database, it shows on the customers page, but not when I try to look at the 'Ad Results' report.

I'd imagine that the problem is in the query in stats_ad_reports.php

but I can't grasp it. Any one else solve this problem???

:-j.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×