Jump to content
Sign in to follow this  
vdcpaladin

Product Attributes - Option Type Feature ISSUES need help urgently

Recommended Posts

Hey guys i have installed this Contribution onto the latest version of OSC.

 

I have used the new manual install instructions.

I have an install that partually works.

 

 

My issue is that if the user is logged into the system before they select product attributes then these appear in the shopping cart.

 

If the user is not logged in and they click buy it now after selecting their attributes. They are taken to the login page asked to ether login or make a new account.

 

When this happens you login or make a new user.... All of the attributes are lost.

 

 

I know theres ether 2 things that are wrong. Ether it is not recording the attributes for a visitor or the data is being lost when you are sent to the login page.

 

 

Can someone please help this issue is stopping me from getting this site working.

 

 

Here is a link if someone wants to see what happens.

 

 

http://linux10.nshosts.com/swishhorse/store

 

 

If you go to the tail bags they have the custom text field with a number of attributes.

 

Someone please help me im pulling whats left of my hair out lol

 

Kind Regards,

Callum Bruce

Share this post


Link to post
Share on other sites

I have found the issue but have no idea how to fix it. When the cart is created the visitor gets a new session which is all fine up until they login in which is when they are given a new session and this is where the product attributes are not passed over to the new session. Its only an issue when using this addon. Can someone please help me to fix it as i know very very little about sessions

Share this post


Link to post
Share on other sites

Ok the issue lies somewhere in the shopping_cart.php under the classes dir. The session is being created and storing information. But when you sign in it is not restoring the cart information into the database. I have now been looking at this for the last 48 hrs I will take any help i can get.

Share this post


Link to post
Share on other sites

Ok this is what i have it down too.

 

When the order is placed and the user is not logged in it creates a session in the DB. This session contains all of the correct information. Once the user logs in the information is transfered from the session to the cart tables. So this part works fine. Only issue is that the information does not display in the order confirmation page. (not a major issue providing the info gets to the order).... That brings me to my next point. When the confirm order button is pushed only the product and price and all order details are transmitted over to the order tables. so you now lose the attributes. This only happens with the OTF addon work fine if that addon is not there. I can not find where it is stuffing up I really really need help now as i have wasted 3 days looking at this and gotten no where.

 

Mind you if the user is logged in it works fine. I have no idea why it doesnt work if you have to log in 1/2 way through an order

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×