Jump to content
Sign in to follow this  
scrush

PayPal Pro (US) Error received in check out...HELP!

Recommended Posts

I have been searching the posted topics for a few days trying to find a solution to the error above! Any help would be greatly appreciated! This is my first time working with the osCommerce application. Everything has gone smoothly until trying to set up a merchant account to accept credit cards on the site. I have a Pay Pal Pro account to accept direct payments. The API numbers have been entered correctly and everything appears to work until someone tries to check out. After filling out the CC info and clicking "Confirm Order" (to submit) an error pops up that says "All payment information fields are required."

 

There is a space to enter the "Card Issue No." for Maestro and Solo cards only...but I would assume that this wouldn't be required if you aren't using a Maestro or Solo card. The other place that might cause problems is the "Card Valid From Date:" spot...which not all cards have. Again, I would assume if this isn't applicable to the card it wouldn't be necessary.

 

Is this a problem that can be solved with an update or something similar? Please help! Just got our website up and are losing orders because we can't accept CC!

 

www.macandtees.com Please feel free to email an help to sgwier@gmail.com!

 

Thanks so much!

Share this post


Link to post
Share on other sites

I am getting the same error, and just want to add my voice to the request for help. Everything else with the store works great but when I checkout I get the error "Error: All payment information fields are required.". The paypal express however works fine.

Share this post


Link to post
Share on other sites
I am getting the same error, and just want to add my voice to the request for help. Everything else with the store works great but when I checkout I get the error "Error: All payment information fields are required.". The paypal express however works fine.

 

Hey I fixed my issue. Works great now, try making this change "http://svn.oscommerce.com/fisheye/browse/o...477&r2=1582"

 

Saw it on this thread "http://forums.oscommerce.com/index.php?showtopic=289521". Make the change and everything works like a charm.

Share this post


Link to post
Share on other sites

please note...I just tried the fix with NO success. I have previously installed the "Stock View with Quantity per Attribute 1.0" and it appears that the checkout_conformatio.php was updated heavily and I'm not sure if this is affecting the fix.

 

Can someone please look into this problem.

Share this post


Link to post
Share on other sites
please note...I just tried the fix with NO success. I have previously installed the "Stock View with Quantity per Attribute 1.0" and it appears that the checkout_conformatio.php was updated heavily and I'm not sure if this is affecting the fix.

 

Can someone please look into this problem.

 

Additional info to above problem...

 

The above issue results in the Pay Pal Pro and Standard apps appearing to work because the Error no longer appears...but the screen just times out (when submitting payment)...in other words nothing happens when clicking confirm to submit order and payment...

 

...additional help/comments appreciated!

 

Thank you!

Share this post


Link to post
Share on other sites
Additional info to above problem...

 

The above issue results in the Pay Pal Pro and Standard apps appearing to work because the Error no longer appears...but the screen just times out (when submitting payment)...in other words nothing happens when clicking confirm to submit order and payment...

 

...additional help/comments appreciated!

 

Thank you!

 

 

We are still experiencing this issue. Has anyone else come across this???

Share this post


Link to post
Share on other sites

I have the issue, and I just used the fix.

Now I get this error message instead:

There\'s an error with this transaction. Please enter your state in the billing address.

 

My customers lives in Europe, and don't have a state. How do I fix this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×