Jump to content
Sign in to follow this  
caniol

Payment, order, and shipping modules not installing...

Recommended Posts

I’ve asked this in the Installation & Configuration Forum with no result. Hoping someone here can help.

 

When I attempt to install the three modules, it appears they are installing, but they never appear. All I end up with is the same "install modules" button. All of the files appear to be in the three module folders and everything else works fine with the installation. What might I be doing wrong?

 

Here are my configure.php files - if it helps.

 

 

includes/configure.php

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
define('HTTP_SERVER', 'http://www.blackstonetactical.com/catalog/'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers
define('HTTPS_SERVER', 'https://www.blackstonetactical.com/catalog/'); // eg, [url="https://localhost"]https://localhost[/url] - should not be empty for productive servers
define('ENABLE_SSL', false); // secure webserver for checkout procedure?
define('HTTP_COOKIE_DOMAIN', '');
define('HTTPS_COOKIE_DOMAIN', '');
define('HTTP_COOKIE_PATH', '');
define('HTTPS_COOKIE_PATH', '');
define('DIR_WS_HTTP_CATALOG', '');
define('DIR_WS_HTTPS_CATALOG', '');
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/');
define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

 

admin/Includes/configure.php

// define our webserver variables
// FS = Filesystem (physical)
// WS = Webserver (virtual)
define('HTTP_SERVER', 'http://www.blackstonetactical.com/catalog/'); // eg, [url="http://localhost"]http://localhost[/url] or - [url="https://localhost"]https://localhost[/url] should not be NULL for productive servers
define('HTTP_CATALOG_SERVER', 'http://www.blackstonetactical.com/');
define('HTTPS_CATALOG_SERVER', 'https://www.blackstonetactical.com/');
define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module
define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)
define('DIR_WS_ADMIN', '/admin/');
define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);
define('DIR_WS_CATALOG', '/catalog/');
define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

Share this post


Link to post
Share on other sites

More info required.

 

What are the three modules?

 

What files are in which folders?

 

Is it a contribution?


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
More info required.

 

What are the three modules?

 

What files are in which folders?

 

Is it a contribution?

They are the three modules that are part of the OSC 2.2RC2a installation: Payment, Shipping, Order Total.

 

My understanding is that once you hit the install button, the module installs and the button changes and you have access to the module. Now, you hit the install button, a few second hourglass, and nothing.

 

osc-1.jpg

osc-2.jpg

osc-3.jpg

 

Thanks for taking a look at this.

Share this post


Link to post
Share on other sites

I had the same problem, but when I checked my admin/includes/configure.php file, I found the line:

 

define('DIR_WS_CATALOG', '/catalog/');

 

which for my site (OSCommerce is installed in the root) I changed to

 

define('DIR_WS_CATALOG', '/');

 

and the shipping module, payment module, and order total module now appear properly.

Share this post


Link to post
Share on other sites
I had the same problem, but when I checked my admin/includes/configure.php file, I found the line:

 

define('DIR_WS_CATALOG', '/catalog/');

 

which for my site (OSCommerce is installed in the root) I changed to

 

define('DIR_WS_CATALOG', '/');

 

and the shipping module, payment module, and order total module now appear properly.

I tried changing that line. In my setup if I change that line to anything else, it messes up everything else. Using '/catalog/', most everything else works ok.

 

Thanks anyway.

Share this post


Link to post
Share on other sites
define('HTTP_SERVER', 'http://www.blackstonetactical.com/catalog/'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://www.blackstonetactical.com/catalog/');

 

This is wrong. Did you go through the install or just copy the files?

 

It should be:

define('HTTP_SERVER', 'http://www.blackstonetactical.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://www.blackstonetactical.com');

 

The catalog name goes in other areas. I suggest you install again.

Share this post


Link to post
Share on other sites

If the module list are not getting displayed in admin then Your FS define in admin has gone wrong.

 

 

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites

I ended up do a reinstall and everything is now ok. Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×