Jump to content
Sign in to follow this  
spooks

FCK WYSIWYG HTML editor

Recommended Posts

Did u check your php version: The Auto Installer script requires PHP 5.2.0

 

 

I've not used the autoinstaller so cant say on any issue, I don't know if it has any support thread. Have you considered trying the manual install theres not that much to do.

well spooks thanks for your answer but finally i install fck editor in following instructions seems working so i renonce to install autoinstaller

but i have another question when you are in the admin section for uploading an image i don't understand how ??

 

in the footer of the page you find product image box ,in fck you have two possibilities icons for source or image i click on image in the box

which url i do for ? if i put in upload tabs Q:\_Bruno\_mes site webs\Aimages artof\photomodcuir\corsetB32.jpg

following by picture information wich url i do for ??

nothing work

if you help me it's great

Share this post


Link to post
Share on other sites

Did u check your php version: The Auto Installer script requires PHP 5.2.0

 

 

I've not used the autoinstaller so cant say on any issue, I don't know if it has any support thread. Have you considered trying the manual install theres not that much to do.

 

I could not get autoinstaller work also, even I have PHP 5.2.8 so how to do this manual installation? I found this info where it says its basically just uploaded to root and thats it?!

So I downloaded old FCK HTML Editor 2.7 27.june2008 and transferred that to root inside fckeditor folder. Then I checked sample data and it all shows so I guess its ok? How do I get editor to work in my product details and information pages? I use information pages unlimited 2.06 and OSC 2.2rc2

Share this post


Link to post
Share on other sites

I could not get autoinstaller work also, even I have PHP 5.2.8 so how to do this manual installation? I found this info where it says its basically just uploaded to root and thats it?!

So I downloaded old FCK HTML Editor 2.7 27.june2008 and transferred that to root inside fckeditor folder. Then I checked sample data and it all shows so I guess its ok? How do I get editor to work in my product details and information pages? I use information pages unlimited 2.06 and OSC 2.2rc2

 

 

The manual install is b4 the auto ones.

 

Look for FCK HTML Editor 2.7 Dated 27 Jun 2008 wink.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

The manual install is b4 the auto ones.

 

Look for FCK HTML Editor 2.7 Dated 27 Jun 2008 wink.gif

 

Thats just what I did, downloaded that and unzip into admin folder. But isn't there supposed to be some files modification or how do I get the editor to show in lets say products details?

I can not find any installation instructions in the zip file.

Share this post


Link to post
Share on other sites

downloaded that and unzip into admin folder

 

 

WHY ??? crying.gif

 

There is a file called FCK HTML Editor 2.7 Install for OSC2.2.txt wink.gif

 

How do I install a contribution http://forums.oscommerce.com/index.php?showtopic=343384&st=0#entry1432157 might help you too. smile.gif

 

 

 

 

 

 

 

 

 

 

 

Edited by spooks

Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Got it working now.

 

Everything is fine, even image uploading.

Only thing left is that I can not change the skin or make options & tips for the fonts.

As a matter of fact, admin/fckeditor/fckconfig.js file doesn't seem to make any difference. I can even delete that and still everything works normally?!

 

Whats that about?

Share this post


Link to post
Share on other sites

Only thing left is that I can not change the skin or make options & tips for the fonts.

As a matter of fact, admin/fckeditor/fckconfig.js file doesn't seem to make any difference. I can even delete that and still everything works normally?!

 

Whats that about?

 

 

Check you uploaded the changed file

Edited by spooks

Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Hi, Sam,

 

Do you, perhaps, know why html editor changes absolute path to images and pages to a relative one. So, if I type this in the editor:

<a href="http://www.mysite.com/elephant-p-371.html"><img src="http://www.mysite.com/images/elephant.jpg"/></a>

the editor changes it to this:

<a href="../elephant-p-371.html"><img src="../images/elephant.jpg"/></a>

 

And this happens ONLY to the internal links to my site. If I include a link to another site, it doesn't crop the path.

 

This, of course, means that I can't send e-mails with links and images to my site, only with links and images to other sites.

 

And I've noticed that if I go to any page on my site, right click, and view html code, all references to images are again cropped the same way as above. If I go to some other internet stores and view their html code, their paths to images are full, i.e. absolute.

 

I've searched everywhere and can't find where to fix it. Maybe you would have an idea. Thank you!

Edited by Terrakota

Share this post


Link to post
Share on other sites

How to send html mails with images..

 

Thats part of the config function, but even if it did'nt you would still have an issue due to the osC mail process, you need to add Send Admin HTML e-mails http://addons.oscommerce.com/info/5806

 

 

I thought was mentioned in the doc? if not its been asked here very often.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Thanx Spooks, I fixed da problem.

I'm a bit tired so I just made a pretty picture of what & where to do :D

 

Problem:

When editing & previewing the product the fckeditor works fine, :)

when viewing / going back to edit page the description is one long text string. :(

 

Solution:

Delete the Strip Html & php code from functions.

in bluesuadeshoes/platapus/includes/function/database.php

(where bluesaudshoes is your catalog folder & platapus is your admin folder, YOU DID CHANGE YOUR ADMIN FOLDER RIGHT?

 

Line 132-136 (mine)

change

function tep_db_input($string, $link = 'db_link', $skip_stripping = false) {

// Strip HTML and PHP tags from string

if (!$skip_stripping) $string = strip_tags($string);

 

to

function tep_db_input($string, $link = 'db_link') {

// Strip HTML and PHP tags from string

// if (!$skip_stripping) $string = strip_tags($string);

 

fckingerror.jpg

 

Thanx again Spook you really help alot of us out there. May we star a "become a fan" thing for spooks on facebook? :D

Edited by Stephan (VS)

"I have no special talent. I am only passionately curious"

- Albert Einstein

Share this post


Link to post
Share on other sites

I want to customise the default toolbar for FCKeditor to make it 99% safe,

I want to allow the max features available but close any possible security holes.

 

Which tools may be harmfull to my site? :o

(like images, flash etc?)

(the file I need to edit:)

FCKConfig.ToolbarSets["Default"] = [

['Source','DocProps','-','Save','NewPage','Preview','-','Templates'],

['Cut','Copy','Paste','PasteText','PasteWord','-','Print','SpellCheck'],

['Undo','Redo','-','Find','Replace','-','SelectAll','RemoveFormat'],

['Form','Checkbox','Radio','TextField','Textarea','Select','Button','ImageButton','HiddenField'],

'/',

['Bold','Italic','Underline','StrikeThrough','-','Subscript','Superscript'],

['OrderedList','UnorderedList','-','Outdent','Indent','Blockquote'],

['JustifyLeft','JustifyCenter','JustifyRight','JustifyFull'],

['Link','Unlink','Anchor'],

['Image','Flash','Table','Rule','Smiley','SpecialChar','PageBreak'],

'/',

['Style','FontFormat','FontName','FontSize'],

['TextColor','BGColor'],

['FitWindow','ShowBlocks','-','About'] // No comma for the last row.

] ;

 

FCKConfig.ToolbarSets["Basic"] = [

['Bold','Italic','-','OrderedList','UnorderedList','-','Link','Unlink','-','About']

] ;


"I have no special talent. I am only passionately curious"

- Albert Einstein

Share this post


Link to post
Share on other sites

Hi Guys,

I just installed the latest ckeditor http://addons.oscommerce.com/info/7112

 

Nice,,,,Smilies and all..... :D

 

I applied it everywhere in admin,,,blog,news,email,newsletter,ect, ect.

 

Now, Im trying to apply it to the catalog side of my site, but Im having one issue..

 

[Example] I added editor to tell_a_friend.php.

Everything works great except, the email content is not delivered in HTML :( .

 

[Example using a smilie]

I type:

----------------------------------------

Today is a good day (smilie)

 

, but tomorrow will be better. (smilie)

----------------------------------------

 

 

The email will show:

----------------------------------------

_p_

 

Today is a good day _img alt=";)" height="20" src="http://youregiftbasket.com/ckeditor/plugins/smiley/images/wink_smile.gif" title=";)" width="20" /__/p_

_p_

 

, but tomorrow will be better. _img alt="" height="20" src="http://youregiftbasket.com/ckeditor/plugins/smiley/images/shades_smile.gif" title="" width="20" /__/p_

----------------------------------------

 

 

ANY ADVICE ??? on how to get ckeditor to work in catalog side ???

 

Thanks in advance :P

 

Ronnie

Edited by ronrrico

Share this post


Link to post
Share on other sites

Yes, looks like configuration, you'll see in your url the images folder is called 'image' instead of 'images' hence your error, the default FCK images folder is 'image' and old installs got round that issue by renaming the osc folder, but that caused othewr issues so I wrote a new install to get around that, perhaps you missed a step.

 

In catalog/admin/fckeditor/editor/filemanager/connectors/php/config.php

 

In Line 30 change:

 

$Config['Enabled'] = false ;

 

To

 

$Config['Enabled'] = true ;

 

In Line 34 change:

 

$Config['UserFilesPath'] = '/userfiles/' ;

 

To:

 

$Config['UserFilesPath'] = '/catalog/' ;

 

In line 132

 

Change

 

$Config['FileTypesPath']['Image'] = $Config['UserFilesPath'] . '/image/' ;

 

to

 

$Config['FileTypesPath']['Image'] = $Config['UserFilesPath'] . '/images/' ;

 

In line 134/5

 

Find:

 

$Config['QuickUploadPath']['Image'] = $Config['UserFilesPath'] ;

$Config['QuickUploadAbsolutePath']['Image'] = $Config['UserFilesAbsolutePath'] ;

 

To:

 

$Config['QuickUploadPath']['Image'] = $Config['FileTypesPath']['Image'] ;

$Config['QuickUploadAbsolutePath']['Image'] = $Config['FileTypesAbsolutePath']['Image'] ;

 

To insert an image, I tick the Browse server, but nothing happens. I have double checked the config file. Because of a contribution Ultra images, my images is located here: /public_html/teststore/images/products/

 

So do I need insert the correct path to images in the config file and would there another modifcation I need to do.

 

Note: When I type the full url address and tick ok, image loads. So it's only when I tick browse button.

 

Thanks.

 

Bennett

Edited by blr044

Share this post


Link to post
Share on other sites

do I need insert the correct path to images in the config file

 

 

yes, always.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

yes, always.

 

I just got to work, I was just getting ready to send a reply, that it is fine now. Will do some testing tomorrow.

 

Thanks.

 

Bennett

Share this post


Link to post
Share on other sites

Hi Sam,

 

I was wondering if you might know about creating image buttons with FCKeditor and session IDs. I have FCKeditor installed with Information Pages Unlimited and I'm using that to edit my main page (index.php). I wanted to just create a couple of simple image buttons that link to certain product pages but there doesn't seem to be any method in FCKeditor to allow for tep_href_links, only standard links. I've looked through forums for both add-ons and can't find an answer. Is there something I'm missing or would I have to sacrifice session integrity too keep things as they are (unless I force cookies)?

 

http://docs.cksource.com/FCKeditor_2.x/Users_Guide/Common_Tasks/Inserting_Images

 

Thanks,

 

Nick

Share this post


Link to post
Share on other sites

I just got to work, I was just getting ready to send a reply, that it is fine now. Will do some testing tomorrow.

 

Thanks.

 

Bennett

 

Thanks sppoks, for a great contribution. Did some testing and with ( Send Admin HTML e-mails ) installed also, everything went fine.

 

Thanks again.

 

Bennett

Share this post


Link to post
Share on other sites

OK, I've read through all 23 pages. Fun times. I'm trying to install FCKeditor2.6.5 (the latest version) that I downloaded from fckeditor.net. I'm not sure if I have php5 (I don't think I do), so I want to do it manually. I downloaded from here: http://addons.oscommerce.com/info/2900 the version that says 27 Jun 2008.

 

I've completely installed it twice and both times I get the same result. No message box at all. When I go to write an email or edit/add a product, the box where you enter your information is just gone.

 

Is it something to do with the version 2.6.5 vs the 2.6.2 that this install was written for? If it hadn't ended up with the exact same result for me both times, I would figure it was some tiny error. But I get no actual errors/warnings, just no box showing.

 

Can anyone make a suggestion as to what this might be? Should I download the older version of the fckeditor? Or which file should I look into for an error?

 

Thanks so much for any help!

Share this post


Link to post
Share on other sites

OK, I've read through all 23 pages. Fun times. ...

 

Can anyone make a suggestion as to what this might be? Should I download the older version of the fckeditor? Or which file should I look into for an error?

 

Thanks so much for any help!

 

I'm having the same issue on my one site wil post if I find it but that's not a priority now...

fck05.png

 

2.7's been the latest one for a while, I think they renamed FCK Editor to CKEditor or somethin, but anyway,

 

Your using this Contribution Right?

 

Check your "images" directory permissions are set to 777,

Check fck's config.php file, (Elmer Fudd Voice) <- This is veeeery importan, I'd start here.

Make sure it's in "catalog/admin/fckeditor" and remember to change your admin folder later for security,

Alter "/admin/categories.php" to change the Textarea

Check /admin/includes/functions/html_output.php

 

and the tips:

in catalog/admin/fckeditor/fckconfig.js

 

change line 153 from:

FCKConfig.FontSizes = 'smaller;larger;xx-small;x-small;small;medium;large;x-large;xx-large' ;

To:

FCKConfig.FontSizes = '8;10;12;14;16;18;20;24;28;32;36;42;50;58;66;smaller;larger;xx-small;x-small;small;medium;large;x-large;xx-large' ;

 

To add extra, but still standard fonts, change line 152 from:

FCKConfig.FontNames = 'Arial;Comic Sans MS;Courier New;Tahoma;Times New Roman;Verdana' ;

To:

FCKConfig.FontNames = 'Arial;Arial Black;Comic Sans MS;Courier New;Tahoma;Times New Roman;Verdana;Georgia;Impact;Palatino Linotype;Trebuchet MS' ;

Edited by Stephan (VS)

"I have no special talent. I am only passionately curious"

- Albert Einstein

Share this post


Link to post
Share on other sites

 

2.7's been the latest one for a while, I think they renamed FCK Editor to CKEditor or somethin, but anyway,

 

Yes, there is a CKeditor download as well as a FCKeditor download. I downloaded the other first and when I went to follow the instructions in the contribution, there are completely different files inside that download. So I went back and downloaded the FCKeditor.

 

Yep, not the autoinstaller but the last manual one. Its dated 27 June 2008.

 

Check your "images" directory permissions are set to 777,

Yep, it is 777.

 

Check fck's config.php file, (Elmer Fudd Voice) <- This is veeeery importan, I'd start here.

OK, I'll start with this one and go back through it again with a fine tooth comb.

 

Make sure it's in "catalog/admin/fckeditor" and remember to change your admin folder later for security,

The way my site it set up its mysite.com/catalog and mysite.com/admin (yes its renamed). So I put the fckeditor folder under admin, not catalog. Is this correct? Should I move my admin folder inside my catalog folder?

 

Alter "/admin/categories.php" to change the Textarea

Yes, I altered that one plus mail.php and categories.php and now none of them have a text area. I cannot make any changes or add new products right now. I'll look at them all again, but I'm suspicious that since its happened to all of them exactly the same that there s an error somewhere else. I'm not that good to create the same mistake exactly the same three times ;).

 

Check /admin/includes/functions/html_output.php

OK, I'll check that one 2nd.

 

and the tips:

in catalog/admin/fckeditor/fckconfig.js

 

change line 153 from:

FCKConfig.FontSizes = 'smaller;larger;xx-small;x-small;small;medium;large;x-large;xx-large' ;

To:

FCKConfig.FontSizes = '8;10;12;14;16;18;20;24;28;32;36;42;50;58;66;smaller;larger;xx-small;x-small;small;medium;large;x-large;xx-large' ;

 

To add extra, but still standard fonts, change line 152 from:

FCKConfig.FontNames = 'Arial;Comic Sans MS;Courier New;Tahoma;Times New Roman;Verdana' ;

To:

FCKConfig.FontNames = 'Arial;Arial Black;Comic Sans MS;Courier New;Tahoma;Times New Roman;Verdana;Georgia;Impact;Palatino Linotype;Trebuchet MS' ;

I did both of these changes as well. Are you saying I should check those for the mistake? OR are you saying that I should do those tips if I hadn't already?

 

Thanks so much for your help, I've been installing, uninstalling, re-installing and staring at the code for four days straight now. I'm tired of this add-on, lol!! My shop isn't live yet and I have more products to load. I'll have to take this down if I can't get it to work. I was just trying to do it before I opened so that my emails would have html for my customers. I've already been using html in my product description boxes to add additional pictures.

Share this post


Link to post
Share on other sites

Is this code correct? It seems very confusing to me what I'm supposed to put here.

 

$Config['UserFilesAbsolutePath'] = '/home/mysite.com/catalog/userfiles/' ;

 

I put the userfiles folder (that I created) under my catalog folder which is under my site name. Do I need the "root"? Or do I need "home"? In the instructions it says:

/home/mysite/public_html/catalog/userfiles/

 

I don't have anything called public_html. But then I also don't have anything titled home or root either. I know next to no programming, so forgive my ignorance please.

Share this post


Link to post
Share on other sites

Is this code correct? It seems very confusing to me what I'm supposed to put here.

 

$Config['UserFilesAbsolutePath'] = '/home/mysite.com/catalog/userfiles/' ;

 

 

NO, neads to be

 

$Config['UserFilesAbsolutePath'] = '/home/mysite/public_html/catalog/userfiles/' ;

 

 

I don't have anything called public_html. But then I also don't have anything titled home or root either

 

Nearly every site has public_html as their root folder (the folder below which there is no public access) I suspect you do have a public_html folder, u just don't know.

 

 

The path detailed is an absolute path, that means the path on the server, these are always of the form: '/home/servername/public_html/catalog/'

 

 

Look in your configure.php you will find: define('DIR_FS_CATALOG', '/home/servername/public_html/catalog/');

 

 

If you still don't understand, ask your host or find someone that can explain the basics to you.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

NO, neads to be

 

$Config['UserFilesAbsolutePath'] = '/home/mysite/public_html/catalog/userfiles/' ;

 

 

 

 

Nearly every site has public_html as their root folder (the folder below which there is no public access) I suspect you do have a public_html folder, u just don't know.

 

 

The path detailed is an absolute path, that means the path on the server, these are always of the form: '/home/servername/public_html/catalog/'

 

 

Look in your configure.php you will find: define('DIR_FS_CATALOG', '/home/servername/public_html/catalog/');

 

 

If you still don't understand, ask your host or find someone that can explain the basics to you.

 

I looked in my configure.php and it says this:

  define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/');

 

I did see somewhere someone said to look in the backup under tools and mine says:

/hsphere/local/home/myname/mysite.com//myadmin/backups/

 

So I tried that (with the correct info and not the backups portion) and it still doesn't work.

 

We have six websites on our account (which the hosting company calls "myname" - see above). When I look in the folders under my website, that's where I load straight html pages and where I see my catalog and admin folders. There is an images folder (for my html pages) and a bunch of folders that the hosting company put there. I looked through all of them and I have nothing titled public_html or anything close.

 

Sorry, but this is all very new to me. I'm of a technical/computer background, but in a totally different area! Thanks so much for all of your help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×