Jump to content
Sign in to follow this  
FWR Media

[contribution] Multilayer SEO Pop Out Menu

Recommended Posts

I have a quick question.. I am going through the steps, and it says to go to mysite.com/adminmenuoptions_installer.php but i can not get to that file. It is actually in the mysite.com/catalog/adminmenuoptions_installer so i just put that into my browser instead.. should i put that into the main directory?? did i miss something?


A great place for newbies to start

Road Map to oscommerce File Structure

DO NOT PM ME FOR HELP. My time is valuable, unless i ask you to PM me, please dont. You will get better help if you post publicly. I am not as good at this as you think anyways!

 

HOWEVER, you can visit my blog (go to my profile to see it) and post a question there, i will find time to get back and answer you

 

Proud Memeber of the CODE BREAKERS CLUB!!

Share this post


Link to post
Share on other sites

i also do not have the FWR Menu in my admin section.. I kinda did not expect to have it because it never told me to do anything in the admin section.. Whats going on here?


A great place for newbies to start

Road Map to oscommerce File Structure

DO NOT PM ME FOR HELP. My time is valuable, unless i ask you to PM me, please dont. You will get better help if you post publicly. I am not as good at this as you think anyways!

 

HOWEVER, you can visit my blog (go to my profile to see it) and post a question there, i will find time to get back and answer you

 

Proud Memeber of the CODE BREAKERS CLUB!!

Share this post


Link to post
Share on other sites

actually, i figured it all out. For some reason, if i typed mysite.com/catalog/AdminMenuOptions_installer.php it would not work, but when i copied the file path from my server to the url bar, it worked fine and now everything seems to be working wonderfully!

 

Now i want to figure out how to apply it to my articles box as well!


A great place for newbies to start

Road Map to oscommerce File Structure

DO NOT PM ME FOR HELP. My time is valuable, unless i ask you to PM me, please dont. You will get better help if you post publicly. I am not as good at this as you think anyways!

 

HOWEVER, you can visit my blog (go to my profile to see it) and post a question there, i will find time to get back and answer you

 

Proud Memeber of the CODE BREAKERS CLUB!!

Share this post


Link to post
Share on other sites

ny suggestions on how to apply this to other categories boxes? If you take a look at my site, you can see on the left column, my articles manager categories. Can I just make a change in the articles.php file or do I have to add the code to the top of every site like with the first one?


A great place for newbies to start

Road Map to oscommerce File Structure

DO NOT PM ME FOR HELP. My time is valuable, unless i ask you to PM me, please dont. You will get better help if you post publicly. I am not as good at this as you think anyways!

 

HOWEVER, you can visit my blog (go to my profile to see it) and post a question there, i will find time to get back and answer you

 

Proud Memeber of the CODE BREAKERS CLUB!!

Share this post


Link to post
Share on other sites
ny suggestions on how to apply this to other categories boxes? If you take a look at my site, you can see on the left column, my articles manager categories. Can I just make a change in the articles.php file or do I have to add the code to the top of every site like with the first one?

 

The menu system very specifically deals with the categories box .. it cannot be applied to other boxes.

Share this post


Link to post
Share on other sites

ok then.. I will search through the contributions to find one that i can work into the other categories on my website.


A great place for newbies to start

Road Map to oscommerce File Structure

DO NOT PM ME FOR HELP. My time is valuable, unless i ask you to PM me, please dont. You will get better help if you post publicly. I am not as good at this as you think anyways!

 

HOWEVER, you can visit my blog (go to my profile to see it) and post a question there, i will find time to get back and answer you

 

Proud Memeber of the CODE BREAKERS CLUB!!

Share this post


Link to post
Share on other sites

I just installed that great contribution but some how it just doesn't show me any pop-ups... so I hope to get some help here.

 

1. I copied all files into directories

2. Added necessary lines just before </head> in all root files where I found it.

3. Updated database fine (I got all success messages) pointing to the browser.

4. Deleted DB updating file just in case.

5. Opened admin panel and saw FWR menu right there smiling at me.

6. Opened FWR menu and made first option True to make pop-up menu available.

 

7 Opened my site and didn't notice any changes (no pop-up menu when I move mouse over the categories folder).

8 Played with cash settings in FWR menu and sorting - didn't noticed any changes after refreshing the site.

No error messages.

 

Can it be my host limitation or something like that? (I tried to install Ultimate SEO URLs, but it didn't work because of my host limitation)

 

P.S. One more: If I set reset setting to true, it stays true even if I open/refresh the site. :(

 

Thanks for any help.

 

Mike

Edited by AlwaysNewbie

Computers777dotcom

Share this post


Link to post
Share on other sites
I just installed that great contribution but some how it just doesn't show me any pop-ups... so I hope to get some help here.

 

1. I copied all files into directories

2. Added necessary lines just before </head> in all root files where I found it.

3. Updated database fine (I got all success messages) pointing to the browser.

4. Deleted DB updating file just in case.

5. Opened admin panel and saw FWR menu right there smiling at me.

6. Opened FWR menu and made first option True to make pop-up menu available.

 

7 Opened my site and didn't notice any changes (no pop-up menu when I move mouse over the categories folder).

8 Played with cash settings in FWR menu and sorting - didn't noticed any changes after refreshing the site.

No error messages.

 

Can it be my host limitation or something like that? (I tried to install Ultimate SEO URLs, but it didn't work because of my host limitation)

 

P.S. One more: If I set reset setting to true, it stays true even if I open/refresh the site. :(

 

Thanks for any help.

 

Mike

 

Interesting ..

 

Try this test .. in catalog/includes/application_top.php immediately above the closing ?> put ..

 

// REMOVE ME
if( isset($_GET['fwrtest']) ) {
 if ( defined('FWR_SUCKERTREE_MENU_ON') && FWR_SUCKERTREE_MENU_ON === 'true' ) {
die('The FWR menu is ON in admin');
 } else {
die('The FWR menu is OFF in admin');
 }
// REMOVE ME

 

Then access your site with www.mysite.com/index.php?fwrtest

 

And report what it prints (then remove the code)

}

Share this post


Link to post
Share on other sites

It prints Parse error: parse error, unexpected $ in /home/www/mydomain.com/includes/application_top.php on line 543

 

P.S. Thanks for so fast reply.

I didn't notice it rightaway, sorry.

 

I look on that code and to me it looks like it should show if option in menu set to true or not, but probably somewhere is the syntax error?

Edited by AlwaysNewbie

Computers777dotcom

Share this post


Link to post
Share on other sites
It prints Parse error: parse error, unexpected $ in /home/www/mydomain.com/includes/application_top.php on line 543

 

P.S. Thanks for so fast reply.

I didn't notice it rightaway, sorry.

 

I look on that code and to me it looks like it should show if option in menu set to true or not, but probably somewhere is the syntax error?

 

My apologies .. sloppy coding ..

 

// REMOVE ME
if( isset($_GET['fwrtest']) ) {
 if ( defined('FWR_SUCKERTREE_MENU_ON') && FWR_SUCKERTREE_MENU_ON === 'true' ) {
die('The FWR menu is ON in admin');
 } else {
die('The FWR menu is OFF in admin');
 }
}
// REMOVE ME

Share this post


Link to post
Share on other sites
The FWR menu is ON in admin

 

Ok good

 

In includes/column_left.php do you have ..

 

if(defined('FWR_SUCKERTREE_MENU_ON') && 'true' === FWR_SUCKERTREE_MENU_ON) {
include(DIR_WS_FUNCTIONS . 'fwr_categories.php');
} else
if ((USE_CACHE == 'true') && empty($SID)) {

Share this post


Link to post
Share on other sites
Ok good

 

In includes/column_left.php do you have ..

 

if(defined('FWR_SUCKERTREE_MENU_ON') && 'true' === FWR_SUCKERTREE_MENU_ON) {
include(DIR_WS_FUNCTIONS . 'fwr_categories.php');
} else
if ((USE_CACHE == 'true') && empty($SID)) {

 

Thank you for reply.

 

Yes, I have that code in the includes/column_left.php file.

 

(I thought you are in UK and sleep... expected to see ya morning :lol: :lol: :lol: )

 

P.S. Probably next question will be about 'fwr_categories.php' file if I follow...

Edited by AlwaysNewbie

Computers777dotcom

Share this post


Link to post
Share on other sites

Wait for a sec,

I looked at the file and saw that because I have STS installed, it's going to code only if STS is OFF (code placed in ELSE part of IF statement which checks if STS is on). So, I turned STS OFF and sure enough got this on a screen:

 

Warning: fopen(/cache/1_categories.ser): failed to open stream: No such file or directory in /home/www/mydomain.com/includes/functions/fwr_cat_functions.php on line 118

Couldn't fopen _categories.ser.ser

 

Looks like it didn't created file or something.

Edited by AlwaysNewbie

Computers777dotcom

Share this post


Link to post
Share on other sites

I made it! :lol:

 

I realised that because I use STS, I should make the same changes in sts_column_left.php file.

I made changes and it worked perfectly. I changed also settings to write file in root directory, because for some reason it couldn't write to file in cache directory despite I set 777 for the folder.

 

Thank you so much for help!

 

Mike


Computers777dotcom

Share this post


Link to post
Share on other sites
I made it! :lol:

 

I realised that because I use STS, I should make the same changes in sts_column_left.php file.

I made changes and it worked perfectly. I changed also settings to write file in root directory, because for some reason it couldn't write to file in cache directory despite I set 777 for the folder.

 

Thank you so much for help!

 

Mike

 

Glad you got it going.

Share this post


Link to post
Share on other sites

Hi, is there any way it show sub categories to column_left? because I have my top-categories in header. Thanks!

Share this post


Link to post
Share on other sites
Hi, is there any way it show sub categories to column_left? because I have my top-categories in header. Thanks!

 

Currently no.

Share this post


Link to post
Share on other sites

When I enable FWR Menu I get the following error on the home page under the header were the categories should be: Couldn't fopen _categories.ser.ser

Edited by Windows

Share this post


Link to post
Share on other sites
When I enable FWR Menu I get the following error on the home page under the header were the categories should be: Couldn't fopen _categories.ser.ser

 

That just means that the filepath to the _categories.ser file is incorrect

 

Try using the standard osc cache path

Share this post


Link to post
Share on other sites

Thats it working now thanks!

 

The categories menu is upside down now? when I change it to sort_order and rebuild the menu it just mixed up? Is there a way to have the category listed in alphabetical order as it was before?

Share this post


Link to post
Share on other sites
Thats it working now thanks!

 

The categories menu is upside down now? when I change it to sort_order and rebuild the menu it just mixed up? Is there a way to have the category listed in alphabetical order as it was before?

 

 

Try changing ..

 

catalog/includes/fwr_cat_functions.php

ORDER BY c.parent_id, $order_by, cDescr.categories_name

 

To ..

 

ORDER BY cDescr.categories_name, c.parent_id, $order_by

Share this post


Link to post
Share on other sites
Since I enebaled cache my search box has dissapeared, it reapears when I set use cache to false?

 

That is not related to this contribution, the cache is a standard osc function. this contribution goes nowhere near the search box.

 

And you didn't need to enable the osc cache just set the menu system to use the cache path.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hi I just tried changing the code in fwr_cat_functions.php and reset the menu, it doesnt change c.sort_order, but it lists all the sub categories as the main category when I chose c.categories_id.

 

I dont have cache enabled in the shop, but it does seem when you use the cache for this contribution, the search box dissapears, same when you switch on cache, must be some bug in oscommerce?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×