Jump to content
Sign in to follow this  
madsci

Fix for missing First Class International

Recommended Posts

Looks like the API changed again, and for once I remembered to test it. I found only first-class international missing, but I didn't check all methods, just the ones I used. The fix was to replace "First-Class Mail International" with "First Class Mail International Package" (note the missing dash and addition of 'package'), in /catalog/includes/modules/shipping/usps.php. Hope that helps someone.

Share this post


Link to post
Share on other sites
Looks like the API changed again, and for once I remembered to test it. I found only first-class international missing, but I didn't check all methods, just the ones I used. The fix was to replace "First-Class Mail International" with "First Class Mail International Package" (note the missing dash and addition of 'package'), in /catalog/includes/modules/shipping/usps.php. Hope that helps someone.

 

This is part of the answer but not quite it totally. First Class Mail International Package returns a mailing cost of $8.60 for less than one ounce.

Share this post


Link to post
Share on other sites

According to the email that I received from USPS, there are actually 3 First Class Mail International formats now: Letter, Flat, and Parcel, which would explain the high cost for 1oz. at the package price. I'm sure the Letter option is less...


Mike Greenleaf

CCG Realm

 

The trust of the innocent is the liar's most useful tool. - Stephen King

Share this post


Link to post
Share on other sites
According to the email that I received from USPS, there are actually 3 First Class Mail International formats now: Letter, Flat, and Parcel, which would explain the high cost for 1oz. at the package price. I'm sure the Letter option is less...

 

How could you have all three options available?

Share this post


Link to post
Share on other sites

Just to backup the quick fix to get USPS First Class International up and running, anywhere in the includes/modules/shipping/usps.php file where it says

'First-Class Mail International' should be changed to

'First Class Mail International Package'

 

Make sure the dash is taken out of the word: First Class.

 

The difference between Letter, Large Enveloped (Flats), and Packages is the following:

  • A letter is just paper correspondence in a small envelope. It only goes up to 3 ounces.
  • A Large Envelope is like a letter where it needs to be flat, like paper, but can be put into a large envelope. Like a 9x11 manila envelope. There should be no lumps or unevenness in the Envelope - needs to be flat and uniform - but can be up to 4 lbs.
  • A Package is anything up to 4 lbs. Including a box or a lumpy envelope.

I use Package for all purposes of shipping due to the nature of our products (they are lumpy.) It is totally confusing to offer three types, and if I could get my hands on the guy whom decides these things at USPS, Id give him a wedgie like no other. More on Int. First Class here:

 

http://www.usps.com/prices/first-class-mai...onal-prices.htm

 

If you need all three, you may think of installing the latest contribution to this module. But the quick fix above should get your international customers Int. First Class choice again.

 

I hope this helps.

Share this post


Link to post
Share on other sites

Thanks much for this fix!!

 

Please - anyone - let us know if you come up with additional fixes. Looking at a couple of the other threads, domestic Priority and Parcel Post may be messed up, too. Also, while most of mine are packages, there are occasions where I would use First Class Letter where it's thin enough to fit through the Postal worker's test slot.

 

USPS e-mailed me about the possible API changes implying that nothing would be affected. After the last fiasco (Uppercase-lowercase changes), though, I figured this would mess things up. :angry:

Edited by TomB01

Share this post


Link to post
Share on other sites

In the usps.php file I was able to edit this line:

 

 

$this->FirstClassIntType = 'Package'; //OPTIONS: 'Letters', 'Package', 'Large Envelope'

 

I can set it to Package and to Large Envelope, but Letters doesn't work????

 

 

Any ideas?


Howard Moscovitz

Share this post


Link to post
Share on other sites
Looks like the API changed again, and for once I remembered to test it. I found only first-class international missing, but I didn't check all methods, just the ones I used. The fix was to replace "First-Class Mail International" with "First Class Mail International Package" (note the missing dash and addition of 'package'), in /catalog/includes/modules/shipping/usps.php. Hope that helps someone.

 

Hi,

 

I tried changing this in the code and in the SQL db and nothing. I have USPS Methods 4.1 installed. First Class Domestic and International do not show up for me. Any help will be very much appreciated. Thank you.

Share this post


Link to post
Share on other sites
Hi,

 

 

 

I tried changing this in the code and in the SQL db and nothing. I have USPS Methods 4.1 installed. First Class Domestic and International do not show up for me. Any help will be very much appreciated. Thank you.

 

I had the same problem. To fix you need to do the following:

1) download , install USPS Methods 4.1 Beta - simple install and has the may 12th First class int fix

http://www.oscommerce.com/community/contri...ch,USPS+Methods

2) Update options in: includes\modules\shipping\usps.php

Look for FirstClassIntType update to Package as below :

/ /FIRST CLASS MAIL INTERNATIONAL OPTION:

$this->FirstClassIntType = 'Package'; //OPTIONS: 'Letters', 'Package', 'Large Envelope'

 

Done!

Edited by peachc

Share this post


Link to post
Share on other sites
Looks like the API changed again, and for once I remembered to test it. I found only first-class international missing, but I didn't check all methods, just the ones I used. The fix was to replace "First-Class Mail International" with "First Class Mail International Package" (note the missing dash and addition of 'package'), in /catalog/includes/modules/shipping/usps.php. Hope that helps someone.

 

How do you get into this to make these changes, could you help me??? My we guy is sick and unable to get this corrected for me at this time. Thanks Dan

Share this post


Link to post
Share on other sites

1st class international is STILL not working for me. I've uploaded 4.1.2 file, made changes to the wording on the 1st class intl. postage in usps.php as suggested and still can't get it to be added as a shipping option (though it shows up in my module, it isn't being offered to my customers, just priority) Any ideas? HELP

Share this post


Link to post
Share on other sites
1st class international is STILL not working for me. I've uploaded 4.1.2 file, made changes to the wording on the 1st class intl. postage in usps.php as suggested and still can't get it to be added as a shipping option (though it shows up in my module, it isn't being offered to my customers, just priority) Any ideas? HELP

You may need to delete and re-install the module via Admin (or delete and re-create the database), not just replace the file, to get the changes to work. Otherwise (someone correct me if I'm wrong), the database may not be fully updated.

Edited by kymar

Share this post


Link to post
Share on other sites

Anybody ever find a fix to this? I'm having the same issues with a current install. Using 4.2.1 changed to 'First Class Mail International Package' still getting no option for this method, and it's the only method I want to use for international.

Share this post


Link to post
Share on other sites

Was a real fix for this ever found?

 

I am also getting everything correctly EXCEPT for the First Class International Package.

 

I don't understand the post about the database :blush: , if that has helped others to get it fixed, can someone please tell me step by step how to do it?

 

Thanks :huh:

 

 

Oh, using 4.3.0 ALPHA

Edited by NothingButRomance

Share this post


Link to post
Share on other sites

Has this problem ever been solved? I tried fixing the usps.php with the correct wording as well, and First Class International and First Class Domestic are still not showing up...

Share this post


Link to post
Share on other sites

I just was informed of this problem today and was able to fix mine quickly so now First Class international is a choice again.

The usps.php file should read:

 

'FIRST-CLASS MAIL INT' => 'First-Class Mail International Package');

 

They added a - in between First Class. Seems usps is trying every configuration of this darn line. LOL

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×