Latest News: (loading..)
Sign in to follow this  
Followers 0
Mitchell69

Importing MySQL data from the 2.1 to the 3!

7 posts in this topic

Hi,

 

Any idea if or how I can import old database before 2003 (2.1) to the latest one without loosing all data?

 

Many thanks in advance

Mitchell

Share this post


Link to post
Share on other sites

Shouldnt be a problem.

 

The upgrade path is in each package, usually in the extras directory.

 

You might have to do it in a few stps depending on how old your orig package is.

Edited by geoffreywalton

Share this post


Link to post
Share on other sites
Shouldnt be a problem.

 

The upgrade path is in each package, usually in the extras directory.

 

You might have to do it in a few stps depending on how old your orig package is.

 

 

Thanks for the quick reply, I will start the website fresh, so I do not need to upgrade the actual script but as I have a huge database only want to upgrade the database.

It seem to be very hard to manualy do it, is there any easy way to just uograde the MYSQL?

 

Many thanks in advance

Mitchell

Share this post


Link to post
Share on other sites

Did you look in the extras directory?

 

2.2 has \extras\pr21_to_pr22

Share this post


Link to post
Share on other sites
Did you look in the extras directory?

 

2.2 has \extras\pr21_to_pr22

 

Yes I did but I couldn't find any help how to upgrade the database!

Are you sure it is there?

Cheers

Mitchell

Share this post


Link to post
Share on other sites
Yes I did but I couldn't find any help how to upgrade the database!

Are you sure it is there?

Cheers

Mitchell

 

I was just wondering about this. I have just downloaded OSC 3.0a4 and I want to upgrade my database to work with it. I checked the download and I dont have an extras folder or anything I can see that will upgrade the database.

 

What has everyone else done that has used version 3.0 a4

 

Thanks

Share this post


Link to post
Share on other sites
What has everyone else done that has used version 3.0 a4

 

I've knocked up a quick script that works for me, it's available here:

http://codeworks.gnomedia.com/update_from_2.2.phps

 

But this is really rough and ready, you're welcome to try it and let me know if it works for you. And if it doesn't, what the problems are.

 

In particular, the images and the languages need some work...

 

cheers

jalal

Edited by jalal

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0