Jump to content
Sign in to follow this  
souzadavi

FULL PORTUGUES LANGUAGE BRAZILIAN - COMPLETO BRASILEIRO

Recommended Posts

Respondendo as minhas próprias dúvidas...

 

1. Precisei alterar o endereço HTTPS diretamente nos arquivos do oscomerce, pois, não achei opção no site Admin.

 

2. Descobri que o erro estava relacionado ao momento em que o site tentava mandar um e-mail (o erro ocorria em todas as telas que eu tentasse enviar um), como meu provedor requer autenticação, instalei um Addon para fazer isto e deu certo.

 

3. Faltavam os campos refenciados no banco de dados, foi só criar os mesmos e pronto.

 

Até.

 

use assim:

 

define('HTTP_SERVER', 'http://blended.com.br/loja/'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'http://blended.com.br/loja/'); // eg, https://localhost - should not be empty for productive servers

 

e retire os lojas do outros lugares.. veja s eda certo...


Davi S Souza

Share this post


Link to post
Share on other sites

PESSOAL Q ESTA PROCURANDO MEU MSN:

 

MEU EMAIL E MSN é contato@linknacional.com.br - fico online todos os dias de segunda a sexta feira das 9 as 18 horas.

 

GTALK - souzadavi2@gmail.com - mesmo horário

 

skype: souzadavi - mesmo horário

 

 

 

vai rolar uma PALESTRA OSCOMMERCE na php conference 2008 em são paulo, vale a pena quem quiser ir da um pulo la...

 

http://www.phpconf.com.br/

 

 

vai ser dia 29/11/2008 no sábado as 11:30 - http://www.phpconf.com.br/publico/dia29.php

conteúdo da palestra - http://www.phpconf.com.br/publico/palestra...stras.php?id=26

 

tenho 2 cortesias caso alguem tenha interesse entre em contato

 

 

OBRIGADO AI PELA COLABORAÇÃO DE TODOS NA TRADUÇÃO... até o fim do ano de 2008 irá sair uma nova versão....


Davi S Souza

Share this post


Link to post
Share on other sites

Ola Davi,

Não tenho duvidas, mas estou escrevendo para te agradecer em nome de todos os membros do fórum por suas colaborações e por seu espírito maravilhoso de compartilhar o saber. Eu sou grato para sempre de tudo que eu aprendi com você.

Valeu Davi .

Abraços.

SBNET

Share this post


Link to post
Share on other sites

Ola, obrigado pela colaborção Davi, só tenho um probleminha, os pedidos só aparecem se eu por a linguagem em ingles, se alguem puder me ajudar, eu só estou conseguindo atualizar os pedidos em ingles, que manda um email em ingles para o comprador dai.

Share this post


Link to post
Share on other sites

Olá. instalei o osCommerce, coloquei seus arquivos e rodei o sql, a codificação ficou errada(ISO-8859-1), eu alterei ela no arquivo portugues.php pra UTF-8 mas ainda continua com a mesma codificação, como último recurso eu converti todos os seus arquivos pra utf-8 com o iconv mas mesmo assim continua o problema, o que pode ser?

Share this post


Link to post
Share on other sites
Ola, obrigado pela colaborção Davi, só tenho um probleminha, os pedidos só aparecem se eu por a linguagem em ingles, se alguem puder me ajudar, eu só estou conseguindo atualizar os pedidos em ingles, que manda um email em ingles para o comprador dai.

 

 

olá, seguinte tente isso aconteceu so nos produtos padrão q veio ja com o SQL??

 

tente cadastrar novas categorias e novos produtos e veja se resolve, eu vi este bug e fiz isso, cadastrei uma categoria nova e um produto nova,,, dai resolveu o problema....

 

 

quem sabe na próxima atualização este bug seja eliminado....

 

vlw davi


Davi S Souza

Share this post


Link to post
Share on other sites

Os produtos padão q veio com o SQL eu apaguei, foi nos novos produtos, mas não chega a prejudicar muito, tudo se resolve. Vamos esperar a proxima atualização!

Share this post


Link to post
Share on other sites

Olá pessoal

 

Eu baixei a versão completa do Oscommerce que o Davi colocou para download, e está tudo bem, no começo ocorreu um erro quando eu entrava em "comentários" no painel de admin, nem dava para deletar o comentário demo do SQL, então deletei direto no PhpMyAdmin e deu certo.

 

Agora estou com uma certa dúvida, na home da loja tem um módulo "Novidades" onde estão aqueles produtos cadastrados? e como eu os edito? Eu clico neles e só aparece "Não encontrado!"

 

 

Alguma luz...

Share this post


Link to post
Share on other sites

Eu achei onde tem os produtos, bom, só achei no link "Produtos mais vistos" dentro do Admin, porem nao tem como editar, e nem tirar aquilo por lá. Alguém me da uma ajudinha, por favor... ;-)

 

 

Olá pessoal

 

Eu baixei a versão completa do Oscommerce que o Davi colocou para download, e está tudo bem, no começo ocorreu um erro quando eu entrava em "comentários" no painel de admin, nem dava para deletar o comentário demo do SQL, então deletei direto no PhpMyAdmin e deu certo.

 

Agora estou com uma certa dúvida, na home da loja tem um módulo "Novidades" onde estão aqueles produtos cadastrados? e como eu os edito? Eu clico neles e só aparece "Não encontrado!"

 

 

Alguma luz...

Share this post


Link to post
Share on other sites

Bom, não encontrei solução a não ser em deletar cada um via phpmyadmin, se alguém tiver alguma solução, ou algo contra, post aqui antes que eu comece esse destruição rs, Eu sou vô até a panificadora e volto. Vocês tem uns 20 min rs

Eu achei onde tem os produtos, bom, só achei no link "Produtos mais vistos" dentro do Admin, porem nao tem como editar, e nem tirar aquilo por lá. Alguém me da uma ajudinha, por favor... ;-)

Share this post


Link to post
Share on other sites

Para remover os Itens "NOVIDADES" que aparecem padrão no site basta entrar na linguagem original "English" e deletar de lá os produtos e as categorias padrões que não deseja. Após isso basta voltar para portugues e voltar ao normal. Não delete categorias e produtos em branco. Estes mesmo são os que você adicionou quando estava em portugues.

 

Recomendo fazer backup antes.

Share this post


Link to post
Share on other sites

Saudações a todos. Sou mais um novato no osCommerce. Acabei de baixar e instalar o OsCommercebr.

Após o processo de instalação um erro de login no MySql aparecia na \catalog\index.php. A entrada no \admin estava ok. Encontrei um oscommerce.sql no \install. Assim como nas versões anteriores deste add-on, importei o sql para dentro do banco.

\admin não mais existia o administrador cadastrado. O cadastramento novamente foi tranquilo e o logon ok. Mas o erro de login no Mysql continua quando carrego a página inicial da loja.

 

\catalog\includes\configure.php

Aparentemente este arquivo não foi alterado com as configurações da página de instalação.

 

Apenas uma dica. Após a extração dos arquivos para o diretório destino, alterar as permissões deste aquivo antes de executar a instalação.

 

Grato pela atenção,

Max.

Edited by maxk

Share this post


Link to post
Share on other sites

Amigos,

 

Fiz a instelação do OS commerce direto do painel da minha hospedagem...

 

Quando rodo o SQL, ele dá a seguinte msg:

 

Erro

consulta SQL:

INSERT INTO `orders_status` ( `orders_status_id` , `language_id` ,

VALUES ( 3, 4, 'Entregue' ) , ( 1, 4, 'Pendente' ) , ( 2, 4, 'Processando'

Mensagens do MySQL :

#1062 - Duplicate entry '3-4' for key 1

 

E não funciona em portugues...

 

Alguem pode me dar uma luz...?

Share this post


Link to post
Share on other sites
Amigos,

 

Fiz a instelação do OS commerce direto do painel da minha hospedagem...

 

Quando rodo o SQL, ele dá a seguinte msg:

 

Erro

consulta SQL:

INSERT INTO `orders_status` ( `orders_status_id` , `language_id` ,

VALUES ( 3, 4, 'Entregue' ) , ( 1, 4, 'Pendente' ) , ( 2, 4, 'Processando'

Mensagens do MySQL :

#1062 - Duplicate entry '3-4' for key 1

 

E não funciona em portugues...

 

Alguem pode me dar uma luz...?

Então...

 

Restaurei o backup e tirei todas as opções de linguagem, menos a ingles...

Num apareceu este problema mas não traduziu não...

 

Alguam dica?

Share this post


Link to post
Share on other sites

Oi Pessoal,

 

Antes de mais nada obrigado pela tradução.

 

Tenho algumas lojas instaladas com a versão Versão 2.2 MS2-BR e tradução da PHPMAnia e OmeuNuke. já fiz inclusive algumas contribuições para esta versão disponíveis aqui no fórum.

Recentemente entrei no site da osCommerce e baixei a nova versão RC2. Também no site da osCommerce baixei a tradução para o português do Brasil http://addons.oscommerce.com/info/5571 feita pelo Davi Souza.

Mas percebi que existem alguns bugs na tradução. O mais chato é o fato dos produtos e categorias sumirem (apesar do total de produtos aparecer) da caixa "categorias" quando se troca o idioma para o português. Tentei apagar todos os produtos, criar novas categorias e inserir novos produtos em português, funcionou para a o idioma português, mas quando mudo para o idioma inglês os produtos somem novamente.

Analisei a tradução e percebi que muitos arquivos estão com linhas e variáveis diferentes dos mesmos arquivos nos idiomas padrão (english, espanol, german) da loja. A tradução do arquivo "includes/languages/portugues.php" inclusive tem a definição de várias variáveis que não existem nos arquivos originais. Apaguei o aqrquivo "includes/languages/portugues.php" e todos os arquivos da pasta "includes/languages/portugues" do servidor, fiz uma cópia do arquivo "includes/languages/english.php" e de todos arquivos da pasta "includes/languages/english", refiz então as traduções dos arquivos e os salvei como um novo idioma (portugues), fiz o upload e atualizei o banco pelo admin, mas ainda não deu certo.

Alguem sabe como resolver este problema?

 

[]s,

 

Luiz


LACA - Internet & Multimídia

Share this post


Link to post
Share on other sites

souzadavi,

 

Ao inves de abrir o arquivo SQL, copiar e rodar, eu importei o arquivo no menu Importar da minha area phpmyadmin.

 

O site ficou em portugues e com a moeda real como alternativa, alem das moedas: Dollar e Euro, e tambem com as linguagens originais: ingles, espanhol e alemao como alternativa.

 

Gostaria de saber se isso já resolve, já que se tem a possibilidade de mudar a linguagem e a moeda, ou é preciso rodar o codigo do arquivo SQL mesmo? Parece que assim vai deixar o site apenas em portugues, ou estou errado?

 

Abraço,

Thompson

Share this post


Link to post
Share on other sites

Oi Pessoal,

 

Estou de volta para informar que descobri o problema.

Trata-se da tradução dos arquivos da pasta admin que, nesta tradução do Davi, foi feita sem levar em conta as mudanças da RC2. Assim, para resolver o problema fiz o mesmo que já havia feito com os arquivos da loja. Ou seja uma revisão completa com exclusão das variáveis que estavam obsoletas e inclusão das novas variáveis. Até mesmo arquivos novos como login.php estavam faltando. Agora está tudo beleza.

 

[]s,

 

Luiz


LACA - Internet & Multimídia

Share this post


Link to post
Share on other sites

Ola Davi, Apaguei duas linguas em meu site e deixei apenas a em inglês porém estou traduzindo ela

para o português, também deixei apenas uma moeda, o real, porém agora os valores só aparecem

como 0,os valores só mudam quando escolhemos a moeda manualmente, mesmo assim quando clicamos

em qualquer link o problema retorna.

Como corrigir o problema sem re-instalação?

 

Obrigado

Share this post


Link to post
Share on other sites

Ola para todos da comunidade é o seguinte em varias vezes eu tive problemas com a tradução nao qual onde apos instalado ocorria erros na consulta dai procurei na net e exemplos demonstrativos na web tmbem estavam com o mesmo problema dai eu resolver procurar como resolver esse problema onde

 

quando se busca um palavra somente exemplo'amor' nao exibia nada, e se se buscavamos por algo com mais de 1 palavra como 'velocidade maxima', dava o erro 1064 e dai depois de procurar e perceber q o erro so ocorria na tradução vi que tem um parametro q foi traduzido no banco de dados que nao poderia ser traduzido e aqui posto o que resolveu meu problema:

 

antes de realizar a inserção dos dados no banco va ao arquivo 'SQL_POTUGUES.sql', procure por:

 

(14,'Operador Padrão de Buscas','ADVANCED_SEARCH_DEFAULT_OPERATOR','e','Operadores padrão de buscas',1,17,NULL,'2007-11-22 10:27:34',NULL,'tep_cfg_select_option(array(\'e\', \'ou\'), '),

 

e modifique por:

 

(14,'Operador Padrão de Buscas','ADVANCED_SEARCH_DEFAULT_OPERATOR','and','Operadores padrão de buscas',1,17,NULL,'2007-11-22 10:27:34',NULL,'tep_cfg_select_option(array(\'and\', \'or\'), '),

 

ou voce pode ja ter inserido e encontrado o erro , se ja tiver inserido todo o arquivo SQL, va ao phpmyadmin, entre no banco da loja e vá a tabela 'configuration' e depois procure pela 'configuration_id' que seja igual a 14 e o 'configuration_title' esteja como "Operador Padrão de Buscas" entao edite as seguintes colunas:

 

'configuration_value' onde se encontra 'e' modifique para 'and'

'set_function' onde se encontrar "tep_cfg_select_option(array('e', 'ou')," modifique para "tep_cfg_select_option(array('and', 'or'),"

 

Espero que tenha ajudado,

Qualquer duvida entra em contato,

 

Abraços

Share this post


Link to post
Share on other sites

Olá!

 

Eu baixei e instalei a loja virtual que está funcionando sem problemas.

 

Apenas tenho algumas dúvidas de configuração.

 

Entre as opções de pagamento, aparece o depósito em conta corrente, mas com os dados de uma outra pessoa. Como posso fazer para alterar?

 

É possível incluir novas formas de pagamento e envio? Eu, por exemplo, trabalho com entrega direta no caso da cidade do Rio de Janeiro (sem frete) e gostaria de incluir esta opção para os meus clientes.

 

No mais, obrigado pela ajuda!

 

A minha loja, caso queira ver o resultado é a seguinte: http://www.beautylife.netrenda.com/loja

 

Abraços.

Share this post


Link to post
Share on other sites

Ola pessoal preciso de ajuda.

 

Eu mudei o locale do meu site de Ingles Americano para Portugues Brasileiro. Dai eu instalei o PayPal pagamento de website diret, o problema e que quando for apgar com cartao de credito no meu sire o campo do "Mes" fica aparecendo os nomes dos meses com a inicial minuscula tipo "janeiro", como que eu faco para que os meses no Drop-Down Menu fiquem com a inicial maiuscula "Janeiro" "Fevereiro" etc...

 

Valeu!

Edited by RiseAgainst

Share this post


Link to post
Share on other sites

hi guys, como faço para ajudar na tradução, não sou muito bom em programação, mas arranho umas linhas.

 

enfim estou querendo contribuir, como funciona a colaboração svn?

 

Halison

web@halison.net

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×