Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

That's just the link to some options. The main section of code is accessed via its own link. Maybe looking at the included screenshot would help?

 

Jack

Share this post


Link to post
Share on other sites

I see what your referencing now, thank-you for the help! It seems like its going to be easier to do a clean store install than to continue looking for my omission. Does the contribution (new store files) have the changes already made to the catalog and admin files or will I be modifying them as I did on my original store?

Share this post


Link to post
Share on other sites

It has some of the files. The index.php, product_info.php and stylesheet.css changes are not included since they vary so much from site to site.

 

Jack

Share this post


Link to post
Share on other sites

Thank-you Jack,

After attempting to create and use my own store I have developed a respect for all who are involved with creating and helping to make OSCommerce what it is. I can't even fathom the hours of work collectively put into this. Your contribution alone is simply amazing. This is quite the community!

Share this post


Link to post
Share on other sites
Are you using V 1.7_1 of articles manger? If so, what are you typing in as the pseudo page.

 

Jack

 

 

Jack,

 

I have tried all 3 combinations as follows:

 

http://mywebsite.com/articles_tpath-3.html

/articles_tpath-3.html

articles_tpath-3.html

 

 

I have checked my directer in ftp and the files are present for exmaple. Another example would be:

 

http://mysite.com/music-earplugs.html

 

the file is definately there.

 

Regarding the verison I only installed it begining of Jan.

 

Hope that helps. Peter.


I have built an online store solely with the help of this forum.

Share this post


Link to post
Share on other sites

The instructions say to enter a pseduo page in the form of article_info.php?articles_id=2 and explains how to determine that. Perhaps reading those will help? For the version, it doesn't necessarily matter when you installed it, just which version you actually installed.

 

Jack

Share this post


Link to post
Share on other sites
Hello.

 

firt of all thanks a lot for this contrib so usefull!

 

I was wondering if it was possible to have different tag and header for the index.php and Index.php?cPath=... or other.

 

I mean tha the "real" index would have his own header tags and metas. and the categories would react as now.

 

I gess it's not that hard but as I'm not good a codding for me it's just impossible ^^.

 

Thanks again.

Year

 

Hello again

 

Let me re-explain my probleme with ax exemple:

 

I'd like to have in my index.php a META like that:

 

<meta name="Keywords" content="hardware, software, etc..." >

 

and in my index.php?cpath=1 a META like that:

 

<meta name="Keywords" content="ram, disque, motherboard,...">

 

I don't see how it already work's like that but I might have overlooked.

 

thanks again for your work.

Share this post


Link to post
Share on other sites

Hi I installed the latest sts on my rc2 oscommerce store then i installed head tags seo problem is when i activate sts the store has the following error

 

Fatal error: Cannot redeclare tep_header_tag_page() (previously declared in /home/saupe1/public_html/bargainscrazy/electrical/includes/functions/header_tags.php:15) in /home/saupe1/public_html/bargainscrazy/electrical/includes/functions/header_tags.php on line 50

 

This is strange as when i switch sts off it works fine, anyone got any ideas why?


I could only ever afford cars under £500 but now i am moving up in the world.

Share this post


Link to post
Share on other sites
Hi I installed the latest sts on my rc2 oscommerce store then i installed head tags seo problem is when i activate sts the store has the following error

 

Fatal error: Cannot redeclare tep_header_tag_page() (previously declared in /home/saupe1/public_html/bargainscrazy/electrical/includes/functions/header_tags.php:15) in /home/saupe1/public_html/bargainscrazy/electrical/includes/functions/header_tags.php on line 50

 

This is strange as when i switch sts off it works fine, anyone got any ideas why?

 

 

You did not follow the STS instructions for installing with HTC SEO.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hello again

 

Let me re-explain my probleme with ax exemple:

 

I'd like to have in my index.php a META like that:

 

<meta name="Keywords" content="hardware, software, etc..." >

 

and in my index.php?cpath=1 a META like that:

 

<meta name="Keywords" content="ram, disque, motherboard,...">

 

I don't see how it already work's like that but I might have overlooked.

 

thanks again for your work.

Set the first in Page Control for index.php. Set the second in admin->Catalog by editing the category.

 

Jack

Share this post


Link to post
Share on other sites

first, thanks for this great contribution, I guess that was a lot of work.

 

until now I was using an older version of htc now I installed just to manage the information pages from (information pages unlimited contribution) and stay up to date. I use the version HeaderTags_SEO_V_3.1.0-1. After installation i tried to add a pseudo page information.php?info_id=16 and it didnt work, the information.php was recognized by the script and the titles i set there were correctly shown. so i searched within this thread and found an other person who changed this line in header_tags_seo.php:

 

else if (($result = FileNotUsingHeaderTags($parts[0])) === 'FALSE')

 

to

 

else if (($result = FileNotUsingHeaderTags($parts[0])) === 'TRUE')

 

so i changed that line. after this change i was able to add the pseudo page, and set the title, also the title is stored in the database correctly. but not in the title tag I changed the sort orders and tried a lot of combinations, no chance. after i added a second pseudo information page and set the title there, it took the changes and showed the title tag i added, but the problem is, now the title of this information page is shown on all other information pages. the root information.php has no individual titles only the pseudo pages but all pseudo pages got the same title in output, not in the database, there the titles are differrent for each page, like it should be.

 

sorry for my bad english i hope you could understand what I mean. may someone got input for me, I use STSv4.5.8 and followed the instructions for this also I use Ultimate SEO URLs v2.6 and Information Pages Unlimited v2.04.7

Edited by straka

Share this post


Link to post
Share on other sites
You did not follow the STS instructions for installing with HTC SEO.

 

Do you mean this

 

1A) ********* FOR STS USERS ONLY *********

 

STS should be installed first. Upload the file located in the STS_Only

directory of this archive to the same location on your server. Then goto

admin->Modules->STS and edit the default module. In the

"Files for normal template box," make the following change and then proceed

with the rest of the installation, starting at Step 2.

 

sts_user_code.php

 

to

 

sts_user_code.php;headertags.php

 

because i did this?


I could only ever afford cars under £500 but now i am moving up in the world.

Share this post


Link to post
Share on other sites
first, thanks for this great contribution, I guess that was a lot of work.

 

.......

 

Ok i found the failure, it was my mistake, I got a Box whos generated by information pages, there is set the info_id static, so every time i loaded the site info_id was still the same :lol:

 

great contribution and support, thanks for all your effort, now it works perfect

Share this post


Link to post
Share on other sites

hi all, jack you have been very helpful brfore, please i hope you or someone can help me again, i amguessing this is a header seo feature seeing is in my headers, but only shows up as a title when i have sbcategories... see photo of extra php ending ?> where should i look to remove???do i need to copy over code for you to see my error on a particular page ie header tags??? please help... i'm so close to being done!

 

help.jpg

Share this post


Link to post
Share on other sites

i guess index.php use a ide who check your code and show you the error lines

Share this post


Link to post
Share on other sites
hi all, jack you have been very helpful brfore, please i hope you or someone can help me again, i amguessing this is a header seo feature seeing is in my headers, but only shows up as a title when i have sbcategories... see photo of extra php ending ?> where should i look to remove???do i need to copy over code for you to see my error on a particular page ie header tags??? please help... i'm so close to being done!

It means a mistake was made with the edits of the index.php file. You missed or added a php delimiter. The easiet approach is to start over with that file, making changes one at a time and checking the file after each change.

 

Jack

Share this post


Link to post
Share on other sites

i found where the exta ?. shows up in the idex file... here is my htp code

<td><h1></h1></td>

<td class="pageHeading" align="right"><img src="images/category_hardware.gif" border="0" alt="Hardware" title=" Hardware " width="57" height="40"></td>

</tr>

?>

</table></td>

</tr>

<tr>

<td><img src="images/pixel_trans.gif" border="0" alt="" width="100%" height="10"></td>

</tr>

 

it is right in the added header tag around line 78 that i copied in via the install file...

 

<?php /*** Begin Header Tags SEO ***/ ?>

<td><h1><?php echo $category['categories_htc_title_tag']; ?></h1></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

<?php if (tep_not_null($category['categories_htc_description'])) { ?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td colspan="2"><h2><?php echo $category['categories_htc_description']; ?></h2></td>

</tr>

<?php }

/*** End Header Tags SEO ***/

?>

 

i see the extra expressed out via html, that i would be able to just delete, but i do not know how to delete it from here (php)b/c i do not see it... what am i not seeing, or could it be still somewhere else in the index file???

Share this post


Link to post
Share on other sites
The instructions say to enter a pseduo page in the form of article_info.php?articles_id=2 and explains how to determine that. Perhaps reading those will help? For the version, it doesn't necessarily matter when you installed it, just which version you actually installed.

 

Jack

 

 

Thanks again for the prompt reply. Apologies should have checked the details more carefully - it worked once I read what to do :blush:

 

Regards. Peter.


I have built an online store solely with the help of this forum.

Share this post


Link to post
Share on other sites

I have some confusion over the install steps for STS with Header Tags SEO. I've installed OSC a few times successfully, and added contributions, but I have MUCH to learn and very much appreciate help with this.

 

I've installed OSC v2.2 RC2. Works fine.

I added STS. Works fine.

 

Header Tags SEO - updated the database successfully.

 

But now I'm confused. Installation instructions say "NOTE: If you have a clean shop, you can just copy all of the files in the directory named ... catalog_for_new_shop_only_RC2."

 

DO I have a clean shop? Or do I only copy the files that the STS install did not change? And then apply all the changes to individual files?

 

I've tried different combinations a few times. Admin side seems to work fine. But catalog (index.php) is not displaying at all. And I'm not very good at PHP (yet).

 

What's the best way to get these working together? Should I install Header Tags SEO first, and THEN STS?

 

Thank you SO much for helping... (I'm not even sure I put this question in properly ...)

Share this post


Link to post
Share on other sites

What constitutes a "clean shop" really depends on the contribution. A more correct wording would be if the files that are being uploaded have not been changed in your shop. But that would require checking each one so a more general reference is used. If you are not sure, the safest way to go is to make the changes as described in the install file. But if you upload files, you still have to make some changes that are mentioned in the install files. This is especially true for STS shops since different instructions are used.

 

Jack

Share this post


Link to post
Share on other sites

I've updated, very carefully I believe, from 3.04 to 3.10 following the update docs shown in the latest file.

But I'm getting the following error when going into SEO Header Tags in admin:

 

Warning: opendir(/mnt/w0503/d19/s34/b02d0062/www//s/catalog/) [function.opendir]: failed to open dir: No such file or directory in /mnt/w0503/d19/s34/b02d0062/www/mysite.com/s/catalog/admin/includes/functions/header_tags.php on line 15

Failed to open dir

 

Any clues?

 

I was having this issue before updating. Thought having the latest version might solve it.

Roger.

Edited by revenson

Share this post


Link to post
Share on other sites
Hi,

I have installed this fantastic contribution and everything seems to be working great. My question is is there a way to stop showing the sort when viewing multi pages of products? For example if someone wants to view page 2 of a list of products "sort_3a | page_2 |" is listed at the start of the title and meta tags.

 

Thanks

Scott

 

has anyone else delt with this before? It must be quite common, if I do a google search on "sort_3a" 78,000 hits to oscommerce stores our found.

 

I can normally work my way through code to find these sort of things, but this one has me stumped if anyone wants to check out a link I have a live sitehere

Share this post


Link to post
Share on other sites
I've updated, very carefully I believe, from 3.04 to 3.10 following the update docs shown in the latest file.

But I'm getting the following error when going into SEO Header Tags in admin:

 

Warning: opendir(/mnt/w0503/d19/s34/b02d0062/www//s/catalog/) [function.opendir]: failed to open dir: No such file or directory in /mnt/w0503/d19/s34/b02d0062/www/mysite.com/s/catalog/admin/includes/functions/header_tags.php on line 15

Failed to open dir

 

Any clues?

 

I was having this issue before updating. Thought having the latest version might solve it.

Roger.

There seems to be a problem with your configure files. Compare these from the errors:

/mnt/w0503/d19/s34/b02d0062/www//s/catalog/

/mnt/w0503/d19/s34/b02d0062/www/mysite.com/s/catalog/

 

You'll need to ask in the general forum for help in getting that fixed.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

 

As mentioned above by following your instructions I did actually manage to add pseudo pages to header tag seo for article manager. However I have noticed that there are a couple of pages that I cannot appear to add, see below:

 

article_info_articles_id-7.html

 

message

 

Entered pseudo page format, article_info_articles_id-7.html, is incorrect.

 

Please let me know if I am doing something wrong :blush:

 

Kind regards. Peter.


I have built an online store solely with the help of this forum.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×