Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

I need some help. I have just installed header tags and I cannot see the new title, "New Home Page Title".

 

I do not know how to fix this problem as I am still learning PHP.

Any help is greatly appreciated! I thank you all in advance!

 

Here are the results from the test,

 

Test Results

Missing Code in File

The Header Tags head code for the index.php file cannot be found.

The Header Tags head code for the product_info.php file cannot be found.

The Header Tags head code for the product_reviews.php file cannot be found.

The Header Tags head code for the product_reviews_info.php file cannot be found.

The Header Tags head code for the product_reviews_write.php file cannot be found.

The Header Tags head code for the specials.php file cannot be found.

Share this post


Link to post
Share on other sites
hello again, I decided to Replace it with the one included in RC2 Like you Said*

And back to My Admin- Catalog is Working NOW! I didn't try this from the begining bc i hav other contribution but i guess there's no problem ther

The included one is only for testing and finding problems unless you have a un-changed categories file. In your case, you can't run with it since it will cause your other contributions to not work.

 

Jack

Share this post


Link to post
Share on other sites
I need some help. I have just installed header tags and I cannot see the new title, "New Home Page Title".

 

I do not know how to fix this problem as I am still learning PHP.

Any help is greatly appreciated! I thank you all in advance!

 

Here are the results from the test,

 

Test Results

Missing Code in File

The Header Tags head code for the index.php file cannot be found.

The Header Tags head code for the product_info.php file cannot be found.

The Header Tags head code for the product_reviews.php file cannot be found.

The Header Tags head code for the product_reviews_info.php file cannot be found.

The Header Tags head code for the product_reviews_write.php file cannot be found.

The Header Tags head code for the specials.php file cannot be found.

You have to add code to the files, as explained in the install instructions. The test results is telling you that that hasn't been done. See the Install_Catalog.txt file where it says to add code to the head section.

 

Jack

Share this post


Link to post
Share on other sites
You have to add code to the files, as explained in the install instructions. The test results is telling you that that hasn't been done. See the Install_Catalog.txt file where it says to add code to the head section.

 

Jack

 

Thanks Jack, I completely missed that step.

I run the test and I thankfully have no problems listed there now.

 

My only issue however, is still that the header is not displayed in my index page... because of this,

header titles are also not displayed when browsing products by category or by manufacturer.

 

Any ideas?

Edited by aking02

Share this post


Link to post
Share on other sites

If you are using a standard shop and all of the changes have been made, it could be the database and/or includes/header_tags.php file that is preventing it. Try replacing that file and uninstall/install the database to see if it makes a difference.

 

Jack

Share this post


Link to post
Share on other sites

I have an install problem in catalog/admin/categories.php

 

I have already installed the 'categories images box' mod & I'm now getting a syntax error when I try to enter the catalog section in my site admin - error is Parse error: syntax error, unexpected ',' in /catalog/admin/categories.php on line 84

 

 

Code changes for the 'categories images mod' are:

// Start Categories images box
         $categories_description_front_array = $_POST['categories_description_front'];
         $sql_data_array = array ('categories_name' => tep_db_prepare_input ($categories_name_array[$language_id] ),
                                  'categories_description_front' => tep_db_prepare_input ($categories_description_front_array[$language_id] ) );
// End Categories images box

 

 

Code changes required for 'Header tags SEO mod' are:

FIND (around line 72)

 

$sql_data_array = array('categories_name' => tep_db_prepare_input($categories_name_array[$language_id]));

 

REPLACE with

 

/*** Begin Header Tags SEO ***/
     $sql_data_array = array('categories_name' => tep_db_prepare_input($categories_name_array[$language_id]),
          'categories_htc_title_tag' => (tep_not_null($categories_htc_title_array[$language_id]) ? tep_db_prepare_input($categories_htc_title_array[$language_id]) :  tep_db_prepare_input($categories_name_array[$language_id])),
          'categories_htc_desc_tag' => (tep_not_null($categories_htc_desc_array[$language_id]) ? tep_db_prepare_input($categories_htc_desc_array[$language_id]) :  tep_db_prepare_input($categories_name_array[$language_id])),
          'categories_htc_keywords_tag' => (tep_not_null($categories_htc_keywords_array[$language_id]) ? tep_db_prepare_input($categories_htc_keywords_array[$language_id]) :  tep_db_prepare_input($categories_name_array[$language_id])),
          'categories_htc_description' => tep_db_prepare_input($categories_htc_description_array[$language_id]));
     /*** End Header Tags SEO ***/

 

 

How should I combine these?

 

I've tried various ways of doing this & the best that I can figure out is:

 $categories_description_front_array = $_POST['categories_description_front'];
     $sql_data_array = array ('categories_name' => tep_db_prepare_input($categories_name_array[$language_id]),
          'categories_description_front' => tep_db_prepare_input($categories_description_front_array[$language_id])),
          'categories_htc_title_tag' => (tep_not_null($categories_htc_title_array[$language_id]) ? tep_db_prepare_input($categories_htc_title_array[$language_id]) :  tep_db_prepare_input($categories_name_array[$language_id])),
          'categories_htc_desc_tag' => (tep_not_null($categories_htc_desc_array[$language_id]) ? tep_db_prepare_input($categories_htc_desc_array[$language_id]) :  tep_db_prepare_input($categories_name_array[$language_id])),
          'categories_htc_keywords_tag' => (tep_not_null($categories_htc_keywords_array[$language_id]) ? tep_db_prepare_input($categories_htc_keywords_array[$language_id]) :  tep_db_prepare_input($categories_name_array[$language_id])),
          'categories_htc_description' => tep_db_prepare_input($categories_htc_description_array[$language_id]));

 

Line 84 is this one:

'categories_description_front' => tep_db_prepare_input($categories_description_front_array[$language_id])),

 

 

Can anybody help?

Share this post


Link to post
Share on other sites
If you are using a standard shop and all of the changes have been made, it could be the database and/or includes/header_tags.php file that is preventing it. Try replacing that file and uninstall/install the database to see if it makes a difference.

 

Jack

 

 

Hi Jack,

so i have uninstalled the database sql, and i have reinstalled the header_tags.php in the includes dir.

 

I am seeing some progress as now when I view my index page i see "New Home Page Title" located within the mozilla tab in my web browser.

 

I do not see "New Home Page Title" written in the actual page.

Share this post


Link to post
Share on other sites

It's not there. Go to admin->Header Tags SEO->Page Control and select index.php from the menu.

 

Jack

Share this post


Link to post
Share on other sites
It's not there. Go to admin->Header Tags SEO->Page Control and select index.php from the menu.

 

Jack

 

 

Hi Jack,

If you click on my site http://www.apparelking.ca you will not see heading located in the center table of the page.

The heading for the product info are present. But not the headings for the index.php

In the seo tags control page I can change the header tags you see in the tabs of the browser..

But i have no option to edit headers located in the center table... or maybe I do have the option and I am just too much of a rookie to see them LOL

Share this post


Link to post
Share on other sites

It appears the page headnig code is missing. Did you make all of the changes mentioned in the Install_Catalog.txt file for the index.php file?

 

Jack

Share this post


Link to post
Share on other sites
It appears the page headnig code is missing. Did you make all of the changes mentioned in the Install_Catalog.txt file for the index.php file?

 

Jack

 

I have actually added everything from scratch using MS2. And also went through it manually just to be sure.

I did not see any missing codes, nor any codes that shouldn't be there.

 

To be more specific, these heading titles are not being shown for each language. Everything else on the site is working fine.

 

if ( ($category_depth == 'products') || (isset($HTTP_GET_VARS['manufacturers_id'])) ) {

define('HEADING_TITLE', 'Let\'s See What We Have Here');

 

} elseif ($category_depth == 'top') {

define('HEADING_TITLE', 'What\'s New Here?');

Edited by aking02

Share this post


Link to post
Share on other sites

The code you show is for the language index.php file. Header Tags doesn't use that. It only changes the root index.php file.

 

Jack

Share this post


Link to post
Share on other sites
The code you show is for the language index.php file. Header Tags doesn't use that. It only changes the root index.php file.

 

Jack

 

yes that I know, those codes are not located in my catalog/index.php.

However, I am still not seeing those headers in the index page of my site.

 

I don't know why they are not being displayed.

I went through the installation several times.

 

What else could it be?

Share this post


Link to post
Share on other sites

The part of the page that is missing is controlled in the index.php file. The reason for the problem is there.

 

Jack

Share this post


Link to post
Share on other sites
The part of the page that is missing is controlled in the index.php file. The reason for the problem is there.

 

Jack

 

Hi Jack, I've been spending the past 3 days analyzing the index.php file and still have not found the reason for the missing headers.

 

Is it possible I may email it to you for your opinion??

it is much too large to paste in the thread.

 

Your help is greatly appreciated. I thank you in advance.

Share this post


Link to post
Share on other sites

No, I don't have time to look at files everyone sends me. You can post it here but help for non-standard files is rare.

 

Jack

Share this post


Link to post
Share on other sites

I have the latest version of headertags seo installed, everything has been working fine. This morning i noticed that there were several new pages listed in the

page control. I ran the test to see if all the pages were setup correctly. This is what I found:

CRE or oscMax Error: 
CRE or oscMax is running and the head code in the index.php file has Header Tags code installed, which is a mistake. 
CRE or oscMax is running and the head code in the product_info.php file has Header Tags code installed, which is a mistake. 
CRE or oscMax is running and the head code in the product_reviews.php file has Header Tags code installed, which is a mistake. 
CRE or oscMax is running and the head code in the product_reviews_info.php file has Header Tags code installed, which is a mistake. 
CRE or oscMax is running and the head code in the product_reviews_write.php file has Header Tags code installed, which is a mistake. 
CRE or oscMax is running and the head code in the specials.php file has Header Tags code installed, which is a mistake. 

I have a regular oscommerce site, not CRE or oscMax. I havent installed any contributions that would cause this.

any help would be greatly appreciated.

Share this post


Link to post
Share on other sites
I have the latest version of headertags seo installed, everything has been working fine. This morning i noticed that there were several new pages listed in the

page control. I ran the test to see if all the pages were setup correctly. This is what I found:

I have a regular oscommerce site, not CRE or oscMax. I havent installed any contributions that would cause this.

any help would be greatly appreciated.

Something in your shop is causing Header Tags to think that one of those shops is installed. If neither are, I can't imagine why the code would indicate that.

 

Jack

Share this post


Link to post
Share on other sites

Jack,

 

I am not familiar with SEO, and how it helps; however, I know it is useful. Could you just answer this question...

 

Can, and should, this addon be used to compliment Ultimate SEO URLs or in place of it?

 

Appreciate your time... Thanks so much!

 

Scott

Share this post


Link to post
Share on other sites

The two can be used togehter. They provide different results so it is not a matter of one or the other.

 

Jack

Share this post


Link to post
Share on other sites
The two can be used togehter. They provide different results so it is not a matter of one or the other.

 

Jack

 

Thank you Jack. I look forward to implementing it and learning more about SEO in the process.

 

Scott

Share this post


Link to post
Share on other sites
Thank you Jack. I look forward to implementing it and learning more about SEO in the process.

 

Scott

Website's not yet showing up on google, yahoo?

Share this post


Link to post
Share on other sites

Hi Jack,

 

I have a bit of an odd problem here!

 

I have installed heder tag seo and it works great. Although when I try and amend the following url:

 

http://mywebiste.com/index.php?cPath=62&am...e=1&sort=2d

 

the following message appears in the top of the screen:

 

File http://mywebsite.com/index.php is not using Header Tags.

 

which is very strange as the page File http://mywebsite.com/index.php can be choosen from the list of pages in header tag seo.

 

I have managed to resolve this issue - I did not add the / before index.php!

 

Regards. Peter.

Edited by BarrySmith

I have built an online store solely with the help of this forum.

Share this post


Link to post
Share on other sites
No, I don't have time to look at files everyone sends me. You can post it here but help for non-standard files is rare.

 

Jack

 

The display error of the headers on my index page occurred after the installation of header tags.

It is a big surprise to me that such key headers are not being displayed.

 

In your installation instructions it suggests reasons why this is not being displayed..

I have troubleshooted like a mad man, and I am yet to reach a solution.

 

If the problem is in fact somewhere within the 400 lines of my index.php page, I am yet to find it.

But all my efforts are sending me straight into a wall.

 

Do you have any other idea's as to why this is not being displayed????????????????

Share this post


Link to post
Share on other sites
Something in your shop is causing Header Tags to think that one of those shops is installed. If neither are, I can't imagine why the code would indicate that.

 

Jack

 

Thanks Jack, I dont have oscMax or CRE installed. I cant figure out why it would all of a sudden start this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×