Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

There is duplicate code somewhere that is including the function. You'll have to isolate it since there is no way to tell from here where the problem might be.

 

Jack

 

Hi Jack,

 

I've got the same problem. What is the exact code I'm looking for that is duplicated?

 

David

Share this post


Link to post
Share on other sites

Whatever code is mentioned in the error. It will mention the function it is failing on.

 

Jack

Share this post


Link to post
Share on other sites

Dear Jack,

 

Many thanks for this great contribution. Overall, it works very well and it has saved me loads of time. But I have a small problem...

 

I have filled all tags and this has worked fine. However, when i go into any category config page, and alter/create a category description, the changes are not saved. If I change the title, that is saved, but the description reverts back to whatever was in the box.

 

I have now had to resort to making the changes in the database back end to amend the category description field.

 

Do you have any ideas as to what might be causing this? I do not get any errors.

 

I fill in the category description, click preview, changes are displayed, click update, and the changes are not saved to the database.

 

All the best,

 

Phillip

Share this post


Link to post
Share on other sites
Dear Jack,

 

Many thanks for this great contribution. Overall, it works very well and it has saved me loads of time. But I have a small problem...

 

I have filled all tags and this has worked fine. However, when i go into any category config page, and alter/create a category description, the changes are not saved. If I change the title, that is saved, but the description reverts back to whatever was in the box.

Please read the troubleshooting instructions in the documentation.

 

Jack

Share this post


Link to post
Share on other sites

Hello,

 

I really like the sound of this contribution and have just tried installing it but it did not work with the shop as it was built using a template. Is it possible to use this with a template? Is it easy to change the code to work with a template? If not, how else could I get keywords / meta tag SEO integrated with my shop?

 

Thank you

Helen. :)

Share this post


Link to post
Share on other sites

It will work with any version of oscommerce but changes would be needed in some situations, like yours. But support isn't provided for that since there are too many possible variations and I just don't have the time. You can use one of the other meta tags contributions to control meta tags on your shop. They are much easier to install but don't come near offerring what Header Tags SEO does.

 

Jack

Share this post


Link to post
Share on other sites
It will work with any version of oscommerce but changes would be needed in some situations, like yours. But support isn't provided for that since there are too many possible variations and I just don't have the time. You can use one of the other meta tags contributions to control meta tags on your shop. They are much easier to install but don't come near offerring what Header Tags SEO does.

 

Jack

 

Hello, Thank you for your reply. :)

Would it be possible for me to manually write the code needed for the header tags seo contribution into the files I have for the template? or is that not possible? This is the first Online shop I have done so I am new to all this :)

Share this post


Link to post
Share on other sites
Hello, Thank you for your reply. :)

Would it be possible for me to manually write the code needed for the header tags seo contribution into the files I have for the template? or is that not possible? This is the first Online shop I have done so I am new to all this :)

You could write in the code but that would depend on the way the templet was wrote

 

The best thing to do is like jack said find another contribution or you could ask who ever you got the templet

 

from see if thay can help with the code so you could use the header tag seo

 

but they might charge you and I am sure that is what you will find here as well

 

that is the big draw back to templets

 

Ben

Edited by whitehawk43

Share this post


Link to post
Share on other sites
You could write in the code but that would depend on the way the templet was wrote

 

The best thing to do is like jack said find another contribution or you could ask who ever you got the templet

 

from see if thay can help with the code so you could use the header tag seo

 

but they might charge you and I am sure that is what you will find here as well

 

that is the big draw back to templets

 

Ben

 

 

ok thank you :)

 

I guess it will probably be trial and error until I find one that works then.

Share this post


Link to post
Share on other sites

Dear Jack,

 

Thank you for your reply. Up until the other day I believed my HT where installed correctly as everything was working just fine, other than the issue I raised. After checking all the code correctly, I found an error in the admin/categories.php file. Before I had been using META TAG contribution, and there was some old code for that still in there.

 

I have taken a fresh copy of the file, made the alterations, and everything is now working as it should. All along I wasn't getting any errors, even when I ran the TEST from the admin section.

 

However, I have a new dilemma. Previously, I had been using the shop category text field in order to display a paragraph or two of text at the top of each category page. This was really handy as I could edit each category page with an opening text.

 

After I fixed this contribution, It has now moved the header tag info boxes, but removed the field for editing this text. I have been back into the Header Tag admin, but the category's are not assessable from there.

 

Please tell me where I can enter text for each category as I am still having to manually enter it via the database back end. (original problem)

 

Many thanks for your help, keep up the very good work.

 

All the best,

 

Phillip

Share this post


Link to post
Share on other sites
Please tell me where I can enter text for each category as I am still having to manually enter it via the database back end. (original problem)

The text is edited on the categories edit page. If your page doesn't work due to other contributions, you'll have to fix that before this one will work.

 

Jack

Share this post


Link to post
Share on other sites
The text is edited on the categories edit page. If your page doesn't work due to other contributions, you'll have to fix that before this one will work.

 

Jack

 

 

Hi Jack, Thanks, that was quick.

 

When I go to edit a category, instead of a fresh page opening, I get the header tag edit fields in the grey right had column. Is this not correct?

I get this column of options now, not the separate page as before.

 

 

Please make any necessary changes

 

Category Name:

English "BOX"

 

Bondage Gear

//images/

bondage.jpg

 

Category Image:"BOX"

 

Sort Order:"BOX"

 

Header Tags Category Title

English "BOX"

 

Header Tags Category Description

English "BOX"

 

Header Tags Category Keywords

English "BOX"

 

Header Tags Categories Description

English "BOX"

 

SAVE & Cancel buttons

Share this post


Link to post
Share on other sites

Jack,

 

I am fairly certain that it is installed correctly and working. I can edit and create new categories, and change all the header tag info.

 

What I am missing is a box for the "category description" which displays text on the categories pages, not the "header tag catergory description" field which is there and working.

 

I am not getting any errors and everything else is also working fine, just no field to enter/edit this text.

 

I have even copied the supplied categories.php file over, and get the same results.

 

All the best,

 

Phillip

Share this post


Link to post
Share on other sites

Hi there,

 

I have two small problems with my installation of this contribution, and I was hoping someone might be able to help?

 

Firstly, I can't get the product name to display in the page title. It adds the shop name and the category/sub-category, and then a seperator, but no product name after this.

 

Perhaps linked to this problem is that it is also displaying the title at the bottom left of the product_info.php page.

 

I'd be really grateful to anyone who can help!

 

Link to the problem page: http://www.basecanvasprints.co.uk/catalog/...products_id=123


hor-i-zon

Share this post


Link to post
Share on other sites

Dear Jack, Problem Solved.....

 

I was confident that your contribution was installed correctly, and it was. The trouble was that my root/index.php file was using echo $category['categories_description'

 

I changed 'categories_description' to 'categories_htc_description' in 2 incidences and now it is displaying the text from HT Category Description field. This is all I needed.

 

I will however, go back through my main index file, and double check that there aren't any other issues in the code, and possibly replace and rebuild it. I suspect that this has been caused by the alterations META TAGS contribution made and I hadn't completely removed.

 

Many thanks for your help.

 

All the best,

 

Phillip

Share this post


Link to post
Share on other sites
Hi there,

 

I have two small problems with my installation of this contribution, and I was hoping someone might be able to help?

 

Firstly, I can't get the product name to display in the page title. It adds the shop name and the category/sub-category, and then a seperator, but no product name after this.

 

Perhaps linked to this problem is that it is also displaying the title at the bottom left of the product_info.php page.

 

I'd be really grateful to anyone who can help!

 

Link to the problem page: http://www.basecanvasprints.co.uk/catalog/...products_id=123

Have you ran Fill Tags? is the product checkbox checked on the product_info page in Page Control?

 

Jack

Share this post


Link to post
Share on other sites

This contribution is awesome! I just installed it today, have only used it a little bit so far but that's enough to be very impressed at what it can do.

 

Great work, thanks for creating it Jack.

Share this post


Link to post
Share on other sites

Hi, Jack,

 

thanks for your contributions, I have upgraded to v.3.0.9. By running the test under Header Tags SEO, I have these Language Mismatch Errors:

 

Language ID 1 in default Header Tags table does not exist in the shops languages.

Language ID 1 in default Header Tags table does not exist in the shops languages.

Language ID 8 in default Header Tags table does not exist in the shops languages.

Language ID 8 in default Header Tags table does not exist in the shops languages.

Language ID 9 in default Header Tags table does not exist in the shops languages.

Language ID 9 in default Header Tags table does not exist in the shops languages.

 

Before I press the delete buttom to eliminate these errors, may I know what the program would do? How can revert if there is any adverse effect on the web site (I have three languages in my web site). Appreciate your advice.

Share this post


Link to post
Share on other sites
Have you ran Fill Tags? is the product checkbox checked on the product_info page in Page Control?

 

Jack

 

 

Many thanks for this - it seems to be a problem associated with uploading products through Easy Populate. When added I have to go back in and add tags to the categories and products through the admin system. If anyone knows if there's a system I can use to associate Easy Populate with Header Tags SEO I'd be very grateful :)


hor-i-zon

Share this post


Link to post
Share on other sites
Hi, Jack,

 

thanks for your contributions, I have upgraded to v.3.0.9. By running the test under Header Tags SEO, I have these Language Mismatch Errors:

 

Language ID 1 in default Header Tags table does not exist in the shops languages.

Language ID 1 in default Header Tags table does not exist in the shops languages.

Language ID 8 in default Header Tags table does not exist in the shops languages.

Language ID 8 in default Header Tags table does not exist in the shops languages.

Language ID 9 in default Header Tags table does not exist in the shops languages.

Language ID 9 in default Header Tags table does not exist in the shops languages.

 

Before I press the delete buttom to eliminate these errors, may I know what the program would do? How can revert if there is any adverse effect on the web site (I have three languages in my web site). Appreciate your advice.

Clicking delete will delete the entries for those languages in the Header Tags table so,worse case, it would only affect your Header Tags code. If that happened, you could re-install the database changes and be back to where you are now. Of course, anytime you changing the database, it is a good idea to back it up first.

 

Jack

Share this post


Link to post
Share on other sites
Many thanks for this - it seems to be a problem associated with uploading products through Easy Populate. When added I have to go back in and add tags to the categories and products through the admin system. If anyone knows if there's a system I can use to associate Easy Populate with Header Tags SEO I'd be very grateful :)

An option for Header Tags has always been in the Easy Populate file. You have to enable it to allow Easy Populate to allow uploading the Header Tags fields, and add the fields to your Easy Populate file, of course. Depending upon your version of Easy Populate, how Header Tags is enabled will vary. If you can't figure it out, you should ask in the Easy Populate support thread (be sure to mention your version number).

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

 

I desperately need your assistance, I messed up BIG time.

 

I previously had Categories Description 5.02 installed before I installed Header Tags SEO v3.0.4. I thought I successfully merged the two contributions. I filled in all the Meta Tag Information (Product Title Tag:, Product Description Tag: and Product Keywords Tag:) in Admin on the product info pages. Then I attempted to correct a Category name\title that displays in the catalog area, but it wouldn’t update (change). So I then un-installed the Categories Description 5.02 contribution thinking that was the cause. I carefully followed the installation steps again for the HT SEO to make sure everything was fine.

 

Now here’s where the problem starts.

I had just finished updating the Meta Tags Information for about 100 products and forgot to backup the database before my GIANT oop’s.

 

Don’t ask me why I did it, haven’t got a clue where my mind was. :wacko:

But I went to Header Tags SEO > Page Control and selected product_info.php. Everything was empty on the left side except Include: - Default Title: 1 and Manufacturer: 2. It didn’t look right to me so I clicked the back browser on my mouse, so I thought. What actually happened is my big thumb hit the left mouse button, right over the update button. The results puckered my butt hole up!

 

Now on my (catalog side) product_info.php pages, I ended up with the correct TITLE, the DESCRIPTION I had is gone and in place is the information from the actual page (as entered in the product description box in admin). Also the KEYWORDS are replaced with the product name\title. Even in admin when I open a product page to edit anything, what I had entered in the Meta Tags Information is gone and follows suit to the above.

 

I went back to the Page Control and tried changing the settings, nothing changes and no error messages. I tried clicking the Delete radio box but receive a message - “Deletion of product_info.php is not allowed”.

 

Is there any chance of recovery?

How come changing the settings in Page Control doesn’t take effect?

Why can't the information on the product_info.php file be deleted?

 

I apologize for the essay and being a pain in the butt. I just figured the more info I provide might be useful.

Please don’t suggest that I go out back in the woods and shoot myself. My wife is already plotting on that. :(

 

[banging head on wall]

 

Jim


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites
I went back to the Page Control and tried changing the settings, nothing changes and no error messages. I tried clicking the Delete radio box but receive a message - “Deletion of product_info.php is not allowed”.

 

Is there any chance of recovery?

How come changing the settings in Page Control doesn’t take effect?

Why can't the information on the product_info.php file be deleted?

 

I apologize for the essay and being a pain in the butt. I just figured the more info I provide might be useful.

Please don’t suggest that I go out back in the woods and shoot myself. My wife is already plotting on that. :(

 

[banging head on wall]

 

Jim

I'm not sure I'm following what happened or what the problem is now but the following may help.

 

The descriptions are stored in the database and are only changed by editing the product, in admin->Catalog, or by running Fill Tags. Since you didn't mention either of those, your descriptions should still be there. Be sure to uncheck the default options for prodcut_info.php in page control and checking the product option. If the descriptions are still there, they will show up in the products edit page so you can look there to check that. If the descriptions were overwritten, then you're out of luck, short of having a backup database.

 

You can't delete product_info from page control because that page requires special setup and without it, the contribution would be mostly useless. You can clear the contents for that page and click update though.

 

Jack

Share this post


Link to post
Share on other sites

Jack,

 

Sorry, me again.

 

Please could you advise me as to what I need to alter in the root/index.php file so that the category description is also displayed on pages without any subcategories. These pages currently only display a list of products. I know its only a small alteration, but can't find it. (can't see the wood for the trees)

 

All the best,

Phil

Share this post


Link to post
Share on other sites

After i have installed Header Tags SEO and made the database changes I changed the index.php file and product-info.php file as recommended. Then i went to my shop and I got the following error message:

 

1146 - Table 'oscommerce.table_headertags_default' doesn't exist

 

select * from TABLE_HEADERTAGS_DEFAULT where language_id = '4'

 

[TEP STOP]

 

What I do wrong and more importantly: how do I fix it?

 

I have four languages in my shop but i see only one (default) in headertags_default / language_ID...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×