Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Hey Jack. I have a live shop running oscmax 2.0. Is there anything special that I should know when installing Header Tags SEO, since oscmax uses BTS? Any help would be appreciated. Thanks.
OscMax isn't supported on this site and I will get my hand slapped if I provide support for it here so you will need to ask in that packages support forums for any instructions not already included in the package.

 

Jack

Share this post


Link to post
Share on other sites
Hello Jack

 

Sorry, I went through trying to explain what I see, but didn't actually say if anything was wrong.

 

After ugrading to V3.0.9 I still get the same problem - the category is showing in the product title on the product page even though I dont have "category" selected in admin/header tags seo/page control product_info.php

 

Yes, I did run "fill all Tags" which was sucessfull

 

If I run the test function no errors are reported

 

This is what I think I should be seeing as the product page title :

 

Product Title Header Tags - Microsoft etc // "Product Title Header Tags" is from Meta Tag Information/Product Title Tag filled by me.

 

This is what I actually see :

 

Sub Category Header Tags - - Product Title Header Tags - Microsoft etc // "Sub Category Header Tags" filled by me in the subcategory title header tag

 

If I put "1234" into the admin/header tags seo/page control/product_info.php Title box, then on the store product page I see the title :

 

Sub Category Header Tags - 1234 - Product Title Header Tags - Microsoft etc

 

Thanks ... Dennis

The changes to the test page in the last update was generated because someone contacted me with a similar problem you what you have. The problem with that site was that the default language wasn't english and the initial mysql changes adds english entries into the tables, thus it was causing the wrong parts of the database to be loaded. You might want to compare your languages in admin with those in the Header Tags table to make sure they match. Other than that, I think your problem is beyond what help can be offered in a support thread.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack

 

I keep getting this error. I upgraded from v3.0.8 to v3.0.9

Parse error: syntax error, unexpected T_DNUMBER in /usr/www/users/easybuz/includes/header_tags.php on line 168

 

If I overwrite the file from the install package, my site comes right for a few hours then the message pops up again. My hosting server was changed from php4 + MySQL 4 to php5 + MySQL5 on the weekend...don't know if that has an influence.

Share this post


Link to post
Share on other sites
Hi Jack

 

I keep getting this error. I upgraded from v3.0.8 to v3.0.9

Parse error: syntax error, unexpected T_DNUMBER in /usr/www/users/easybuz/includes/header_tags.php on line 168

 

If I overwrite the file from the install package, my site comes right for a few hours then the message pops up again. My hosting server was changed from php4 + MySQL 4 to php5 + MySQL5 on the weekend...don't know if that has an influence.

Changing that file was not part of the update so you can try your old file if you still have it. I don't know what is at line 168 since it will vary from shop to shop but you may need to do an unintall and install of the database again to get the files and database synced. Does the test in admin show any errors?

 

Jack

Share this post


Link to post
Share on other sites

Hello Jack, I hope you can help me out on this.

i'm getting this error:

parse error: syntax error, unexpected t_class /[path]/includes/header_tags.php on line 178

 

I just installed the latest version of HTSEO and didn't have it before.

When I look in the header_tags.php on line 178 I found out that there is no line 178. The file goes only until line 158..??

When I get this message, the thing that helps is overwriting the file with the orignal, but every time I add a product, add missing pages etc I always get this error and need to overwrite the file again.

Test doesn't give any errors either.

 

Any help and info is appreciated.

Thank you.

Share this post


Link to post
Share on other sites
Hello Jack, I hope you can help me out on this.

i'm getting this error:

parse error: syntax error, unexpected t_class /[path]/includes/header_tags.php on line 178

 

I just installed the latest version of HTSEO and didn't have it before.

When I look in the header_tags.php on line 178 I found out that there is no line 178. The file goes only until line 158..??

When I get this message, the thing that helps is overwriting the file with the orignal, but every time I add a product, add missing pages etc I always get this error and need to overwrite the file again.

Test doesn't give any errors either.

 

Any help and info is appreciated.

Thank you.

That is probably due to a formatting problem in that file. I can't explain why it would only happen with your site - maybe the ftp or editor program you are using.

 

Jack

Share this post


Link to post
Share on other sites
Changing that file was not part of the update so you can try your old file if you still have it. I don't know what is at line 168 since it will vary from shop to shop but you may need to do an unintall and install of the database again to get the files and database synced. Does the test in admin show any errors?

 

Jack

 

Hi Jack

 

Thanks for your reply

 

Since posting yesterday I restored the V3.0.8 admin files and everything is fine since. There were no errors when I ran test with V3.0.9 BTW this is what is at line 168 (just the part in bold)

 

echo ' <meta http-equiv="Content-Type" content="text/html; charset=' . CHARSET . '" />'."\n";

echo '<!-- EOF: Header Tags SEO Generated Meta Tags -->' . "\n";

?>

 

I will uninstall and reinstall the database a bit later and post the results.

 

Thanks

Share this post


Link to post
Share on other sites
That is probably due to a formatting problem in that file. I can't explain why it would only happen with your site - maybe the ftp or editor program you are using.

 

Jack

 

Thank you Jack for the fast answer.

I use WSFTP Pro for uploading files and I edit them with Wordpad.

Occasionally I do it with Dreamweaver, but php only with Wordpad.

 

Any idea?

 

Also any idea why previous versions didn't have that problem?

 

Thank you!

Share this post


Link to post
Share on other sites

Der Everyone, & Jack_MCS,

 

I have searched through this forum and via the internet, and can't find a solution to this issue.

 

I have Header Tags SEO installed, and all is working fine. It is a great contribution, many thanks.

 

However, when I try to add a new page via the Pseudo box, I get an error saying;

 

"The base file entered, index.php, does not support pseudo pages." I also get this error for the product_info.php page

 

I have read once that this may be a result of having the site hosted on a Linux server and that I should move the site to be hosted on a Windows server but can not find any other reference to this to confirm.

 

Could someone please advise as to how to resolve this. Without this feature, I will be unable to create unique keywords etc for each product.

 

Many Thanks,

 

Phillip

Share this post


Link to post
Share on other sites

Hi, I installed this contribution and my shop runs STS. I have gone over the code edits twice and am still running into the same problem.

 

The problem is that on my product_info pages the title tag is not being updated by Header Tags SEO. All of my other pages have been updated by HTSEO using teh fill tags or custom title updates.

 

I just cant seem to get the product_info.php file to get updated. I tried filling the tag and tried manually writing a title through HTSEO backend. The header tags code is on the page in the same place as the code on all of the other pages. So I am lost as to why it will not work...

When i run the test module for HTSEO this is the result I get:

 

Missing File Error:
Cannot find file D:/[path]/www/store/backend/includes/header_tags_seo_words.txt.
Missing Code in File
The Header Tags head code for the index.php file cannot be found.
The Header Tags head code for the product_info.php file cannot be found.
The Header Tags head code for the product_reviews.php file cannot be found.
The Header Tags head code for the product_reviews_info.php file cannot be found.
The Header Tags head code for the product_reviews_write.php file cannot be found.
The Header Tags head code for the specials.php file cannot be found.

 

1. the header_tags_seo.txt file, I could not find that anywhere in the installation... My other title tags filled fine w/o it however.

2. The missing code errors... The code is on the pages I need it to be (index.php and product_info.php)

3. This confuses me because as I said, using HTSEO to fill the index.php info is working just fine, but it is not working on the product_info.php

 

Now I have a little bit of an odd set up in my shop... The index.php is actually the products_new.php code. In other words I just erased all the code from index.php and replaced it with the code from products_new.php BEFORE I installed HTSEO. I am assumiong this doesnt have anything to do with my problem since the code on index.php is pulling the titles from HTSEO.

 

Can you think of why this problem with product_info.php is happening?

Share this post


Link to post
Share on other sites
The changes to the test page in the last update was generated because someone contacted me with a similar problem you what you have. The problem with that site was that the default language wasn't english and the initial mysql changes adds english entries into the tables, thus it was causing the wrong parts of the database to be loaded. You might want to compare your languages in admin with those in the Header Tags table to make sure they match. Other than that, I think your problem is beyond what help can be offered in a support thread.

 

Jack

Hello Jack

 

Thank you for your patience.

 

By pure luck I was able to get the title in the product page to appear correctly.

 

In admin>>Header Tags SEO>>Page Controll>> "Default Tags - English, includes, the category, manufacturer and product options were selected. I unselected these and updated and everything looks ok.

 

Has this happened because I have put code in the wrong place ?

 

Could you clarify for me what the "root" option is for?

 

Great contribution.

 

Thanks ... Dennis

Share this post


Link to post
Share on other sites

Hello!

 

First i have installed the newest Version of OSC (RC2) and then i installed STS newest Version and played a little with the Layout of the Page.

Then i found this SEO HEader thing and installed it.

 

I installed the SQL File via phpmyadmin and then copied all files for RC2 and then changed all files like in the "install_catalog.txt".

But i get the message

Fatal error: Call to a member function image() on a non-object in /var/www/web292/html/includes/functions/html_output.php on line 78

when i try to open my website.

 

On this line only stands

 

	// START STS v4.4:
  global $sts; 
	  $sts->image($src); // Take image from template folder if exists.
// END STS v4.4

 

That doesn't tell my anything at all ^^

 

Can someone help me plz? :-/

 

Greetings from Germany ;)

Share this post


Link to post
Share on other sites
Hello!

 

First i have installed the newest Version of OSC (RC2) and then i installed STS newest Version and played a little with the Layout of the Page.

Then i found this SEO HEader thing and installed it.

 

I installed the SQL File via phpmyadmin and then copied all files for RC2 and then changed all files like in the "install_catalog.txt".

But i get the message

 

If I am understanding you correctly you uploaded the files for RC2 as they are AFTER you installed STS4.

 

If you have anything other than the default you must updated teh pages manually.

 

Also try and see if your store works when you turn off STS. that way you can pinpoint the problem.

Share this post


Link to post
Share on other sites
If I am understanding you correctly you uploaded the files for RC2 as they are AFTER you installed STS4.

 

If you have anything other than the default you must updated teh pages manually.

 

Also try and see if your store works when you turn off STS. that way you can pinpoint the problem.

 

I turned off STS and i had the same problem :/

 

What do you mean with the default? I did not change anything, only installed RC2, STS and the Header Tags... so it should be default at all?

Share this post


Link to post
Share on other sites
Uninstalled the database, reinstalled databse with V3.0.9 admin files and get same error as above.
The line of code it is failing on hasn't been changed in years so that can't be the problem. If 3.0.8 woks for you, then you can try installing it and them replacing the includes/header_tags.php file from 3.0.9 and see what happens. It should be the same file though so I can't imagine what the problem is.

 

Jack

Share this post


Link to post
Share on other sites
Thank you Jack for the fast answer.

I use WSFTP Pro for uploading files and I edit them with Wordpad.

Occasionally I do it with Dreamweaver, but php only with Wordpad.

 

Any idea?

 

Also any idea why previous versions didn't have that problem?

 

Thank you!

No idea.

 

Jack

Share this post


Link to post
Share on other sites
Der Everyone, & Jack_MCS,

 

I have searched through this forum and via the internet, and can't find a solution to this issue.

 

I have Header Tags SEO installed, and all is working fine. It is a great contribution, many thanks.

 

However, when I try to add a new page via the Pseudo box, I get an error saying;

 

"The base file entered, index.php, does not support pseudo pages." I also get this error for the product_info.php page

 

I have read once that this may be a result of having the site hosted on a Linux server and that I should move the site to be hosted on a Windows server but can not find any other reference to this to confirm.

 

Could someone please advise as to how to resolve this. Without this feature, I will be unable to create unique keywords etc for each product.

 

Many Thanks,

 

Phillip

The index and product_info pages are not pseudo pages so you can't add them. The individual tags for them are handled with Fill Tags or in the categories and product edit pages.

 

Jack

Share this post


Link to post
Share on other sites
1. the header_tags_seo.txt file, I could not find that anywhere in the installation... My other title tags filled fine w/o it however.

2. The missing code errors... The code is on the pages I need it to be (index.php and product_info.php)

3. This confuses me because as I said, using HTSEO to fill the index.php info is working just fine, but it is not working on the product_info.php

 

Now I have a little bit of an odd set up in my shop... The index.php is actually the products_new.php code. In other words I just erased all the code from index.php and replaced it with the code from products_new.php BEFORE I installed HTSEO. I am assumiong this doesnt have anything to do with my problem since the code on index.php is pulling the titles from HTSEO.

 

Can you think of why this problem with product_info.php is happening?

Follow the included instructions for installing in STS. If it doesn't work, try it with STS turned off to isolate the problem.

 

Jack

Share this post


Link to post
Share on other sites
Hello Jack

 

Thank you for your patience.

 

By pure luck I was able to get the title in the product page to appear correctly.

 

In admin>>Header Tags SEO>>Page Controll>> "Default Tags - English, includes, the category, manufacturer and product options were selected. I unselected these and updated and everything looks ok.

 

Has this happened because I have put code in the wrong place ?

 

Could you clarify for me what the "root" option is for?

 

Great contribution.

 

Thanks ... Dennis

The root option refers to the text entered in the box for that page in Page Control.

 

Jack

Share this post


Link to post
Share on other sites
Hello!

 

First i have installed the newest Version of OSC (RC2) and then i installed STS newest Version and played a little with the Layout of the Page.

Then i found this SEO HEader thing and installed it.

 

I installed the SQL File via phpmyadmin and then copied all files for RC2 and then changed all files like in the "install_catalog.txt".

But i get the message

Fatal error: Call to a member function image() on a non-object in /var/www/web292/html/includes/functions/html_output.php on line 78

when i try to open my website.

 

On this line only stands

 

	// START STS v4.4:
  global $sts; 
	  $sts->image($src); // Take image from template folder if exists.
// END STS v4.4

 

That doesn't tell my anything at all ^^

 

Can someone help me plz? :-/

 

Greetings from Germany ;)

Those aren't Header Tags related errors that I can see. The first is looking for an image function but can't find it and that is not a function in Header Tags. You may want to post in the STS thread.

 

Jack

Share this post


Link to post
Share on other sites
Those aren't Header Tags related errors that I can see. The first is looking for an image function but can't find it and that is not a function in Header Tags. You may want to post in the STS thread.

 

Jack

 

Very thanks. But i don't understand. First i installed STS and it does work 100% correct! No Errors... After i installed YOUR script for Header Tags SEO, i got that error message.

I don't want to post in 100.000 Topics all over the world and annoy everbody ;) Maybe someone else knows that problem :/

Share this post


Link to post
Share on other sites
Follow the included instructions for installing in STS. If it doesn't work, try it with STS turned off to isolate the problem.

 

Jack

 

Yes, I had overlooked adding the header_tags to include for the content templates. It works now

 

what about header_tags_seo.txt file? Is that just a list of keywords related to my store which I need to create and upload?

Share this post


Link to post
Share on other sites
Hi,

 

How do I configure title/desc./keywords for each categories in the shop (product_listing.php) pages?

 

see www.xn--kreditkb-c5a.dk

 

See

Jesper

Running Fill Tags would be the first step. If you want them changed more than that, edit each of the categories.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×