Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Hello Jack, I have my product_info into the index.php for a contribution, and the titles for the product_info dont work, to solve this I have copied the code of product_info part into index part in the includes/header_tags.php. But dont work very well, show this:

Hardware - - Oscommerce title, for the category

GT Interactive - - Oscommerce title, for the manufacturer

How can I fix it?

I don't offer support for special projects. Maybe someone will respond if you post in the general forums, although I doubt it. One usually has to pay to have special coding issues handled, if they aren't able to do it themselves.

 

Jack

Share this post


Link to post
Share on other sites

Thanks!

 

No problem is found.

 

By the way,after I read the how_to_operate.txt

I still don't understand how to use it.

For example

product_reviews.php - English View Result: Delete:

 

Title:

Description:

Keyword(s):

Logo Text:

Include: Default Title:

Default Description

 

Default Keywords:

Default Logo:

 

Category:

Manufacturer:

 

Product:

Root:

 

What should I type in order to attract more people to come to my site?

Thanks!

 

 

 

More "reading directions" problem.

 

Catalog Install.txt answers the question.

 

In summary, there's a bit of code that you have to add to every file you want HT-SEO to play with. Go ahead and have a read through the install instructions again - you'll find it there.

Share this post


Link to post
Share on other sites
What should I type in order to attract more people to come to my site?

That's a matter of SEO and beyond the scope of this support thread, but, in general, you enter text that people will search for to get to that page.

 

Jack

Share this post


Link to post
Share on other sites
Hi Jack

 

When I add the code to general.php the admin goes blank, any ideas?

If you are just adding it to that one file and trying it, you are making a mistake in that file. But if the whole installation has been done, then there is probably a mistake elsewhere.

 

Jack

Share this post


Link to post
Share on other sites
If you are just adding it to that one file and trying it, you are making a mistake in that file. But if the whole installation has been done, then there is probably a mistake elsewhere.

 

Jack

 

Hi Jack

 

The whole installation is complete, and it actually works without the code in general.php

 

I realise mistakes can happen so I will check it once again.

Share this post


Link to post
Share on other sites

The function tep_get_category code was already in my general.php, so it was duplicated when I added it, causing the error.

Share this post


Link to post
Share on other sites
The function tep_get_category code was already in my general.php, so it was duplicated when I added it, causing the error.

Ahh, you didn't mention an error.

 

Jack

Share this post


Link to post
Share on other sites

OKay how do I find out what seo version I am using.

 

Then how do I get my categories, to stop displaying the default tags but display there own.

 

I noticed that several improvements are available to the header tag, just wondering how difficult these would be to upgrade our site. such as the social tagging etc.

 

Thanks

Wayne

Share this post


Link to post
Share on other sites
OKay how do I find out what seo version I am using.

 

Then how do I get my categories, to stop displaying the default tags but display there own.

 

I noticed that several improvements are available to the header tag, just wondering how difficult these would be to upgrade our site. such as the social tagging etc.

 

Thanks

Wayne

The social tagging was in the frist release of Header Tags SEO so if you don't have them already, this contribution isn't installed at all, or installed incorrectly.

 

Jack

Share this post


Link to post
Share on other sites

Hello,

thanks for this nice contrib Jack !!!!

But, I have problem.

Test doesnt work...

 

TEST_RESULTS_HEADING

ERROR_HEADING_DATABASE

ERROR_MISSING_CONFIGURATION_GROUP

ERROR_MISSING_CODE

ERROR_MISSING_CODE

ERROR_MISSING_CODE

ERROR_MISSING_CODE

 

 

Is it normal?

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Hi. I installed Header Tags and everything looks ok. I see the new meta tags in the header. But when I go to the admin and attempt to edit the tag information, I look at the "Select an Option" and the drop-down only contains three items: Select a File, Show All Files and Add Missing Pages I ran the Add Missing Pages selection, but the list remains empty. The headertags table contains entries for index.php, product_info.php, etc. but none of these show up in the drop down list. Can you give me an idea of where to start looking for where to fix this?

 

Many thanks in advance.

L

Share this post


Link to post
Share on other sites
Hi. I installed Header Tags and everything looks ok. I see the new meta tags in the header. But when I go to the admin and attempt to edit the tag information, I look at the "Select an Option" and the drop-down only contains three items: Select a File, Show All Files and Add Missing Pages I ran the Add Missing Pages selection, but the list remains empty. The headertags table contains entries for index.php, product_info.php, etc. but none of these show up in the drop down list. Can you give me an idea of where to start looking for where to fix this?

 

Many thanks in advance.

L

 

Any other file in the root directory (the same location where your index.php

file is located) that you want Header Tags to work with should also be changed.

For example, if you want your privacy page to have its own title and meta tags,

then you should make this change to the privacy.php file. Only files that

contain <title><?php echo TITLE; ?></title> can be altered. Since the <TITLE>

tag is different in popup_image.php and is not handled by Header Tags SEO,

there is no need to modify that file.

 

In each file you want to edit, make the following modification:

 

FIND:

 

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

 

REPLACE with the following then continue with Step 2:

 

<?php

/*** Begin Header Tags SEO ***/

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<title><?php echo TITLE; ?></title>

<?php

}

/*** End Header Tags SEO ***/

?>

Share this post


Link to post
Share on other sites
Any other file in the root directory (the same location where your index.php

file is located) that you want Header Tags to work with should also be changed.

For example, if you want your privacy page to have its own title and meta tags,

then you should make this change to the privacy.php file. Only files that

contain <title><?php echo TITLE; ?></title> can be altered. Since the <TITLE>

tag is different in popup_image.php and is not handled by Header Tags SEO,

there is no need to modify that file.

 

In each file you want to edit, make the following modification:

 

FIND:

 

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

 

REPLACE with the following then continue with Step 2:

 

<?php

/*** Begin Header Tags SEO ***/

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<title><?php echo TITLE; ?></title>

<?php

}

/*** End Header Tags SEO ***/

?>

 

I made the changes to all the files in the main directory. I'm talking about in the in the Admin, under Header Tags SEO -> Page Control. I only have three options in the Select an Option drop-down and I am unable to view or edit the tags for the individual pages. Even after selecting the Add Missing Pages option, I do not see any of the individual files from the main directory for which I can edit the tags. How is that list filled in? Where can I look to figure out why I am not getting any pages to edit the tags for?

 

L

Share this post


Link to post
Share on other sites

I had someone help me and they found it. It turns out that the code for the FileNotUsingHeaderTags() function was looking for the "Header Tag Controller" text within the comments. I didn't put in all the comments so it wasn't finding them in any of my files.

 

I changed the function to look for the file name that is being included: 'header_tags.php'. Now it finds all the files just fine.

Share this post


Link to post
Share on other sites
Capital letters usually mean an incomplete installation.

 

Jack

 

 

Thanks for your answer.

I have verified again my installation... I have not found any incomplete installation :(

Share this post


Link to post
Share on other sites

Hi jack

 

I am installing the header tags Seo

 

and during the install I came across a place I need clearaifcation

 

NOTE: In any page in which you make the change to the title for Header Tags,

you should also locate the line containing HEADING_TITLE, remove the

pageHeading class and add the h1 tags as above.

 

are you talking about the changes made to the other files in the root directory

Index.php

product_info.php ect.

 

might seam like a dumb ? but I don't want to mess up the install

so when in dought ask it out :)

 

Thanks

 

Ben

Share this post


Link to post
Share on other sites

I can answer this, because I just did it.

 

Yes, in every file in your catalog/ directory, you need to make changes. Wherever you see the use of class="pageHeading" you should remove that and use the <h1> tags instead.

 

So, where you might see

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

 

change it to

<td><h1><?php echo HEADING_TITLE; ?></h1></td>

 

Just do a search for pageHeading in all your files and you'll see where you need to make the changes.

Share this post


Link to post
Share on other sites
I can answer this, because I just did it.

 

Yes, in every file in your catalog/ directory, you need to make changes. Wherever you see the use of class="pageHeading" you should remove that and use the <h1> tags instead.

 

So, where you might see

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

 

change it to

<td><h1><?php echo HEADING_TITLE; ?></h1></td>

 

Just do a search for pageHeading in all your files and you'll see where you need to make the changes.

 

 

Thanks for the reply

 

Be Well

Ben

Share this post


Link to post
Share on other sites

I am running OSC 2.2rc2

and I have other contributions added

 

at the end of the catalog install file it states

 

If you have installed other

contributions, then you should only upload the files in the catalog

directory.

 

That means I don't do the Header Tags SEO admin install instructions

 

Thanks

Ben

Share this post


Link to post
Share on other sites
I am running OSC 2.2rc2

and I have other contributions added

 

at the end of the catalog install file it states

 

If you have installed other

contributions, then you should only upload the files in the catalog

directory.

 

That means I don't do the Header Tags SEO admin install instructions

 

Thanks

Ben

Thanks for pointing that out. I see it isn't clear. To clarify, if you have installed other contributions, then upload the files in the catalog directory and then make the edits list in the install file.

 

Jack

Share this post


Link to post
Share on other sites

Thanks Jack

 

Hope you don't mind the ?

sometimes I get a little nervous making the changes so

I was just making sure

 

I got the install done all looks good but :lol:

I lost the width of my site it went back to the default width

It should be the same size as my hearer image.

 

where do I make the change to get it back

here is my url

http://mosgifts.com

 

and I also lost the page title

where do I fix that

 

Thnaks for the Great contribution this was one of the easyist I have done.

Very well Done...... :D

 

Thanks again

Ben

Edited by whitehawk43

Share this post


Link to post
Share on other sites

None of the changes should have affected the width of the site but if any did, I would guess the changes to the includes/header.php file is the one. The missing title could be a number of things. Be sure you have ran fill tags and added the code to the nidex.php file, assuming you have a standard shop.

 

Jack

Share this post


Link to post
Share on other sites

Hi

The new header tags does not work with pseudo pages Jack I could nearly fall in love with you if you tell me I am wrong!!

Works fine for me and the shops I have installed it into. But you need to ask these questions in the support thread for that contribution


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×