Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Hi,

 

Is this supported with 2.2rc2a? I have tried to update index and product_info files but code mentioned in install_catalogue is not matching with new version files. I am confused. Can someone please help me?

Share this post


Link to post
Share on other sites
Hi,

 

Is this supported with 2.2rc2a? I have tried to update index and product_info files but code mentioned in install_catalogue is not matching with new version files. I am confused. Can someone please help me?

The code for those files is the same in the two shops, or very close to it, and, yes, this contribution works for either. But if you are using a template or some non-standard shop, then the instructions may not apply to your shop.

 

Jack

Share this post


Link to post
Share on other sites

Hi, Jack

 

I have installed HeaderTags_SEO_V_3.0.7 and have some probs:

 

1) when I try page control for my page "domains.php" it will not update as I have inputted it as

 

domains-php.gif

 

 

This is my V/S for domains.php:

 

 

<head>

<title>West One Hosting</title>

<meta name="Description" content="Webhosting" />

<meta name="Keywords" content="hosting, domain names, SSL, osCommerce" />

<meta name="googlebot" content="all" />

<meta http-equiv="Content-Language" content="en-US" />

<meta name="robots" content="noodp" />

<meta name="slurp" content="noydir" />

<meta name="revisit-after" content="1 days" />

<meta name="robots" content="index, follow" />

<meta name="no-email-collection" value="http://westonehosting.com" />

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

<!-- EOF: Header Tags SEO Generated Meta Tags -->

<base href="https://westonehosting.com/">

<link rel="stylesheet" type="text/css" href="stylesheet.css">

</head>

 

 

 

 

can you help me

Edited by West One Hosting

Thanks Simon

 

osCommerce Version: Online Merchant v2.2 RC 2a - Test Site with: oscommerce-2.2ms2-060817

cPanel Version: 11.23.4-RELEASE - Apache version: 2.0.63 - PHP version: 5.2.5 - MySQL version: 5.0.51a-community - Operating system: Linux

========================================================================

Share this post


Link to post
Share on other sites
I have installed HeaderTags_SEO_V_3.0.7 and have some probs:

 

1) when I try page control for my page "domains.php" it will not update as I have inputted it as

It appears you have it setup correctly but it is loading the default settings for some reason. If your other pages are working correctly, then it is either something to do with that file or the includes/header_tags.php file. You might want to check the latter to make sure there is an entry for default.php and that the filename definition it shows is the actual one for the site.

 

Jack

Share this post


Link to post
Share on other sites
It appears you have it setup correctly but it is loading the default settings for some reason. If your other pages are working correctly, then it is either something to do with that file or the includes/header_tags.php file. You might want to check the latter to make sure there is an entry for default.php and that the filename definition it shows is the actual one for the site.

 

Jack

 

sorry could not work out what you needed me to do.

 

so I just Delete: it again (I did Delete it before about 3 to 4 time) but it worked this time?

 

how odd is that!!

 

thanks and keep up the good work if you can as this is my 5th mod of yours and they all work fine.

 

ps. will you be updating PageMaker for RC2

Edited by West One Hosting

Thanks Simon

 

osCommerce Version: Online Merchant v2.2 RC 2a - Test Site with: oscommerce-2.2ms2-060817

cPanel Version: 11.23.4-RELEASE - Apache version: 2.0.63 - PHP version: 5.2.5 - MySQL version: 5.0.51a-community - Operating system: Linux

========================================================================

Share this post


Link to post
Share on other sites

Hello everyone,

 

I try to install the SEO v3.0.7. I'm using STS v4.5.8.

 

problems:

 

1 When I finish install_catalog, I didn't see the "New Home Page Title". Perhaps I've not yet use $headcontent in STS?

 

2 The $breadcrumbs worked increctely. Perhaps because the colomn of categories_htc_title_tag is NULL?

 

3, when I click a product, the template was changed!! The colomn_right was at the foot of the page. Why?

 

Sorry, I don't know how to insert the local image...

Share this post


Link to post
Share on other sites
Sorry, I don't know how to insert the local image...

 

do the screen shot then save it then upload it to your server with ftp or the like then use insert image when posting.

Edited by West One Hosting

Thanks Simon

 

osCommerce Version: Online Merchant v2.2 RC 2a - Test Site with: oscommerce-2.2ms2-060817

cPanel Version: 11.23.4-RELEASE - Apache version: 2.0.63 - PHP version: 5.2.5 - MySQL version: 5.0.51a-community - Operating system: Linux

========================================================================

Share this post


Link to post
Share on other sites
Hello everyone,

 

I try to install the SEO v3.0.7. I'm using STS v4.5.8.

 

problems:

 

1 When I finish install_catalog, I didn't see the "New Home Page Title". Perhaps I've not yet use $headcontent in STS?

 

2 The $breadcrumbs worked increctely. Perhaps because the colomn of categories_htc_title_tag is NULL?

 

3, when I click a product, the template was changed!! The colomn_right was at the foot of the page. Why?

 

Sorry, I don't know how to insert the local image...

 

the screenshot:

products%20new%20home%20-.jpg

 

Thanx for all your helps

Edited by hoken

Share this post


Link to post
Share on other sites
the screenshot:

 

 

Thanx for all your helps

 

Hi

 

can you give a url to the site it looks like a </tr> or </td> missing?

 

have a look at your colomn_left at the bott you have "Paiement Securis?/td>" should this not be "Paiement Securis?" then the code </td>

Edited by West One Hosting

Thanks Simon

 

osCommerce Version: Online Merchant v2.2 RC 2a - Test Site with: oscommerce-2.2ms2-060817

cPanel Version: 11.23.4-RELEASE - Apache version: 2.0.63 - PHP version: 5.2.5 - MySQL version: 5.0.51a-community - Operating system: Linux

========================================================================

Share this post


Link to post
Share on other sites
sorry could not work out what you needed me to do.

 

so I just Delete: it again (I did Delete it before about 3 to 4 time) but it worked this time?

 

how odd is that!!

 

thanks and keep up the good work if you can as this is my 5th mod of yours and they all work fine.

 

ps. will you be updating PageMaker for RC2

I'm glad you got it going.

 

I had planned on rewriting that so it would work for all of the shops but haven't had the time. Although it should work with RC2 as it is.

 

Jack

Share this post


Link to post
Share on other sites
Hello everyone,

 

I try to install the SEO v3.0.7. I'm using STS v4.5.8.

 

problems:

 

1 When I finish install_catalog, I didn't see the "New Home Page Title". Perhaps I've not yet use $headcontent in STS?

 

2 The $breadcrumbs worked increctely. Perhaps because the colomn of categories_htc_title_tag is NULL?

 

3, when I click a product, the template was changed!! The colomn_right was at the foot of the page. Why?

 

Sorry, I don't know how to insert the local image...

1 - Be sure to include headertags in the STS settings as described in the installation file. If you don't do that, it won't work correctly.

 

3 - There was most likely a mistake made with the changes to the product_info file. You should remove those changes and do them again, checking the page after each one to find where the problem is at.

 

Jack

Share this post


Link to post
Share on other sites

hi community!

 

installed SEO 3.0.7 few days ago and just realized that my admin/catalog has gone...

all I get is a blank page. all other admin modules work fine.

 

any ideas?

 

greetings

Ragnar

Share this post


Link to post
Share on other sites
Hi

 

can you give a url to the site it looks like a </tr> or </td> missing?

 

have a look at your colomn_left at the bott you have "Paiement Securis?/td>" should this not be "Paiement Securis?" then the code </td>

 

I cannt put them on server right now, sorry. But I'm sure of that is not the reason. Because it's fine pour all the other kind of pages, just display like that in the product page. I wondered that if SEO change the output of the product page?

Share this post


Link to post
Share on other sites
hi community!

 

installed SEO 3.0.7 few days ago and just realized that my admin/catalog has gone...

all I get is a blank page. all other admin modules work fine.

 

any ideas?

 

greetings

Ragnar

Read the install instructions for that problem.

 

Jack

Share this post


Link to post
Share on other sites

Hi, Jack

 

Have upgraded the HeaderTags_SEO, 3.0.7. Everything went well until after I updated the product_info.php, all the URL related to product information at the categories has been changed to Default value as set at Admin/Header Tags SEO. Any ideas where it went wrong. (by the way, it does not help even I undo the changes at the product_info.php.)

 

Thanks.

Share this post


Link to post
Share on other sites
Hi, Jack

 

Have upgraded the HeaderTags_SEO, 3.0.7. Everything went well until after I updated the product_info.php, all the URL related to product information at the categories has been changed to Default value as set at Admin/Header Tags SEO. Any ideas where it went wrong. (by the way, it does not help even I undo the changes at the product_info.php.)

 

Thanks.

The latest version didn't change anything in that file. It might have something to do with the database. I suggest running the uninstall and install scripts and replacing the includes/header_tags.php file. Then go to Page Control to reload all of the pages and see if that works.

 

Jack

Share this post


Link to post
Share on other sites

I use FCK Editor for my products description and it adds some HTML code. How do I strip that HTML code from the meta products description, as it's creating problems for my store.

 

Thank you.

Share this post


Link to post
Share on other sites
Read the install instructions for that problem.

 

Jack

 

Hi Jack,

 

went through the whole install procedure, couldn't find any mistakes. i had to merge some lines in the categories.php with the ultrapics contrib. reverted to a categories.php from before the header tags install as a test, but no difference.... got any pointers as to which file could be causing the problem?

Share this post


Link to post
Share on other sites

may appear like a stupid question but on the contribution page where you download it doesnt say what this contribution actually does. as newbie could anyone please explain.

 

(Sorry if its a stupid question)

 

Thanks

 

Andy

Share this post


Link to post
Share on other sites
may appear like a stupid question but on the contribution page where you download it doesnt say what this contribution actually does. as newbie could anyone please explain.

 

(Sorry if its a stupid question)

 

Thanks

 

Andy

 

the name says it all.... Header Tags SEO (SearchEngineOptimization) lets you configure the Header Tags (and other parts of the code) to improve search engine ranking for your website.

Share this post


Link to post
Share on other sites
I use FCK Editor for my products description and it adds some HTML code. How do I strip that HTML code from the meta products description, as it's creating problems for my store.

 

Thank you.

There is already code in place to strip such tags from the title and meta tags. If yours isn't working, try the included categories file to make sure it does (you'll have to change the code to use the editor).

 

Jack

Share this post


Link to post
Share on other sites
Hi Jack,

 

went through the whole install procedure, couldn't find any mistakes. i had to merge some lines in the categories.php with the ultrapics contrib. reverted to a categories.php from before the header tags install as a test, but no difference.... got any pointers as to which file could be causing the problem?

The instructions say to replace your categories file with the included one when there are problems with that section. So are you saying it still fails with the included file?

 

Jack

Share this post


Link to post
Share on other sites
The instructions say to replace your categories file with the included one when there are problems with that section. So are you saying it still fails with the included file?

 

Jack

 

hi jack,

 

tried both ms2 and rc2 categories.php still blank page under Admin/Catalog, is there any way to invoke error messages?

Edited by raschaa

Share this post


Link to post
Share on other sites
The latest version didn't change anything in that file. It might have something to do with the database. I suggest running the uninstall and install scripts and replacing the includes/header_tags.php file. Then go to Page Control to reload all of the pages and see if that works.

 

Jack

 

Hi, Jack,

 

Thanks for your reply. Used WinMerge to investigate the problem, no problem at the database. It seems that when I update the Product_reviews.php at Admin/Header Tag SEO,

 

this was added in the include/header_tags.php

 

// product_reviews.php

case (strstr($_SERVER['PHP_SELF'],FILENAME_PRODUCT_REVIEWS) or strstr($PHP_SELF,FILENAME_PRODUCT_REVIEWS)):

$header_tags_array = tep_header_tag_page(FILENAME_PRODUCT_REVIEWS);

break;

 

but at the same time, this whole part was removed from include/header_tags.php

 

// PRODUCT_REVIEWS.PHP

// PRODUCT_REVIEWS_INFO.PHP

// PRODUCT_REVIEWS_WRITE.PHP

case (strstr($_SERVER['PHP_SELF'],FILENAME_PRODUCT_INFO) or strstr($PHP_SELF,FILENAME_PRODUCT_INFO)):

case (strstr($_SERVER['PHP_SELF'],FILENAME_PRODUCT_REVIEWS) or strstr($PHP_SELF,FILENAME_PRODUCT_REVIEWS)):

case (strstr($_SERVER['PHP_SELF'],FILENAME_PRODUCT_REVIEWS_INFO) or strstr($PHP_SELF,FILENAME_PRODUCT_REVIEWS_INFO)):

case (strstr($_SERVER['PHP_SELF'],FILENAME_PRODUCT_REVIEWS_WRITE) or strstr($PHP_SELF,FILENAME_PRODUCT_REVIEWS_WRITE)):

 

switch (true)

{

case (strstr($_SERVER['PHP_SELF'],FILENAME_PRODUCT_INFO) or strstr($PHP_SELF,FILENAME_PRODUCT_INFO)): $filename = FILENAME_PRODUCT_INFO; break;

case (strstr($_SERVER['PHP_SELF'],FILENAME_PRODUCT_REVIEWS) or strstr($PHP_SELF,FILENAME_PRODUCT_REVIEWS)): $filename = FILENAME_PRODUCT_REVIEWS; break;

case (strstr($_SERVER['PHP_SELF'],FILENAME_PRODUCT_REVIEWS_INFO) or strstr($PHP_SELF,FILENAME_PRODUCT_REVIEWS_INFO)): $filename = FILENAME_PRODUCT_REVIEWS_INFO; break;

case (strstr($_SERVER['PHP_SELF'],FILENAME_PRODUCT_REVIEWS_WRITE) or strstr($PHP_SELF,FILENAME_PRODUCT_REVIEWS_WRITE)): $filename = FILENAME_PRODUCT_REVIEWS_WRITE; break;

default: $filename = FILENAME_PRODUCT_INFO;

}

$pageTags_query = tep_db_query("select * from " . TABLE_HEADERTAGS . " where page_name like '" . $filename . "' and language_id = '" . (int)$languages_id . "'");

$pageTags = tep_db_fetch_array($pageTags_query);

 

$the_product_info_query = tep_db_query("select p.products_id, pd.products_head_title_tag, pd.products_head_keywords_tag, pd.products_head_desc_tag, p.manufacturers_id from " . TABLE_PRODUCTS . " p left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id where p.products_id = '" . (int)$_GET['products_id'] . "' and pd.language_id ='" . $languages_id . "'");

$the_product_info = tep_db_fetch_array($the_product_info_query);

$header_tags_array['product'] = $the_product_info['products_head_title_tag']; //save for use on the logo

$tmpTags['prod_title'] = (tep_not_null($the_product_info['products_head_title_tag'])) ? $the_product_info['products_head_title_tag'] : '';

$tmpTags['prod_desc'] = (tep_not_null($the_product_info['products_head_desc_tag'])) ? $the_product_info['products_head_desc_tag'] : '';

$tmpTags['prod_keywords'] = (tep_not_null($the_product_info['products_head_keywords_tag'])) ? $the_product_info['products_head_keywords_tag'] : '';

 

$catStr = "select c.categories_htc_title_tag as htc_title_tag, c.categories_htc_desc_tag as htc_desc_tag, c.categories_htc_keywords_tag as htc_keywords_tag from " . TABLE_CATEGORIES_DESCRIPTION . " c, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where c.categories_id = p2c.categories_id and p2c.products_id = '" . (int)$the_product_info['products_id'] . "' and language_id = '" . (int)$languages_id . "'";

$manStr = "select mi.manufacturers_htc_title_tag as htc_title_tag, mi.manufacturers_htc_desc_tag as htc_desc_tag, mi.manufacturers_htc_keywords_tag as htc_keywords_tag from " . TABLE_MANUFACTURERS . " m LEFT JOIN " . TABLE_MANUFACTURERS_INFO . " mi on m.manufacturers_id = mi.manufacturers_id where m.manufacturers_id = '" . (int)$the_product_info['manufacturers_id'] . "' and mi.languages_id = '" . (int)$languages_id . "' LIMIT 1";

 

if ($pageTags['append_root'])

{

$sortOrder['title'][$pageTags['sortorder_root']] = $pageTags['page_title'];

$sortOrder['description'][$pageTags['sortorder_root']] = $pageTags['page_description'];

$sortOrder['keywords'][$pageTags['sortorder_root']] = $pageTags['page_keywords'];

$sortOrder['logo'][$pageTags['sortorder_root']] = $pageTags['page_logo'];

}

 

if ($pageTags['append_product'])

{

$sortOrder['title'][$pageTags['sortorder_product']] = $tmpTags['prod_title']; //places the product title at the end of the list

$sortOrder['description'][$pageTags['sortorder_product']] = $tmpTags['prod_desc'];

$sortOrder['keywords'][$pageTags['sortorder_product']] = $tmpTags['prod_keywords'];

$sortOrder['logo'][$pageTags['sortorder_product']] = $tmpTags['prod_title'];

}

 

$sortOrder = GetCategoryAndManufacturer($sortOrder, $pageTags, $defaultTags, $catStr, $manStr, true);

if ($pageTags['append_default_title'] && tep_not_null($tmpTags['def_title'])) $sortOrder['title'][$pageTags['sortorder_title']] = $tmpTags['def_title'];

if ($pageTags['append_default_description'] && tep_not_null($tmpTags['def_desc'])) $sortOrder['description'][$pageTags['sortorder_description']] = $tmpTags['def_desc'];

if ($pageTags['append_default_keywords'] && tep_not_null($tmpTags['def_keywords'])) $sortOrder['keywords'][$pageTags['sortorder_keywords']] = $tmpTags['def_keywords'];

if ($pageTags['append_default_logo'] && tep_not_null($tmpTags['def_logo_text'])) $sortOrder['logo'][$pageTags['sortorder_logo']] = $tmpTags['def_logo_text'];

 

FillHeaderTagsArray($header_tags_array, $sortOrder);

break;

 

// SPECIALS.PHP

case (strstr($_SERVER['PHP_SELF'],FILENAME_SPECIALS) or strstr($PHP_SELF,FILENAME_SPECIALS)):

$pageTags_query = tep_db_query("select * from " . TABLE_HEADERTAGS . " where page_name like '" . FILENAME_SPECIALS . "' and language_id = '" . (int)$languages_id . "'");

$pageTags = tep_db_fetch_array($pageTags_query);

 

// Build a list of ALL specials product names to put in keywords

$new = tep_db_query("select p.products_id, pd.products_name, p.products_price, p.products_tax_class_id, p.products_image, s.specials_new_products_price from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_SPECIALS . " s where p.products_status = '1' and s.products_id = p.products_id and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' and s.status = '1' order by s.specials_date_added DESC ");

$row = 0;

$the_specials='';

while ($new_values = tep_db_fetch_array($new)) {

$the_specials .= clean_html_comments($new_values['products_name']) . ', ';

}

 

if (strlen($the_specials) > 30000) //arbitrary number - may vary with server setting

$the_specials = substr($the_specials, 0, 30000); //adjust as needed

 

if ($pageTags['append_root'])

{

$sortOrder['title'][$pageTags['sortorder_root']] = $pageTags['page_title'];

$sortOrder['description'][$pageTags['sortorder_root']] = $pageTags['page_description'];

$sortOrder['keywords'][$pageTags['sortorder_root']] = $pageTags['page_keywords'];

$sortOrder['logo'][$pageTags['sortorder_root']] = $pageTags['page_logo'];

}

 

$sortOrder['keywords'][10] = $the_specials;;

 

if ($pageTags['append_default_title'] && tep_not_null($tmpTags['def_title'])) $sortOrder['title'][$pageTags['sortorder_title']] = $tmpTags['def_title'];

 

I have reversed that above and the program work well so far.

Share this post


Link to post
Share on other sites

Hello

 

Just finished installing this great looking contribution - but I am stuck !!!!!

 

I installed the catalog ok and every thing looked fine.

 

Then installed the admin and when I try to open the admin login panel I get the following warnings

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at W:\www\oscommerce\security_panel\includes\database_tables.php:68) in W:\www\oscommerce\security_panel\includes\functions\sessions.php on line 102

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at W:\www\oscommerce\security_panel\includes\database_tables.php:68) in W:\www\oscommerce\security_panel\includes\functions\sessions.php on line 102

Warning: Cannot modify header information - headers already sent by (output started at W:\www\oscommerce\security_panel\includes\database_tables.php:68) in W:\www\oscommerce\security_panel\includes\functions\general.php on line 22

 

After these messages I replace the general.php and categories.php with the originals but still get the same problem !!!!

 

Hope some one can help

 

Thanks ... Dennis

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×