Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

There probably isn't one. The stand-alone category descriptions addon became a waste of time since the main two SEO addons - this one and Header Tags SEO Reloaded - both have that option. You will need to convert the code for that addon so it works with your shop if you want to use it.

Share this post


Link to post
Share on other sites

Hello.

 

I really like your script. I finally am about to finish with my webshop, but when i was on page control I accidently added the index link with http://www.mydomainname/index.php/pathid in pseudo page and now my webshop gets a blank screen. I've been searching for hours but i cannot find any table in phpmyadmin, or any other solution for this problem. I deleted the name out of the page control, but i still can't acces index.php, my admin section is still working fine though.

I really hope you could help me, it would save me days of work if i dont have to do everything again.

 

Thank you in advance,

Kind regards,

Martin

Share this post


Link to post
Share on other sites

Now back to what I was looking for in first place, i read that it is possible to add category description with header tags, but i can't find how. Could someone please explain me how to do it ? kind regards

Share this post


Link to post
Share on other sites

@@headertagsfan For the index problem, I don't know how you were able to add the page in the first place. The code should have prevented that - it does when I try it here.  If you haven't made too many changes yet, I suggest using the uninstall and install scripts to clear that up.

 

For adding category descriptions, when you edit a category you will see a large box at the bottom of the right column. Anything you enter there will appear on that category page. You should do the same for the manufacturers if you use them. But both of those are controlled by index.php so if that file is not entered correctly in Page Control, you may have problems.

Share this post


Link to post
Share on other sites

I added the code by putting the entire webshop https://www.-----.com/index.php/pathid link in it. I could delete it right away and when i added a new page the problem was fixed. This is one for a future update, for novice people like me :P. Thank you very much for your fast response.

 

Back to the description: I clicked on "edit category" but it shows like default options. screenshot: http://www.tiikoni.com/tis/view/?id=8db4226

 

It shows only category name, images, and sort order. Could this mean that i made a mistake when installing header seo? Because the mod is working perfectly fine, i can fill tags etc. Would be nice to be able to add cat descriptions.

 

Thank you.

Edited by headertagsfan

Share this post


Link to post
Share on other sites

Hi All

 

I have set the Display Category Parents in Title and Tags =  'Full Category Path'

In my page control I have ticked off the  'Category' box for product_info.php  but I do not see the parent category in my title.

 

I am using OsCommerce V2.3.3  and Header Tags SEO V 3.3.4

Share this post


Link to post
Share on other sites

@@shoshoni Be sure you have the category boxed checked (see the note in the setting). Also, to be clear, the title that setting refers to is the web browser title, not the page title. If you view the source of the page you should see the category name there.

Share this post


Link to post
Share on other sites

Hello @Jack_mcs.. Thank you for this addon.. I would like to ask you, I am trying to install it on osc 2.3 bs Edge. I have  Modular Product Page (Bootstrap) installed.. so the product_info.php so different ,I found almost all the changing code but still one change I didn't find it ,  Do you have any idea  where I can change or add  this code :

FIND:

    $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'");
    $product_info = tep_db_fetch_array($product_info_query);

REPLACE WITH:

    /*** Begin Header Tags SEO ***/
    $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id, pd.products_head_sub_text from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'");
    $product_info = tep_db_fetch_array($product_info_query);
    
    $product_info['products_name'] = $header_tags_array['title_alt'];
    /*** End Header Tags SEO ***/ 

Joe

Share this post


Link to post
Share on other sites

I'm not familiar with Modular Product Page so I can't say where the code might be. But it has to be calling the database similar to what is in the instructions so you could try searching your files for it. If you still can't fine it, you can ask in the support thread for that addon.

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

  • Added IP Tracking to the keyword tool.  
  • Added a new page to display links using model numbers.
  • Added am option to enable the html editor, if installed, for manufacturers.
  • Added an additional words option for the products.
  • Fixed the character counter in Page Control so it displays correctly on page load.
  • Fixed the code for adding pseudo pages. Uses a common function to control all of the pages.
  • Fixed the keyword search to work with assigned words.
  • Fixed some security holes.
  • Changed the test function to check for missing category and manufacturer descriptions.
  • Changed the install and uninstall files to be more generic and to allow for deleting the files after use.
  • Changed code throughout for speed improvements.
  • Corrected mistake in admin/manufacturers.php.
  • Corrected mistake in index.php.
  • Corrected mistake in admin/includes/functions/header_tags.php that prevented titles and tags from showing on some pages.
  • Corrected mistake in admin/includes/functions/header_tags_general.php that prevented the breadcrumb text from showing - found by member milerwan.
  • Corrected mistake in install instructions for admin changes - found by IWAS.
  • Corrected mistake in includes/header_tags.php that prevented product titles from showing when the "Use Item Name on Page" was used.
  • Corrected mistake in the admin test section that incorrectly reported missing files.
  • Optimized the css file for speed and to use the shops fonts.
  • Removed the need for filename definitions in admin.
  • Removed the ssl check for the keywords module in the footer.
  • Removed STS checking code.

Notes:

1 - This version marks the end of keeping the install files up-to-date for pre-2.3 shops. Update files will still be provided but may not cover all versions. However, the included files will be kept up-to-date.

2 - The page to display model numbers needs to be enabled. That can be done via the modules section in BS shops, and maybe later 2.3.4 shops. For all others, a link will have to be added (an example link is included in the docs). This was not done automatically since not all shops use model numbers, at least not official ones. For those that do use them, this page allows a way for customers to quickly find what they want and will provide additional links to products via the model numbers, which helps with SEO.

3 - The handling of pseudo pages has been changed a great deal. This fixes the problem some shops were having where the includes/header_tags.php file would become corrupted. I have tested this code in a number of shops but there is a large number of variations that can occur so I can't test them all. Should the shop fail after visiting Page Control, this is most likely the cause. The quick fix is to replace the includes/header_tags.php file with the one from this package. I don't expect this to happen but...

Please let me know if any problems are found.

 

Share this post


Link to post
Share on other sites

I think I found some errors in admin docu:

In admin/categories.php,

...

FIND (around line 1084):

        $category_inputs_string = $category_description_string = $category_seo_description_string = $category_seo_keywords_string = $category_seo_title_string = '';
        $languages = tep_get_languages();

...
       tep_draw_input_field('categories_seo_keywords[' . $languages[$i]['id'] . ']', tep_get_category_seo_keywords($cInfo->categories_id, $languages[$i]['id']), 'style="width: 300px;" placeholder="' . PLACEHOLDER_COMMA_SEPARATION . '"');
    }    //    <===MISSING LINE

....

Make the following changes to admin/manufacturers.php

....

FIND (around line 213):

      $manufacturer_inputs_string = $manufacturer_description_string = $manufacturer_seo_description_string = $manufacturer_seo_keywords_string = $manufacturer_seo_title_string = '';

      $languages = tep_get_languages();

...
      tep_draw_input_field('manufacturers_seo_title[' . $languages[$i]['id'] . ']', NULL, 'style="width: 300px;"');

    }    //    <===MISSING LINE

Share this post


Link to post
Share on other sites

Thanks for posting the possible problem but I don't think it is one. The instructions don't say to remove the } so it isn't in the replacement code.  The code being inserted goes above the } you mention. Please re-read the instructions and compare it to what you did and let me know if that is not the case.

Share this post


Link to post
Share on other sites

@Jack_mcs In a large shop with a lot of categories and products, the silo box slows down index.php and manufacturers.php when enabled. When it's disabled, the site is lightening fast.

Thanks for the improvements

Share this post


Link to post
Share on other sites

Yeah, the silo code really needs an update. One change I think will help is this. Find this line

             $catname = tep_db_fetch_array(tep_db_query("select categories_name from " . TABLE_CATEGORIES_DESCRIPTION . " where categories_id = '" . (int)$catID . "' and language_id = '" . $languages_id . "' limit 1"));

and move to above this line

        while ($silo = tep_db_fetch_array($silo_query)) {

I haven't tested this but I think it will work. Please let me know how it goes.

Share this post


Link to post
Share on other sites

Keywords are first and foremost priority of any SEO header Expert. In the matter, we first do the research of best keywords according to the web page and then categorize these keywords into focus keyword, primary keyword, secondary keyword and tertiary keyword. Focus Keyword is always one for the web page. It’s better to include your focus keyword into the title, Meta tags, header tags and h1 to h6 of the webpage.

Share this post


Link to post
Share on other sites
5 hours ago, webdogs678 said:

Keywords are first and foremost priority of any SEO header Expert.

Don't confuse people. Due to chronic abuse by SEO "experts", most search engines simply ignore the meta keywords tag, or at best, use it as an advisory to see what to pick out as keywords from other places on the page. You certainly do want to decide on some key words (terms that people will search for) to use in various places on the page, but don't confuse these with a list of keywords in a meta tag.

Share this post


Link to post
Share on other sites

Hi Jack

 

I decided to "bite the bullet" and have a go at installing this addon. It looks great. However I seem to have 1 problem

1) Only a few of my manufacturers are showing, as  listed below and not in order, the others appear as "The name for this item is missing". Goodness knows why this might have happened. I also have this message showing at the top of the Page Control page " Manufacturers table has 10 items with missing meta tag information. "

Look forward to any comments.

Many thanks

Grandpa

 

SEO.jpg.e399b41233200b596939bf5b4179904c.jpg

Share this post


Link to post
Share on other sites

All of those listed have problems. The ones that show "The name for this item is missing" means the name of the manufacturer is missing. For the others, it  means the items mentioned are missing the entry for the web browser title or meta tags. What you are seeing are links so if you click on one it will take you to the edit page for that item so you can check it. If you didn't run Fill Tags for Manufacturers then that would explain the ones with the names.

Share this post


Link to post
Share on other sites

Hi Jack

I did run the Full Tags first, As far as Im aware I followed all instructions to the letter. "The name for this item is missing"  all the Categories are present,  except fpr some reason don't all appear in the "Test". I am again going to uninstall and re install and see what happens. Rather strange this one.

I am using Version 3.3.4 Header Tags SEO (April 2016) as my site is about 12/18 months old so I doubt that the latest version of Header Tags SEO will work with it.

Will report back later.

Many thanks

Grandpa

Edited by grandpaj
More info

Share this post


Link to post
Share on other sites

Instead of starting over, which I don't think will help, I suggest you first look at one of those items. Click on the link and make sure all of the standard entries, like the name, are there.

I don't recall there being any big differences for the various BS shops. The code in that shop was changed quite a bit over time and I don't know which version I used for the released package.

Share this post


Link to post
Share on other sites

Hello Jack,

I upgraded to your latest version (posted on the previous page), compared all files, did the database upgrade and all works as before except one glitch... when in admin and copying a product the Title Tag - URL shows up in the block for Title Tag and the Meta Description in the block for Title Tag - Alternate and the Meta Description and keywords blocks are empty !

 

I compared each file once again and can not find an explanation for this erroneous database pull. Any ideas ?

 

Thanks in advance

Share this post


Link to post
Share on other sites

Thank you for reporting this. To fix it, in admin/categories.php, around line 407, find

              tep_db_query("insert into products_description (products_id, language_id, products_name, products_description, products_url, products_viewed, products_head_title_tag, products_head_title_tag_alt, products_head_title_tag_url, products_head_desc_tag, products_head_keywords_tag, products_head_breadcrumb_text, products_head_listing_text, products_head_sub_text, products_head_additional_words) values ('" . (int)$dup_products_id . "', '" . (int)$description['language_id'] . "', '" . tep_db_input($description['products_name']) . "', '" . tep_db_input($description['products_description']) . "', '" . tep_db_input($description['products_head_title_tag']) . "', '" . tep_db_input($description['products_head_title_tag_alt']) . "', '" . tep_db_input($description['products_head_title_tag_url']) . "', '" . tep_db_input($description['products_head_desc_tag']) . "', '" . tep_db_input($description['products_head_keywords_tag']) . "', '" . tep_db_input($description['products_head_breadcrumb_text']) . "', '" . tep_db_input($description['products_head_listing_text']) . "', '" . tep_db_input($description['products_head_sub_text']) . "', '" . tep_db_input($description['products_head_additional_words']) . "', '" . tep_db_input($description['products_url']) . "', '0')");

and replace it with

              tep_db_query("insert into products_description (products_id, language_id, products_name, products_description, products_url, products_viewed, products_head_title_tag, products_head_title_tag_alt, products_head_title_tag_url, products_head_desc_tag, products_head_keywords_tag, products_head_breadcrumb_text, products_head_listing_text, products_head_sub_text, products_head_additional_words) values ('" . (int)$dup_products_id . "', '" . (int)$description['language_id'] . "', '" . tep_db_input($description['products_name']) . "', '" . tep_db_input($description['products_description']) . "', '" . tep_db_input($description['products_url']) . "', '0', '" . tep_db_input($description['products_head_title_tag']) . "', '" . tep_db_input($description['products_head_title_tag_alt']) . "', '" . tep_db_input($description['products_head_title_tag_url']) . "', '" . tep_db_input($description['products_head_desc_tag']) . "', '" . tep_db_input($description['products_head_keywords_tag']) . "', '" . tep_db_input($description['products_head_breadcrumb_text']) . "', '" . tep_db_input($description['products_head_listing_text']) . "', '" . tep_db_input($description['products_head_sub_text']) . "', '" . tep_db_input($description['products_head_additional_words']) . "')");

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×