Jump to content
Latest News: (loading..)
Jack_mcs

Header Tags SEO

Recommended Posts

Thanks for the response, but I don't quite understand. I took my site back over from a crooked webmaster years ago and what little has sunk into my brain isn't quite enough to understand your help completely. If I just rename the index file, how does that help me see changes to a category page? I don't know if my site uses a url rewriter or not, or what that is.

Share this post


Link to post
Share on other sites

The index.php file controls the home, categories and manufacturers pages. If you can see index.php in the browsers url box when on a category page then you probably are not using a url rewriter.

Share this post


Link to post
Share on other sites

This site must use  a url rewriter then, as the category (and product) pages end in  .html ...........I guess this site has  seo url contribution or something, so I toggled that off in admin (made "enable seo url" false) but that broke something and made category pages unreachable, so I turned it back on right quick. Whatever, I'm just a monkey pushing buttons at random, basically, and shouldn't be tinkering with anything at this point.

Share this post


Link to post
Share on other sites

It sounds like you have an older version of Ultimate SEO installed since that problem existed in them. If you want to test the index file, you can type this directly into the url box without turning off the rewriter:

 

http://YOUR DOMAIN NAME//index.php?cPath=xx

 

xx is the ID of the category you want to view. It is the number that appears in the normal url as -c-xx.html

Share this post


Link to post
Share on other sites

That worked, thanks a bunch. So yeah, since that worked on the renamed index.php, I just need to compare them to find out what I did wrong on the install.

Share this post


Link to post
Share on other sites

Yes, that's correct. There is a free compare program named WinMerge that works well for doing that.

Share this post


Link to post
Share on other sites

Hi,  I have installed  Header Tags Seo V3.3.4  but I wanna delete the Title/Description etc but it don't delete it when I push the button, even new content it don't overwrite. 

Edited by Boldman

Share this post


Link to post
Share on other sites

@@Boldman This is too vague a question for me to respond. Are you editing Page Control, a category, a product, a manufacturer? If you want to clear them all, you can use the clear all tags in Fill Tags?

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

There's nothing to stop that as far as I can remember. I just tried it here on a test shop and it worked. But that would be a big mistake with regards to SEO so I suggest you not do it.

Share this post


Link to post
Share on other sites

Are the permissions set correctly on the includes/header_tags.php file? That's the only thing I can think of that may stop it, though I don't think it will. If you are saying you go into Page Control, select index.php, make a change to the title box, click update and it doesn't take, then if it is not the permissions, it has to be something wrong with your installation. When the update button is clicked, the database is updated using standard oscommerce code. Are you able to edit a product and change one of its fields?

Share this post


Link to post
Share on other sites

When I change the content from index.php from the title box and update it updates in the title box but when I looking the source of the page itself it won't change, strange.

 

I got notest when I was busy with rankingcoach, it was advice me to write some words in the title,  when I did a change in header tags Seo index.php and update then I did a recheck and it did not found the words I have updated.

 

permissions set correctly on the includes/header_tags.php file  755

 

this line is in the tiitle box of index.php :  Fiets Damesfiets Herenfiets meisjesfiets jongensfiets Herselt

Check the index on fashionbikes.be/shop/index.php

Edited by Boldman

Share this post


Link to post
Share on other sites

This is different than what you originally said. If you can change the text in Page Control then the admin is working correctly. In that case, the problem is on the shop side. The problem could be in a few places. Does the title work correctly on the product page? If not, then you've made a mistake in the includes/template_top.php file.

Share this post


Link to post
Share on other sites

When I want to delete the index.php header tags it shows  error.gif Deletion of index.php is not allowed

Edited by Boldman

Share this post


Link to post
Share on other sites

That's correct. Doing so would render the addon mostly useless.

Share this post


Link to post
Share on other sites

@@Jack_mcs 

 

Running osc234 w/ bootstap

 

Ok I took the step and started the install

 

I did the first step, I installed the database > it came back successful with a continued button.

 

Then I uploaded the second step, I uploaded the catalog part.  Went to the site and all I had was a white screen. 

 

What is wrong.

Dean

Share this post


Link to post
Share on other sites

There is a directory named catalog and another named catalog_only_new_files. You can, and should, upload the latter without causing any problems. But the catalog directory contains edited files that probably don't match your site. So if you uploaded them, it will break the shop, as mentioned in the installation instructions. For shops that have been edited, you have to apply the changes manually. 

Share this post


Link to post
Share on other sites

@@Jack_mcs

 

I read the "read me first"

 

Went to the BS version, printed out both catalog and admin install.  I followed the instructions and uploaded the seo install and installed it, successfull.

Then the (still in BS) the Cat new files. 

Thin I used the Merge program, following the BS install catalog.txt, to but the parts of the files in the pages as the instruction said.  I compared the BS Catalog directory files to mine and used merge to place the files.  

Next I uploaded them.  Then the White page. 

Share this post


Link to post
Share on other sites

@@Jack_mcs

 

one more thing.  Before I opened my site I did go and and change the permission to 755 on the header tags.php file.

Share this post


Link to post
Share on other sites

@@dculley  If I recall correctly, you have a 2.3.4 shop with the Bootstrap code added as opposed to the actual BS shop. If that is correct, then the files in the "Use_if_version_greaterthan_2.3" directory are probably closer to what you have. Either set of files will work for comparing. Just be watchful of the differences.

 

The white screen means there is a fatal mistake in the code. To find out what it is, try one of these:

 

1 - See if there is a file named error_log in the root of the shop. If there is, it should have the cause of the failure (last line).

 

2 - Open the includes/application_top.php file, find the line near the top starting with error_reporting and add this line after it:

  ini_set('display_errors','1'); 

Be sure you don't already have that line. If you do, then set it to 1, assuming it is set to 0. Then reload the page and you should see at least one failure. It is usually the last one that is causing the problem. When you are done, you should leave that line in the file but change it to a value of 0.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

@@Jack_mcs

 

I may will work on it again this week end. 

 

I was very careful of watching where the lines were placed.  Kind of bombed out about it.  I took me some time to get the files ready or I thought ready.  It was no rush job.  But we will see.

 

Thanks

Share this post


Link to post
Share on other sites

When there are problems like this, the best approach, in my opinion, is to get the admin changes applied and working first. That way the shop side is not affected and you know the database is setup correctly. Then on the shop side, the only changes needed for an initial test is those to the includes/template_top.php and index.php or product_info.php (the latter is the easier of the two). If it still fails, then the problem is in one of those two files and should be easy to located. Good luck. :)

Share this post


Link to post
Share on other sites

@@Jack_mcs

 

one more thing.  Before I opened my site I did go and and change the permission to 755 on the header tags.php file.

That is rarely necessary. Only a few very oddly set-up servers need .php files to be marked "executable". 644 (read-write by owner, read-only by everyone else) will usually do the job, although files that PHP needs to write to (update) may have to be "writable" by group (664) or even by world (666), depending on how your server is set up (where PHP is running). In general, you want to give directories and files the least (most restrictive) permissions that will do the job. Don't listen to fools who blithely tell you to "chmod 777 everything" -- they're dead wrong.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

@@Jack_mcs Hi Jack

I didn't get very far this weekend. I just got a chance to start on it late today. 

 

I took what you said earlier  "If I recall correctly, you have a 2.3.4 shop with the Bootstrap code added as opposed to the actual BS shop. If that is correct, then the files in the "Use_if_version_greaterthan_2.3" directory are probably closer to what you have. Either set of files will work for comparing. Just be watchful of the differences."

 

So I started from scratch and went to the "version greaterthan 2.3".  I ran into 2 things right of the bat.  On the Install Catalog.txt, last thing want me to add a line the sytlesheet.css.  Well I don't have that file.  Never did since I went to osc with BS.  So I said okay lets try to do the first step - File changes to includes/template_top.php.  Using eh template top.php under the catalog file (greater then) I used winmerge, when I went to but the file agents mine it was way off.  2 totally different files.  So I went back to the BS SEO, went to that catalog file and compared that file with mine, now it looked cohesive.

 

So I'm guessing that I may be using a truer BS version.  I didn't go any further with the "greater than".  I guess I will have to revisit the BS and see what I can do. 

 

Just wanted to bring you up to date. 

 

Dean

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×