Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

OK so basically if i cannot resolve it with the host i can always just add the data via an editor manually then re-upload to the server.

 

Thanks for your help.

Share this post


Link to post
Share on other sites

Also i have just noticed that my Banners have been disabled and aren't showing despite being set in Banner Manager to enabled, do you happen to know what might be causing that?

Share this post


Link to post
Share on other sites

OK so basically if i cannot resolve it with the host i can always just add the data via an editor manually then re-upload to the server.

 

Thanks for your help.

No, that's not necessarily. The image you showed was for the View Result option. That allows you to see the title and tags on the page as a search engine would. It is just a viewing tool. You can, or at least should be able to, enter the data in Page Control and click update.

 

This addon doesn't have anything to do with the banners. If it is affecting them, it is because a mistake was made in the installation.

Share this post


Link to post
Share on other sites

Ok i will look into the banners issue later, the problem i am having is when i click update in Page Control i get 2 red boxes and a 403 forbidden message, this occurs for product_info.php

Share this post


Link to post
Share on other sites

The image you showed is for the View Result option and isn't looked at when the update button is pressed. It sounds like you have more issues with your installation than can be handled here. I do suggest you create a stock shop and use the included code in it. If you still have all of these problems then it is server related, though I've never see that happen.

Share this post


Link to post
Share on other sites
Some days ago I upgraded on osc 2.3.4. On product info page I have links to datasheet among description of products. If I download fill tags manufacturers all links become wrong and they lead me to page error 404. Instead of .../datasheet-manafacturers-

productname.pdf  changes into .../datasheet-<strong>manafacturers</strong>-productname.pdf

If I clear manufacturers tags then links work.

Share this post


Link to post
Share on other sites

@@Matjaz It might be because of the Highlight Keywords option. Try turning that off to see if the problem goes away.

Share this post


Link to post
Share on other sites

Yes, problem was in this. It work correctly only if Keyword Highlighter is off. In other two options of highlighter links do not work. Thank you.

Share this post


Link to post
Share on other sites

Hi,

 

I have OSC 2.3.3.3 installed and in the contri pack there are two versions before en after 2.3 which one is the best to install.. i don't use sts or bts

 

Greetings.. Anne

Share this post


Link to post
Share on other sites

This is the support thread for Header Tags SEO, not oscommerce. You should post your question in the general forum.

Share this post


Link to post
Share on other sites

Hi,

 

Ive been installing HTSEO and have come up with a bit of a problem that I have search for an answer for but had no real luck....

 

The keywords page in admin does not load properly.

 

here is an image of what it looks like http://creativeabundance.com.au/header_tag_SEO_keywords.jpg ... because I have not seen this working anywhere else I don't know what is missing or where the problem could be - every other page seems to be loading properly (at least without having done any actual using of the functions)

 

By the way are there any good online resources to explain all the SEO stuff that people would recommend?

Share this post


Link to post
Share on other sites

Hi,

 

Forgot a few things in my post.. Correct question :

 

I have OSC 2.3.3.3 installed and in the contri pack of Header Tags SEO there are two versions before en after 2.3 which one is the best to install.. on 2.3.3.3 i don't use sts or bts

 

Greetings.. Anne

Share this post


Link to post
Share on other sites

@@bigbird_3156 The store keywords options needs to be enabled and at least one search done on the site. Other than that, there shouldn't be any reason for the keywords not to display.

Share this post


Link to post
Share on other sites

@@Dj-Viper The text on the directories say if less than or greater than 2.3. Since 2.3.3.3 is greater than 2.3, you would use that one.

Share this post


Link to post
Share on other sites

Hi,

 

Ok thanxs for the info... was asking because another contri was also before and after 2.3 and the after 2.3 didn't work there..

 

So was asking to make sure..

 

Greetings, Anne

Share this post


Link to post
Share on other sites

Question, upgrading my SEO from 3.3.0 to 3.3.1 the upgrade instructions are pointing to something that has not been part of the admin/categories.php.  In step 9 around line 388 find:  it is looking for something that is not part of categories.php or found in categories.php.  Also the the same is true for line 417, the layout in the categories.php dos not match the file to find.

 

So the question is what to do?

 

I have stopped here not sure what else I will find. 

Share this post


Link to post
Share on other sites

@@dculley You don't mention what version of oscommerce you are using or what the missing text is so I can't offer much help. But there are 3 or 4 variations of the stock categories file so the instructions can't cover them all. Well, it could but I don't have the time it would take to maintain them all. So the best thing to do in a case like this is to compare your file against the included one. It won't match but should be close. Or ask a specific question with all of the needed information and I will try to address it here.

Share this post


Link to post
Share on other sites

I've used the old version of this great contribution on my old Oscommerce site. Now I have upgraded to latest version (OSC 2.3.4) and I wonder if Header Tags SEO V 3.0 works on that?

 

I also have Ultimate Seo Urls 5 PRO installed, I hope that is not a problem.

 

 

Share this post


Link to post
Share on other sites

Hi,

 

I installed the contribution, did everthing in de install files...  sql, php changes... etc..

 

Also no error.. But when i want to fill tags... i get this message in the box..

 

No Category tags have been filled. No Manufacturer tags have been filled.

No Product tags have been filled.

 

Using 3.3.2a and osc 2.3.3.4

 

Greetings, Anne

Edited by Dj-Viper

Share this post


Link to post
Share on other sites

@@Dj-Viper If this is an update, that may be valid. If it is new, then maybe it is a language problem. In that case, please run the test routine to see if anything shows up.

Share this post


Link to post
Share on other sites

@@Jack_mcs  I will try to give you more information.  I’m using Osc v 2.3.4.  I trying to catch up on some other updates.  In your version of 3.3.0 upgrade to 3.3.1, under the use_if_version_greaterthan_2.3/catalog/admin/categories.php. I used as a reference against mine.  The one in the upgrade does not have the files either to match step 9.

 

With the above said.  And I’m upgrading from 3.3.0, I’, using the document under: headerTags_SEO_v_3.3.1\Docs\Update_Docs\update_v_3.3.0_to_v_3.3.1.txt.  Everything was matching until I got to step 9 line 388

 

FIND:

 

      $products_head_title_tag = $HTTP_POST_VARS['products_head_title_tag'];

      $products_head_desc_tag = $HTTP_POST_VARS['products_head_desc_tag'];

      $products_head_keywords_tag = $HTTP_POST_VARS['products_head_keywords_tag'];

      $products_head_listing_text = $HTTP_POST_VARS['products_head_listing_text'];

      $products_head_sub_text = $HTTP_POST_VARS['products_head_sub_text'];

      $products_url = $HTTP_POST_VARS['products_url'];

    } else {

      $product_query = tep_db_query("select p.products_id, pd.language_id, pd.products_name, pd.products_description, pd.products_head_title_tag, pd.products_head_desc_tag, pd.products_head_keywords_tag, pd.products_head_listing_text, pd.products_head_sub_text, pd.products_url, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status, p.manufacturers_id  from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = pd.products_id and p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "'");

      $product = tep_db_fetch_array($product_query);

      /*** End Header Tags SEO ***/

 

The above is no were to found in the admin/categories.php.   I went back to my oldest backup in 2012 and it is not part of the page.  So is it needed?  If so what is the correct coding?

 

Next on line 417 it does not match the page.

 

Doc says to find:

FIND:

 

        $pInfo->products_head_title_tag = tep_db_prepare_input($products_head_title_tag[$languages[$i]['id']]);

        $pInfo->products_head_desc_tag = tep_db_prepare_input($products_head_desc_tag[$languages[$i]['id']]);

        $pInfo->products_head_keywords_tag = tep_db_prepare_input($products_head_keywords_tag[$languages[$i]['id']]);

        $pInfo->products_head_listing_text = tep_db_prepare_input($products_head_listing_text[$languages[$i]['id']]);

        $pInfo->products_head_sub_text = tep_db_prepare_input($products_head_sub_text[$languages[$i]['id']]);

        $pInfo->products_url = tep_get_products_url($pInfo->products_id, $languages[$i]['id']);

      } else {

        $pInfo->products_name = tep_db_prepare_input($products_name[$languages[$i]['id']]);

        $pInfo->products_description = tep_db_prepare_input($products_description[$languages[$i]['id']]);

        $pInfo->products_head_title_tag = tep_db_prepare_input($products_head_title_tag[$languages[$i]['id']]);

        $pInfo->products_head_desc_tag = tep_db_prepare_input($products_head_desc_tag[$languages[$i]['id']]);

        $pInfo->products_head_keywords_tag = tep_db_prepare_input($products_head_keywords_tag[$languages[$i]['id']]);

        $pInfo->products_head_listing_text = tep_db_prepare_input($products_head_listing_text[$languages[$i]['id']]);

        $pInfo->products_head_sub_text = tep_db_prepare_input($products_head_sub_text[$languages[$i]['id']]);

        $pInfo->products_url = tep_db_prepare_input($products_url[$languages[$i]['id']]);

      }

    /*** End Header Tags SEO ***/

 

The admin/categories.php the only thing close is the following;

 

    /*** Begin Header Tags SEO ***/

    $languages = tep_get_languages();

    for ($i=0, $n=sizeof($languages); $i<$n; $i++) {

      $pInfo->products_name = tep_get_products_name($pInfo->products_id, $languages[$i]['id']);

      $pInfo->products_description = tep_get_products_description($pInfo->products_id, $languages[$i]['id']);

      $pInfo->products_head_title_tag = tep_db_prepare_input($products_head_title_tag[$languages[$i]['id']]);

      $pInfo->products_head_desc_tag = tep_db_prepare_input($products_head_desc_tag[$languages[$i]['id']]);

      $pInfo->products_head_keywords_tag = tep_db_prepare_input($products_head_keywords_tag[$languages[$i]['id']]);

      $pInfo->products_head_listing_text = tep_db_prepare_input($products_head_listing_text[$languages[$i]['id']]);

      $pInfo->products_head_sub_text = tep_db_prepare_input($products_head_sub_text[$languages[$i]['id']]);

      $pInfo->products_url = tep_get_products_url($pInfo->products_id, $languages[$i]['id']);

    /*** End Header Tags SEO ***/

 

So what do I need to update?

 

I haven’t gone any further.   I’m used to things matching a lot better than the above.

Share this post


Link to post
Share on other sites

Hi,

 

Did the test in Header Tags SEO Configuration - Test

 

Got this.. 

 

Duplicate title found:  explain   for Nederlands exists more than once.  
pixel_black.gif   Duplicate meta description found:  explain   for Nederlands exists more than once.  
pixel_black.gif   Missing Title and/or descriptions:  explain     Products Hama Achtergrond 135cm x 11m Beige

 

Greetings, Anne

Share this post


Link to post
Share on other sites

@@dculley That looks like code In a pre-2.3 shop so I may not have edited the instructions correctly. You may want to use the actual install instructions instead because I think they are correct. But it would be easier if you used a compare program, link WinMerge, and compared the included file with yours. The blocks of code for Header Tags SEO are the same, there are just edits within them. So if you search for Begin and End Header Tags SEO, you can quickly find the sections that need changing.

Share this post


Link to post
Share on other sites

@@Dj-Viper Is this an update or a new installation? If you go into a category or product edit page, is the Header Tags SEO title box filled in?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×