Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Thanks for responding. I think, or I'm pretty sure that all the database table entries are complete as I added them when the errors popped up, and nore more db issues have surfaced. I am 99.99 % certain that all of the files were uploaded correctly. As I mentioned, everything does appear to be functioning properly except for those errors about missing files which I know are there, and the cache reset function issue I mentioned. If I knew where that function was being called from I could probably figure it out from there. If you could point me in that direction that would be great.

 

Thanks again Jack. I cannot imagine how much effort you put into this.

 

AJ

Share this post


Link to post
Share on other sites

When you say "upload," I assume you are referring to Easy Populate. If that is the case, then you need to enable the Header Tags setting in that file and fill in the Header Tags fields before uploading.

 

I know that I can set it in Easy Populate. I thought that I could just set it in the Admin for the Product Header Tags and have the title and descriptions come up on the new products instead of having to mess with the header tags in the spreadsheet every time. In the Admin I can use ITEMNAME in the place of my product name whereas in the spreadsheet I can't and I have to mess with all those formulas to get things right every time I upload new products which is aggravating. It would be easier to just set it one time in the Admin. Is there not a way to just be able to set the Product Titles and Descriptions in the Admin and have them apply to all the new products I upload?

Share this post


Link to post
Share on other sites

Is there not a way to just be able to set the Product Titles and Descriptions in the Admin and have them apply to all the new products I upload?

When you first installed Header Tags SEO, you should have ran the basic Fill Tags (bottom of the page). That pre-fills all categories, manufacturers and products. You can edit those in their edit pages. When you add a new product, the title and tags are filled in automatically if you don't enter anything. If you are adding a new product and the title and tags don't get filled in, then there is either something wrong with your code or there is some problem in the Header Tags code that I am not aware of.

Share this post


Link to post
Share on other sites

When you first installed Header Tags SEO, you should have ran the basic Fill Tags (bottom of the page). That pre-fills all categories, manufacturers and products. You can edit those in their edit pages. When you add a new product, the title and tags are filled in automatically if you don't enter anything. If you are adding a new product and the title and tags don't get filled in, then there is either something wrong with your code or there is some problem in the Header Tags code that I am not aware of.

 

Do you know what file or where to look for the error? My categories fill out fine. It's just the products when I upload new products.

Edited by shelby72

Share this post


Link to post
Share on other sites

When you "upload" a new product, you either do so via Easy Populate or the products edit page in admin. At least, those are the only two ways I can guess at. Easy Populate uploads directly into the database. The Header Tags code is built-in so if you have a recent version, it should work. The products edit page is controlled by the categories.php file in admin. You can use the included one for testing.

Share this post


Link to post
Share on other sites

Hi Jack.

 

OK, well, I have a number of issues which I will need your help in sorting out. I've gone through the installation pretty thoroughly and ran into issues which are beyond my ability to solve.

 

First I want to say that this seems like an amazing contribution - you threw everything in there but the kitchen sink. I hope I can get it to do everything it appears capable of, especially with google being such a snot these days.

 

Anyhow, the download I did is supposed to be the complete package, but I run into these errors when trying to edit a product listing in admin:

 

 

TEXT_PRODUCTS_LISTING_TEXT Fatal error: Call to undefined function tep_get_products_head_listing_text() in /home/..../public_html/..../categories.php ....

TEXT_PRODUCTS_SUB_TEXT Fatal error: Call to undefined function tep_get_products_head_sub_text() in /home/..../public_html/..../categories.php ....

 

I searched through the package to see if I could find those functions and the define text, and the only place I got results from was from the installation instruction files.

 

I also followed the instructions, I believe, to the letter when modifying product info, but unfortunately the right column winds up below the left column. If I made a mistake I missed it, but I went through it twice and cannot find it. I am hoping you have seen or heard of this before and can tell me what to look for in trying to fix it. (I am horrible with nested tables, and I hate them!!).

 

I am working through this the best I can and trying not to bother you as you have already put in so much effort, but I am stuck on this atm.

 

Your help will be greatly appreciated. tia

 

AJ

Share this post


Link to post
Share on other sites

TEXT_PRODUCTS_SUB_TEXT is defined in admin/includes/languages/english/categories.php. The error you are seeing is saying it can't find one of the Header Tags SEO functions. That function gets included with the edit to the admin/includes/functions/general.php file.

 

I don't offer support for layout issues in this trhead since there are too many possible problems. You can use the included file to figure it out though. Also look back a page or three and see what was said with someone that had the same, or similar, problem.

Share this post


Link to post
Share on other sites

I'm not sure how I missed that edit - it was the first one on the page! doh!!!

 

Anyhow, it seems there were functions from header_tags which were creating a php problem, so I went and deleted the old ones in general.

 

This is perplexing on the defines as this is what the edits are:

 

/*** Begin Header Tags SEO ***/

define('TEXT_PRODUCT_METTA_INFO', '<b>Meta Tag Information</b>');

define('TEXT_PRODUCTS_PAGE_TITLE', 'Product Title Tag:');

define('TEXT_PRODUCTS_HEADER_DESCRIPTION', 'Product Description Tag:');

define('TEXT_PRODUCTS_KEYWORDS', 'Product Keywords Tag:');

/*** End Header Tags SEO ***/

 

TEXT_PRODUCTS_LISTING_TEXT and TEXT_PRODUCTS_SUB_TEXT are missing. What did I miss here? I searched the files for the edits on them but nothing comes up,,,,,,???

 

Other than that I think things will be alright. I'll have a look backwards on the alignment

 

 

Thanks again Jack

Share this post


Link to post
Share on other sites

This is what is in the english/categories.php file in the package

/*** Begin Header Tags SEO ***/
define('TEXT_PRODUCT_METTA_INFO', '<b>Meta Tag Information</b>');
define('TEXT_PRODUCTS_PAGE_TITLE', 'Product Title Tag:');
define('TEXT_PRODUCTS_HEADER_DESCRIPTION', 'Product Description Tag:');
define('TEXT_PRODUCTS_KEYWORDS', 'Product Keywords Tag:');
define('TEXT_PRODUCTS_LISTING_TEXT', 'Product Listing Text');
define('TEXT_PRODUCTS_SUB_TEXT', 'Product Page Sub Text:');
/*** End Header Tags SEO ***/

Share this post


Link to post
Share on other sites

Thanks Jack. I don't know why my search turned up zilch - it is in the admin install file for 2.3 but not <2.3, just so u know.

 

Anyhow, hopefully once I get the formatting squared away it will be smooth sailing..

Share this post


Link to post
Share on other sites

Jack, what would cause one or more of my files to not show up in the drop-down lists? I noticed 2 right off the bat that are missing.

 

Thanks again 4 this super contribution..

Share this post


Link to post
Share on other sites

If you are using version less than 2.3 you have to add the Header Tags code to each file you want to use. This is mentioned in the installation instructions.

Share this post


Link to post
Share on other sites

Hello - Is the Header Tags SEO contribution compatible with the Power SEO URL's contribution from magneticone.com?

 

Trying to determine which is better the Ultimate SEO V 2.2d vs. Ultimate SEO URLs vs. Power SEO URL's and the Header Tags SEO contribution appears to have features that are not included in either of those three I just listed so I want to make sure it's compatible.

 

Thank you!

Share this post


Link to post
Share on other sites

Header Tags SEO doesn't have anything to do with url's, which is what those three are for. I am not familiar with Power SEO so I can't say if it will work with this addon or not.

Share this post


Link to post
Share on other sites

Hi there,

 

I don't know if this has been answered before but I'm on v3.26 and on the product_info page at the foot where it says "currently viewing" it displays the category and the product name but has " - - " separating them. It seems as though the headertags seo is expecting to have another bit of text between those two hyphens. I understand HEADER_TAGS_SEPARATOR_DESCRIPTION is the name of the hyphen, but I cannot seem to find where the second redundant hyphen is being created.

 

It is the

 

$header_tags_array['title']

 

variable that is outputting the suspect text.

 

if (isset($sortOrder['title']))	 $header_tags_array['title'] = ltrim(tep_db_prepare_input(implode(' ' . HEADER_TAGS_SEPARATOR_DESCRIPTION . ' ', $sortOrder['title'])), ' ' . HEADER_TAGS_SEPARATOR_DESCRIPTION);

 

has some bearing on it?

 

edited to say thanks in advance!

Edited by teamwhatever

Share this post


Link to post
Share on other sites

Hi jack,

 

I use the latest version of header tags SEO working in oscommerce rc2a and I'm having a very common problem which has to be with basic oscommerce functions. Google webmaster tools is currently showing duplicate title/descriptions in product listing of my categories. I wonder if header tags seo has a way to solve it. Because the only solution I've found is to change to KissMT Dynamic SEO Meta & Canonical Header Tags and I wouldn't like to change.

 

Thank you

Share this post


Link to post
Share on other sites

Hi there,

 

I don't know if this has been answered before but I'm on v3.26 and on the product_info page at the foot where it says "currently viewing" it displays the category and the product name but has " - - " separating them. It seems as though the headertags seo is expecting to have another bit of text between those two hyphens. I understand HEADER_TAGS_SEPARATOR_DESCRIPTION is the name of the hyphen, but I cannot seem to find where the second redundant hyphen is being created.

When you see dashes around a space in anything related to this addon, it means there is a missing title somewhere. Maybe you didn't run fill tags or added a new product and somehow didn't fill in the title and tags. You need to look at the product you are on in the admin and see what is missing.

Share this post


Link to post
Share on other sites

Hi jack,

 

I use the latest version of header tags SEO working in oscommerce rc2a and I'm having a very common problem which has to be with basic oscommerce functions. Google webmaster tools is currently showing duplicate title/descriptions in product listing of my categories. I wonder if header tags seo has a way to solve it. Because the only solution I've found is to change to KissMT Dynamic SEO Meta & Canonical Header Tags and I wouldn't like to change.

 

Thank you

It's not a problem. They are just reporting that two pages on the site use the same title and tags, which is fine, though usually not desireable. Just edit the reviews_info file in Page Control and add something to the root boxes, like "review of" (be sure to check that check box) and they will go away. Changing to that url rewriter, or even turning your current one off, won't make any difference at all since this is due to titles and tags.

Share this post


Link to post
Share on other sites

My problem is referred to the product listing, so I don’t understand what product_rewiews_info has to be with this. In my case when I have more than one page in product listing such as:

 

/category/subcategory/-c-41_55.html?page=1

/category/subcategory/-c-41_55.html?page=2

 

They are 2 pages with the same metatags. I think it’s not a big problem, but is a bit annoying to see this in google webmaster tools.

 

Thank you again.

Share this post


Link to post
Share on other sites

I apologize. I didn't read your post well enough. That questions usually refers to the review pages. There's not a solution for the problem you are having and, probably, shouldn't be. The product listing page is for a category and the category doesn't change just because the page number changes so the category description, which you should be using, should be the same for best SEO. You do need to be sure the canonical tag is set in Page Control. But otherwise, google is just saying the titles and tags are the same, which isn't a real problem in this case.

Share this post


Link to post
Share on other sites

Thank you Jack for the reply! Have looked at the titles and all the header tags related fields and on the product info page I still get the - -

 

It actually prints as: nameofcategory - - name of product (both using the header tags title)

 

As you've indicated, something is missing between the - - but it isn't the title tags for the cat or the product in question. Any other ideas appreciated.

 

Thanks again

Share this post


Link to post
Share on other sites

The various parts of the title are enabled in Page Control. So look there to see what check boxes are enabled and then check that section. Sounds like you have the manufacuters or root boxes checked.

Share this post


Link to post
Share on other sites

Hello,

 

I don;t know if this question has been asked but my current version of headertags SEO is 3.2.2

To upgrade it to the current version, I have to follow the instructions on the Update docs. However, my website has been heavily modified so some of the instructions such as

"2) Upload all files in the catalog directory. If you are using pseudo pages, you will

need to delete and re-enter one pseudo page for each contribution that uses them."

 

don't work for me. Is there another way for me to update my files to the latest version?

Share this post


Link to post
Share on other sites

I just used the headertags_seo_update.php to try to update my current version to the latest version but when I use version checker, it tells me that nothing has changed. Does that mean that I just ignore the uploading files instructions when I go through the update logs?

Edited by mokx2280

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×