Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

It's a mistake in the instructions as mentioned here recently. Add the following to the database_tables.php file

 define('TABLE_HEADERTAGS_KEYWORDS', 'headertags_keywords');

 

Hi Jack,

This line is still missing from the install notes, was driving me crazy for a few minutes before I found the thread! :)

Share this post


Link to post
Share on other sites

I apologize to eveyone affected by the mistake in the instructions. As Adam points out, it has been known about for a while. I was holding off uploading a new version since I had some things I wanted to add to it but I never found the time so I've gone ahead and uploaded a new version with the following changes for now:

 

-> Added code to strip html tags when the auto fill listing option is used

-> Added pinterest to the social bookmarks

-> Added code to advanced_search_result.php to ignore quotes if that contribution is installed.

-> Changed code for the footer tag cloud to ignore urls that are not complete.

-> Changed error code display in admin/includes/functions/header_tags.php to better display the open failure, if needed.

-> Corrected code in the included includes/template_top.php file for 2.3

-> Corrected install instructions for Install_Catalog.txt (missing database define).

-> Corrected code in includes/header_tags.php to create the correct canonical tag for products when language is in the url.

-> Corrected code in includes/functions/header_tags.php for the manufacturers section.

-> Corrected code in includes/functions/header_tags.php that would cause a failure if a search was done on a work with an apostrophe.

Share this post


Link to post
Share on other sites

I clicked the link above to try to get the newest version but it is still saying Jan 29 2012. Will it take awhile to be available?

Share this post


Link to post
Share on other sites

Thank you. I'm just new to this and don't know how things work. I just figure I should wait for the newest version if it will be ready soon.

Share this post


Link to post
Share on other sites

can I place my own tags?

If by "place" you mean "enter," then yes, you can.

Share this post


Link to post
Share on other sites

@@Jack_mcs You have helped me with my store before and I need some help with a canonical issue. Can you help?

What's the issue?

Share this post


Link to post
Share on other sites

Hello,

 

I tried upgrading Header Tags from 3.1.8 to 3.2.9, set by step in the upgrade docs. I must have done something wrong. Couldn't figure it out so I decided to uninstall. That didn't work oit to well either.

 

This is a 2rc2a shop.

 

When I click on a category, I get,

 

Warning: mysql_fetch_array() expects parameter 1 to be resource, null given in .../includes/functions/database.php on line 99

 

From what I've read, its probably not the database.php file but something in index.php or product_info.php. I just can't find it.

 

I hate to post that much code, but can.

 

Anyone know what I need to be looking for?

 

TIA

Share this post


Link to post
Share on other sites

I am adding the new version and everything was going along fine. I got the replace me in page control message and now I am doing the Install admin changes. In admin/categories.php it says to find:

 

$sql_data_array = array('products_name' => tep_db_prepare_input($HTTP_POST_VARS['products_name'][$language_id]),

'products_description' => tep_db_prepare_input($HTTP_POST_VARS['products_description'][$language_id]),

'products_url' => tep_db_prepare_input($HTTP_POST_VARS['products_url'][$language_id]));

 

I can't find this. The only thing I can find with products_name is this. Is this something that I might have changed for another contribution? I think I've only added the Super Download Store.

 

$parameters = array('products_name' => '',

'products_description' => '',

'products_url' => '',

'products_id' => '',

'products_quantity' => '',

'products_model' => '',

'products_image' => '',

'products_larger_images' => array(),

'products_price' => '',

'products_weight' => '',

'products_date_added' => '',

'products_last_modified' => '',

'products_date_available' => '',

'products_status' => '',

'products_tax_class_id' => '',

'manufacturers_id' => '');

 

Any help is appreciated.

Lori

Share this post


Link to post
Share on other sites

Hello,

 

I tried upgrading Header Tags from 3.1.8 to 3.2.9, set by step in the upgrade docs. I must have done something wrong. Couldn't figure it out so I decided to uninstall. That didn't work oit to well either.

 

This is a 2rc2a shop.

 

When I click on a category, I get,

 

Warning: mysql_fetch_array() expects parameter 1 to be resource, null given in .../includes/functions/database.php on line 99

 

From what I've read, its probably not the database.php file but something in index.php or product_info.php. I just can't find it.

 

I hate to post that much code, but can.

 

Anyone know what I need to be looking for?

 

TIA

Unfortunately, that error is happening because of what is sent to function and the function is reporting the error. So it doesn't indicate anything by itself. You will need to isolate the cause of the problem or just re-install from scratch. If the error only occurs on product pages, for example, then replace your product_info.php file with your original or with the one in the contribution to see if the problem goes away. If it does, then use that file to compare against the failing one to find the problem.

Share this post


Link to post
Share on other sites

I am adding the new version and everything was going along fine. I got the replace me in page control message and now I am doing the Install admin changes. In admin/categories.php it says to find:

 

$sql_data_array = array('products_name' => tep_db_prepare_input($HTTP_POST_VARS['products_name'][$language_id]),

'products_description' => tep_db_prepare_input($HTTP_POST_VARS['products_description'][$language_id]),

'products_url' => tep_db_prepare_input($HTTP_POST_VARS['products_url'][$language_id]));

 

I can't find this. The only thing I can find with products_name is this. Is this something that I might have changed for another contribution? I think I've only added the Super Download Store.

That is common oscommerce code so it should be in your file. First, be sure you are using the correct instructions for your shop (2.3 or not). If you are, then the code in the file must have been changed somehow. It might be that it uses $_POST instead of $HTTP_POST_VARS so if you reduce the search to something like $sql_data_array = array('products_name' => tep_db_prepare_input, you may find it.

Share this post


Link to post
Share on other sites

Unfortunately, that error is happening because of what is sent to function and the function is reporting the error. So it doesn't indicate anything by itself. You will need to isolate the cause of the problem or just re-install from scratch. If the error only occurs on product pages, for example, then replace your product_info.php file with your original or with the one in the contribution to see if the problem goes away. If it does, then use that file to compare against the failing one to find the problem.

 

Thanks, Jack! That fixed it.

 

Will start over with a fresh install. :sweating:

 

Oh, one more thing. I skipped over the parts with the editors since I don't have one installed. Maybe that's where I went wrong. Should I skip over those parts or is it safe to add them?

 

Thanks!!

Edited by edukes

Share this post


Link to post
Share on other sites

Thanks, Jack! That fixed it.

 

Will start over with a fresh install. :sweating:

 

Oh, one more thing. I skipped over the parts with the editors since I don't have one installed. Maybe that's where I went wrong. Should I skip over those parts or is it safe to add them?

 

Thanks!!

It's safe to add that code. There are settings for this contribution that turns it on - default is off.

Share this post


Link to post
Share on other sites

Thanks, Jack. I tried doing the manual install for categories.php twice, and couldn't get it right. But then I remembered that the other contribution I had installed hadn't made any changes to categories. I just copied the file in and now it works! It was so nice to see some of my products rise right up to the first page searches. Definitely worth the effort of installing this.

Share this post


Link to post
Share on other sites

Hello Jack,

 

I would like to start tweaking new 2.3.3 version and I've noticed that it already should contain New Canonical Header Tag Module
 - Adds canonical meta links to the product information and category listing pages.
 How does it work with canonical tag feature within this contribution?


Absinthe Original Liquor Store

Share this post


Link to post
Share on other sites

I haven't played around with that version yet. If it inserts a canonical tag and can't be turned off, or if you prefer to use it, then the one in Header Tags can be turned off in the default section of Page Control, so this should be a non-issue.

Share this post


Link to post
Share on other sites

It seemed that I had gotten everything working properly, so I filled in tags for each of my products. I didn't test it that much after I finished adding to the new fields. Today it seems that all the products are loading realllyyyyyy slowly. It seems like especially the pictures. No other websites seems slow. I am wondering if it is my code, or if it just happens to be a problem with my host. I did also notice one other thing - for one of my products I initially entered the wrong file for the small product image. I went back in to edit and not the new picture shows in the product listing, but the old picture shows on the product page. I've tried to change it several times and it is still wrong.

 

I guess what I am asking is if there is some known installation problem /mistake on my part that can cause slow loading of the pictures or pages?

Edited by FeisMom

Share this post


Link to post
Share on other sites

It seemed that I had gotten everything working properly, so I filled in tags for each of my products. I didn't test it that much after I finished adding to the new fields. Today it seems that all the products are loading realllyyyyyy slowly. It seems like especially the pictures. No other websites seems slow. I am wondering if it is my code, or if it just happens to be a problem with my host. I did also notice one other thing - for one of my products I initially entered the wrong file for the small product image. I went back in to edit and not the new picture shows in the product listing, but the old picture shows on the product page. I've tried to change it several times and it is still wrong.

 

I guess what I am asking is if there is some known installation problem /mistake on my part that can cause slow loading of the pictures or pages?

No, you shouldn't see a difference in the speed and Header Tags doesn't do anything with the images so it would seem you've made a mistake in the installation. On the shop side, you can replace the index.php or product_info.php with your original files to see if that makes a difference. On the admin side, the categories.php file can be replaced. Those are the obvious choices but you can replace them all, of course. Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Question about Pinterest. Do I need to do something special for it to work? The Pinterest button shows up with all the others on my products pages. But when you click, it comes to a page where the photo box is blank. I can edit the description and click a "Pin It" button, but it does not post to my Pinterest. Not sure why the picture is not showing up.

 

Lori

Share this post


Link to post
Share on other sites

Question about Pinterest. Do I need to do something special for it to work? The Pinterest button shows up with all the others on my products pages. But when you click, it comes to a page where the photo box is blank. I can edit the description and click a "Pin It" button, but it does not post to my Pinterest. Not sure why the picture is not showing up.

 

Lori

I don't have a pinterest account so I can't check it. It mihgt be that they require some other parameter. That could be easily added but I would need to know the format. If they are responsive, you could contact them and ask what the problem is. Post their response here and I will make the code change if it is not too involved.

Share this post


Link to post
Share on other sites

Hi,

Im using the PDF-Datasheet contribution made by Kymation (http://addons.oscommerce.com/info/8364)

It worked perfect before I installed the Ulitmate SEO contr (which is a very good contr, thank you jack).

 

To generate a PDF it sends a link, for example: http://www.website.com/pdf_datasheet.php?products_id=2&language=english

 

Now I get an error related to Ultimate SEO:

 

Notice: Undefined index: pName in website.com\includes\classes\seo.class.php on line 2095

 

Can anyone explain the function on line 2095 so I can try to get the PDF datasheet to work?

Share this post


Link to post
Share on other sites

I did some playing around with Pinterest and found that this code works for me in header_tags_social_bookmarks. But, I am rather new at this and only got it working by hard coding in my shop url.

 

<td><a href="http://pinterest.com/pin/create/button/?url=<?php echo urlencode (tep_href_link (FILENAME_PRODUCT_INFO, 'products_id=' .$product_info['products_id']))?>&media=<?php echo 'http://www.feismomembroidery.com/Shop/images/'. $product_info['products_image'].'"'?>

class='pin-it-button' count-layout='none'><img border='0' src='//assets.pinterest.com/images/PinExt.png' title='Pin It' /></a>

 

It also needs this line from Pinterest at the bottom:

<script type="text/javascript" src="//assets.pinterest.com/js/pinit.js"></script>

 

If you could help me do it that right way, that would be great.

Thanks so much!

Lori

Share this post


Link to post
Share on other sites

I did some playing around with Pinterest and found that this code works for me in header_tags_social_bookmarks. But, I am rather new at this and only got it working by hard coding in my shop url.

The code already in place should be the same that you posted. You can view the source of a product page in a browser and search for pinterest to check that. The javascript can be pasted at the bottom of the includes/modules/header_tags_social_bookmarks.php file. It should wok there though I haven't tried it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×