Latest News: (loading..)
Jack_mcs

Header Tags SEO

8,221 posts in this topic

It sounds like there is an installation problem. All I can suggest is that you upgrade it to the latest version and go from there.

 

Thanks Jack. Will do the full upgrade on the code and see what happens.

 

This is why developers should backup! Really wish the old developer had a backup :(

Share this post


Link to post
Share on other sites

That option is only for categories. I will add an option to select products in a category in the next release.

 

OK thanks, sort of figured that was the case but wanted confirmation. Look forward to future updates.

 

Nav

Share this post


Link to post
Share on other sites

On my own personal oscommerce page that I sell a few items having issues with the Categories.

 

My store uses categories_listing.php an categories_nested.php for Categories but when I edit those within Header Tags SEO inside the Control Panel it does not change them.

 

Changing the Title/Description/Keywords within Categories/Products for the appropriate category it changes it but I want the ability to add the Default Title to the Category string without having to add it manually so it wont affect the Breadcrumbs.

 

Similar to how you can add Default Title to the end of a product title within Products.php in the Header Tags SEO page and it will not effect the breadcrumbs but will show up in the Title of the page.

 

Thanks in advance.

Edited by mvanderhoff

Share this post


Link to post
Share on other sites

On my own personal oscommerce page that I sell a few items having issues with the Categories.

 

My store uses categories_listing.php an categories_nested.php for Categories but when I edit those within Header Tags SEO inside the Control Panel it does not change them.

 

Changing the Title/Description/Keywords within Categories/Products for the appropriate category it changes it but I want the ability to add the Default Title to the Category string without having to add it manually so it wont affect the Breadcrumbs.

 

Similar to how you can add Default Title to the end of a product title within Products.php in the Header Tags SEO page and it will not effect the breadcrumbs but will show up in the Title of the page.

 

Thanks in advance.

Check the Default Title in Page Control for index.php.

Share this post


Link to post
Share on other sites

Check the Default Title in Page Control for index.php.

 

Okay I see that but maybe I was not clear about what I am trying to accomplish.

 

In Index.php you can enter the Title, Keywords, Description, Logo Text it shows the Title, Keywords, Description and Logo Text on the main page http://www.yourdomain.com/index.php

 

But what I want is to have the Categories show <Categories> + <New Text Ending>

 

In example - Index.php title is: Emergency Outdoors - Outdoor, Camping, Survival and Preparedness Gear

 

When I check Categories - 1 it will show <Category> Emergency Outdoors - Outdoor, Camping, Survival and Preparedness Gear

 

But what I want it to show when you are looking at a Category is <Category> - Emergency Outdoors and that is it, not additional - Outdoor, Camping, Survival and Preparedness Gear.

 

Is that possible?

Share this post


Link to post
Share on other sites

But what I want it to show when you are looking at a Category is <Category> - Emergency Outdoors and that is it, not additional - Outdoor, Camping, Survival and Preparedness Gear.

 

Is that possible?

Then you need to turn off the option for whatever has Outdoor, Camping, Survival and Preparedness Gear. If that is part of the text, Emergency Outdoors - Outdoor, Camping, Survival and Preparedness Gear, then you can't just display part of it.

Share this post


Link to post
Share on other sites

@@Jack_mcs

Thank you, I have uninstalled and reinstalled and everything works perfectly well already.

Thanks again Jack, I've been very helpful

Cheloki

Share this post


Link to post
Share on other sites

hello Jack,

 

i am using osc 2.3

 

in Header Tags SEO V 3.2.8>Page Control in the admin section, in the option box Select an option, i am selecting 'Show all files'.

 

I will go to a file (i.e. this.php) and choose delete-- a pop up appears:

 

Do you really wamt to delete this.php

 

this only deletes the the entry in Header Tags, not the Actual file,

 

pressing ok.

 

it resets the page with Select an option defaulted at Show all files, with no php pages listed.

 

if i reselect the option to - Select a File and then Show all files--- the files list

 

but this.php is still there, it is not being deleted.

 

thanks,

 

craig

Share this post


Link to post
Share on other sites

if i reselect the option to - Select a File and then Show all files--- the files list

 

but this.php is still there, it is not being deleted.

Try turn off the automatially add pages option in the Header Tags settings.

Share this post


Link to post
Share on other sites

hello Jack,

 

i was deleting some of the php pages in header tags seo.

 

i received this error:

 

Parse error: syntax error, unexpected T_CASE in /home/comta3/public_html/includes/header_tags.php on line 89

 

i restored headertags,php from backup and everything is ok.

 

 

now in the configuration section of header tags seo all options are listed in triplicate.

 

how did this happen??

 

thanks,

craig

Share this post


Link to post
Share on other sites

now in the configuration section of header tags seo all options are listed in triplicate.

 

how did this happen??

No idea.

Share this post


Link to post
Share on other sites

zpupster it sounds like there may be triplicate information in your database from when you restored.

 

Please check your db via phpmyadmin

Share this post


Link to post
Share on other sites

thanks Jack and mvanderhoff,

 

i still do not understand why i would receive triplicate titles in configuration>> headertags seo. when the file came from a good backup.

 

anyway, i went into the db and deleted the triplicated titles down to a single title.

 

i also duplicated the erro i had earlier:

setting in admin section configuration>> Header Tags SEO >> Automatically Add New Pages >> FALSE

 

when i deleted reviews.php from admin section headertags Seo >> page control>> selected the file and deleted. and checked the website.

 

Parse error: syntax error, unexpected T_CASE in /home/comta3/public_html/includes/header_tags.php on line 89

 

 

 

although, this time i restored header_tags.php from the one included in Header Tags SEO V 3.2.8.

 

no triplicates!

 

and after refresh-- reviews.php is deleted.

 

thanks,

craig

Share this post


Link to post
Share on other sites

Hi

when i go into my admin/products

and i click on a category to edit..im getting a 404 error in the Header Tags Categories Description section

 

anyone know how to fix this or where i should look.

 

Thanks

Share this post


Link to post
Share on other sites

Hi

when i go into my admin/products

and i click on a category to edit..im getting a 404 error in the Header Tags Categories Description section

You've made a mistake in the categories.php edits. use the included one to test and compare against.

Share this post


Link to post
Share on other sites

Trouble after install. V2.3.8 on oSC 3.1 running on Windows Server

 

Database upgraded successfully

Copied files accordingly

performed Catalog items

Performed Admin items

 

now site comes up ok

"Replace me in Page Control" title on index.php

Clicking on products ok and "default title" displays as title

 

PROBLEMS:

Advance search does not work - returns blank page

Clicking on any category on left box, returns the Header, footer and left column only.

Cannot access Admin.

 

Couple other comments

1. Admin was renamed Adminbackend previously. Could that be an issue?

2. Another contribution "ULTIMATE SEO" is installed - Coudl that conflict?

 

Can you suggest resolution?

 

Thanks for your time.

 

Mark

Share this post


Link to post
Share on other sites

Trouble after install. V2.3.8 on oSC 3.1 running on Windows Server

 

PROBLEMS:

Advance search does not work - returns blank page

Do you possibly mean 3.2.8 on 2.3.1? Assuming that to be the case and assuming the problem is only on the advanced search page, then the problem is with the edits you made for that page. Use the included file to find the problem.

Share this post


Link to post
Share on other sites

Do you possibly mean 3.2.8 on 2.3.1? Assuming that to be the case and assuming the problem is only on the advanced search page, then the problem is with the edits you made for that page. Use the included file to find the problem.

 

Sorry, yes I meant V 3.2.8 and osc I really though was 3.1, it was the most receint release downloaded and originally installed in March (couple of months ago) but I cannot access the Admin pages any longer either. Do you think the Advanced Search the Category Link and Admin visibility are all related to the Advanced Search Page edits? I will check that now, but could that effect the access to Admin?

 

Thanks

Share this post


Link to post
Share on other sites

Sorry, yes I meant V 3.2.8 and osc I really though was 3.1, it was the most receint release downloaded and originally installed in March (couple of months ago) but I cannot access the Admin pages any longer either. Do you think the Advanced Search the Category Link and Admin visibility are all related to the Advanced Search Page edits? I will check that now, but could that effect the access to Admin?

 

Thanks

Both 2.31 and 3.xx are available for download. If you downloaded the V3 package, this won't work at all. Plus, that is not a useable package. Assuming 2.3, if it was working before and isn't now, then something wasn't done correctly. The admin is completely separate from the shop side so the search page wouldn't break the admin. If you don't find anything to fix it, I suggest you restore your files to get the shop working and try again. This time, just make the changes to admin first so that your shop is not affected if you run into a problem.

Share this post


Link to post
Share on other sites

Both 2.31 and 3.xx are available for download. If you downloaded the V3 package, this won't work at all. Plus, that is not a useable package. Assuming 2.3, if it was working before and isn't now, then something wasn't done correctly. The admin is completely separate from the shop side so the search page wouldn't break the admin. If you don't find anything to fix it, I suggest you restore your files to get the shop working and try again. This time, just make the changes to admin first so that your shop is not affected if you run into a problem.

 

Yes, I restored the system and unfortunately, I am on oSC v 3.02, so I will abort the process. Thanks for your time.

Share this post


Link to post
Share on other sites

When i enable Header Tags Seo modules, the whole site turns into blank. When i de-activate them, all is ok. Any ideas whats the problem?

Share this post


Link to post
Share on other sites

When i enable Header Tags Seo modules, the whole site turns into blank. When i de-activate them, all is ok. Any ideas whats the problem?

What are "Header Tags Seo modules?" What version of oscommerce are you using?

Share this post


Link to post
Share on other sites

Hi,Jack,

Thanks for your great contribution.

Today I installed Header Tags SEO V 3.2.8 on Osc v2.2RC2,everything seems working fine.Now I have a problem.when I clicked

a product and went to product_info.php page,I got an error message:Fatal error: Call to undefined function StripSID()...catalog/includes/modules/header_tags_social_bookmarks.php on line 10 Call Stack: 0.0021 449944 1. {main}()...catalog/product_info.php:0 2.4631 1976312 2. include('/usr/local/...catalog/includes/modules/header_tags_social_bookmarks.php') /usr/local/.../catalog/product_info.php:361,I searched this error in this support thread,several people had a similar problem,some people in the following link even had some solution:

http://forums.oscommerce.com/topic/298099-header-tags-seo/page__st__5840__p__1597765#entry1597765

But I don't know how to do it.

Thanks for your help in advance!

 

Joe

Share this post


Link to post
Share on other sites

Hi,Jack,

Thanks for your great contribution.

Today I installed Header Tags SEO V 3.2.8 on Osc v2.2RC2,everything seems working fine.Now I have a problem.when I clicked

a product and went to product_info.php page,I got an error message:Fatal error: Call to undefined function StripSID

It is saying it can't find one of the Header Tags functions so you, most likely, didn't upload all of the files in the catalog directory.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now