Jack_mcs

Header Tags SEO

8,213 posts in this topic

To clarify, I didn't say to remove that code. It was the surrounidng code I was referring to. By removing that line, you are preventing that option from working. That option displays the keyword for the page at the very top. If you don't want to use it, you should turn the page top option off in the settings. The code is just general code and may not appear correctly in all shops. If your design allows it to blend in, you won't see much difference. But it has a header that contains a background image or color, it may not look right. In that case, the code needs to be edited to blend in.

 

Hi,

Thanks for the clarification. Yes I had a background image so just changed the colour as you suggested to blend in and put the code back in.

 

Funny thing is with or without the code

 

<div style="text-align:center; color:#aaa; font-size:10px;"><?php echo $header_tags_array['title']; ?></div>

 

I when I view page source I still have the

 

<title>new shop test</title>

 

even when I clear the browser cache. I can also update the page from admin so for some reason it does not prevent the option from working??

Very happy with the new header tags not complaining just wondering.

Thanks John

Edited by joli1811

Share this post


Link to post
Share on other sites

I when I view page source I still have the

 

<title>new shop test</title>

 

even when I clear the browser cache. I can also update the page from admin so for some reason it does not prevent the option from working??

For any page, it is displaying the web browser title setup in Header Tags for that page. So it would seem your web browser title for the home page is "new shop test."

Share this post


Link to post
Share on other sites

Jack_mcs: Great contrib! Wow, 327 pages of comments... popular too!

 

I have been looking all over for to find out where the links from the tag cloud keywords are taken and stored. No luck... The problem is that some of the keywords link to pages that aren't related to the keyword, and this would not be directing the robots to a page that is irrelevant. Even after deleting - clearing cache - manually inserting in phpmyadmin I have the keywords pointing to the same url...

 

Is there a way to adjust or control the urls/landing pages?

 

Many, many thanks!

Share this post


Link to post
Share on other sites

Jack_mcs: Great contrib! Wow, 327 pages of comments... popular too!

Thank you. I appreciate it. Yes, Header Tags SEO is very popular and has over 100,000 confirmed installations.

 

I have been looking all over for to find out where the links from the tag cloud keywords are taken and stored. No luck... The problem is that some of the keywords link to pages that aren't related to the keyword, and this would not be directing the robots to a page that is irrelevant. Even after deleting - clearing cache - manually inserting in phpmyadmin I have the keywords pointing to the same url.

 

Is there a way to adjust or control the urls/landing pages?

 

The keywords are stored in their own table and can be deleted or re-poinited from the keywords section of Header Tags. I knew when I released it that there wasn't enough control there and that will probably be enhanced in the next version. But, for now, you can control the links by using that tool in admin.

Share this post


Link to post
Share on other sites

Feels like Im missing something... I dont see where to repoint the keyword in the keyword section. Or actually any way to make changes to the keywords (Im assuming you mean in Admin > Header Tags SEO > Keywords). Could be because Im using Mindsparx admin.. not 100% with all contribs.

Share this post


Link to post
Share on other sites

Feels like Im missing something... I dont see where to repoint the keyword in the keyword section. Or actually any way to make changes to the keywords (Im assuming you mean in Admin > Header Tags SEO > Keywords). Could be because Im using Mindsparx admin.. not 100% with all contribs.

You can't edit the keywords. But in the right column you can enter a product ID for what you want that keyword to point to and then click the Search Site link at the top of that column. You have to have the Search Site option enabled for that to work.

Share this post


Link to post
Share on other sites

Ah... That's why I have a problem. Some of the keywords are not related to any specific products but to info pages (e.g about us or about our products). No way to manually code the to land on these pages?

Share this post


Link to post
Share on other sites

Ah... That's why I have a problem. Some of the keywords are not related to any specific products but to info pages (e.g about us or about our products). No way to manually code the to land on these pages?

Yes, it can be done but isn't something I would go over in a support thread due to the time involved.

Share this post


Link to post
Share on other sites

Ok. Thanks for your support, Jack! I know in which direction to go.

Share this post


Link to post
Share on other sites

Hi, I’m way in over my head – but at least I can ask for directions before I delete the shop

When I add the code to template_top.php I get the following message.

1146 - Table 'dbxxxxxx_mydatabase.TABLE_HEADERTAGS_DEFAULT' doesn't exist

 

select * from TABLE_HEADERTAGS_DEFAULT where language_id = '1'

 

[TEP STOP]

Info: I have 2 languages and quite a few add-ons installed.

I’ll keep on trying….

 

---------------------

Test Results languages in the Header Tags table are: 1 ( English ).

Edited by TVpro

Share this post


Link to post
Share on other sites

Hi, I’m way in over my head – but at least I can ask for directions before I delete the shop

When I add the code to template_top.php I get the following message.

1146 - Table 'dbxxxxxx_mydatabase.TABLE_HEADERTAGS_DEFAULT' doesn't exist

 

select * from TABLE_HEADERTAGS_DEFAULT where language_id = '1'

 

[TEP STOP]

Info: I have 2 languages and quite a few add-ons installed.

I’ll keep on trying….

 

---------------------

Test Results languages in the Header Tags table are: 1 ( English ).

Nevermind!!! I found my mistake - I missed to add in database_table

 

 

/*** Begin Header Tags SEO ***/

define('TABLE_HEADERTAGS', 'headertags');

define('TABLE_HEADERTAGS_CACHE', 'headertags_cache');

define('TABLE_HEADERTAGS_DEFAULT', 'headertags_default');

define('TABLE_HEADERTAGS_SEARCH', 'headertags_search');

define('TABLE_HEADERTAGS_SILO', 'headertags_silo');

/*** End Header Tags SEO ***/

Share this post


Link to post
Share on other sites

I’m not a PHP expert and I need your good will to help me out with an issue I got with the Header Tags Seo.

 

I did install the Header Tags contribution from osCommerce Solution and everything is very fine. Just one little problem that I know can be solve easily.

 

I’m using the Product Description –Insert and the Product Keywords – Insert at the admin/Modules/Header Tags.

 

As you know, both fields are available for me to type the description and keywords manually for the product in the admin content.

When I type the description and keywords in their corresponding fields and save, only the description is recorded but the keywords isn’t. The keywords insert field returns BLANK as you never wrote anything there.

 

The only way to record the keywords content is doing it manually in the MySQL data base, by the “products_description/head_keywords” value, and that is what I’m being doing since I installed the contribution. I think it’s time for me to fix the issue to focus on the admin content only.

 

I checked every corner in the uploaded files and I couldn’t find anything wrong.

 

My only option is trying find an answer here.

 

I will appreciate your help.

Share this post


Link to post
Share on other sites

I’m not a PHP expert and I need your good will to help me out with an issue I got with the Header Tags Seo.

 

I did install the Header Tags contribution from osCommerce Solution and everything is very fine. Just one little problem that I know can be solve easily.

 

I’m using the Product Description –Insert and the Product Keywords – Insert at the admin/Modules/Header Tags.

 

As you know, both fields are available for me to type the description and keywords manually for the product in the admin content.

When I type the description and keywords in their corresponding fields and save, only the description is recorded but the keywords isn’t. The keywords insert field returns BLANK as you never wrote anything there.

 

It means you made a mistake with the changes to the categories.php file. You can use the included one to compare against to find the problem.

Share this post


Link to post
Share on other sites

I didn’t make any changes to the categories.php file. All I know is that file came with three different lines which are:

// Modular SEO Header Tags

include( DIR_WS_MODULES . 'header_tags/categories_products_process.php' );

 

// Modular SEO Header Tags

include( DIR_WS_MODULES . 'header_tags/products_insert.php' );

 

// Modular SEO Header Tags

include( DIR_WS_MODULES . 'header_tags/categories_insert.php' );

 

If I have to make any changes in that file, I will appreciate so much if you tell me what should I get there.

Once again, thank you very much for your help.

Share this post


Link to post
Share on other sites

I didn’t make any changes to the categories.php file. All I know is that file came with three different lines which are:

// Modular SEO Header Tags

include( DIR_WS_MODULES . 'header_tags/categories_products_process.php' );

It looks like you are posting in the wrong trhead. This is for the Header Tags SEO contribution. It doesn't have " Modular SEO Header Tags" anywhere in it.

Share this post


Link to post
Share on other sites

Hi, I have one big problem.

 

When I view-source I notice that I only get the information from the root or from what I wrote in the index.php file. I can´t get description or keywords from other pages or from the information that I have put in the catalog. But still index.php works fine…

 

First of all I just want to make sure that I should be able to get the info I added in product “Product Keywords Tag” to be visible when I view-source?

Second I wonder if there is some code to put in every page I would like to be able to modify, e.g. product_info.php

 

(Swede so pardon my English…)

Share this post


Link to post
Share on other sites

Hi, I have one big problem.

 

When I view-source I notice that I only get the information from the root or from what I wrote in the index.php file. I can´t get description or keywords from other pages or from the information that I have put in the catalog. But still index.php works fine…

 

First of all I just want to make sure that I should be able to get the info I added in product “Product Keywords Tag” to be visible when I view-source?

Second I wonder if there is some code to put in every page I would like to be able to modify, e.g. product_info.php

 

(Swede so pardon my English…)

Have you enabled them in Page Control?

Share this post


Link to post
Share on other sites

When I replaced application_top I can view the code - must have done something wrong there :(

Edited by TVpro

Share this post


Link to post
Share on other sites

The good news (for me) is that I found the problem in the application_top.php file – it is “SEO URLs 5”. When I disable it everything works fine…

 

But can’t get it to work even if I change URI to rewrite

 

Read somewhere “Ultimate Seo Url's 5 requires a code change in Header Tags in order for it to work” so will look into that tomorrow.

Share this post


Link to post
Share on other sites

Now everything works perfectly – thanks for a great contribution! Learn a lot about my shop on the way to get it to work to :) Had to use the rewrite for my url (as mention in the FAQ)

 

Take care and happy Walpurgis Night.!

Share this post


Link to post
Share on other sites

Hello, good morning:

I have a problem with the installation. I installed automatically on new installation of oscommerce 2.3.1 and all is well, the problem comes when you install the admin in another language, I get the error in the tab admin / header tags seo / page control, and says something :

1062 - Duplicate entry 'advanced_search.php-1' for key 'PRIMARY'

 

insert into headertags (page_name, page_title, page_description, page_keywords, page_logo, page_logo_1, page_logo_2, page_logo_3, page_logo_4, append_default_title, append_default_description, append_default_keywords, append_default_logo, append_category, append_manufacturer, append_model, append_product, append_root, sortorder_title, sortorder_description, sortorder_keywords, sortorder_logo, sortorder_category, sortorder_manufacturer, sortorder_model, sortorder_product, sortorder_root, sortorder_root_1, sortorder_root_2, sortorder_root_3, sortorder_root_4, language_id) values ('advanced_search.php', '', '', '', '', '', '', '', '', '0', '0', '0', '0', '0', '0', '0', '1', '1', '0', '0', '0', '0', '0', '0', '0', '10', '1', '1', '1', '1', '1', '1')

 

[TEP STOP]

 

 

I would greatly appreciate someone help me, I'm not a programmer but I copy and paste very well ^_^

thanks

Share this post


Link to post
Share on other sites

Hello, good morning:

I have a problem with the installation. I installed automatically on new installation of oscommerce 2.3.1 and all is well, the problem comes when you install the admin in another language, I get the error in the tab admin / header tags seo / page control, and says something :

1062 - Duplicate entry 'advanced_search.php-1' for key 'PRIMARY'

 

insert into headertags (page_name, page_title, page_description, page_keywords, page_logo, page_logo_1, page_logo_2, page_logo_3, page_logo_4, append_default_title, append_default_description, append_default_keywords, append_default_logo, append_category, append_manufacturer, append_model, append_product, append_root, sortorder_title, sortorder_description, sortorder_keywords, sortorder_logo, sortorder_category, sortorder_manufacturer, sortorder_model, sortorder_product, sortorder_root, sortorder_root_1, sortorder_root_2, sortorder_root_3, sortorder_root_4, language_id) values ('advanced_search.php', '', '', '', '', '', '', '', '', '0', '0', '0', '0', '0', '0', '0', '1', '1', '0', '0', '0', '0', '0', '0', '0', '10', '1', '1', '1', '1', '1', '1')

 

[TEP STOP]

 

 

I would greatly appreciate someone help me, I'm not a programmer but I copy and paste very well ^_^

thanks

Does it happen if you click on Header Tags in the left column after refreshing the admin?

Share this post


Link to post
Share on other sites

Hello, nice to meet you Jack, thanks for answering.

this happens just when you install the admin in Spanish, to change the language with the drop down above right, if I click on admin / Header Tags Seo (left column, bottom) / COntrol page gives this error,after refreshing the admin, I did it several times and occurs at all the same.

Consuelo

Share this post


Link to post
Share on other sites

Hello, nice to meet you Jack, thanks for answering.

this happens just when you install the admin in Spanish, to change the language with the drop down above right, if I click on admin / Header Tags Seo (left column, bottom) / COntrol page gives this error,after refreshing the admin, I did it several times and occurs at all the same.

Consuelo

Did you make the database changes with headertags_seo_install.php? The the test routine provide any errors for the language?

Share this post


Link to post
Share on other sites

Hello again,

Yes, I maked the database changes with headertags_seo_install.php.

the test comes out you hit it directly, because I still do not understand very well, so you see it:

 

Test Results <br>

<br>

Duplicate title found: explain <br>

<br>

for English <br>

exists more than once. <br>

<br>

for Español <br>

exists more than once. <br>

<p> <br>

<br>

Duplicate meta description found: explain <br>

<br>

for English <br>

exists more than once. <br>

<br>

for Español <br>

exists more than once. <br>

</p>

<p> <br>

<br>

Missing Title and/or descriptions: explain <br>

<br>

<br>

Products <br>

Matrox G200 MMS <br>

Matrox G200 MMS <br>

Matrox G400 32MB <br>

Matrox G400 32MB <br>

Microsoft IntelliMouse Pro <br>

Microsoft IntelliMouse Pro <br>

The Replacement Killers <br>

The Replacement Killers <br>

Blade Runner - Director's Cut <br>

Blade Runner - Director's Cut <br>

The Matrix <br>

The Matrix <br>

You've Got Mail <br>

You've Got Mail <br>

A Bug's Life <br>

A Bug's Life <br>

Under Siege <br>

Under Siege <br>

Under Siege 2 - Dark Territory <br>

Under Siege 2 - Dark Territory <br>

Fire Down Below <br>

Fire Down Below <br>

Die Hard With A Vengeance <br>

Die Hard With A Vengeance <br>

Lethal Weapon <br>

Lethal Weapon <br>

Red Corner <br>

Red Corner <br>

Frantic <br>

Frantic <br>

Courage Under Fire <br>

Courage Under Fire <br>

Speed <br>

Speed <br>

Speed 2: Cruise Control <br>

Speed 2: Cruise Control <br>

There's Something About Mary <br>

There's Something About Mary <br>

Beloved <br>

Beloved <br>

SWAT 3: Close Quarters Battle <br>

SWAT 3: Close Quarters Battle <br>

Unreal Tournament <br>

Unreal Tournament <br>

The Wheel Of Time <br>

The Wheel Of Time <br>

Disciples: Sacred Lands <br>

Disciples: Sacred Lands <br>

Microsoft Internet Keyboard PS/2 <br>

Microsoft Internet Keyboard PS/2 <br>

Microsoft IntelliMouse Explorer <br>

Microsoft IntelliMouse Explorer <br>

Hewlett Packard LaserJet 1100Xi <br>

Hewlett Packard LaserJet 1100Xi <br>

Samsung Galaxy Tab <br>

Samsung Galaxy Tab <br>

<br>

Categories <br>

Hardware <br>

Software <br>

DVD Movies <br>

Graphics Cards <br>

Printers <br>

Monitors <br>

Speakers <br>

Keyboards <br>

Mice <br>

Action <br>

Science Fiction <br>

Comedy <br>

Cartoons <br>

Thriller <br>

Drama <br>

Memory <br>

CDROM Drives <br>

Simulation <br>

Action <br>

Strategy <br>

Gadgets <br>

Hardware <br>

Software <br>

DVD Movies <br>

Graphics Cards <br>

Printers <br>

Monitors <br>

Speakers <br>

Keyboards <br>

Mice <br>

Action <br>

Science Fiction <br>

Comedy <br>

Cartoons <br>

Thriller <br>

Drama <br>

Memory <br>

CDROM Drives <br>

Simulation <br>

Action <br>

Strategy <br>

Gadgets <br>

<br>

Manufacturers <br>

Matrox <br>

Microsoft <br>

Warner <br>

Fox <br>

Logitech <br>

Canon <br>

Sierra <br>

GT Interactive <br>

Hewlett Packard <br>

Samsung <br>

Matrox <br>

Microsoft <br>

Warner <br>

Fox <br>

Logitech <br>

Canon <br>

Sierra <br>

GT Interactive <br>

Hewlett Packard <br>

Samsung <br>

</p>

<p> <br>

<br>

Database/File Mismatch Error: explain <br>

The number of file entries in the database (6) does not match the number in

the includes/header_tags.php file (22). <br>

Files not in the database: <br>

advanced_search.php <br>

advanced_search_result.php <br>

conditions.php <br>

contact_us.php <br>

cookie_usage.php <br>

download.php <br>

info_shopping_cart.php <br>

opensearch.php <br>

popup_image.php <br>

privacy.php <br>

products_new.php <br>

redirect.php <br>

reviews.php <br>

shipping.php <br>

shopping_cart.php <br>

tell_a_friend.php <br>

</p>

<p> <br>

languages in the Header Tags table are: 1 ( English ). </p>

Edited by Cheloki

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now