Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Thank you Jack_mcs for your quick responce , yes i understand and i found that ,that was a nasty little div missing in index php and it fixed , all good :)

 

but i found a new problem now i already done the fill tags and in the in the page control i already put the default tags and updated ,

in the left hand site drop down manu i selected index.php and added the tags same as default tags and updated it ,no error message is showing but when i check the index.php thru wiew result there is no keywords and discriptions in there its not saving (red color instead of yellow color )for some reason

i hope you would probably know why this is happening ,

Try viewing it with view source on the actual page. Also be sure you applied the fixes for the manufacturers mentioned in this thread recently.

Share this post


Link to post
Share on other sites

url rewriter ? where in .htaccess file ? and what should i have to change in there ?

when i click a product its comes like www.mywebsite.com//product_info.php?cPath=34&products_id=122 is that correct?

You need to ask questions about other contributions in their support threads. This one is just for Header Tags SEO.

Share this post


Link to post
Share on other sites

You need to ask questions about other contributions in their support threads. This one is just for Header Tags SEO.

i'm not using any other contributions to make changes on them

Share this post


Link to post
Share on other sites

i'm not using any other contributions to make changes on them

The url you posted was http://www.cuteaz.com.au/-c-24.html. That's not a standard url.

Share this post


Link to post
Share on other sites

Hello,

 

I have osc 2.3.1 and I installed headertags 3.2.8 and I'm now testing out security pro by entering the messed up characters into the search bar on my site..

 

When I click the search button I get this error

 

1146 - Table 'ntr_u7a8ikv2w.TABLE_HEADERTAGS_KEYWORDS' doesn't exist

 

select 1 FROM TABLE_HEADERTAGS_KEYWORDS where keyword = 'working' and language_id = 1

 

[TEP STOP]

I go to phpmyadmin and see headertags_keywords is clearly there so I don't know what it's talking about...

 

Does anyone know what I did wrong?

 

 

Thanks

Adamanto75

Edited by Adamanto75

Share this post


Link to post
Share on other sites

hello,

 

this is an amazing add on , just what we need for our site. thank you, jack_mcs.

 

i had a heavily modded socomm 2.2 site and i could never get this to install, close but not quite.

 

i am in the process of upgrading to 2.3 and when we added headertags 3.27.

 

i have a few issues.

 

in the screen shot in the admin section under the Header Tags SEO.

 

there is:

Page Control

Fill Tags

Test

 

under my Header Tags Seo:

Page Control

Silo Control

BOX_HEADER_TAGS_KEYWORDS

Fill Tags

Test

 

 

BOX_HEADER_TAGS_KEYWORDS is probably wrong i searched my site and can not find this referenced.

 

could you please comment on this.

 

thanks,

craig

Edited by zpupster

Share this post


Link to post
Share on other sites

BOX_HEADER_TAGS_KEYWORDS is probably wrong i searched my site and can not find this referenced.

 

 

Add you your admin/includes/languages/english.php

 

define('BOX_HEADER_TAGS_KEYWORDS', 'Keywords');

 

and that should solve itt.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Hello,

 

I have osc 2.3.1 and I installed headertags 3.2.8 and I'm now testing out security pro by entering the messed up characters into the search bar on my site..

 

When I click the search button I get this error

 

1146 - Table 'ntr_u7a8ikv2w.TABLE_HEADERTAGS_KEYWORDS' doesn't exist

 

select 1 FROM TABLE_HEADERTAGS_KEYWORDS where keyword = 'working' and language_id = 1

 

[TEP STOP]

I go to phpmyadmin and see headertags_keywords is clearly there so I don't know what it's talking about...

 

Does anyone know what I did wrong?

 

 

Thanks

Adamanto75

 

 

Make sure you have

 

define('TABLE_HEADERTAGS_KEYWORDS', 'headertags_keywords');

 

in your admin/includes/filenames.php


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

thanks for the help-14 steve 14. that fixed that problem.

 

but when i try the link--error

 

Not Found

 

The requested URL /stead/cpanel/FILENAME_HEADER_TAGS_KEYWORDS was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

header_tags_seo_keywords.php is there under cpanel.

 

this is what is on admin/includes/languages/english.php

 

// header_tags_seo text in includes/boxes/header_tags_seo.php

define('BOX_HEADING_HEADER_TAGS_SEO', 'Header Tags SEO');

define('BOX_HEADER_TAGS_ADD_A_PAGE', 'Page Control');

define('BOX_HEADER_TAGS_SILO', 'Silo Control');

define('BOX_HEADER_TAGS_FILL_TAGS', 'Fill Tags');

define('BOX_HEADER_TAGS_KEYWORDS', 'Keywords');

define('BOX_HEADER_TAGS_TEST', 'Test');

/*** End Header Tags SEO ***/

 

 

ok i got the link to work by adding----define('FILENAME_HEADER_TAGS_KEYWORDS', 'header_tags_seo_keywords.php');

to admin/includes/filenames

 

/*** Begin Header Tags SEO ***/

define('FILENAME_HEADER_TAGS_SEO', 'header_tags_seo.php');

define('FILENAME_HEADER_TAGS_SILO', 'header_tags_seo_silo.php');

define('FILENAME_HEADER_TAGS_KEYWORDS', 'header_tags_seo_keywords.php');

define('FILENAME_HEADER_TAGS_FILL_TAGS', 'header_tags_fill_tags.php');

define('FILENAME_HEADER_TAGS_TEST', 'header_tags_test.php');

/*** End Header Tags SEO ***/

 

 

new error:

 

1146 - Table 'comta3_osc23.TABLE_HEADERTAGS_KEYWORDS' doesn't exist

 

select * from TABLE_HEADERTAGS_KEYWORDS order by language_id, found DESC, keyword ASC

 

 

 

here i am confused it looks like a database error--isee now same error as Adamanto75.

 

somewhere it is not referencing the table, but where???

 

off to look can someone help?

 

thanks,

craig

Share this post


Link to post
Share on other sites

hello,

 

adamanto, and 14Steve14,

 

to get rid of that error you need to add this:

 

define('TABLE_HEADERTAGS_KEYWORDS', 'headertags_keywords'); 

 

to admin/includes/database_tables.php

 

anyway per instructions i do not have a get position column ,maybe this is a work in progress by Jack_mcs.

 

because when i checked the install_admin.txt file all these namings were leftout.

 

 

thanks,

 

craig

Share this post


Link to post
Share on other sites

anyway per instructions i do not have a get position column ,maybe this is a work in progress by Jack_mcs.

 

because when i checked the install_admin.txt file all these namings were leftout.

Here's what's in the latest versions install_admin file:

In admin/includes/database_tables.php before the last ?>,

ADD:

/*** Begin Header Tags SEO ***/

define('TABLE_HEADERTAGS', 'headertags');

define('TABLE_HEADERTAGS_CACHE', 'headertags_cache');

define('TABLE_HEADERTAGS_DEFAULT', 'headertags_default');

define('TABLE_HEADERTAGS_KEYWORDS', 'headertags_keywords');

define('TABLE_HEADERTAGS_SEARCH', 'headertags_search');

define('TABLE_HEADERTAGS_SILO', 'headertags_silo');

/*** End Header Tags SEO ***/

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Hi Jack

I hope you can help, I have installed this contribution however it dont seem to be working correctly for me. It is only picking up the product name and then putting this as the keyword and the description even though in the admin i have set it to override and use actual keywords from the product. if you view the source here you will see what i mean

 

http://www.jp-tackle.co.uk/korda-krusha-p-11213.html

 

Any suggestions?

Share this post


Link to post
Share on other sites

Hi Jack

I hope you can help, I have installed this contribution however it dont seem to be working correctly for me. It is only picking up the product name and then putting this as the keyword and the description even though in the admin i have set it to override and use actual keywords from the product. if you view the source here you will see what i mean

 

http://www.jp-tackle.co.uk/korda-krusha-p-11213.html

 

Any suggestions?

 

I have also noticed that in the admin when i try the override function I get this warning message

Failed to load page from shop: http://www.jp-tackle.co.uk/product_info.php?products_id=11703&language=en

Share this post


Link to post
Share on other sites

Here's what's in the latest versions install_admin file:

Since you didn't mention your shops version I can only guess that it is 2.3. If that is the case, then that option won't work since I haven't converted the code for the search function. I may do that in the furture but, to be honest, it is not something I suggest using. Finding keywords dynamically rarely works well. You are relying on a program to pick the most important part of the page - just not a good idea for SEO work.

Share this post


Link to post
Share on other sites

Here's what's in the latest versions install_admin file:

hello,

 

adamanto, and 14Steve14,

 

to get rid of that error you need to add this:

 

define('TABLE_HEADERTAGS_KEYWORDS', 'headertags_keywords'); 

 

to admin/includes/database_tables.php

 

anyway per instructions i do not have a get position column ,maybe this is a work in progress by Jack_mcs.

 

because when i checked the install_admin.txt file all these namings were leftout.

 

 

thanks,

 

craig

 

Yes, those solutions did not work... Do you have any other suggestions?

 

Thanks

 

Adamanto75

Share this post


Link to post
Share on other sites

Yes, those solutions did not work... Do you have any other suggestions?

 

Thanks

 

Adamanto75

Whenver you see capital letters in an error like that, it means a mistake has been made in the installation. You need to compare your files with those included to see where you went wrong.

Share this post


Link to post
Share on other sites

Whenver you see capital letters in an error like that, it means a mistake has been made in the installation. You need to compare your files with those included to see where you went wrong.

 

Oh yes thank you I forgot I downloaded that program a couple days ago for that reason lol and forgot about it.

Share this post


Link to post
Share on other sites

Whenver you see capital letters in an error like that, it means a mistake has been made in the installation. You need to compare your files with those included to see where you went wrong.

 

Which files do I compare? I never used the program before

Share this post


Link to post
Share on other sites

Which files do I compare? I never used the program before

The database_tables.php files. But all really should be checked when such a mistake is made.

Share this post


Link to post
Share on other sites

Hi Jack,

Updating my site with the new version and I get this error at the bottom of the admin/categories page

Fatal error: Call to undefined function tep_get_products_head_listing_text() in /home/xxxxxxxx/public_html/xxxxx/categories.php on line 1064

I double checked the install and all seems to be correct.

I have rc2.2


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites

Hi Jack,

Updating my site with the new version and I get this error at the bottom of the admin/categories page

Fatal error: Call to undefined function tep_get_products_head_listing_text() in /home/xxxxxxxx/public_html/xxxxx/categories.php on line 1064

I double checked the install and all seems to be correct.

I have rc2.2

It looks like you didn't upload the admin/includes/functions/header_tags_general.php file or failed to make the change for it.

Share this post


Link to post
Share on other sites

hey adamanto75,

 

iuse examdiff. i usually compare the same file old and new.

 

for example index.php from the original download file from oscommerce 2.3 to a file that has added on (or modded).

 

the differences will show up and you can go from there.

 

thanks

craig

 

P.S. i was hesitant at first but after delving into it I find it invaluable tool.

Edited by zpupster

Share this post


Link to post
Share on other sites

Once again Obiwan, you are correct.

 

I merged the files located in the rc2 folder, but didn't check the catalog folder for updated files. That file was updated in the catalog folder but not rc2.


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites

Hey Instead of doing that I just reinstalled a fresh clean version of oscommerce, and I uploaded the catalog files for a new shop and after I uploaded them it broke my shop...

 

It gives me this error

 

Warning: require(includes/functions/header_tags_general.php) [function.require]: failed to open stream: No such file or directory in/hermes/web08/b2492/moo.oursacredgardencom/oursacredgarden.com/includes/functions/general.php on line 1479

 

Fatal error: require() [function.require]: Failed opening required 'includes/functions/header_tags_general.php' (include_path='.:/usr/local/lib/php-5.2.17/lib/php') in/hermes/web08/b2492/moo.oursacredgardencom/oursacredgarden.com/includes/functions/general.php on line 1479

Edited by Adamanto75

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×