Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Jack (or anyone else that knows)

 

Could you give me a little info on the Silo Box.

 

I see the concept behind it, but I am just not too sure what the most ideal settings would be for it.

 

For example, What should I make the title of the box? Right now I have a title of "Most Popular" and I choose the "Best Seller" radio button, but that seems too close to the standard "Bestsellers" box

 

How many links should I have it display? Right now I have 5.

 

I just don't know if how I have it setup right now is ideal or wrong in someway.

 

Just looking for some insight/ideas I guess.

Share this post


Link to post
Share on other sites

Hey, just want to make you aware of an error in the package. I downloaded and installed on an existing 2.2RC store.

 

I was getting a StripSID function does not exist error when I tried to enable the social bookmarks. I was able to fix it by adding the function from the header_tags.php file to the general function file. For some reason it was not loading up from the header_tags file. Maybe something to look at because on the same issue, you told people to update their files, but in this case, the function was there, just not accessible until I put it in the general file.

Share this post


Link to post
Share on other sites

Jack (or anyone else that knows)

 

Could you give me a little info on the Silo Box.

 

I see the concept behind it, but I am just not too sure what the most ideal settings would be for it.

 

For example, What should I make the title of the box? Right now I have a title of "Most Popular" and I choose the "Best Seller" radio button, but that seems too close to the standard "Bestsellers" box

 

How many links should I have it display? Right now I have 5.

 

I just don't know if how I have it setup right now is ideal or wrong in someway.

 

Just looking for some insight/ideas I guess.

It doesn't matter much as to what the title is. I would make it something that is helpful to your visitors. As for the number of links, the more links there are, the better, as far as the search engines are concerned, but too many may clutter the page. I wouldn't suggest going over ten, but that is just an arbitrary number. That option, while it works to a point, is not a completed option. It can be useful as long as it doesn't cause confusion to your visitors. Its use has to be evaluated on a shop-by-shop basis.

Share this post


Link to post
Share on other sites

Hey, just want to make you aware of an error in the package. I downloaded and installed on an existing 2.2RC store.

 

I was getting a StripSID function does not exist error when I tried to enable the social bookmarks. I was able to fix it by adding the function from the header_tags.php file to the general function file. For some reason it was not loading up from the header_tags file. Maybe something to look at because on the same issue, you told people to update their files, but in this case, the function was there, just not accessible until I put it in the general file.

Thanks for the input. I will look into it for the next version.

Share this post


Link to post
Share on other sites

It doesn't matter much as to what the title is. I would make it something that is helpful to your visitors. As for the number of links, the more links there are, the better, as far as the search engines are concerned, but too many may clutter the page. I wouldn't suggest going over ten, but that is just an arbitrary number. That option, while it works to a point, is not a completed option. It can be useful as long as it doesn't cause confusion to your visitors. Its use has to be evaluated on a shop-by-shop basis.

 

Okay, just thought I would check.

 

Thank you.

Share this post


Link to post
Share on other sites

Hi Forum,

 

Thanks Jack_mcs for the reply.

 

Made the mods you suggested but not much change.

 

If you say it's not that important then I'll maybe not bother about it but I'm sure I read on a 'website Top Ten tips' that 'flawless' HTML validation was more or less a must for the crawlers.

 

Thanks for the input.

 

semper-linux

Share this post


Link to post
Share on other sites

Hi! I'm not sure what I've done, but after I uploaded everything, there was a massive shift in my store layout.

 

Here's the link:: http://www.the-broomcloset.com/catalog/index.php

 

Thanks

 

Also, here are my test results::

 

Duplicate title found: explain

for English

exists more than once.

 

 

Duplicate meta description found: explain

for English

exists more than once.

 

AND

 

I've replaced the files with the files from "Catalog_from_new_shop_only" and the layout is still the same.

Edited by JenniferJordan

Share this post


Link to post
Share on other sites

Also, my store logo has been doubled, one says "Replace me in Page Control under index.php."

 

On my source code for the page, the extra store logo code is:

<div id="storeLogo"><a href="http://www.the-broomcloset.com/catalog/index.php"><img src="images/store_logo.png" alt="Replace me in Page Control under index.php" title=" Replace me in Page Control under index.php " width="950" height="250" /></a></div> 

 

I want to remove that meta tag. I think it will sort out the page alignment problem I'm having, but I don't know where to go to remove it.

Share this post


Link to post
Share on other sites

Also, my store logo has been doubled, one says "Replace me in Page Control under index.php."

 

On my source code for the page, the extra store logo code is:

<div id="storeLogo"><a href="http://www.the-broomcloset.com/catalog/index.php"><img src="images/store_logo.png" alt="Replace me in Page Control under index.php" title=" Replace me in Page Control under index.php " width="950" height="250" /></a></div> 

 

I want to remove that meta tag. I think it will sort out the page alignment problem I'm having, but I don't know where to go to remove it.

I don't know what the shop should look like normally so it is difficult to say what the problem might be. The meta tag code should cause an alignment problem. I suspect you used the wrong version for your shop or you copied something that shouldn't have been copied. There's just no way to tell from here though. I suggest you restore the shop side and start again, checking the shop between steps.

Share this post


Link to post
Share on other sites

I replaced the original files, ran the uninstall.php, and now I have this as a website :P

 

 

1091 - Can't DROP 'products_head_title_tag'; check that column/key exists

 

ALTER TABLE products_description DROP products_head_title_tag

 

[TEP STOP]

Share this post


Link to post
Share on other sites

Also,

When I run the uninstall php, I get this before I lose my website:

 

Warning: require(includes/column_left.php) [function.require]: failed to open stream: No such file or directory in /home7/thebroo2/public_html/catalog/headertags_seo_uninstall.php on line 66

 

Fatal error: require() [function.require]: Failed opening required 'includes/column_left.php' (include_path='.:/usr/lib64/php:/usr/lib/php:/usr/share/pear') in /home7/thebroo2/public_html/catalog/headertags_seo_uninstall.php on line 66

 

 

 

AND, theres now a data error when I try to access my files though file manager.

 

Even when everything is returned to normal and I've uninstalled it, its still looking for header seo files.

Edited by JenniferJordan

Share this post


Link to post
Share on other sites

Also,

When I run the uninstall php, I get this before I lose my website:

 

Warning: require(includes/column_left.php) [function.require]: failed to open stream: No such file or directory in /home7/thebroo2/public_html/catalog/headertags_seo_uninstall.php on line 66

 

Fatal error: require() [function.require]: Failed opening required 'includes/column_left.php'

 

AND, theres now a data error when I try to access my files though file manager.

 

Even when everything is returned to normal and I've uninstalled it, its still looking for header seo files.

The install file was written for a standard shop. It may not display correctly on all shops but you can ignore the column_left error.

 

If you are seeing some reference to Header Tags, then you didn't uninstall everything. By the way, it's too late now but when I said uninstall on the shop side, I was referring to the files. There was no reason to change the database.

 

If you are using the file manager in the shop (actually if you even have it installed), that is a large security hole and you should fix that. There are many threads in these forums that explain that.

Share this post


Link to post
Share on other sites

The install file was written for a standard shop. It may not display correctly on all shops but you can ignore the column_left error.

 

If you are seeing some reference to Header Tags, then you didn't uninstall everything. By the way, it's too late now but when I said uninstall on the shop side, I was referring to the files. There was no reason to change the database.

 

If you are using the file manager in the shop (actually if you even have it installed), that is a large security hole and you should fix that. There are many threads in these forums that explain that.

 

 

Oh! Okay! Thanks :] I got it all back to normal last night. I've backed up the normal version, database and local files, and I'm going to try it again, checking the website between steps to figure out what caused the duplicate store logo if it happens again. I think, also, that I'll instal via sql file instead of cheating with the php :P I got kind of bored at the end of the install, so I may have missed something there. Either way, I liked the individual product metatags, so thats why I want to continue trying your conrib. But, here I go! Thanks for trying to help so far :] I have v 2.3.1, so I'll be using the later than 2.3 folder of files.

Edited by JenniferJordan

Share this post


Link to post
Share on other sites

Hello, am new to OSCommerce but have muddled my way through and wanted finally to add this module before adding my products & SEO data before getting my site live.

I have added Header Tags SEO V 3.2.6 on to a 2.3.1 database (using catalog versiongreaterthan2.3), i was confused initially as i didn't appear to be either a BTS or STS user, but saw a response was posted to someone with a similar issue on 30 June 2011, 22:43 stating " That's a mistake in the instructions. BTS and STS won't work with 2.3 so you can skip those steps."

So i have not completed any of the items in 1a or 1b and moved on to step 2 in install_catalog.txt , i've completed all catalog and admin steps now and during some initially testing i am receiving the following error: Call to undefined function StripSID() in ..catalog/includes/modules/header_tags_social_bookmarks.php on line 10

 

I am wondering if perhaps it is something that might have been performed in steps 1a or 1b that deal with the definition of this StripSID funtion that i am missing ? Or any other suggestions of where i should back track to ?

 

Thank you, Christine.

Share this post


Link to post
Share on other sites

Oh! Okay! Thanks :] I got it all back to normal last night. I've backed up the normal version, database and local files, and I'm going to try it again, checking the website between steps to figure out what caused the duplicate store logo if it happens again. I think, also, that I'll instal via sql file instead of cheating with the php :P I got kind of bored at the end of the install, so I may have missed something there. Either way, I liked the individual product metatags, so thats why I want to continue trying your conrib. But, here I go! Thanks for trying to help so far :] I have v 2.3.1, so I'll be using the later than 2.3 folder of files.

If by "via sql file" you mean the sql database file, you should only use that if you have one language. It will be removed in the next version.

 

It is a long, and sometimes difficult, installation but the resultds are worth it so hang in there. :)

Share this post


Link to post
Share on other sites

Hello, am new to OSCommerce but have muddled my way through and wanted finally to add this module before adding my products & SEO data before getting my site live.

I have added Header Tags SEO V 3.2.6 on to a 2.3.1 database (using catalog versiongreaterthan2.3), i was confused initially as i didn't appear to be either a BTS or STS user, but saw a response was posted to someone with a similar issue on 30 June 2011, 22:43 stating " That's a mistake in the instructions. BTS and STS won't work with 2.3 so you can skip those steps."

So i have not completed any of the items in 1a or 1b and moved on to step 2 in install_catalog.txt , i've completed all catalog and admin steps now and during some initially testing i am receiving the following error: Call to undefined function StripSID() in ..catalog/includes/modules/header_tags_social_bookmarks.php on line 10

 

I am wondering if perhaps it is something that might have been performed in steps 1a or 1b that deal with the definition of this StripSID funtion that i am missing ? Or any other suggestions of where i should back track to ?

 

Thank you, Christine.

No, you did correctly by skipping those steps. That StripSID function is in one of the included Header Tags files so my quess is that you didn't upload all of the files. There are two directories for each oscommerce version. One named catalog and one named catalog_for_new_shop.... All of the files in the catalog directory are Header Tags files and they all need to be uploaded to the server. Be sure to upload them to the correct location (includes to includes, etc.).

Share this post


Link to post
Share on other sites

If by "via sql file" you mean the sql database file, you should only use that if you have one language. It will be removed in the next version.

 

It is a long, and sometimes difficult, installation but the resultds are worth it so hang in there. :)

 

Wonderful! I do have only english :] So far, I've finished the catalog adjustments and everything looks fine. The only thing I see so far is:

Warning: call_user_func(header_tags_reset_cache) [function.call-user-func]: First argument is expected to be a valid callback in /home7/thebroo2/public_html/catalog/admin/includes/functions/general.php on line 1417

But that's because I haven't done any admin edits yet. YAY! No double logos! :]]

Share this post


Link to post
Share on other sites

YES! It works wonderfully!! Thank you very, very much for being patient with me! I did, however, have to remove this code from my header.php file::

 

<?php /*** Begin Header Tags SEO ***/ ?>

   <div id="storeLogo"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'store_logo.png', (tep_not_null($header_tags_array['logo_text']) ? $header_tags_array['logo_text'] : STORE_NAME)) . '</a>'; ?></div>

   <?php /*** End Header Tags SEO ***/ ?>

 

It throws off the alignment when its in, so I left it as

<div id="storeLogo">

Which is what it was before. For some reason, my header.php didn't have the full code the instructions asked for to replace. So, I'm just leaving it off for now.

 

THANKS!! :D

Share this post


Link to post
Share on other sites

YES! It works wonderfully!! Thank you very, very much for being patient with me! I did, however, have to remove this code from my header.php file::

 

It throws off the alignment when its in, so I left it as

<div id="storeLogo">

Which is what it was before. For some reason, my header.php didn't have the full code the instructions asked for to replace. So, I'm just leaving it off for now.

 

THANKS!! :D

That's common with some templates. They use css to load the image so all you can do is skip that part. Congratulations on getting it installed. :)

Share this post


Link to post
Share on other sites

No, you did correctly by skipping those steps. That StripSID function is in one of the included Header Tags files so my quess is that you didn't upload all of the files. There are two directories for each oscommerce version. One named catalog and one named catalog_for_new_shop.... All of the files in the catalog directory are Header Tags files and they all need to be uploaded to the server. Be sure to upload them to the correct location (includes to includes, etc.).

 

 

Hey, thank you very much Jack for getting back to me (sorry if this is a repeat response but the one i was just working on just vanished!)

 

Anyway i wanted to let you know i went back over everything with a fine toothcomb and then an even finer one .... it seems in my haste to skip steps 1a and 1b i also skipped the amendment detailed in step 1 (namely the update to <meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>"> <title><?php echo TITLE; ?></title> ... with that now in place it's all looking a lot better !

 

Thanks,

Christine

Share this post


Link to post
Share on other sites

Hey, thank you very much Jack for getting back to me (sorry if this is a repeat response but the one i was just working on just vanished!)

 

Anyway i wanted to let you know i went back over everything with a fine toothcomb and then an even finer one .... it seems in my haste to skip steps 1a and 1b i also skipped the amendment detailed in step 1 (namely the update to <meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>"> <title><?php echo TITLE; ?></title> ... with that now in place it's all looking a lot better !

You're welcome. Glad to hear you figured it out. :)

Share this post


Link to post
Share on other sites

Been over the installation twice and ran the test function - everything looks fine. But every time I try to update the seo header tags in oscommerce admin I get the following message on all, but home and category pages -

 

Fatal error: Call to undefined function filename_templ_product_list() in /home3/twistfou/public_html/includes/header_tags.php on line 242

 

Can't find anything like "filename_templ_product_list" in the header_tags.php file or filenames.php

 

Any ideas on how to fix?

 

S

Share this post


Link to post
Share on other sites

Been over the installation twice and ran the test function - everything looks fine. But every time I try to update the seo header tags in oscommerce admin I get the following message on all, but home and category pages -

 

Fatal error: Call to undefined function filename_templ_product_list() in /home3/twistfou/public_html/includes/header_tags.php on line 242

 

Can't find anything like "filename_templ_product_list" in the header_tags.php file or filenames.php

 

Any ideas on how to fix?

 

S

No, that's not part of the contribution. Since it is in the includes/header_tags.php file, my guess is that you have some illegally named file in the root and the header tags code is trying to make sense of it. You'll need to remove any such files and reload the includes/header_tags.php file to fix it.

Share this post


Link to post
Share on other sites

Hi Jack,

 

I have created a new page which I want to have custom header tags. I have based the new page on the shipping.php page. The new page is found within 'Page Control' and I have changed the title, descripton and keywords from the default settings I have for my store. When I check my source code on the page it shows the default tags. I have run the test and it says there's no errors and is showing my chosen tags as expected. Cache is turned off and permissions are granted on the header_tags.php file in includes. I've also checked the database and the changed tags are there. When i view result under page control, the default tags show even though in the fields above are my custom tags.

 

Any ideas why it's insisting on showing the default tags and not my chosen tags?

 

Cheers


Ah, the world wide web. What a wonderful place.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×