Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Please can someone help me with this because I am confused here. The titles, keyword content, keywords, descriptions and subject I have written were for my individual products in the category section. Can I make titles, keyword content, keywords, descriptions (meta tags) for each individual product or am I just limited to the product info page? The individual product pages is what I wanted to come across on the internet, not so much the other pages. Well maybe the contact us page though. Anyways, I appreciate any and all help regarding this subject matter. Please reply. Thank you. Carla


I have installed:

Oscommerce version 2.2rc2a, STS version 4.5.8, Header Tags SEO version 3.1.5, SEO Assistant version 2.1

 

Thanks

Joey

Share this post


Link to post
Share on other sites
Hey Jack, I was wondering have you can across this little problem...on my index and product info pages in my store it only shows 6 of the social bookmark icons....is there a reason for this??? I have the social bookmark folder in my /images....but I uploaded the whole folder... I did not upload the images individually...could this be why?? although I dont see how it could be....
The code is only setup to display that many. I included the rest of the images in case someone wanted to add the code to more.

 

Jack

Share this post


Link to post
Share on other sites
Please can someone help me with this because I am confused here. The titles, keyword content, keywords, descriptions and subject I have written were for my individual products in the category section. Can I make titles, keyword content, keywords, descriptions (meta tags) for each individual product or am I just limited to the product info page? The individual product pages is what I wanted to come across on the internet, not so much the other pages. Well maybe the contact us page though. Anyways, I appreciate any and all help regarding this subject matter. Please reply. Thank you. Carla
The title and meta tags for the products are set in the products edit page for each. You can pre-set them using the Fill Tags option but to set each to whatever you want, you need to edit them there. The same goes for the categories and manufacturers.

 

Jack

Share this post


Link to post
Share on other sites
Hey Jack, I was wondering have you can across this little problem...on my index and product info pages in my store it only shows 6 of the social bookmark icons....is there a reason for this??? I have the social bookmark folder in my /images....but I uploaded the whole folder... I did not upload the images individually...could this be why?? although I dont see how it could be....

 

 

Thanks in advance....

 

 

 

Gloria

For a few more tags you can open your header_tags_social_bookmarks.php and replace everything under line 5 with the following:

<tr>
<td><table border="0" align="right">
 <tr>
 <td><a rel="nofollow" target="_blank" href="http://www.google.com/bookmarks/mark?op=edit&output=popup&bkmk=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/google.png" alt="<?php echo 'Add ' . $NAME . ' to Google'; ?> " title="<?php echo 'Add ' . $NAME. ' to Google'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="https://favorites.live.com/quickadd.aspx?marklet=1&mkt=en-us&url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/live.png" alt="<?php echo 'Add ' . $NAME . ' to Windows Live'; ?> " title="<?php echo 'Add ' . $NAME. ' to Windows Live'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://myweb2.search.yahoo.com/myresults/bookmarklet?t=<?php echo $TITLE . '&u=' . $URL; ?>">
 <img src="images/socialbookmark/yahoo.png" alt="<?php echo 'Add ' . $NAME . ' to Yahoo'; ?> " title="<?php echo 'Add ' . $NAME. ' to Yahoo'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://myjeeves.ask.com/mysearch/BookmarkIt?v=1.2&t=webpages&url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/ask.png" alt="<?php echo 'Add ' . $NAME . ' to Ask'; ?> " title="<?php echo 'Add ' . $NAME. ' to Ask'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://www.netscape.com/submit/?U=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/netscape.png" alt="<?php echo 'Add ' . $NAME . ' to Netscape'; ?> " title="<?php echo 'Add ' . $NAME. ' to Netscape'; ?> " border="0"></a></td> 

 <td><a rel="nofollow" target="_blank" href="http://del.icio.us/post?url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/delicious.png" alt="<?php echo 'Add ' . $NAME . ' to del.icio'; ?> " title="<?php echo 'Add ' . $NAME. ' to del.icio'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://digg.com/submit?phase=2&url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/digg.png" alt="<?php echo 'Add ' . $NAME . ' to Digg'; ?> " title="<?php echo 'Add ' . $NAME . ' to Digg'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://www.newsvine.com/_wine/save?popoff=1&u=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/newsvine.png" alt="<?php echo 'Add ' . $NAME . ' to Newsvine'; ?> " title="<?php echo 'Add ' . $NAME . ' to Newsvine'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://technorati.com/cosmos/search.html?url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/technorati.png" alt="<?php echo 'Add ' . $NAME . ' to Technorati'; ?> " title="<?php echo 'Add ' . $NAME . ' to Technorati'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://furl.net/storeIt.jsp?t=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/furl.gif" alt="<?php echo 'Add ' . $NAME . ' to Furl'; ?> " title="<?php echo 'Add ' . $NAME . ' to Furl'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://reddit.com/submit?url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/reddit.gif" alt="<?php echo 'Add ' . $NAME . ' to Reddit'; ?> " title="<?php echo 'Add ' . $NAME . ' to Reddit'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://ekstreme.com/socializer/?url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/Socializer16.png" alt="<?php echo 'Add ' . $NAME . ' to The Socializer'; ?> " title="<?php echo 'Add ' . $NAME . ' to The Socializer'; ?> " border="0"></a></td>
 </tr>
</table></td>
</tr>


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites
For a few more tags you can open your header_tags_social_bookmarks.php and replace everything under line 5 with the following:

<tr>
<td><table border="0" align="right">
 <tr>
 <td><a rel="nofollow" target="_blank" href="http://www.google.com/bookmarks/mark?op=edit&output=popup&bkmk=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/google.png" alt="<?php echo 'Add ' . $NAME . ' to Google'; ?> " title="<?php echo 'Add ' . $NAME. ' to Google'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="https://favorites.live.com/quickadd.aspx?marklet=1&mkt=en-us&url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/live.png" alt="<?php echo 'Add ' . $NAME . ' to Windows Live'; ?> " title="<?php echo 'Add ' . $NAME. ' to Windows Live'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://myweb2.search.yahoo.com/myresults/bookmarklet?t=<?php echo $TITLE . '&u=' . $URL; ?>">
 <img src="images/socialbookmark/yahoo.png" alt="<?php echo 'Add ' . $NAME . ' to Yahoo'; ?> " title="<?php echo 'Add ' . $NAME. ' to Yahoo'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://myjeeves.ask.com/mysearch/BookmarkIt?v=1.2&t=webpages&url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/ask.png" alt="<?php echo 'Add ' . $NAME . ' to Ask'; ?> " title="<?php echo 'Add ' . $NAME. ' to Ask'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://www.netscape.com/submit/?U=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/netscape.png" alt="<?php echo 'Add ' . $NAME . ' to Netscape'; ?> " title="<?php echo 'Add ' . $NAME. ' to Netscape'; ?> " border="0"></a></td> 

 <td><a rel="nofollow" target="_blank" href="http://del.icio.us/post?url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/delicious.png" alt="<?php echo 'Add ' . $NAME . ' to del.icio'; ?> " title="<?php echo 'Add ' . $NAME. ' to del.icio'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://digg.com/submit?phase=2&url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/digg.png" alt="<?php echo 'Add ' . $NAME . ' to Digg'; ?> " title="<?php echo 'Add ' . $NAME . ' to Digg'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://www.newsvine.com/_wine/save?popoff=1&u=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/newsvine.png" alt="<?php echo 'Add ' . $NAME . ' to Newsvine'; ?> " title="<?php echo 'Add ' . $NAME . ' to Newsvine'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://technorati.com/cosmos/search.html?url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/technorati.png" alt="<?php echo 'Add ' . $NAME . ' to Technorati'; ?> " title="<?php echo 'Add ' . $NAME . ' to Technorati'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://furl.net/storeIt.jsp?t=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/furl.gif" alt="<?php echo 'Add ' . $NAME . ' to Furl'; ?> " title="<?php echo 'Add ' . $NAME . ' to Furl'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://reddit.com/submit?url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/reddit.gif" alt="<?php echo 'Add ' . $NAME . ' to Reddit'; ?> " title="<?php echo 'Add ' . $NAME . ' to Reddit'; ?> " border="0"></a></td>

 <td><a rel="nofollow" target="_blank" href="http://ekstreme.com/socializer/?url=<?php echo $URL . '&title=' . $TITLE; ?>">
 <img src="images/socialbookmark/Socializer16.png" alt="<?php echo 'Add ' . $NAME . ' to The Socializer'; ?> " title="<?php echo 'Add ' . $NAME . ' to The Socializer'; ?> " border="0"></a></td>
 </tr>
</table></td>
</tr>

 

Hey G.L. thanks for the code..thumbs up.gif....it works perfect now..... :D


Gloria

Share this post


Link to post
Share on other sites

I have searched the forum and cannot find the answer. I have re-installed several times and still not working properly.

I edit the tags in categories product description. I then got to header tags seo and choose fill all tags. I then go to the catalog page I wanted changed. Look at the page source and it is still the default SEO settings NOT the settings I typed in. What am I doing wrong?

Share this post


Link to post
Share on other sites
I have searched the forum and cannot find the answer. I have re-installed several times and still not working properly.

I edit the tags in categories product description. I then got to header tags seo and choose fill all tags. I then go to the catalog page I wanted changed. Look at the page source and it is still the default SEO settings NOT the settings I typed in. What am I doing wrong?

Fill Tags, assuming you are using the all option, is overwriting the tags you enter. Either run it first or use the fill empty option.

 

Jack

Share this post


Link to post
Share on other sites

Jack,did you figured out categories unique meta tags away from index.php?

I mean if index.php have meta tags tiltle "aaa - aaa - aaa",I don't want category have the same title or "aaa - aaa - aaa - bbb"

Is there a way let category have "bbb - bbb - bbb"?

Share this post


Link to post
Share on other sites
Fill Tags, assuming you are using the all option, is overwriting the tags you enter. Either run it first or use the fill empty option.

 

Jack

 

Thanks for your speedy reply Jack. I still have the same problem. I cleared all tags. Went to my product, enter tags and updated. went to the web page and I still see the default page settings. Looked at page source and all tags are default. As I said previously, I have unonstalled and re-installed several times paying close attention to each step. I am sure there is something very simple that I am overlooking.

 

Any other suggestions?

Share this post


Link to post
Share on other sites
Thanks for your speedy reply Jack. I still have the same problem. I cleared all tags. Went to my product, enter tags and updated. went to the web page and I still see the default page settings. Looked at page source and all tags are default. As I said previously, I have unonstalled and re-installed several times paying close attention to each step. I am sure there is something very simple that I am overlooking.

 

Any other suggestions?

If you are running a standard shop, you can try the troubleshooting steps mentioned previously in this thread.

 

Jack

Share this post


Link to post
Share on other sites
Jack,did you figured out categories unique meta tags away from index.php?

I mean if index.php have meta tags tiltle "aaa - aaa - aaa",I don't want category have the same title or "aaa - aaa - aaa - bbb"

Is there a way let category have "bbb - bbb - bbb"?

 

We have this issue as well - we want defaults to show ion the index page, but they also show in the category pages, being based on index,php.

 

We have thought about this and think the easiest way to approach this from the admin pages, is to add a "home page" setting unrelated to the categories, so that index.php relates to Categories AND home page, but can be overridden by any "Home page" setting.

 

Would this solve the issue? If so we can probably code it up if you want..

Share this post


Link to post
Share on other sites
Would this solve the issue? If so we can probably code it up if you want..
Please feel free to do that if you like and post the code. I can't say it will be included in the contribution but others may find it useful.

 

Jack

Share this post


Link to post
Share on other sites

Hello !!

good jobJ Jack ... Thank's

I installed Header Tag SEO 3.0.4. After verification of Tag with FireFox Meta Tags SidBar, I note that for the pages in french and english:

http://www.mywebsite.com/?language=fr and http://www.mywebsite.com/?language=en

I've always Content-language [H]: U.S.

What I be done to correct this bug? I think we should change the line 145 of includes/header_tags.php

if ($ defaultTags [ 'meta_language']) echo '<meta http-equiv="Content-Language" content="en-US" />'. "\ n";

Thank you

Edited by centel

Share this post


Link to post
Share on other sites
Hi Jack

 

I thought I installed the contrib correctly but when I go into a product page....here

 

There is some code at the bottom of the page which wasn't there before. This is the code:

 

Currently viewing: <a title="" href="http://www.homelandart.ie/phil-lynott-p-90.html"/# ">

 

Any suggestion?

 

Thanks

Adding the currently viewing code is part of the contribution but you added it in the wrong place. You need to go back over the changes for the product_info.php file.

 

Jack

Share this post


Link to post
Share on other sites

If using information pages unlimited here is a simple code that will echo your page title in the pages title meta description and keywords. I would love to use the Information pages description as metadescription but cannot figure out how to strip html out of that description, so everything uses the title for now.

 

Just place it in catalog/includes/header_tags.php above the line that reads : // ALL OTHER PAGES NOT DEFINED ABOVE

 

// INFORMATION.PHP
 case (basename($PHP_SELF)==FILENAME_INFORMATION): 
$pageTags_query = tep_db_query("select * from " . TABLE_HEADERTAGS . " where page_name like '" . FILENAME_INFORMATION . "' and language_id = '" . (int)$languages_id . "'");
$pageTags = tep_db_fetch_array($pageTags_query);  
$information_query = tep_db_query("select information_title, information_description FROM " . TABLE_INFORMATION . " WHERE visible='1' AND information_id='" . (int)$info_id . "' AND language_id = '" . (int)$languages_id . "'");

$information = tep_db_fetch_array($information_query);
$header_tags_array['information'] = $information['information_title'];  //save for use on the logo
$tmpTags['information_title'] = (tep_not_null($information['information_title'])) ? $information['information_title'] : '';
$tmpTags['information_description'] = (tep_not_null($information['information_title'])) ? $information['information_title'] : '';
$tmpTags['information_keywords'] = (tep_not_null($information['information_title'])) ? $information['information_title'] : '';


//$sortOrder['title'][0] = $pageTags['page_title'];
$sortOrder['title'][0] = $tmpTags['information_title'];
$sortOrder['description'][10] = $pageTags['page_description']; 
$sortOrder['description'][0] = $tmpTags['information_description'];
$sortOrder['keywords'][10] = $pageTags['page_keywords'];
$sortOrder['keywords'][0] = $tmpTags['information_keywords']; 
$sortOrder['logo'][0] = $pageTags['page_logo'];
$sortOrder['logo'][10] = $tmpTags['information_title']; 

if ($pageTags['append_default_title'] && tep_not_null($tmpTags['def_title'])) $sortOrder['title'][$pageTags['sortorder_title']] = $tmpTags['def_title'];
if ($pageTags['append_default_description'] && tep_not_null($tmpTags['def_desc'])) $sortOrder['description'][$pageTags['sortorder_description']] = $tmpTags['def_desc'];
if ($pageTags['append_default_keywords'] && tep_not_null($tmpTags['def_keywords'])) $sortOrder['keywords'][$pageTags['sortorder_keywords']] = $tmpTags['def_keywords'];
if ($pageTags['append_default_logo'] && tep_not_null($tmpTags['def_logo_text']))  $sortOrder['logo'][$pageTags['sortorder_logo']] = $tmpTags['def_logo_text'];

FillHeaderTagsArray($header_tags_array, $sortOrder);  

break;


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites

If anyone besides me still uses newsdesk here is a simple code add on that will work automatically with newsdesk. It will use the newsdesk article and category name for meta title and keyword and logo text. It will use the newsdesk articles Summary as meta description, so you cannot use HTML in the summary, but give and take right? Its about as automatic as I could make it.

 

Just place it in catalog/includes/header_tags.php above the line that reads : // ALL OTHER PAGES NOT DEFINED ABOVE

 

//NEWSDESK_INDEX
case (basename($PHP_SELF)==FILENAME_NEWSDESK_INDEX):
$pageTags_query = tep_db_query("select * from " . TABLE_HEADERTAGS . " where page_name like '" . FILENAME_NEWSDESK_INDEX . "' and language_id = '" . (int)$languages_id . "'");
$pageTags = tep_db_fetch_array($pageTags_query);

$catStr = "select categories_name as htc_title_tag, categories_name as htc_desc_tag, categories_name as htc_keywords_tag from " . TABLE_NEWSDESK_CATEGORIES_DESCRIPTION . " where categories_id = '" . (int)$current_category_id . "' and language_id = '" . (int)$languages_id . "'";


$sortOrder['title'][0] = $pageTags['page_title']; 
$sortOrder['description'][0] = $pageTags['page_description']; 
$sortOrder['keywords'][0] = $pageTags['page_keywords']; 
$sortOrder['logo'][0] = $pageTags['page_logo']; 
$sortOrder = GetCategoryAndManufacturer($sortOrder, $pageTags, $defaultTags, $catStr);

if ($pageTags['append_default_title'] && tep_not_null($tmpTags['def_title'])) $sortOrder['title'][$pageTags['sortorder_title']] = $tmpTags['def_title'];
if ($pageTags['append_default_description'] && tep_not_null($tmpTags['def_desc'])) $sortOrder['description'][$pageTags['sortorder_description']] = $tmpTags['def_desc'];
if ($pageTags['append_default_keywords'] && tep_not_null($tmpTags['def_keywords'])) $sortOrder['keywords'][$pageTags['sortorder_keywords']] = $tmpTags['def_keywords'];
if ($pageTags['append_default_logo'] && tep_not_null($tmpTags['def_logo_text']))  $sortOrder['logo'][$pageTags['sortorder_logo']] = $tmpTags['def_logo_text'];

FillHeaderTagsArray($header_tags_array, $sortOrder);  

break;	

// NEWSDESK_INDEX.PHP etc
 case (basename($PHP_SELF)==FILENAME_NEWSDESK_INFO):
 case (basename($PHP_SELF)==FILENAME_NEWSDESK_REVIEWS_ARTICLE):
 case (basename($PHP_SELF)==FILENAME_NEWSDESK_REVIEWS_WRITE):
switch (true)
{
 case (basename($PHP_SELF)==FILENAME_NEWSDESK_INFO):		  $filename = FILENAME_NEWSDESK_INFO;	break;
 case (basename($PHP_SELF)==FILENAME_NEWSDESK_REVIEWS_ARTICLE):	   $filename = FILENAME_NEWSDESK_REVIEWS_ARTICLE; break;
 //case (basename($PHP_SELF)==FILENAME_PRODUCT_REVIEWS_INFO):  $filename = FILENAME_PRODUCT_REVIEWS; break; 
 case (basename($PHP_SELF)==FILENAME_NEWSDESK_REVIEWS_WRITE): $filename = FILENAME_NEWSDESK_REVIEWS_WRITE;   break;
 default: $filename = FILENAME_NEWSDESK_INFO;
} 

 $pageTags_query = tep_db_query("select * from " . TABLE_HEADERTAGS . " where page_name like '" . $filename . "' and language_id = '" . (int)$languages_id . "'");
$pageTags = tep_db_fetch_array($pageTags_query);

$the_newsdesk_info_query = tep_db_query("select p.newsdesk_id, pd.newsdesk_article_name, pd.newsdesk_article_shorttext from " . TABLE_NEWSDESK . " p left join " . TABLE_NEWSDESK_DESCRIPTION . " pd on p.newsdesk_id = pd.newsdesk_id where p.newsdesk_id = '" . (int)$_GET['newsdesk_id'] . "' and pd.language_id ='" .  $languages_id . "'");
$the_newsdesk_info = tep_db_fetch_array($the_newsdesk_info_query);
$header_tags_array['news_article'] = $the_newsdesk_info['newsdesk_article_name'];  //save for use on the logo
$tmpTags['news_title'] = (tep_not_null($the_newsdesk_info['newsdesk_article_name'])) ? $the_newsdesk_info['newsdesk_article_name'] : '';
$tmpTags['news_desc'] = (tep_not_null($the_newsdesk_info['newsdesk_article_shorttext'])) ? $the_newsdesk_info['newsdesk_article_shorttext'] : '';
$tmpTags['news_keywords'] = (tep_not_null($the_newsdesk_info['newsdesk_article_name'])) ? $the_newsdesk_info['newsdesk_article_name'] : '';

$catStr = "select c.categories_name as htc_title_tag from " . TABLE_NEWSDESK_CATEGORIES_DESCRIPTION . " c, " . TABLE_NEWSDESK_TO_CATEGORIES . " p2c where c.categories_id = p2c.categories_id and p2c.newsdesk_id = '" . (int)$the_newsdesk_info['newsdesk_id'] . "' and language_id = '" . (int)$languages_id . "'";



$sortOrder['title'][0] = $pageTags['page_title'];
$sortOrder['title'][10] = $tmpTags['news_title'];  //places it at the end of the list
$sortOrder['description'][10] = $pageTags['page_description']; 
$sortOrder['description'][0] = $tmpTags['news_desc'];
$sortOrder['keywords'][0] = $tmpTags['news_keywords'];
$sortOrder['keywords'][10] = $pageTags['page_keywords']; 
$sortOrder['logo'][0] = $pageTags['page_logo']; 
$sortOrder['logo'][10] = $tmpTags['news_title'];
$sortOrder = GetCategoryAndManufacturer($sortOrder, $pageTags, $defaultTags, $catStr, true);

if ($pageTags['append_default_title'] && tep_not_null($tmpTags['def_title'])) $sortOrder['title'][$pageTags['sortorder_title']] = $tmpTags['def_title'];
if ($pageTags['append_default_description'] && tep_not_null($tmpTags['def_desc'])) $sortOrder['description'][$pageTags['sortorder_description']] = $tmpTags['def_desc'];
if ($pageTags['append_default_keywords'] && tep_not_null($tmpTags['def_keywords'])) $sortOrder['keywords'][$pageTags['sortorder_keywords']] = $tmpTags['def_keywords'];
if ($pageTags['append_default_logo'] && tep_not_null($tmpTags['def_logo_text']))  $sortOrder['logo'][$pageTags['sortorder_logo']] = $tmpTags['def_logo_text'];

FillHeaderTagsArray($header_tags_array, $sortOrder);  

break;


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites

Hi Jack_mcs

 

I have recently installed this extensive contribution of yours... and saw that the catalog install part of it works fine.

On the other hand i get this troubling message when i try to access my administration.

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /customers/rynkebyvin.dk/rynkebyvin.dk/httpd.www/catalog/admin/includes/filenames.php:114) in /customers/rynkebyvin.dk/rynkebyvin.dk/httpd.www/catalog/admin/includes/functions/sessions.php on line 97

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /customers/rynkebyvin.dk/rynkebyvin.dk/httpd.www/catalog/admin/includes/filenames.php:114) in /customers/rynkebyvin.dk/rynkebyvin.dk/httpd.www/catalog/admin/includes/functions/sessions.php on line 97

 

Warning: Cannot modify header information - headers already sent by (output started at /customers/rynkebyvin.dk/rynkebyvin.dk/httpd.www/catalog/admin/includes/filenames.php:114) in /customers/rynkebyvin.dk/rynkebyvin.dk/httpd.www/catalog/admin/includes/functions/general.php on line 22

 

I am usually able to either find the bug myself or find someone in this forum with exactly the same issues and the solution.

But i have not been able to find anyone that has a similar problem, and I have not been able to pinpoint waht i have done wrong or what is conflicting in my heavily modified webshop.

 

Anyone ever encountered this before and knows something that might help me to find the problem.

 

Of course, the webshop worked fine before installing this contribution, I will just add.

 

I thank anyone in advance who has an idea what i did wrong. i assume i did something wrong, cause I dont seem to find anyone else with this problem.

 

SimonT

Share this post


Link to post
Share on other sites
See my signature for that error.

 

Jack

 

 

hehehehe... I have to laugh

 

It was the simplest bug hunt ever after reading your signature headers already sent

 

There was one line just after the last ?> in the filenames.php

 

Thanks, for helping me from drowning in the little pudle :lol:

 

SimonT

Share this post


Link to post
Share on other sites

Not sure if this is an error.

 

I wasn't getting a pages tags and title to work so I checked includes/header_tags.php

 

The file name in the filenames.php is: define('FILENAME_STORE_POLICIES', 'store_pol.php');

 

In header_tags.php I noticed that the page that wasn't working was:

 

// store_pol.php

case (strstr($_SERVER['PHP_SELF'],FILENAME_STORE_POL) or strstr($PHP_SELF,FILENAME_STORE_POL)):

$header_tags_array = tep_header_tag_page(FILENAME_STORE_POL);

break;

 

What I then did was change the

define('FILENAME_STORE_POLICIES', 'store_pol.php');

TO

define('FILENAME_STORE_POL', 'store_pol.php');

 

and the page that wasn't working before now works. Maybe there is a bug that is causing the page name to be shortened?

 

 

Finally, I, like some people can't get the category tags to work, still defaulting to the index.php tags. But I think there may be a small bug somewhere.

Share this post


Link to post
Share on other sites
Not sure if this is an error.

 

I wasn't getting a pages tags and title to work so I checked includes/header_tags.php

 

The file name in the filenames.php is: define('FILENAME_STORE_POLICIES', 'store_pol.php');

 

In header_tags.php I noticed that the page that wasn't working was:

 

// store_pol.php

case (strstr($_SERVER['PHP_SELF'],FILENAME_STORE_POL) or strstr($PHP_SELF,FILENAME_STORE_POL)):

Good catch. The code builds the name to compare against, FILENAME_STORE_POL, from the file name. If they don't match, then this is what happens. The code will have to be changed to read in the filenames.php file and parse it to get the correct name. I'll try to get this into the next version.

 

Jack

Share this post


Link to post
Share on other sites

Hi I just finished reading all 29 pages on this forum and I cannot find a solution to my problem. After reinstalling for the forth time and getting the same problem, I don’t know what else to do.

 

Everything seems to be working ok, or how the instructions say they should up to this point. When I put my cursor over the link in admin categories box for header tags I get this url:

 

http://123456789.com/admin/FILENAME_HEADER...cted_box=header tags

 

and of course when I click on it gives me a 404. page not found.

 

I read Jacks post about files with capital letters but I cannot find help there. I uploaded all files.

 

Can someone please point out what I did wrong.

 

thank you.

Share this post


Link to post
Share on other sites
Hi I just finished reading all 29 pages on this forum and I cannot find a solution to my problem. After reinstalling for the forth time and getting the same problem, I don’t know what else to do.

 

Everything seems to be working ok, or how the instructions say they should up to this point. When I put my cursor over the link in admin categories box for header tags I get this url:

 

http://123456789.com/admin/FILENAME_HEADER...cted_box=header tags

 

and of course when I click on it gives me a 404. page not found.

 

I read Jacks post about files with capital letters but I cannot find help there. I uploaded all files.

 

Can someone please point out what I did wrong.

 

thank you.

 

 

 

Sorry, long nite got, it fixed thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×