Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

To upgrade from HTC to this one, run the headertags_seo_update.sql file. Then just follow the instructions in the read me files, skipping the database changes mentioned in them. If you are not using Ultimate SEO V 2.2d, you may need to upgrade that too.

 

Thanks Jack - are these PHP 4+ compatible?

 

AJ

Share this post


Link to post
Share on other sites

Hello, I am very interested in your contribution and am willing to pay for you to install as we have a custome skin and many custom contributions installed but first I would like to check that you can confirm it will work for our setup. We have one main site and four "affilliate" or "feeder" sites. They not only run from an xml feed of the products but also share the databse of the main site. This means that any registered customers are registered only on the main site and no customers are actually registeered on the other site databases. All products are on the main site and all orders etc are processed only through the main database. The main site is lacremedvd dot com and one of the affiliate site is adult-dvd-streaming dot co.uk

Please could you review my information and the two sites mentioned and tell me if you beleive your contribution should work? Also would we need to install on just the main site or install on all five sites bearing in mind that all sites use the same database?

 

Thanks in advance for your time and advice. Sami

Share this post


Link to post
Share on other sites

Hello, I am very interested in your contribution and am willing to pay for you to install as we have a custome skin and many custom contributions installed but first I would like to check that you can confirm it will work for our setup. We have one main site and four "affilliate" or "feeder" sites. They not only run from an xml feed of the products but also share the databse of the main site. This means that any registered customers are registered only on the main site and no customers are actually registeered on the other site databases. All products are on the main site and all orders etc are processed only through the main database. The main site is lacremedvd dot com and one of the affiliate site is adult-dvd-streaming dot co.uk

Please could you review my information and the two sites mentioned and tell me if you beleive your contribution should work? Also would we need to install on just the main site or install on all five sites bearing in mind that all sites use the same database?

 

Thanks in advance for your time and advice. Sami

If I am understanding your setup correctly, then this will work somewhat. In your admin, you would still edit all of the categories and products as normal and their titles and tags could each be changed. When a category or product was displayed on whichever site, it would load the correct information since that is determined by the ID. But the home page control would only exist once so you couldn't have unique title and tags for each home page. Some other, small, things may not work exactly right but that would be the main problem.

Share this post


Link to post
Share on other sites

I would appreciate if someone could point me to the right direction here. I just installed Header SEO Tags on the 2.3.1 version. Everything looks good, but when I ran first TEST I've got this Warning:

Cannot find file ..admin/header_tags_seo.php.

Cannot find file ..admin/header_tags_fill_tags.php.

Cannot find file ..admin/includes/header_tags_seo_words.txt.

Cannot find file ..admin/includes/functions/header_tags.php.

Cannot find file ..admin/includes/boxes/header_tags_seo.php.

Cannot find file ..admin/includes/languages/lithuanian/header_tags_seo.php.

 

I noticed that there is a DOT at the end of the files name which are not found. I made sure that correct files are in correct places, but maybe I've done some mistake with files editing and looks like now Header Tags is looking not for .php files but for .php. ? ? ?

Edited by carpshop

Share this post


Link to post
Share on other sites

I would appreciate if someone could point me to the right direction here. I just installed Header SEO Tags on the 2.3.1 version. Everything looks good, but when I ran first TEST I've got this Warning:

Cannot find file ..admin/header_tags_seo.php.

Cannot find file ..admin/header_tags_fill_tags.php.

Cannot find file ..admin/includes/header_tags_seo_words.txt.

Cannot find file ..admin/includes/functions/header_tags.php.

Cannot find file ..admin/includes/boxes/header_tags_seo.php.

Cannot find file ..admin/includes/languages/lithuanian/header_tags_seo.php.

 

I noticed that there is a DOT at the end of the files name which are not found. I made sure that correct files are in correct places, but maybe I've done some mistake with files editing and looks like now Header Tags is looking not for .php files but for .php. ? ? ?

The period is correct but the ..admin is not. That should be the full path to the files and .. is saying the code is looking for the files above the admin directory,which won't work. So it appears there is a mistake in your admin/includes/configure.php file.

Share this post


Link to post
Share on other sites

The period is correct but the ..admin is not. That should be the full path to the files and .. is saying the code is looking for the files above the admin directory,which won't work. So it appears there is a mistake in your admin/includes/configure.php file.

 

Thank you Jack, it was my mistake

Share this post


Link to post
Share on other sites

Hi Jack,

I tried using the filltags for my keywords and I clicked the option to use the product description to source the keywords. Now, the only thing in the keyword box on each product page is the product title.

Shouldn't this pull individual words from the description?

Thanks,

Matt


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites

I tried using the filltags for my keywords and I clicked the option to use the product description to source the keywords. Now, the only thing in the keyword box on each product page is the product title.

Shouldn't this pull individual words from the description?

There's no option to use the products description for the keywords.

Share this post


Link to post
Share on other sites

Then what does this do? Fill keywords for all added pages from derived keywords on actual pages?


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites

Then what does this do? Fill keywords for all added pages from derived keywords on actual pages?

That attempts to create keywords from text on the page. The way I read your first post was that you were using the decription override option. If you mean keywords from the page, then that will only work if there are keywords to use. A lot of page have text that is useless so the code ignores it by comparing against an included list. If you have a large amount of text on the pages, then the option should work. It is not recommended though. A script can't be written that will properly setup keywords from a page since only guesses can be made.

Share this post


Link to post
Share on other sites

Hello Jack,

 

Is this version of Header Tags SEO compatible with OSCommerce v2.3?

 

If not,please point me to the correct version.

 

Thanks.

Share this post


Link to post
Share on other sites

Hello Jack,

 

Is this version of Header Tags SEO compatible with OSCommerce v2.3?

 

If not,please point me to the correct version.

 

Thanks.

Yes.

Share this post


Link to post
Share on other sites

Thanks Jack. I have downloaded the latest version. Do you know of any version of Ultimate SEO Urls that will work with Header Tags and OSC 2.3.1? I've tried one by FWR but couldn't get it going and eventually I had to reinstall OSC. While I'm at it, I'll install your ultimate SEO contribution!

 

Thanks for your continued support.

Share this post


Link to post
Share on other sites

can somebody help me with this please.

 

Cannot find file /home/zlunfcsz/public_html/vanity-flair-uk.com/admin/includes/header_tags_seo_words.txt.

 

this error code shows when i run test. i have read in a previous post that you have to upload it from the contributions. i presume i downloaded the whole file for htseo and i cant find it anywhere.

 

thanks in advanced

Share this post


Link to post
Share on other sites

hi.

 

i found the lost file. but then i was stupid and tried to install a site map addon without backing up. the inevitable happened and i had to get the host to restore my websites. now i have had to re-install header tags seo and i now have a new error. as far as i know the database was not changed or restored in anyway, just the pages.

 

the error code i get in admin now is

 

Warning: call_user_func(header_tags_reset_cache) [function.call-user-func]: First argument is expected to be a valid callback in /home/zlunfcsz/public_html/vanity-flair-uk.com/admin/includes/functions/general.php on line 1277

 

can somebody help with this please.

 

thanks

:(

Share this post


Link to post
Share on other sites

Hello everyone, I installed header tags seo and everything works as it should. I have filled my descriptions, keywords and title. I also installed SEO URLs and the two work very well. Despite all this though my Google reference title and url, but it does not apply the description of each product, it still uses text that is in my index page: this is the result:

 

#

Products Sold - Poemanuia lucky Tahitian Pearl

Poemanuia the Tahitian cultured pearl on Twitter · The flow ... Poemanuia present in this category with all the jewelry and Tahitian pearls that have ...

www.poemanuia.com/produits-vendus-c-56.html?language=fr&page ... -

1301626117

#

Reviews - Poemanuia lucky Pearl of Tahiti

Poemanuia the Tahitian cultured pearl on Twitter · The flow Poemanuia the cultured pearl TAHITI · Blog.poemanuia.com · RSS feed for our blog ...

www.poemanuia.com/collier-cuir-rglable-noire-pr-137.html -

1301626117

#

2 - Poemanuia lucky Pearl of Tahiti

Poemanuia the Tahitian cultured pearl on Twitter · The flow Poemanuia the cultured pearl TAHITI · Blog.poemanuia.com · RSS feed for our blog ...

www.poemanuia.com/jlcc-perles-m-1.html?page=2&currency ... -

1301626117

#

JLCC Beads - Lucky Poemanuia Pearl of Tahiti

Poemanuia the Tahitian cultured pearl on Twitter · The flow Poemanuia the cultured pearl TAHITI · Blog.poemanuia.com · RSS feed for our blog ...

www.poemanuia.com/jlcc-perles-m-1.html?sort=6a&filter_id=53 ... -

1301626117

#

Pendant - Lucky Poemanuia Pearl of Tahiti

Poemanuia the Tahitian cultured pearl on Twitter · The flow ... Poemanuia support team Olympique Marseille, she moved to Fri. ...

www.poemanuia.com/pendentifs-avec-perles-culture-tahiti-c-42.html -

1301626117

#

Pearl Naked - Lucky Poemanuia Pearl of Tahiti

Poemanuia the Tahitian cultured pearl on Twitter · The flow Poemanuia the cultured pearl TAHITI · Blog.poemanuia.com · RSS feed for our blog ...

www.poemanuia.com/perles-culture-nues-c-47.html -

1301626117

#

Ring - Poemanuia lucky Tahitian Pearl

Poemanuia the Tahitian cultured pearl on Twitter · The flow Poemanuia the cultured pearl TAHITI · Blog.poemanuia.com · RSS feed for our blog ...

www.poemanuia.com/bagues-avec-perles-culture-tahiti-c-46.html -

 

you can see the results by typing in google POEMANUIA. Can you tell me what he does not go, it's pretty disturbing and I fear that google penalize me for duplicate

Share this post


Link to post
Share on other sites

i have sorted my problem i read throught the trouble shooting.

Share this post


Link to post
Share on other sites

hi.

 

i found the lost file. but then i was stupid and tried to install a site map addon without backing up. the inevitable happened and i had to get the host to restore my websites. now i have had to re-install header tags seo and i now have a new error. as far as i know the database was not changed or restored in anyway, just the pages.

 

the error code i get in admin now is

 

Warning: call_user_func(header_tags_reset_cache) [function.call-user-func]: First argument is expected to be a valid callback in /home/zlunfcsz/public_html/vanity-flair-uk.com/admin/includes/functions/general.php on line 1277

 

can somebody help with this please.

That usually means you are missing a part of the installation, probably some file wasn't uploaded.

Share this post


Link to post
Share on other sites

Hello everyone, I installed header tags seo and everything works as it should. I have filled my descriptions, keywords and title. I also installed SEO URLs and the two work very well. Despite all this though my Google reference title and url, but it does not apply the description of each product, it still uses text that is in my index page: this is the result:

It is occurring because the title and tags haven't been filled in for French (and maybe others). Try running fill tags and just check French as the language. Or, try switching to French in admin and then run fill tags. Also run the test routine and correct any language errors that show up, if they do. The problem is that the current release doesn't handle language ID's properly when they have been changed, which is most the case here. That has been fixed in the next version but it isn't ready for upload so you will need to work around it with the above methods.

Share this post


Link to post
Share on other sites

Jack thank you for your reply. But all my descriptions, titles, and keywords have all been completed in all languages​​. And when I do the test everything works, the program indicates a yellow color that everything is good. What to do, why google does not read the descriptions when they see the rest?

Share this post


Link to post
Share on other sites

I also just noticed that when I go to my site on a category and that I look at the source code meta tags are not filled

Share this post


Link to post
Share on other sites

After installation I am getting a weird error when click on any Products. The error is

 

1054 - Unknown column 'categories_htc_title_tag' in 'field list'

select categories_htc_title_tag from categories_description where categories_id = '21' and language_id = '1' LIMIT 1

[TEP STOP]

 

Also when going to the Admin section the page is blank.

 

Any help would be greatly appreciated.

 

EDIT TO ADD: Running OSC 2.3.1

Edited by mvanderhoff

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×