Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

It sounds like there was a mistake in the installation. You can try using the categories file supplied with the contribution to see if the box shows up.

 

Jack

 

Jack

 

I went back and made the edits again to admin>categories.php but still no effect.

 

Anything else I might try?

 

Thank

Share this post


Link to post
Share on other sites
Jack

 

I went back and made the edits again to admin>categories.php but still no effect.

 

Anything else I might try?

 

Thank

You can try using the categories file supplied with the contribution to see if the box shows up.

 

Jack

Share this post


Link to post
Share on other sites
You can try using the categories file supplied with the contribution to see if the box shows up.

 

Jack

 

Sorry Jack. I obviously misunderstood.

Can you explain how I use the categories file supplied to see if the box shows up?

Share this post


Link to post
Share on other sites
Sorry Jack. I obviously misunderstood.

Can you explain how I use the categories file supplied to see if the box shows up?

I think Jack suggest you to use the categories.php supplied in the contribution to take place your current categories.php, it might verify your edit.

Share this post


Link to post
Share on other sites
I think Jack suggest you to use the categories.php supplied in the contribution to take place your current categories.php, it might verify your edit.

 

Is that the categories.php in catalog for new shop only MS2>admin>catagories.php?

 

Just so I understand, I should replace my admin/catagories.php with the file above to see what happens?

 

I'm pretty new at this...so forgive my novice questions!

Share this post


Link to post
Share on other sites

I added the categories.php file from the install package for new shops only. Now I have a category description box, which is what I was looking for.

 

Only thing is...all my categories now have the default title info. I want to custom edit each category page.

 

I tried to add the category.php file to the drop down menu on the Heade Tags SEO page by replacing this code:

 

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

 

with this code:

 

<?php

/*** Begin Header Tags SEO ***/

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<title><?php echo TITLE; ?></title>

<?php

}

/*** End Header Tags SEO ***/

?>

 

But it didn't add to the drop down menu. I know it's something very simple but I've gone cross-eyed at this stage - looking at it too closely.

 

Any suggestions?

Share this post


Link to post
Share on other sites
I added the categories.php file from the install package for new shops only. Now I have a category description box, which is what I was looking for.

 

Only thing is...all my categories now have the default title info. I want to custom edit each category page.

 

I tried to add the category.php file to the drop down menu on the Heade Tags SEO page by replacing this code:

I'm not familliar with a category.php file so I don't know what you are trying to do but if you follow the installation directions, it should work for you.

 

Jack

Share this post


Link to post
Share on other sites

Tried installing the htseo contrib, and had major problems. Im using the newest osc version and have modified it a little.

installed meta tags on the fly (which I am trying to replace with htseo) installed article manager 1.5 and category short descriptions.

 

Are there any major conflicts. Once installed my homepage would stop just a little below the store logo. showing the contact us picture but nothing in the blue heading area ex. contact, cart etc

Share this post


Link to post
Share on other sites
Tried installing the htseo contrib, and had major problems. Im using the newest osc version and have modified it a little.

installed meta tags on the fly (which I am trying to replace with htseo) installed article manager 1.5 and category short descriptions.

 

Are there any major conflicts. Once installed my homepage would stop just a little below the store logo. showing the contact us picture but nothing in the blue heading area ex. contact, cart etc

The only conflict would be with meta tags on the fly since they serve the same purpose. When a page stops loading, it is failing on some piece of code or waiting for some link. Where it stops will help determine where the problem is at. Right below the logo most likely means the includes/header.php or includes/column_left.php file. You can temporarily comment out the left column by placing // before the require text. If the page then loads, you know the problem is in something the left column code is loading. If it just starting happening after trying to install this contribution, then I would look at the change to the logo code in header.php and the code to add a box in the column_left file as likely problem areas.

 

Jack

Share this post


Link to post
Share on other sites

Hi, Jack, first of the all, thanks very much for your wonderful contribution.

 

The install looks no problem, and I have try to click for quite a lot, but seem can not get a clear clue to get a better title in product_info.php

 

Qustion 1, say the original title is product name, it is easy to get

1) catalog name + default title on the left of page control + product name

2) new enter title on the right of page control + catalog name + product name

 

so if i want the title looks like " product name + default title on the left of page control + some other word ", how can i set the order?

 

Question 2, about the include on the right and left in page control. I donot get an idea it was included in each field of (Title Description: Keyword(s): Logo Text:) or only one of them. say it is append after or before which filed.

 

Question 3, about the sort order of default title, default description... on the left in page control. the order is relevant with which field, all the items in include table or indicate the position on final title, description?

 

Question 4, you have provided option of using the TinyMCE editor with the description fields, but my current editor is FCKeditor for Product Descriptions, I would like to know which file i can modify it, the modify looks very simple by replacing the textarea by replacing the string "textarea_field" with "fckeditor", I just could not find out where i can use it for "Header Tags Categories Description" box.

 

Thanks very mcuh for your work!

 

best regards,

Share this post


Link to post
Share on other sites

One more questions (5), is it possible i seperate part of Categories Description to the end of pictures of sub-catagories, bexcause some time long introduce is necessary, about 150 words after catogory name before sub-catagory picture would be better than long text block

Share this post


Link to post
Share on other sites
I'm not familliar with a category.php file so I don't know what you are trying to do but if you follow the installation directions, it should work for you.

 

Jack

 

 

Per your suggestion :

 

QUOTE (Jack_mcs @ Jun 16 2008, 04:19 PM)

You can try using the categories file supplied with the contribution to see if the box shows up.

 

Jack

 

I assumed that when you say "the categories file supplied with the contribution" you meant the categories.php file in the catalog for new shop only>admin.

 

I uploaded that file (even though my shop is not brand new) and it seems to have produced the box of "Header Tags Category Description" in Catalog>categories/products.

 

As I said in my previous post, now my problem is that my category pages have the same title, which is the info in the title box under "default tags"

 

How can I prevent the default tags - english from populating all of my category titles?

 

Thanks

Edited by dgriff

Share this post


Link to post
Share on other sites

(Already posted as new topic - sorry for that, but I'm new in this community)

 

Hi,

 

first, when I went to Header Tags SEO in the admin section I received only this error message:

Warning: opendir(/html/) [function.opendir]: failed to open dir: No such file or directory in /home/www/nc1675/html/admin/includes/functions/header_tags.php on line 15

Failed to open dir

 

When I changed in header_tags.php the directory from:

($dir = opendir(DIR_FS_CATALOG))

to:

($dir = opendir(DIR_WS_CATALOG))

the page is shown, but still I get those warnings at the top:

 

Failed to open directory: /html/

Fehler Found Missing Tags:

Products table has 210 items with missing meta tag information.

Fehler Permissions settings for the /html/includes/header_tags.php file appear to be incorrect. Change to 755

 

1. Why the failing to opne the directory?

2. I already changed the permission to 755. Why the warning still appears?

 

I'm looking forward to all helpful answers!!!

Thank you all!

Share this post


Link to post
Share on other sites
Hi, Jack, first of the all, thanks very much for your wonderful contribution.

 

The install looks no problem, and I have try to click for quite a lot, but seem can not get a clear clue to get a better title in product_info.php

 

Qustion 1, say the original title is product name, it is easy to get

1) catalog name + default title on the left of page control + product name

2) new enter title on the right of page control + catalog name + product name

 

so if i want the title looks like " product name + default title on the left of page control + some other word ", how can i set the order?

 

Question 2, about the include on the right and left in page control. I donot get an idea it was included in each field of (Title Description: Keyword(s): Logo Text:) or only one of them. say it is append after or before which filed.

 

Question 3, about the sort order of default title, default description... on the left in page control. the order is relevant with which field, all the items in include table or indicate the position on final title, description?

 

Question 4, you have provided option of using the TinyMCE editor with the description fields, but my current editor is FCKeditor for Product Descriptions, I would like to know which file i can modify it, the modify looks very simple by replacing the textarea by replacing the string "textarea_field" with "fckeditor", I just could not find out where i can use it for "Header Tags Categories Description" box.

 

Thanks very mcuh for your work!

 

best regards,

1 - You can't.

2 - Can't figure out the question.

3 - Can't figure out the question.

4 - admin/categories.php.

 

Jack

Share this post


Link to post
Share on other sites
How can I prevent the default tags - english from populating all of my category titles?
Uncheck the includes default title, description, keyword option for that page.

 

Jack

Share this post


Link to post
Share on other sites
1. Why the failing to opne the directory?

2. I already changed the permission to 755. Why the warning still appears?

 

I'm looking forward to all helpful answers!!!

Thank you all!

1 - Your configure file is not setup properly. You will need to post in the general forum for that problem.

2 - 755 may not be correct. Please read previous posts regarding this.

 

Jack

Share this post


Link to post
Share on other sites
1 - Your configure file is not setup properly. You will need to post in the general forum for that problem.

2 - 755 may not be correct. Please read previous posts regarding this.

 

Jack

 

Thank you, Jack! But are you sure? Before I installed headertags_seo everything was fine and I never got this warning...

Share this post


Link to post
Share on other sites
Thank you, Jack! But are you sure? Before I installed headertags_seo everything was fine and I never got this warning...
Assuming you are referring to the first item, I can't say for a 100%, not having see the problem and the code. However, Header Tags just uses the default settings in the shop. If it is failing because it can't load a file, it means the supplied path is invalid, or something along those lines. And that comes from the configure file.

 

Jack

Edited by Jack_mcs

Share this post


Link to post
Share on other sites
Hi all,

 

Header Tags SEO is working great but my categories and products pages are without title, decryption and keywords in meta tags. Each of my product has own title, keywords and description. I dont know where is the problem. I tried default settings but It didint work as well.

 

My index.php (and contact, about us pages) are working great. They have own title description and keywords.

 

If you can help me could be great.

 

Thanks

Did you run Fill Tags? Check in admin to see that the categories/products have the tags filled in.

 

Jack

 

 

I checked that one more time and my category display title but there is still problem with my products.

 

Maybe that can help find solution. My product pages have only store name (which you can find in Admin>>My Store>>Store Name) instead of title tag. That is very weird.

 

I found it. In my product_info.php I haven't got this:

<?php

/*** Begin Header Tags SEO ***/

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<title><?php echo TITLE; ?></title>

<?php

}

/*** End Header Tags SEO ***/

?>

Now is working, if there should be something different, tell me please.

 

Thanks for all.

Edited by demsey

Share this post


Link to post
Share on other sites

HEADER TAGS ARE NOT WORKING ON INDEX PAGE WITH OR WITHOUT STS ON!!

I just installed the newest version of this contrib and have done nothing but what the installation instructions told me to do. Im seeing the default header tags in all the pages except for the home page index.php (I tried adding them in the admin but nothing shows but the default store name in the tab) I can see them on index.php/cPath/1 etc.. or products.php Was there something I had to do to get it to show up on other pages? has anyone found any error in the new download?

I use the sts system (the tags didnt work with it on or off for the index page) with sts on, the index page is pulled from index.php.html

This is what the instruction had me install on the index page

 

<?php /*** Begin Header Tags SEO ***/ ?>

<td><h1><?php echo $category['categories_htc_title_tag']; ?></h1></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

<?php if (tep_not_null($category['categories_htc_description'])) { ?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td colspan="2"><h2><?php echo $category['categories_htc_description']; ?></h2></td>

</tr>

<?php }

 

when do I fallow these instruction ?

4) In product_info.php

 

FIND (around line 33)

 

<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">

 

ADD UNDER IT:

 

<?php /*** Begin Header Tags SEO ***/ ?>

<a name="<?php echo $header_tags_array['title']; ?>"></a>

<?php /*** End Header Tags SEO ***/ ?>

 

=============================================

FIND (around line 102)

<td class="pageHeading" valign="top"><?php echo $products_name; ?></td>

<td class="pageHeading" align="right" valign="top"><?php echo $products_price; ?></td>

 

REPLACE with

 

<?php /*** Begin Header Tags SEO ***/ ?>

<td valign="top"><h1><?php echo $products_name; ?></h1></td>

<td align="right" valign="top"><h1><?php echo $products_price; ?></h1></td>

<?php /*** End Header Tags SEO ***/ ?>

 

NOTE: In any page in which you make the change to the title for Header Tags,

you should also locate the line containing HEADING_TITLE, remove the

pageHeading class and add the h1 tags as above.

Edited by cms08

Share this post


Link to post
Share on other sites

after installed header tags seo files, everything is working so far untill i clicked the (page control) i get this error

 

1146 - Table 'all0814302384126.TABLE_HEADERTAGS' doesn't exist

 

select * from TABLE_HEADERTAGS

 

[TEP STOP]

 

I can not seem to find where this error is coming from. Any ideas? Thanks in advance!

Share this post


Link to post
Share on other sites
after installed header tags seo files, everything is working so far untill i clicked the (page control) i get this error

 

1146 - Table 'all0814302384126.TABLE_HEADERTAGS' doesn't exist

 

select * from TABLE_HEADERTAGS

 

[TEP STOP]

 

I can not seem to find where this error is coming from. Any ideas? Thanks in advance!

You need to make the changes to the database.php file per the instructions.

 

Jack

Share this post


Link to post
Share on other sites
You need to make the changes to the database.php file per the instructions.

 

Jack

 

I'm having the same issue

1146 - Table 'mydbname.TABLE_HEADERTAGS_DEFAULT' doesn't exist

 

select * from TABLE_HEADERTAGS_DEFAULT where language_id = '1'

 

[TEP STOP]

 

except that it's on all pages that I added this to:

FIND:

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo TITLE; ?></title>

REPLACE with:

<?php
/*** Begin Header Tags SEO ***/
if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {
 require(DIR_WS_INCLUDES . 'header_tags.php');
} else {
?>
 <title><?php echo TITLE; ?></title>
<?php
}
/*** End Header Tags SEO ***/
?>

 

Installing HeaderTags_SEO_V_3.0.4_1_2

 

I don't see any instructions that mention changes to database.php file. I installed the database changes via the headertags_seo_install.php file.

 

Thanks.

Share this post


Link to post
Share on other sites

Ok, I found where some of the changes that need to take place to solve my problem

http://forums.oscommerce.com/index.php?s=&...t&p=1264339

 

I'm putting the instructions here, as I still can't find where this is stated in any instructions

 

change these two files:

catalog/admin/includes/database_tables.php

catalog/includes/database_tables.php

 

Add this code snippet to the bottom:

  /*** Begin Header Tags SEO ***/
 define('TABLE_HEADERTAGS', 'headertags');
 define('TABLE_HEADERTAGS_DEFAULT', 'headertags_default');
 /*** End Header Tags SEO ***/

Share this post


Link to post
Share on other sites

Hey Jack, I was wondering have you can across this little problem...on my index and product info pages in my store it only shows 6 of the social bookmark icons....is there a reason for this??? I have the social bookmark folder in my /images....but I uploaded the whole folder... I did not upload the images individually...could this be why?? although I dont see how it could be....

 

 

Thanks in advance....

 

 

 

Gloria


Gloria

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×