Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

How do i edit the code to search for the includes/header_tags.php file? Do you mean search for the includes/header.php file? I'm not after a blow by blow explanation if it's long winded, if you could just point us in the right direction to get me started that would be great.

I'm sorry but I don't offer support for such changes.

Share this post


Link to post
Share on other sites

I'm sorry but I don't offer support for such changes.

 

Fair enough I just don't understand if it works for BTS it should work with the way i have it. It's essentially the same setup but done in a simplier way. How does it work as standard currently with BTS? How does it know the header tags code is there even when it's not in any of the root files? I can't find any reference to BTS or main_Page.tpl only some mention of STS. Could you at least give me a filename or function name where it does the search as standard please? Cheers.

Edited by annuity100

Share this post


Link to post
Share on other sites

Hi Jack,

 

Just wanted to say thanks for this contribution. I've been trying this out for a few days with the all the different options you have available with it.

 

One feature that I ended up botching into the code myself (in admin/header_tags_fill_tags.php) is for products to include their 'products_model' in the header tags.

 

The industry this site is for is heavy on searching by part numbers or item numbers, and I wanted to have it displayed in the title tag for each product that may return in search results.

 

I was just curious if you had considered this feature before, or may possibly add it in the future. Mine is currently functional with my settings, but I've not tested it under all conditions and don't have any options for it in the admin pages.

Share this post


Link to post
Share on other sites

One feature that I ended up botching into the code myself (in admin/header_tags_fill_tags.php) is for products to include their 'products_model' in the header tags.

 

The industry this site is for is heavy on searching by part numbers or item numbers, and I wanted to have it displayed in the title tag for each product that may return in search results.

 

I was just curious if you had considered this feature before, or may possibly add it in the future. Mine is currently functional with my settings, but I've not tested it under all conditions and don't have any options for it in the admin pages.

Yes, it has been asked for quite a few times and is already in the next version.

Share this post


Link to post
Share on other sites

Fair enough I just don't understand if it works for BTS it should work with the way i have it. It's essentially the same setup but done in a simplier way. How does it work as standard currently with BTS? How does it know the header tags code is there even when it's not in any of the root files? I can't find any reference to BTS or main_Page.tpl only some mention of STS. Could you at least give me a filename or function name where it does the search as standard please? Cheers.

 

Right i can't work out how to fix this issue and if the guy that wrote the thing won't help i have no choice. What ive done is to move the bit of the <head> tag from doctype to the end of the header tags code, so only a few lines, out of the includes/header.php file and put it back into all the root files, so everythings working now 100% except for the double // on the homepage canonical issue and the root files aren't as clean as i wanted them to be but it's no big deal as the doctype, html params and header tags code shouldn't need changing very often if at all and ive adjusted my blank page template as well so shouldn't be any problems in the future. Look forward to the next version coming out and it'll also give me chance to see if the version checker is working.

Share this post


Link to post
Share on other sites

Hello Jack

 

I am in process to install Header Tags SEO, but I am stock in file changes. I follow all the steps but this one I can't understand it.

Regarding: ******** NOTE: STS USERS ONLY - Skip to step 1A. *********

******** NOTE: BTS USERS ONLY - Skip to step 1B. *********

Your shop is an STS shop if there is an includes/sts_templates/ directory.

Your shop is a BTS shop if there is a templates directory in the root directory.

 

I am not able to know if I have STS or BTS, please help me with that.

 

Thank you

Sam

 

Yes, it has been asked for quite a few times and is already in the next version.

Share this post


Link to post
Share on other sites

Hi Jack,

 

I got everything to work thus far. Read all the docs that I could read too.

 

I did the following to the file product_reviews.php:

FIND:

 

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

 

REPLACE with the following then continue with Step 2:

 

<?php

/*** Begin Header Tags SEO ***/

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

<?php

}

/*** End Header Tags SEO ***/

 

The index.php and product_info.php pages are working fine. But the product_reviews.php meta is not updated.

 

This is from the test of the poduct_reviews.php file:

 

Title and Meta Tag results for product_reviews.php explain

English

From Site:

Title ->

Meta Description ->

Meta Keywords ->

From Settings:

Title -> Asset Protection Book Reviews, Testimonials

Meta Description -> Asset protection book reviews & testimonials.

Meta Keywords -> asset protection book

Results of scan:

product_reviews.php is missing Header Tags code or it is not installed correctly. Verify that Fill Tags has been ran and that the root checkbox or the default checkboxes have been checked in Page Control.

 

The snapshot of the test for product_reviews.php is here:

http://tutorialref.com/images/oscommerce-header-tags-seo-test-product_reviews.png

 

I ran the fill tags and selected Fill only empty tags for Categories, Manufacturers, and Products. I also checked the root checkbox and the default checkboxes are checked. Here's a snapshot of my settings:

http://tutorialref.c...uct_reviews.png

 

The site is:

http://asset-protect...com/reviews.php

Edited by vkimura

16"For God so loved the world, that he gave his only Son, that whoever believes in him should not perish but have eternal life. 17For God did not send his Son into the world to condemn the world, but in order that the world might be saved through him.-John 3:16-17

Share this post


Link to post
Share on other sites

I am in process to install Header Tags SEO, but I am stock in file changes. I follow all the steps but this one I can't understand it.

Regarding: ******** NOTE: STS USERS ONLY - Skip to step 1A. *********

******** NOTE: BTS USERS ONLY - Skip to step 1B. *********

Your shop is an STS shop if there is an includes/sts_templates/ directory.

Your shop is a BTS shop if there is a templates directory in the root directory.

 

I am not able to know if I have STS or BTS, please help me with that.

Is there a directory named sts_templates in the includes directory?

 

Is there a directory named templates in the root directory (where your index.php file is located)?

Share this post


Link to post
Share on other sites

The index.php and product_info.php pages are working fine. But the product_reviews.php meta is not updated.

 

Results of scan:

product_reviews.php is missing Header Tags code or it is not installed correctly. Verify that Fill Tags has been ran and that the root checkbox or the default checkboxes have been checked in Page Control.

The error is saying you didn't make the <head> section change to the product_reviews.php file. You also need to be sure to setup that page correctly in Page Control.

Share this post


Link to post
Share on other sites

Hello Jack

 

I just download osCommerce Online Merchant v2.2 RC2a, and I am not able to found the files. I really don't know why did I miss something or this contribution is not working with my oscommerce version.

 

Also I have a error message since this today:

1146 - Table 'sam71_sunglasses.TABLE_HEADERTAGS_DEFAULT' doesn't exist

select * from TABLE_HEADERTAGS_DEFAULT where language_id = '1'

[TEP STOP]

 

It'S under links on my home page: http://www.sunglasseshubs.com/links.php.

 

Also under Header Tags SEO on configuration, I have a warning message:

Warning: call_user_func(header_tags_reset_cache) [function.call-user-func]: First argument is expected to be a valid callback in /home/sam71/public_html/sunglasseshubs.com/admin/includes/functions/general.php on line 1195

 

Please let me know what should I do.

 

Thank you

Sam

 

 

Is there a directory named sts_templates in the includes directory?

 

Is there a directory named templates in the root directory (where your index.php file is located)?

Share this post


Link to post
Share on other sites

I just download osCommerce Online Merchant v2.2 RC2a, and I am not able to found the files. I really don't know why did I miss something or this contribution is not working with my oscommerce version.

 

Also I have a error message since this today:

1146 - Table 'sam71_sunglasses.TABLE_HEADERTAGS_DEFAULT' doesn't exist

select * from TABLE_HEADERTAGS_DEFAULT where language_id = '1'

You don't mention what files you can't find so I can't help with that. But the error you are getting means you didn't make the required file changes.See theinstall files for this contribution.

Share this post


Link to post
Share on other sites

I am not able to find sts_templates and any other templates files in my directory.

 

You don't mention what files you can't find so I can't help with that. But the error you are getting means you didn't make the required file changes.See theinstall files for this contribution.

Share this post


Link to post
Share on other sites

I am not able to find sts_templates and any other templates files in my directory.

Then you probably don't have STS installed. It is not required. The instructions are different though if you do have it installed. If you don't, then don't try to install for it.

Share this post


Link to post
Share on other sites

If I don't have what should I do, uninstall it or continue the installation. If I continue what is the next steps should I do please help me.

 

Then you probably don't have STS installed. It is not required. The instructions are different though if you do have it installed. If you don't, then don't try to install for it.

Share this post


Link to post
Share on other sites

If I don't have what should I do, uninstall it or continue the installation. If I continue what is the next steps should I do please help me.

If you want it installed, you continue. If you don't want it installed, then remove whatever changes you want.

 

The instructions state

******** NOTE: STS USERS ONLY - Skip to step 1A. *********
That says, if you have STS installed then skip to step 1A. The implication is that if you do not have it installed, then continue.

 

I mean no offense but this is the easy part of the installation. If you are getting lost on these instructions I don't know that you will be able to make through the rest. In the least, you should make sure you have backups of eveything in case mistakes are made.

Share this post


Link to post
Share on other sites

A new version has been uploaded containing these changes:

 

-> Added requirement note that Search Engine Friendly setting must be off

-> Added social bookmark icon for stumbleupon

-> Added option to include the model number in product pages title and tags

-> Added code to prevent slashes from being added when using the generic override option in Fill Tags

-> Added a language option to Fill Tags*

-> Changed canonical code so duplicate slashes are removed for the home page

-> Fixed includes/functions/header_tags.php so that the manufacturers name are shown on the product page if the option is set

-> Fixed code in Fill Tags that prevented the description and/or keywords from being filled with the Fill Empty option

-> Fixed coding mistakes in Fill Tags that prevented cache from being cleared

-> Fixed problem with FCKEditor not working with categories description (a workaround)**

-> Made various, minor, appearance changes

-> Removed troubleshooting statement from admin/header_tags_seo.php

 

* This is a quick and dirty way of handling the languages. It works fine but isn't how it should be coded. But due to time constraints, it will have to do.

** There is something in the FCKEditor code that kicks it out of the table its code is in. Instead of tracing through that, again due to time constraints, I added the code directly for it. This won't be a problem unless, maybe, someone uses special settings for the editor, which is unlikely, I think.

Share this post


Link to post
Share on other sites

The error is saying you didn't make the <head> section change to the product_reviews.php file. You also need to be sure to setup that page correctly in Page Control.

 

Hi Jack,

 

I have this bit of code in my 'product_reviews.php' file:

<head>
<?php
/*** Begin Header Tags SEO ***/
if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {
require(DIR_WS_INCLUDES . 'header_tags.php');
} else {
?>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo TITLE; ?></title>
<?php
}
/*** End Header Tags SEO ***/
?>

 

Here is a snapshot of the my product_reviews.php file settings from the Page Control:

http://tutorialref.c...ws_settings.png

 

Anythings else I need to do?

 

Much thanks,

Victor

Edited by vkimura

16"For God so loved the world, that he gave his only Son, that whoever believes in him should not perish but have eternal life. 17For God did not send his Son into the world to condemn the world, but in order that the world might be saved through him.-John 3:16-17

Share this post


Link to post
Share on other sites

I have this bit of code in my 'product_reviews.php' file:

 

Anythings else I need to do?

Visit the product_reviews.php in a browser and it redirects to reviews.php. Use the browsers view source option and you will see the Header Tags code is not installed.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

A new version has been uploaded containing these changes:

 

-> Added requirement note that Search Engine Friendly setting must be off

-> Added social bookmark icon for stumbleupon

-> Added option to include the model number in product pages title and tags

-> Added code to prevent slashes from being added when using the generic override option in Fill Tags

-> Added a language option to Fill Tags*

-> Changed canonical code so duplicate slashes are removed for the home page

-> Fixed includes/functions/header_tags.php so that the manufacturers name are shown on the product page if the option is set

-> Fixed code in Fill Tags that prevented the description and/or keywords from being filled with the Fill Empty option

-> Fixed coding mistakes in Fill Tags that prevented cache from being cleared

-> Fixed problem with FCKEditor not working with categories description (a workaround)**

-> Made various, minor, appearance changes

-> Removed troubleshooting statement from admin/header_tags_seo.php

 

* This is a quick and dirty way of handling the languages. It works fine but isn't how it should be coded. But due to time constraints, it will have to do.

** There is something in the FCKEditor code that kicks it out of the table its code is in. Instead of tracing through that, again due to time constraints, I added the code directly for it. This won't be a problem unless, maybe, someone uses special settings for the editor, which is unlikely, I think.

 

 

Hi Jack, No new version uploaded....

Share this post


Link to post
Share on other sites

Hi Jack, No new version uploaded....

It was uploaded but isn't immediately visible due to its size. It should be OK'ed after 24 hours but the weekend may slow that down. If it is not there by tomorrow, it might be necessary to contact a moderator.

Share this post


Link to post
Share on other sites

Hi,

 

i have found a error in my source-code caused by header tags seo:

  ADD ABOVE it:

     <?php /*** Begin Header Tags SEO ***/ ?>
     <tr>
      <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
     </tr>
     <tr>
      <td class="smallText" align="center"><?php echo TEXT_VIEWING; ?> 
      <?php echo '<a title="' . $header_tags_array['title'] . '" href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL') . '"/# ' . $header_tags_array['title'] . '">' . $header_tags_array['title']; ?></a></td>
     </tr>
     <?php /*** End Header Tags SEO ***/ ?>

 

in this step the part:

 

. '"/# ' . $header_tags_array['title'] . '">

 

is not clear to me. It causes a source like this:

 

<a title="here goes the title" href="link goes here"/# here goes the title">here goes the title</a></td>

 

what is the /# good for?

 

greetz

Share this post


Link to post
Share on other sites

what is the /# good for?

It's called an anchor link and it creates a link to somewhere on the same page. It's purpose is to provide another link to the product, which google counts towards PR.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Hello Jack

 

I installed Header Tags SEO, and I have this message, I don't understand why?

 

1146 - Table 'sam71_sunglasses.TABLE_HEADERTAGS_CACHE' doesn't exist

 

select * from TABLE_HEADERTAGS_CACHE where title =

 

'K7YytrRSykhNTEktii9JTC+Oz8xLSa3QK8goiE/NS8/JLM6IT05MzkiNz0yJV7IGAA==' limit 1

 

[TEP STOP]

 

 

Thanks

Sam

Share this post


Link to post
Share on other sites

I installed Header Tags SEO, and I have this message, I don't understand why?

 

1146 - Table 'sam71_sunglasses.TABLE_HEADERTAGS_CACHE' doesn't exist

 

select * from TABLE_HEADERTAGS_CACHE where title =

 

'K7YytrRSykhNTEktii9JTC+Oz8xLSa3QK8goiE/NS8/JLM6IT05MzkiNz0yJV7IGAA==' limit 1

It means you missed a step in the installation. Search the install files for define('TABLE_HEADERTAGS_CACHE' and you will find the mistake.

Share this post


Link to post
Share on other sites

Hi,

 

I have installed Header Tag SEO, it seems to work fine, but I can't change the title of some page "Replace me in Page Control under index.php".

 

In admin panel > Header Tag SEO > Page control, the dropdown menu "Select an option" is almost empty, there are only 3 items ("Select a file", "Show All Files" and "Add Missing Pages"), so I can't change title and description of index.php for example.

 

How can I fix this ?

 

In the database ("headertags" table), there is a row for each following page : index.php, product_info.php, product_reviews.php, product_reviews_info.php, product_reviews_write.php and specials.php, with language_id = 4 (the language_id of the store)

 

When I try the test page, I got at the bottom of the page :

languages in the Header Tags table are: 2 ( Deutsch ).

languages in the Header Tags table are: 3 ( Español ).

languages in the Header Tags table are: 1 ( English ).

 

There is no language 4 (French), I don't what it means...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×