Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Hi Jack,

 

I am doing some seo work, and noticed the following issue with my titkes.

 

Title:- Category-sub category -- product name

Description:- Category-sub category -- product description

 

the double - bewteen category and description.

 

I doubt this is realated to my other issue with ultimate SEO but thought I would mention it here just in case.

 

Add category parent to product URLs? doesnt work, the category one does work.

 

I am guessing that somewher in the code I can ressolve these two issues, just need to know where to look for it.

 

Thanks


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

I would like to remove from meta description the product category. It's possible?

I don't understand the question but you can try unchecking the checkboxes in page control for whatever page you are talking about.

Share this post


Link to post
Share on other sites

I am doing some seo work, and noticed the following issue with my titkes.

 

Title:- Category-sub category -- product name

Description:- Category-sub category -- product description

 

the double - bewteen category and description.

It means, as mentione recently in this thread, that you are telling the code to insert some item in those strings but you have not filled that item. You can read back through the forum for more details if that isn't clear.

Share this post


Link to post
Share on other sites

I don't understand the question but you can try unchecking the checkboxes in page control for whatever page you are talking about.

Hi Jack_ms, thanks for your answer.

 

If unchek the category checbox in page control for product_info.php it modify <title> and <meta name="Description">

 

I would like to remove category product from <meta name"Description">, by default it shows like this:

 

<tile>"category product" - "product name"</title>

<meta name"Description" content="category product" - "product description">

 

I would like to...

 

<tile>"category product" - "product name"</title>

<meta name"Description" content="product description">

 

would be possible?

 

Sorry for my poor english

Thanks for all :)

Share this post


Link to post
Share on other sites

It means, as mentione recently in this thread, that you are telling the code to insert some item in those strings but you have not filled that item. You can read back through the forum for more details if that isn't clear.

 

 

I'll try again to find it, but what should be going between the -- when the category and prodct name etc are all I went to add.


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

I would like to remove category product from <meta name"Description">, by default it shows like this:

I don't know what "category product" refers to. There are categories and there are products but there are not category products.

Share this post


Link to post
Share on other sites

I'll try again to find it, but what should be going between the -- when the category and prodct name etc are all I went to add.

It depends on what you told it to include.

Share this post


Link to post
Share on other sites

I don't know what "category product" refers to. There are categories and there are products but there are not category products.

You're right sorry, I want to say "category" - "product name".

 

Is possible to show only the product description (without category) in meta description?

 

Thanks!!

Share this post


Link to post
Share on other sites

Is possible to show only the product description (without category) in meta description?

You can uncheck the category box in page control but that will remove it from the title, meta description and meta keywords tags. You can't just remove it from the meta description, unless you edit the code, of course.

Share this post


Link to post
Share on other sites

It depends on what you told it to include.

 

As far as i can tell, just the full category path and product name/ title

 

 

what goes in the cat-subcat -- product name/title I dont know

Edited by johnnybebad

Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

I'm also having the same issue with the canonical tags showing up with double slashes on the end. Have there been any updates for this yet?

Share this post


Link to post
Share on other sites

You can uncheck the category box in page control but that will remove it from the title, meta description and meta keywords tags. You can't just remove it from the meta description, unless you edit the code, of course.

I'll try to do it.

 

I think that the file that I need to edit is catalog/includes/functions/header_tags.php, but... can you tell me the line where I must look, please?

 

Thanks!!

Share this post


Link to post
Share on other sites

As far as i can tell, just the full category path and product name/ title

 

 

what goes in the cat-subcat -- product name/title I dont know

Whatever you have set for the index.php in page control. Maybe you didn't run fill tags?

Share this post


Link to post
Share on other sites

I'm also having the same issue with the canonical tags showing up with double slashes on the end. Have there been any updates for this yet?

This has been fixed, I think, in the next version. I had hoped to have it uploaded this last weekend but decided to make a last addition so it may not be for another week or two.

Share this post


Link to post
Share on other sites

I think that the file that I need to edit is catalog/includes/functions/header_tags.php, but... can you tell me the line where I must look, please?

Yes, that is the file. I don't know the location off of the top of my head but you can search for "description" to find that specific code.

Share this post


Link to post
Share on other sites

Yes, that is the file. I don't know the location off of the top of my head but you can search for "description" to find that specific code.

Ok, I'll try it.

 

Thanks!!! :)

Share this post


Link to post
Share on other sites

Whatever you have set for the index.php in page control. Maybe you didn't run fill tags?

 

Okay got it...lol well think I have.

 

I needed to set product_info to cat, products and set there order, then make sure evrything else was unchecked, the box that was checked was root.

 

and this lead to the --

 

powerful tool but takes some getting use to.

 

 

Okay the next question is how do i get the dull category path in the product title but not the description and keywords sections?

 

 

Thanks

Edited by johnnybebad

Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Okay the next question is how do i get the dull category path in the product title but not the description and keywords sections?

The correct way to SEO a page is to have the title and tags contain the same keywords so the code doesn't allow for changing that. You will have to edit the code if you want it to work differently, as just recently stated.

Share this post


Link to post
Share on other sites

Hello,

 

Here is a question. I installed the latest HeaderTags_SEO_V_3.2.2. All is OK. But I got this error message when I access the specials.php in Deutsch or in Spanish:

 

Warning: implode(): Bad arguments. in /home/content/x/x/x/xxxxxxx/html/includes/functions/header_tags.php on line 63

Warning: implode(): Bad arguments. in /home/content/x/x/x/xxxxxxx/html/includes/functions/header_tags.php on line 64

Warning: implode(): Bad arguments. in /home/content/x/x/x/xxxxxxx/html/includes/functions/header_tags.php on line 66

 

Anyhow, all English pages are OK.

I also saw this problems in many other osC stores. How should I resolve this problem?

Thanks very much:)

Share this post


Link to post
Share on other sites

Hello,

 

Here is a question. I installed the latest HeaderTags_SEO_V_3.2.2. All is OK. But I got this error message when I access the specials.php in Deutsch or in Spanish:

 

Warning: implode(): Bad arguments. in /home/content/x/x/x/xxxxxxx/html/includes/functions/header_tags.php on line 63

Warning: implode(): Bad arguments. in /home/content/x/x/x/xxxxxxx/html/includes/functions/header_tags.php on line 64

Warning: implode(): Bad arguments. in /home/content/x/x/x/xxxxxxx/html/includes/functions/header_tags.php on line 66

 

Anyhow, all English pages are OK.

I also saw this problems in many other osC stores. How should I resolve this problem?

Thanks very much:)

It means you have all of the checkboxes for the specials page and all of the default checkboxes turned off in page control.

Share this post


Link to post
Share on other sites

It means you have all of the checkboxes for the specials page and all of the default checkboxes turned off in page control.

 

Hi Jack, thanks for your super fast reply. It's OK now:)

Share this post


Link to post
Share on other sites

hi Jack

i have problem with Simple multi image add-on

stop working after install seo :D i will check again but look like they dont work togheter :D seo work now ok

thats is copy of one line were is code of simple and seo

<head>
<!-- Simple multi image addon -->
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
<!-- EOF Simple multi image addon	 -->
<?php
/*** Begin Header Tags SEO ***/
if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {
 require(DIR_WS_INCLUDES . 'header_tags.php');
} else {
?>
 <meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
 <title><?php echo TITLE; ?></title>
<?php
}
/*** End Header Tags SEO ***/
?> 

can that be a problem?

some codes go into each other

 

 

 

 $pInfo = new objectInfo($parameters); $products_image_array = array();
// EOF Simple multi image addon

   /*** Begin Header Tags SEO ***/
  if (isset ($HTTP_GET_VARS['pID']) && (!$HTTP_POST_VARS) ) {
// Simple multi image addon
     $product_query = tep_db_query("select pd.products_name, pd.products_description, pd.products_head_title_tag, pd.products_head_desc_tag, pd.products_head_keywords_tag, pd.products_url, p.products_id, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, date_format(p.products_date_available, '%Y-%m-%d') as products_date_available, p.products_status, p.products_tax_class_id, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "'");
     $product = tep_db_fetch_array($product_query);                            
  /*** End Header Tags SEO ***/
$products_image_array = unserialize($product['products_image_array']);
   if (!is_array($products_image_array)) $products_image_array = array();
// EOF Simple multi image addon			

 

some ideas?

I will check again maybe I but something wrong

Share this post


Link to post
Share on other sites

A new version has been uploaded with the following changes:

 

-> Added cache option

-> Added missing code for pseudo pages in admin

-> Added missing type cast for $languages_id and moved meta tag in includes/header_tags.php (found by member RusNN)

-> Added missing code for canonical tag in the test function

-> Added code to display invalid page messages with the message stack instead of at the top of the page

-> Added option in test section to dynamically check a page to see if it is working

-> Added option in test section to check for invalid filenames

-> Added option in test section to check for missing pseudo entries

-> Changed code in admin/includes/functions/header_tags.php to prevent conflicts with other contributions

-> Changed code in admin/includes/functions/header_tags.php to cast int so it works with php 5.3

-> Changed code in test function so errors for duplicate titles and tags link to the product

-> Changed code in test function to better display language errors

-> Changed code in fill tags so errors for missing values link to the category, manufacturer or product

-> Changed HTML Editor option so one of the three most popular editors can be selected

-> Changed code in includes/functions/header_tags.php to prevent implode error when tags are empty

-> Fixed coding mistake in includes/boxes/header_tags.php

-> Fixed coding mistake where the canonical meta setting wasn't handled correctly

-> Fixed canonical code so that meta tag works correctly

-> Fixed coding mistake in test function that failed to show items with missing names, titles or tags

-> Fixed mistakes in the install and uninstall database files

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×