Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Now I have another question. Is it possible to add data from "extra field" to title and keywords?

I have got extra field products_writer in products table and I would like to append its content to title and keywords? Which files should be modified and which parts of them?

I'm not familiar with that contribution but, for any, there isn't a built-in way to handle that. You would have to edit the code. The title and tags are built in includes/header_tags.php. You can look there to start.

Share this post


Link to post
Share on other sites

When I put that in the said position it put all of my right column underneath the centre main picture for some reason?

 

Hi Nick. I got the same trouble. How did you fix it? Thanks.

Share this post


Link to post
Share on other sites

For some reason the first letter of the title is being cut off in the browser. I checked the length of the title and it's 63 characters. Has anyone else had this problem? I tried searching but didn't find anything.

Share this post


Link to post
Share on other sites

I forgot to mention that I received this error when importing the database tables. I had an earlier version of this installed previously and ran the uninstall. This is the only error however, and since the table is in the database I don't think it should be causing the issue.

 

Error

 

SQL query:

 

ALTER TABLE products_description ADD products_head_title_tag VARCHAR( 80 ) NULL ;

 

MySQL said: Documentation

#1060 - Duplicate column name 'products_head_title_tag'

Edited by christianbright

Share this post


Link to post
Share on other sites

I forgot to mention that I received this error when importing the database tables. I had an earlier version of this installed previously and ran the uninstall. This is the only error however, and since the table is in the database I don't think it should be causing the issue.

 

ALTER TABLE products_description ADD products_head_title_tag VARCHAR( 80 ) NULL ;

 

MySQL said: Documentation

#1060 - Duplicate column name 'products_head_title_tag'

You shouldn't see such an error if the uninstall is ran since that removes everything related to Header Tags from the database and that error is saying there is Header Tags entries in the database. You might want to try running it again and then running the headertags_seo_install.php file.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Second time was the charm. The error the first time must have been caused by my connection I guess. Forgive me asking, but which code is absolutely necessary for the proper function of this module? I have inserted the title code into index.php and product_info.php. Most additions look unnecessary to me, like social bookmarking, echo heading_title, etc. I'm not being lazy either, I have a template so pretty much nothing matches up with your instructions and I was picking and choosing what looked crucial to the operation. I will only be using this module for title tags and nothing more.

 

Maybe I am not understanding the use entirely, but the fill tags is what should be used for category and product titles...Is there an option to create custom title tags for categories? From reading the instructions it seems only the text replaced in ITEMNAME will show in the title. I need completely unique tags. Even though I don't have canonical tags checked either they are being inserted into pages.

Edited by christianbright

Share this post


Link to post
Share on other sites

When log in OSCommerce Admin/ Page Control, I got the message as below.

error.gifPermissions settings for the /includes/header_tags.php file appear to be incorrect. Change to 755. NOTE: Disregard if on Windows server.

error.gif Missing sort orders are not allowed -> product_info.php

How can I fix that please? Thanks.

Share this post


Link to post
Share on other sites

When log in OSCommerce Admin/ Page Control, I got the message as below.

error.gifPermissions settings for the /includes/header_tags.php file appear to be incorrect. Change to 755. NOTE: Disregard if on Windows server.

error.gif Missing sort orders are not allowed -> product_info.php

How can I fix that please? Thanks.

 

Be sure that your host uses an Apache server. Most do. I would suggest using cPanel to change file permissions. If you have this, use the file manager and navigate to includes, right click on header_tags.php and change permissions. Set it to 755. This will fix your first error. The second error I am not exactly sure of. Hope this helps a little!

Share this post


Link to post
Share on other sites

Second time was the charm. The error the first time must have been caused by my connection I guess. Forgive me asking, but which code is absolutely necessary for the proper function of this module? I have inserted the title code into index.php and product_info.php. Most additions look unnecessary to me, like social bookmarking, echo heading_title, etc. I'm not being lazy either, I have a template so pretty much nothing matches up with your instructions and I was picking and choosing what looked crucial to the operation. I will only be using this module for title tags and nothing more.

 

Maybe I am not understanding the use entirely, but the fill tags is what should be used for category and product titles...Is there an option to create custom title tags for categories? From reading the instructions it seems only the text replaced in ITEMNAME will show in the title. I need completely unique tags. Even though I don't have canonical tags checked either they are being inserted into pages.

This contribution, unlike all of the other meta tags contributions, is much more about SEO'ing a site than just providing a way to add meta tags. All of those little things add to that. You don't have to have them but it is recommended for best results.

 

You can edit the category, manufacturer and product titles and tags in each of those sections in admin->Catalog. Fill Tags just provides a way to quickly fill in all of them at one time.

Share this post


Link to post
Share on other sites

When log in OSCommerce Admin/ Page Control, I got the message as below.

error.gifPermissions settings for the /includes/header_tags.php file appear to be incorrect. Change to 755. NOTE: Disregard if on Windows server.

error.gif Missing sort orders are not allowed -> product_info.php

How can I fix that please? Thanks.

As Christian mentioned, you need to change the permissions to fix the first, though a Linux server is not required. If you can't figure out how to do it, your host should be able to help with that. For the other, when you are in Page Control and you select a checkbox, you have to put a number in the box next to it, which is the sort order for that item. The error is saying you didn't do that.

Share this post


Link to post
Share on other sites

Hi

 

Just installed locally and all seems OK. Just a quick question tho.

 

The first is my store logo. The Alt for the image is fine on info pages but changes to the product name when viewing a product. I read a post from Sept 2009 and the answer mentioned keyword density (I think) but just want to check if that's right or if I've missed something.

 

 

Cheers

 

Ian

Edit: Solved!! You struggle for hours and as soon as you post, the lighbulb lights up. In admin, I had the "include product name" ticked for the pages. Un-ticked and it now works.

 

Cheers

 

Ian

Edited by ianric

Share this post


Link to post
Share on other sites

How to make this:

 

When adding new product and after filling products description I would like to take the "product description" and automatically cut it to (for example) 150 characters and the result put into "products header description" (only if it is empty - it means only when adding new product, not when editing it).

 

I know I can use the Fill Tags - but I dont want to use it each time I will add new product.

 

How to modify the admin/categories.php to do this?

Share this post


Link to post
Share on other sites

How to make this:

 

When adding new product and after filling products description I would like to take the "product description" and automatically cut it to (for example) 150 characters and the result put into "products header description" (only if it is empty - it means only when adding new product, not when editing it).

 

I know I can use the Fill Tags - but I dont want to use it each time I will add new product.

 

How to modify the admin/categories.php to do this?

The code could be changed to automatically do that but if you are adding the product anyway, it is easier to just copy and paste into the header tags box, which is on the same page.

Share this post


Link to post
Share on other sites

Dear Jack

HI

 

I am facing difficulty after embed the contribution of os commerce. I downloaded the three contribution.

 

1- http://addons.oscommerce.com/info/1263 Basic Template structure

2- http://addons.oscommerce.com/info/2823 Ultimate SEO urls

3- http://addons.oscommerce.com/info/5851 Header Tags

 

i did embed successfully first two contribution, when i tried to embed 3rd one, then i could not find the code in catalog/index.php as per instruction in given contribution helf file. The reason was this when i uploaded the all catalog folder for contribution of (1-BTS) as per given instruction, this contribution changed the files and code as well.

 

Thats why i could not find the code for 3rd contribution. Please guide me what to do that i can embed all contribution as per my requirement easily.

 

Your help will be highly appriciable for me.

 

I m very much upset about it to resolve this issue, please please please guide for what to do.

Share this post


Link to post
Share on other sites

Dear Jack

HI

 

I am facing difficulty after embed the contribution of os commerce. I downloaded the three contribution.

 

1- http://addons.oscommerce.com/info/1263 Basic Template structure

2- http://addons.oscommerce.com/info/2823 Ultimate SEO urls

3- http://addons.oscommerce.com/info/5851 Header Tags

 

i did embed successfully first two contribution, when i tried to embed 3rd one, then i could not find the code in catalog/index.php as per instruction in given contribution helf file. The reason was this when i uploaded the all catalog folder for contribution of (1-BTS) as per given instruction, this contribution changed the files and code as well.

 

Thats why i could not find the code for 3rd contribution. Please guide me what to do that i can embed all contribution as per my requirement easily.

 

Your help will be highly appriciable for me.

 

I m very much upset about it to resolve this issue, please please please guide for what to do.

Share this post


Link to post
Share on other sites

Thats why i could not find the code for 3rd contribution. Please guide me what to do that i can embed all contribution as per my requirement easily.

Intructions for installing into a BTS shop are already included.

Share this post


Link to post
Share on other sites

Be sure that your host uses an Apache server. Most do. I would suggest using cPanel to change file permissions. If you have this, use the file manager and navigate to includes, right click on header_tags.php and change permissions. Set it to 755. This will fix your first error. The second error I am not exactly sure of. Hope this helps a little!

 

Thanks Chirs.

Share this post


Link to post
Share on other sites

As Christian mentioned, you need to change the permissions to fix the first, though a Linux server is not required. If you can't figure out how to do it, your host should be able to help with that. For the other, when you are in Page Control and you select a checkbox, you have to put a number in the box next to it, which is the sort order for that item. The error is saying you didn't do that.

 

Thanks Jack. fixed.

Share this post


Link to post
Share on other sites

Hi, Jack,

 

I have installed this many a times and never ran across any errors before, but however I have this error just after the catalog installation.

 

Fatal error: Call to a member function add_current_page() on a non-object in /home/public_html/includes/application_top.php on line 319

 

Ill proceed with the admin install and run the test, however like I said Ive never seen this after the catalog install,

 

Thanks


Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites

Fatal error: Call to a member function add_current_page() on a non-object in /home/public_html/includes/application_top.php on line 319

See here.

Share this post


Link to post
Share on other sites

Sorry I had found the answer

This is why I got the error Somehow seems the navigation parameter remains registered so the class is not instantiated.

 

So

I changed this in application top

 

// navigation history

if (tep_session_is_registered('navigation')) {

if (PHP_VERSION < 4) {

$broken_navigation = $navigation;

$navigation = new navigationHistory;

$navigation->unserialize($broken_navigation);

}

} else {

tep_session_register('navigation');

$navigation = new navigationHistory;

}

$navigation->add_current_page();

 

 

Replace it with this

CODE

// navigation history

if (tep_session_is_registered('navigation')) {

if (PHP_VERSION < 4) {

$broken_navigation = $navigation;

$navigation = new navigationHistory;

$navigation->unserialize($broken_navigation);

} else {

$navigation = new navigationHistory;

}

} else {

tep_session_register('navigation');

$navigation = new navigationHistory;

}

$navigation->add_current_page();

 

For whatever reason it works fine now

 

Thanks

Edited by matrix2223

Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites

Hi,

my oscommerce version is 2.2RC1 so which catalogue folder i should use?

The one for RC2.

Share this post


Link to post
Share on other sites

Hi!!!

 

I would like to remove from meta description the product category. It's possible?

 

Thanks!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×