Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Hi jack

that double Header tags is now removed but the problem of url still exists, folliwng is the code how the google fetches one of my web page taken from webmaster.

You've got something wrong with your code. If you view the actual source, you will see

<html $htmlparams>

which shouldn't be. There are also two entries of

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

I suggest you compare your file to the included one and fix all of the mistakes before doing anything else.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

All of the update code is handled the same way so one should not work while the other fails. I may have made some mistake in the fixes I applied to the latest version. Please try downloading version 3.1.8 and just uploading the admin/headertags_seo.php file and see if the problem goes away.

 

No Still no luck, I agree its very odd! Also the add pseudo box does not work either.

Edited by wroughtec

Share this post


Link to post
Share on other sites

It is working for me here. Maybe you need to clear your browsers cache?

 

Nothing should have changed that would cause it to require register globabls.

 

 

I think this line in the included new admin/includes/application_top.php causes the problem

// Check if register_globals is enabled.
// Since this is a temporary measure this message is hardcoded. The requirement will be removed before 2.2 is finalized.
 if (function_exists('ini_get')) {
// Patch 2.2MS2-051113 next line message modified
   ini_get('register_globals') or exit('Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.');
 }

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Hi,

 

I've installed 3.18 and all is fine on index.php with title, keywords and metatags but in products I can only get the default title, keywords and description to show - the default tags section seems to overide any of the products. Have used fill tags etc and the breadcrumb etc updates with the metatags but the page title, description and keywords still show whats in the default tags so each product page has the same title, description and metatags.

 

Any advice on how to change each product page to show its own title and description - have been trying lots of options but the default tags always seem to show.

 

Thanks

Share this post


Link to post
Share on other sites

I think this line in the included new admin/includes/application_top.php causes the problem

That's standard oscommerce code, not from Header Tags. Perhaps youused the incorrect application_top file for the version of your shop?

Share this post


Link to post
Share on other sites

I've installed 3.18 and all is fine on index.php with title, keywords and metatags but in products I can only get the default title, keywords and description to show - the default tags section seems to overide any of the products. Have used fill tags etc and the breadcrumb etc updates with the metatags but the page title, description and keywords still show whats in the default tags so each product page has the same title, description and metatags.

 

Any advice on how to change each product page to show its own title and description - have been trying lots of options but the default tags always seem to show.

 

Thanks

Since you didn't post the test results I assume you have read the trobleshooting tips in the install file or on the test page, which specifically addresses that problem. Please do so once you follow those steps.

Share this post


Link to post
Share on other sites

Jack, I was wondering if your contribution may fix an issue i'm having with KissMT.

 

I have some products linked to many different sections of my site as this is how I have setup my navigation.

 

With KissMT it pulls the Header Tags and Meta information from the database rather than using the cpath so no matter what section the product is viewed in it displays the header tag and Meta for the category it was originally created in.

Share this post


Link to post
Share on other sites

Hi Jack

 

Trying the upgrade 3.1.8 to 3.2.0 i get also this message:

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

 

This in local with Wamp. Hope this helps.

Share this post


Link to post
Share on other sites

I have some products linked to many different sections of my site as this is how I have setup my navigation.

 

With KissMT it pulls the Header Tags and Meta information from the database rather than using the cpath so no matter what section the product is viewed in it displays the header tag and Meta for the category it was originally created in.

The title and meta tags can be individually set in the products edit page so you would be able to set them to whatever you want.

Share this post


Link to post
Share on other sites

Trying the upgrade 3.1.8 to 3.2.0 i get also this message:

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

Are you changing the applications_top file as the previous poster was doing? If so, are you sure you are using the correct one for the version of your shop?

Share this post


Link to post
Share on other sites

Are you changing the applications_top file as the previous poster was doing? If so, are you sure you are using the correct one for the version of your shop?

 

Hi again Jack,

 

The update file says "1) Replace all admin files with the ones in catalog/admin" I therefor assumed that it was the files from your Catalog/admin in the download. Are you saying I need to use the ones from catalog_for_new_shop_only_RC2 ? including all the database tables, column left, filenames etc?

 

Many Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Hi again Jack,

 

The update file says "1) Replace all admin files with the ones in catalog/admin" I therefor assumed that it was the files from your Catalog/admin in the download. Are you saying I need to use the ones from catalog_for_new_shop_only_RC2 ? including all the database tables, column left, filenames etc?

 

Many Thanks

 

i had the same problem, and when i looked inside the catalog/admin/includes folder the only application_top.php file was one for MS2

and i am on RC2

but the instrusctions says to go from 3.1.9 (which i was on to 3.2.0 was to

1) Replace all admin files with the ones in catalog/admin

which i did, and i got the error, but changeing back to my old application top stopped the error

 

 


App created for phoenix
TinyMCE editor for admin

 

Share this post


Link to post
Share on other sites

The update file says "1) Replace all admin files with the ones in catalog/admin" I therefor assumed that it was the files from your Catalog/admin in the download. Are you saying I need to use the ones from catalog_for_new_shop_only_RC2 ? including all the database tables, column left, filenames etc?

This is my mistake. The catalog/ directory in the contribution should only have Header Tags specific files in it. I see now that I somehow copied an application_top file into it. That should not be uploaded. I apologize to anyone this mistake caused to have problems.

Share this post


Link to post
Share on other sites

Thanks Jack,

 

That one really had me scratching my head.

 

Great Contribution


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Hello,

 

I've installed Ultimate SEO V 2.2d-7 and also Header Tags SEO V 3.12.

 

When I press the "Buy" button, it goes to shopping_cart page, but I got something strange at the top, we see

 

dir="LTR" lang="fr"

 

and the title with <?php echo TITLE; ?>

 

It seems related to Header Tags, I don't know which file to look at, can you please help?

 

Thanks very much

 

Carina

Share this post


Link to post
Share on other sites

Jack,

 

I am a complete novice and need some help. I am trying to install Header Tags SEO and got to the instruction in Install_Catalog.txt #3) where you say to find around line 78

 

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

My code is:

 

<td class="pageHeading"><?php echo $category['categories_name']; ?></td>

</tr>

<tr>

<td class="pageHeading" align="left">

<?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT);?></td>

<td class="productListing-data" align="left"><?php echo $categories_desc['categories_description']; ?></td>

</tr>

 

what should I do? Should I replace my code with the instructions or modify something?

Share this post


Link to post
Share on other sites

I've installed Ultimate SEO V 2.2d-7 and also Header Tags SEO V 3.12.

 

When I press the "Buy" button, it goes to shopping_cart page, but I got something strange at the top, we see

 

dir="LTR" lang="fr"

 

and the title with <?php echo TITLE; ?>

 

It seems related to Header Tags, I don't know which file to look at, can you please help?

The file is whichever page you are on when the failure occurs. If it is on the shopping cart page, then the file is shopping_cart.php. Although that file should not have been changed with the installation of Header Tags. The code "dir="LTR" is in the language files. I'm guessing lanugages/french.php in this case. You need to look at that file for the problem.

Share this post


Link to post
Share on other sites

what should I do? Should I replace my code with the instructions or modify something?

Your code has already been modified for changing the name so it is difficult to tell you what to do since I don't know all of the changes that were made. If you have a backup from before that change was made, you should work off that. If not, you will have to guess at it. The general idea behind that particular change is that you change any code that looks like this

<td class="pageHeading">SOMETHING HERE</td>

to

<td><h1>SOMETHING HERE</h1></td>

The "SOMETHING HERE" doesn't get changed.

Share this post


Link to post
Share on other sites

OK, I'll try once more. :angry: A new version has been uploaded with these changes:

 

-> Fixed mistakes in previous upload

-> Fixed coding error in admin/headertags_seo.php that prevented updates to the correct languages

-> Fixed remaining STRICT coding problems

 

If your shop uses different languages, this version should fix a long-standing problem I couldn't cause to happen before. You will need to edit your products so the database gets updated with the correct data.

Share this post


Link to post
Share on other sites

The title and meta tags can be individually set in the products edit page so you would be able to set them to whatever you want.

 

In that situation though it would use the same META and Header information for that product in different sections though correct? I want the header tag and META to be slightly different for the product under each section but the product needs to be linked not duplicated otherwise it screws up the search and manufacturers sections in displaying the same product 10 times.

Share this post


Link to post
Share on other sites

In that situation though it would use the same META and Header information for that product in different sections though correct? I want the header tag and META to be slightly different for the product under each section but the product needs to be linked not duplicated otherwise it screws up the search and manufacturers sections in displaying the same product 10 times.

Oh, I misunderstood what you meant. I wouldn't change the meta tag code, whichever contribution you use, to have different titles and tags since that would defeat the purpose of the contribution, at least for those products. You should instead fix the search code. Adding distinct to the mysql clause may be all that is needed but that is a topic for another forum.

Share this post


Link to post
Share on other sites

Oh, I misunderstood what you meant. I wouldn't change the meta tag code, whichever contribution you use, to have different titles and tags since that would defeat the purpose of the contribution, at least for those products. You should instead fix the search code. Adding distinct to the mysql clause may be all that is needed but that is a topic for another forum.

 

Hmm, thats another option although then updating a products information, price etc would require me doing it tens of times.

 

I made a thread here to see if anyone can help me with that though, http://forums.oscommerce.com/topic/355353-distinct-search-in-mysql/

Share this post


Link to post
Share on other sites

Hi together,

 

when changing betwenn languages, the language is mentioned in the title of the page.

For example:

language_en | other title => for english
language_de | other title => for german
language_es | other title => for espanol

 

How can I move the language to another position within the title, including an change of the separator "|" ?

Same for keywords and description.

 

Thanks in advance

kind regards

Andreas

Edited by Andreas2003

Share this post


Link to post
Share on other sites

 

 

-> Fixed mistakes in previous upload

-> Fixed coding error in admin/headertags_seo.php that prevented updates to the correct languages

-> Fixed remaining STRICT coding problems

 

If your shop uses different languages, this version should fix a long-standing problem I couldn't cause to happen before. You will need to edit your products so the database gets updated with the correct data.

 

I do have it only in spanish...what kind of products edit i need? don´t scare me....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×