Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Okay. But you definitely think the addon isnt installed correctly? The programmer seems to think its working perfectly fine. He says google wont pick up the new title tags until they crawl the site again which could be a month or so away....depending of course.

It's either not installed correctly or you haven't set it up correctly. If you go to admin->catalog and edit a category, there is a place for the header tags title and categories description (large box at the bottom). Whatever you put in those fields should appear on that category page in the shop. But since all of your categories have the same name, something is not right.

Share this post


Link to post
Share on other sites

Hi Jack,

 

Fist of all, all the best for the new year :D

 

I am using the Header Tags SEO contrib. and would like to achieve the following title:

 


  •  
  • product name
  • manufacturer name
  • product description [using the meta description from the description override BUT truncated to 60 chars]
  • store’s name

 

Kindly guide me as how to accomplish the product description in just the title and not affect the breadcrumb trail.

 

Finally, since I cannot make use of the Ultimate SEO URLs due to hosting not allowing the .htaccess and I cannot change the host at the moment, is there a way to have Header Tags SEO store the titles [to decrease page download time] and also have such reflect in the your other contrib. Google XML Sitemap SEO, as all I get in the sitemaps are dynamic urls.

Share this post


Link to post
Share on other sites

I am using the Header Tags SEO contrib. and would like to achieve the following title:

 


  •  
  • product name
  • manufacturer name
  • product description [using the meta description from the description override BUT truncated to 60 chars]
  • store’s name

 

Kindly guide me as how to accomplish the product description in just the title and not affect the breadcrumb trail.

 

Finally, since I cannot make use of the Ultimate SEO URLs due to hosting not allowing the .htaccess and I cannot change the host at the moment, is there a way to have Header Tags SEO store the titles [to decrease page download time] and also have such reflect in the your other contrib. Google XML Sitemap SEO, as all I get in the sitemaps are dynamic urls.

For the description in the title, you can't do it. At least, not without editing the code, which isn't something that i would go over in a support thread since it is too specific. Plus, I doubt it would be worth the time since the search engines truncate the title. So if you only have a few words to add, which is probably what it would come down to, just add them in the title using the product edit page or an override in fill tags.

 

I will probably add cache to the contribution at some point but I haven't time to do so yet.

Share this post


Link to post
Share on other sites

I have installed SEO tags to my site and I ran fill tags.I have setup the default tags and data as needed. it's working for few pages properly.

 

For some pages I have set up different tags values from default tags. In few pages of that though i have given tag data it's getting only the default tag data only.

 

???????

Share this post


Link to post
Share on other sites

First off, thank you for all your work it is most appreciative.

 

I was just wondering if there was going to be a mspace add-on to the social bookmarks. If I get the time to look at it I will try to figure it out.

 

Thank you,

Edited by matrix2223

Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites

For the description in the title, you can't do it. At least, not without editing the code, which isn't something that i would go over in a support thread since it is too specific. Plus, I doubt it would be worth the time since the search engines truncate the title. So if you only have a few words to add, which is probably what it would come down to, just add them in the title using the product edit page or an override in fill tags.

 

I will probably add cache to the contribution at some point but I haven't time to do so yet.

 

Hi Jack,

 

Thanks for the reply. I was after a dynamic title alternative due to my store having 1000+ products

 

I await your contrib.

 

With best regards

 

Fabian

Share this post


Link to post
Share on other sites

I have installed SEO tags to my site and I ran fill tags.I have setup the default tags and data as needed. it's working for few pages properly.

 

For some pages I have set up different tags values from default tags. In few pages of that though i have given tag data it's getting only the default tag data only.

It's probably your settings in page control for the "few pages." Reading through this thread should supply the fix.

Share this post


Link to post
Share on other sites

I was just wondering if there was going to be a mspace add-on to the social bookmarks. If I get the time to look at it I will try to figure it out.

You can add social bookmarks by editing the includes/modules/header_tags_social_bookmarks.php file. Just copy the three lines for one of the other sites and change the relevant parts.

Share this post


Link to post
Share on other sites

Thanks for the reply. I was after a dynamic title alternative due to my store having 1000+ products

I'm not sure what you mean by that. Header Tags already dynamically handles the titles. If you are meaning you want the title to be built from the decription, that is a mistake, for the reason menitoned and because there would be text in the title that takes away from its effectiveness.

Share this post


Link to post
Share on other sites

I'm not sure what you mean by that. Header Tags already dynamically handles the titles. If you are meaning you want the title to be built from the decription, that is a mistake, for the reason menitoned and because there would be text in the title that takes away from its effectiveness.

 

Sorry, maybe I didn't quite address the intention.

 

My titles are too short,

 

The Title for Ruger Mini-14 StripLULA may be too short. It is 23 characters long. 
The Title for MS-GL 2 may be too short. It is 7 characters long. 
The Title for MS-AL 2 may be too short. It is 7 characters long. 
The Title for MS-BE 1 may be too short. It is 7 characters long. 
The Title for MS-CZ 2 may be too short. It is 7 characters long. 
The Title for MS-CZ 1 may be too short. It is 7 characters long. 
The Title for MS-CZ 3 may be too short. It is 7 characters long. 
The Title for FN FAL LULA may be too short. It is 11 characters long. 
The Title for StripLULA may be too short. It is 9 characters long. 
The Title for MS-AL 1 may be too short. It is 7 characters long. 
The Title for BabyUpLULA may be too short. It is 10 characters long. 
The Title for HK G36 - XM8 BenchLoader may be too short. It is 24 characters long. 
The Title for Galil BenchLoader may be too short. It is 17 characters long. 
The Title for STEYR AUG and M16 - AR15 USGI BenchLoader may be too short. It is 41 characters long. 
The Title for M-16 - AR-15 LULA may be too short. It is 18 characters long. 
The Title for AK-47 - Galil LULA may be too short. It is 19 characters long. 
The Title for MP5 LULA may be too short. It is 8 characters long. 
The Title for COLT SMG LULA may be too short. It is 13 characters long. 
The Title for UZI LULA may be too short. It is 8 characters long. 
The Title for M1A - M14 LULA may be too short. It is 14 characters long. 
The Title for MS-GL 1 may be too short. It is 7 characters long. 
The Title for UpLULA may be too short. It is 6 characters long. 
The Title for M16 - AR15 USGI BenchLoader may be too short. It is 27 characters long. 
The Title for M16 - SA80 - HK416 BenchLoader may be too short. It is 30 characters long. 
The Title for MS-GL 5 may be too short. It is 7 characters long. 
The Title for MS-GL 6 may be too short. It is 7 characters long. 
The Title for MS-GL 4 may be too short. It is 7 characters long. 

 

Ok, once that HT SEO kicks-in the page tile of the browser displays the product name, category and manufacturer.

 

Wished could have it in a way to display an auto truncated product description, all the more if such could be cached and also used in Google XML SEO.

 

Regs Fab

Share this post


Link to post
Share on other sites

My titles are too short,

 

Ok, once that HT SEO kicks-in the page tile of the browser displays the product name, category and manufacturer.

 

Wished could have it in a way to display an auto truncated product description, all the more if such could be cached and also used in Google XML SEO.

The titles are too short is only a suggestion that there might be a problem. If the title makes sense being short, it is OK.

 

I'm not making myself clear about the description. Let's say there was an option to add twenty characters from the description to the title. If the title was "MS-GL 2" and the description was "This is a great product for IBM computers," then the title for the page would be something like, "MS-GL 2 - This is a great product," which does nothing at all for the SEO of the page and actually reduces the efectivenss. I suggest you give up that idea since it will only cause problems.

 

As for the google sitemap, if you are using my version of Ultimate SEO (V2.2d), there is an option to use the Header Tags title. Once that is set and cache refreshed, running the google sitemap will display the Header Tags title.

Share this post


Link to post
Share on other sites

Well, after I installed this all of my products in all the categories have vanished. This happened after completing the catalog portion of the install. I also have a question about the admin installation. I used the admin in the root of my server. Should I have used that or the renamed admin folder in public_html? The catalog portion seems to have worked at least as the titled has changed to "Replace me..."

Share this post


Link to post
Share on other sites

Well, after I installed this all of my products in all the categories have vanished. This happened after completing the catalog portion of the install. I also have a question about the admin installation. I used the admin in the root of my server. Should I have used that or the renamed admin folder in public_html? The catalog portion seems to have worked at least as the titled has changed to "Replace me..."

Use the one that is your actual admin.

Share this post


Link to post
Share on other sites

 

As for the google sitemap, if you are using my version of Ultimate SEO (V2.2d), there is an option to use the Header Tags title. Once that is set and cache refreshed, running the google sitemap will display the Header Tags title.

 

Hi Jack,

 

Thanks for the reply. Content Noted and accepted :D I cannot run Ultimate SEO due to the current host restrictions for using .htaccess files.

 

Regs Fabian

Share this post


Link to post
Share on other sites

Ok, now I've made the correct changes to the admin files. My products still aren't showing up on the site. I'm not seeing any errors anywhere. What could be the issue? The contribution did change the title of the index properly and also added in the osC admin panel...

Share this post


Link to post
Share on other sites

Ok, now I've made the correct changes to the admin files. My products still aren't showing up on the site. I'm not seeing any errors anywhere. What could be the issue? The contribution did change the title of the index properly and also added in the osC admin panel...

A full set of working files are included in the contribution package. Instructions on how to use those and not disrupt your site were mentioned here recently. You'll need to make changes using those files to isolate where the problem is at.

Share this post


Link to post
Share on other sites

That's what I saw too but I don't know enough to know why everything gets stripped at the "&". And it's not only FB... it's all those that I've tried that I'm a member of. What could it be? Browser issue or maybe because I'm on a Windows server? If you have it working somewhere that you can share a link to, I'd really like to see. Maybe we can compare what's different from my own set up.

 

Thanks still.

 

 

I hate to make a pest of myself but does anyone have the Social Bookmarks working on their site? If so, would someone be willing to post a link to one of their pages and maybe exchange an email or 2 with me so I can compare notes. I'd really like to make this work if I could. I've been trying all I could think about but I haven't figured it out.

 

Thanks

Share this post


Link to post
Share on other sites

I've just installed this and everything is working fine except the description. At the beginning and the end of the tag it has this "P" and i have no idea how i can lose this. The only post i have found says re-fill your tags, i tried that but all it done was lose all my tags that i had already entered. This only happens on a product page. Anyone have any ideas????

 

<meta name="Description" content="_p_This would be the description on my products page_/p_" >

Edited by twistedpress

Share this post


Link to post
Share on other sites

<meta name="Description" content="_p_This would be the description on my products page_/p_" >

Maybe a mistake in your products description? Try creating a new product with a one word description and see if that has the same problem.

Share this post


Link to post
Share on other sites

SEO doesn't seem to use actual keywords from my product pages in admin - Header Tags SEO area

After upgrading to the new version my Google page rank went from 3 down to 1?

 

So I need help getting it all back together and making sure everything is correctly selected in admin

 

What really happens to new categories keywords and new product keywords we enter? can these keywords be included?

What should be the best selection at Header Tags SEO

 

Eg. I found my Category keywords appearing below categories title code - index.php

  <tr>

          <td colspan="2"><h2><?php echo $htc['htc_description']; ?></h2></td>

         </tr>

So this code I've move down to the footer.php as it stands out in the middle page, however this is the keywords showing when we enter a new categories and its keywords

 

Is this code at the right place or should I move it somewhere else??

 

Thank's


Getting the Phoenix off the ground

Share this post


Link to post
Share on other sites

SEO doesn't seem to use actual keywords from my product pages in admin - Header Tags SEO area

After upgrading to the new version my Google page rank went from 3 down to 1?

 

What really happens to new categories keywords and new product keywords we enter? can these keywords be included?

What should be the best selection at Header Tags SEO

Googles PR is determined strictly based on the links to your site. You could erase your site completely and just add an html page and PR wouldn't change, unless maybe due to the link relevancy. So if your PR dropped, it was due to other reasons, most likely.

 

The keywords you entered are used in the title and meta tags of the pages as well as a few other places, like the breadcrumb and logo.

 

The best selection depends on the page. The keywords should match those of the page.

Share this post


Link to post
Share on other sites

Googles PR is determined strictly based on the links to your site. You could erase your site completely and just add an html page and PR wouldn't change, unless maybe due to the link relevancy. So if your PR dropped, it was due to other reasons, most likely.

 

The keywords you entered are used in the title and meta tags of the pages as well as a few other places, like the breadcrumb and logo.

 

The best selection depends on the page. The keywords should match those of the page.

 

Thanks, now I changed a few options.

 

Is it recommended to exclude the breadcrumb and logo from page control? - product_info.php everything is selected as follows:

Default Title:

Default Description

Default Keywords:

Default Logo:

Category:

Manufacturer:

Product:

Root:

 

On the right I filled in my default title, description, keywords, logo text and selected to include category, manufacturer and product

 

If you want to take a look at my site - http://shop.pgprojects.co.za


Getting the Phoenix off the ground

Share this post


Link to post
Share on other sites

Is it recommended to exclude the breadcrumb and logo from page control? - product_info.php everything is selected as follows:

No, you should exclude the breadcrumb or logo. The default section should almost never be used. See previous posts about that.

Share this post


Link to post
Share on other sites

No, you should exclude the breadcrumb or logo. The default section should almost never be used. See previous posts about that.

 

Thanks again

 

Seems to make some sense doing that as keywords and descriptions would be nearly the same for every product

So now I've got only Category, Manufacturer, Product and Root enabled for my products

 

Other thing is the fill page - description - I choose 300 characters - select - Fill keywords for all added pages from derived keywords always times out and nothing gets changed

 

Is there something wrong with my installation?


Getting the Phoenix off the ground

Share this post


Link to post
Share on other sites

Hi,

 

I have a admittedly simple problem that I just can't seem to figure out or find the answer to in this forum so far. Everything was working perfectly after my header tags SEO install, and then a few add-ons later, including product listing enhancements, I noticed that on my product info page, TEXT_VIEWING following by the page title hyperlinked showed up centered just below the reviews and add to cart buttons. Of course I can just delete TEXT_VIEWING out, but if I delete everything in lines 336-339 below will there be any repercussions for the functioning of header tags SEO? I can't see any so far but I'm no expert by any means. Someone here can hopefully save me a ton of time going back and reinstalling and testing my backups one by one.

 

Many thanks,

 

Nick

 

 

 

332 <?php /*** Begin Header Tags SEO ***/ ?>

333 <tr>

334 <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

335 </tr>

336 <tr>

337 <td class="smallText" align="center"><?php echo ''; ?> 

338 <?php echo '<a title=TEXT_VIEWING"' . $header_tags_array['title'] . '" href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' .

339 $product_info['products_id'], 'NONSSL'). '"/# ' . $header_tags_array['title'] . '">' . $header_tags_array['title']; ?></a></td>

340 </tr>

341 <?php /*** End Header Tags SEO ***/ ?>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×