Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

i have no includes/sts_templates/ directory.

and no templates directroy in the root directory.

 

how can i found out ?

Share this post


Link to post
Share on other sites

Hey with this contrib. with bts. Any reason why it would be showing the default settings, but not the page control custom settings?

Share this post


Link to post
Share on other sites

Hey with this contrib. with bts. Any reason why it would be showing the default settings, but not the page control custom settings?

Either it's not installed correctly or you have set the options in page control, most likely.

Share this post


Link to post
Share on other sites

THANK YOU THANK YOU for the GREAT CONTRIBUTION. I thought I could never SEO by using oscommerce.

 

Could I cheated by asking this error question?

 

Fatal error: require() [function.require]: Failed opening required 'DIR_WS_LANGUAGES/FILENAME_DEFAULT' (include_path='.:/usr/local/php52/pear') in /home/topdispl/public_html/index.php on line 36

 

Could anyone help me with this one. Where can I find it?

 

Thank in advance Jack

Share this post


Link to post
Share on other sites

THANK YOU THANK YOU for the GREAT CONTRIBUTION. I thought I could never SEO by using oscommerce.

 

Could I cheated by asking this error question?

 

Fatal error: require() [function.require]: Failed opening required 'DIR_WS_LANGUAGES/FILENAME_DEFAULT' (include_path='.:/usr/local/php52/pear') in /home/topdispl/public_html/index.php on line 36

You're welcome. :)

 

Errors with capital letters in them mean there is something wrong with your installation. In this case, those two definitions, DIR_WS_LANGUAGES and FILENAME_DEFAULT, are a standard part of oscommerce, though I don't see why the failure would only be with Header Tags. My guess is that you uploaded one of the included files to the wrong location or something like that. If you are the same sort of errors elsewhere in the shop, then you are missing one of the main files or it is not setup correctly or has been altered somehow.

Share this post


Link to post
Share on other sites

Wow! This was the longest, biggest addon install I made.

 

Surprisingly, no big mistakes.

 

However I ran the Test at the end and got the following:

 

Test Results

1)

Duplicate title found: explain

for Australian

exists more than once.

 

Duplicate meta description found: explain

for Australian

exists more than once.

 

2)

Missing Code in File explain

The Header Tags head code for the product_reviews_info.php file cannot be found.

The Header Tags head code for the product_reviews_write.php file cannot be found.

 

1) Now, Australian, is that a file somewhere? I looked in the usual places like admin/includes/languages/languages/, and /includes/languages/english/ etc, but could not find it? Will this warning disappear after I start using Header Tags?

 

2) With the Install_Catalog instructions I added code to the following additional files:

 

product_reviews.php,

products_new.php,

specials.php, and

reviews.php

 

I did NOT add code to product_reviews_info.php, nor product_reviews_write.php However I am guessing there may be some interdependency of the above two files with the files I did add code to? So what should I do? Should I revert some of those files I added code to to their previous versions, or should I add the same code to the two reported files too? For example, I am not sure adding code to product_reviews.php was a good idea, as perhaps it is the reviews.php file that does what I think it does, in terms of tags, search engines, and promotion of my products? Any ideas, suggestions?

 

Permissions

I'm also a bit concerned about having to drop permissions right down to 0777 for header_tags. I'm wondering if I can find a better way around them. I will try and study up about permissions in other parts of the forum. The Admin came up with the chmod error for 0755 setting.

 

Otherwise, this install went without a hitch. I haven't read the how to use instructions yet, but I'm quite impressed with the amount of work that must have gone into it, the comprehensive install instructions, and the substantial end result (well what I can see in admin anyway). Thanks to all those who put this together.


I'm fluent in gibberish. I've been reading gibberish since 1982.

Share this post


Link to post
Share on other sites

Thank You Jack. I have reupload all the files again. But I still get the same error. I also go back to the instruction and find:

 

5) In includes/application_top.php, ***Is This a Mistake or something? Because I could not find anything like that in my include/application_top.php files"

 

FIND:

 

// add category names or the manufacturer name to the breadcrumb trail

if (isset($cPath_array)) {

for ($i=0, $n=sizeof($cPath_array); $i<$n; $i++) {

$categories_query = tep_db_query("select categories_name from " . TABLE_CATEGORIES_DESCRIPTION . " where categories_id = '" . (int)$cPath_array[$i] . "' and language_id = '" . (int)$languages_id . "'");

if (tep_db_num_rows($categories_query) > 0) {

$categories = tep_db_fetch_array($categories_query);

$breadcrumb->add($categories['categories_name'], tep_href_link(FILENAME_DEFAULT, 'cPath=' . implode('_', array_slice($cPath_array, 0, ($i+1)))));

} else {

break;

}

}

} elseif (isset($HTTP_GET_VARS['manufacturers_id'])) {

$manufacturers_query = tep_db_query("select manufacturers_name from " . TABLE_MANUFACTURERS . " where manufacturers_id = '" . (int)$HTTP_GET_VARS['manufacturers_id'] . "'");

if (tep_db_num_rows($manufacturers_query)) {

$manufacturers = tep_db_fetch_array($manufacturers_query);

$breadcrumb->add($manufacturers['manufacturers_name'], tep_href_link(FILENAME_DEFAULT, 'manufacturers_id=' . $HTTP_GET_VARS['manufacturers_id']));

}

}

 

// add the products model to the breadcrumb trail

if (isset($HTTP_GET_VARS['products_id'])) {

$model_query = tep_db_query("select products_model from " . TABLE_PRODUCTS . " where products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "'");

if (tep_db_num_rows($model_query)) {

$model = tep_db_fetch_array($model_query);

$breadcrumb->add($model['products_model'], tep_href_link(FILENAME_PRODUCT_INFO, 'cPath=' . $cPath . '&products_id=' . $HTTP_GET_VARS['products_id']));

}

}

 

REPLACE with:

 

/*** Begin Header Tags SEO ***/

// add category names or the manufacturer name to the breadcrumb trail

if (isset($cPath_array)) {

for ($i=0, $n=sizeof($cPath_array); $i<$n; $i++) {

$categories_query = tep_db_query("select categories_htc_title_tag from " . TABLE_CATEGORIES_DESCRIPTION . " where categories_id = '" . (int)$cPath_array[$i] . "' and language_id = '" . (int)$languages_id . "' LIMIT 1");

if (tep_db_num_rows($categories_query) > 0) {

$categories = tep_db_fetch_array($categories_query);

$breadcrumb->add($categories['categories_htc_title_tag'], tep_href_link(FILENAME_DEFAULT, 'cPath=' . implode('_', array_slice($cPath_array, 0, ($i+1)))));

} else {

break;

}

}

} elseif (isset($_GET['manufacturers_id'])) {

$manufacturers_query = tep_db_query("select manufacturers_htc_title_tag from " . TABLE_MANUFACTURERS_INFO . " where manufacturers_id = '" . (int)$_GET['manufacturers_id'] . "' AND languages_id = '" . (int)$languages_id . "' LIMIT 1");

if (tep_db_num_rows($manufacturers_query)) {

$manufacturers = tep_db_fetch_array($manufacturers_query);

$breadcrumb->add($manufacturers['manufacturers_htc_title_tag'], tep_href_link(FILENAME_DEFAULT, 'manufacturers_id=' . $_GET['manufacturers_id']));

}

}

 

// add the products name to the breadcrumb trail

if (isset($_GET['products_id'])) {

$products_query = tep_db_query("select pd.products_head_title_tag from " . TABLE_PRODUCTS . " p left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id where p.products_id = '" . (int)$_GET['products_id'] . "' and pd.language_id ='" . (int)$languages_id . "' LIMIT 1");

if (tep_db_num_rows($products_query)) {

$products = tep_db_fetch_array($products_query);

$breadcrumb->add($products['products_head_title_tag'], tep_href_link(FILENAME_PRODUCT_INFO, 'cPath=' . $cPath . '&products_id=' . $_GET['products_id']));

}

}

/*** End Header Tags SEO ***/

Share this post


Link to post
Share on other sites

Test Results

1)

Duplicate title found: explain

for Australian

exists more than once.

 

Duplicate meta description found: explain

for Australian

exists more than once.

 

2)

Missing Code in File explain

The Header Tags head code for the product_reviews_info.php file cannot be found.

The Header Tags head code for the product_reviews_write.php file cannot be found.

 

1) Now, Australian, is that a file somewhere? I looked in the usual places like admin/includes/languages/languages/, and /includes/languages/english/ etc, but could not find it? Will this warning disappear after I start using Header Tags?

Guess I need to make that explain link larger. No one seems to be able to find it. The first error means the code has found what appears to be duplicate entries in the meta tag description for the products shown. You can clcik on them to find out more but those are usually not too important.

 

2) With the Install_Catalog instructions I added code to the following additional files:

 

product_reviews.php,

products_new.php,

specials.php, and

reviews.php

 

I did NOT add code to product_reviews_info.php, nor

Thus the reason for the message. If you want to be able to control the title and tags for that page (any page), you need to add the code, as explained in the installation file.

 

Permissions

I'm also a bit concerned about having to drop permissions right down to 0777 for header_tags. I'm wondering if I can find a better way around them. I will try and study up about permissions in other parts of the forum. The Admin came up with the chmod error for 0755 setting.

There's nothing in the docs that says to set it to 777. It does say to set it to the same as the images directory. If it won't work correctly without it being set to 777, it is because of how your server is setup and there's nothing to be done for that. Although the file is in a secure area so setting it to 777 is not a problem.

Share this post


Link to post
Share on other sites

Guess I need to make that explain link larger. No one seems to be able to find it. The first error means the code has found what appears to be duplicate entries in the meta tag description for the products shown. You can clcik on them to find out more but those are usually not too important.

 

Thanks for your reply.

 

I did click the link, and did read the explanation. However, I thought it was apparent that I didn't understand it, and still don't know where to go to correct it. It's saying the duplicate Title and Meta Descriptions are found in Australian. Australian is I assume, a language or currency file? And where is it? Is it a php file, or an an sql file? I couldn't find it, and when I do find it, what do I change?

 

Thus the reason for the message. If you want to be able to control the title and tags for that page (any page), you need to add the code, as explained in the installation file.

There's nothing in the docs that says to set it to 777. It does say to set it to the same as the images directory. If it won't work correctly without it being set to 777, it is because of how your server is setup and there's nothing to be done for that. Although the file is in a secure area so setting it to 777 is not a problem.

 

Ok let me try to explain myself more clearly. I don't know if I want, or need those files headers and tags controlled. I mean, as far as listing by Google search engine goes [for product promotion], are those important pages? Or do those files merely work in the background, where only the product_info and reviews page is perhaps important?

 

As for permissions. I will play with images folder settings to see if it will work with 0755. The last time I tried that, the images didn't display, but will try again. As for the server setup. Umm, this same amateur is the owner of the Virtual Private Server. So, I may have to find a clue about server settings and adjust them so 0755 does work, and yet still provide optimum security.

 

Thanks again for your reply.


I'm fluent in gibberish. I've been reading gibberish since 1982.

Share this post


Link to post
Share on other sites

Thanks for your reply.

 

I did click the link, and did read the explanation. However, I thought it was apparent that I didn't understand it, and still don't know where to go to correct it. It's saying the duplicate Title and Meta Descriptions are found in Australian. Australian is I assume, a language or currency file? And where is it? Is it a php file, or an an sql file? I couldn't find it, and when I do find it, what do I change?

That message says it found a posible duplicate for the product Australian. I didn't add the word product to the search since I thought a shop owner would know what his products are.

 

 

Ok let me try to explain myself more clearly. I don't know if I want, or need those files headers and tags controlled. I mean, as far as listing by Google search engine goes [for product promotion], are those important pages? Or do those files merely work in the background, where only the product_info and reviews page is perhaps important?

That's a matter of contention among SEO people. Some say you should only list pages specific to some keyword. Other, myself included, think that all regular pages should be optimized. They will show up on google either way so you might as well take advantage of that.

 

As for permissions. I will play with images folder settings to see if it will work with 0755. The last time I tried that, the images didn't display, but will try again. As for the server setup. Umm, this same amateur is the owner of the Virtual Private Server. So, I may have to find a clue about server settings and adjust them so 0755 does work, and yet still provide optimum security.

It depends on the file ownership of the account and is not a subject for this thread (or forum, really). But, they shouldn't be set to 777 but if the ownership is not correct, that is the only way they will work. Look into suPHP, which is a secure way of controlling your files.

Share this post


Link to post
Share on other sites

I just want to say this is a GREAT Contribution!!!! It works so well for me. I'm next battle is go get URL SEO. I'm scared to install it since a lot of ppl are having problem...

 

THANK YOU JACK

Share this post


Link to post
Share on other sites

Hi,

 

Strange thing happend here.

when I view the source code of my product_info.php pages I noticed that my header tags are in front of the html tags

 

<title>ovens - Oven - Beko - OIE22101X</title>
<meta name="Description" content="ovens - Oven - Beko - OIE22101X" >
<meta name="Keywords" content="ovens , Oven - Beko - OIE22101X" >
<meta name="robots" content="noodp" >
<meta name="slurp" content="noydir" >
<link rel="canonical" href="http://.../ovens-oven-beko-oie22101x-p-198.html" >
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" >
<!-- EOF: Header Tags SEO Generated Meta Tags -->
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html dir="LTR" lang="nl">

 

It seems to be fine on all other pages.

I have STS installed and I use a template for the product info pages.

<!--$headcontent--> is in the head of page.

 

Is there something I'm missing here?

 

 

Kind regards

Share this post


Link to post
Share on other sites

Hello,

1st. Thank you for this contribution! works like a charm.

 

I have an issue trying to style anything that is in between <h1> and </h1>,

like product_name, price, ect, ect.

 

The install says to:

 

FIND (around line 102)

<td class="pageHeading" valign="top"><?php echo $products_name; ?></td>

<td class="pageHeading" align="right" valign="top"><?php echo $products_price; ?></td>

 

REPLACE with

 

<?php /*** Begin Header Tags SEO ***/ ?>

<td valign="top"><h1><?php echo $products_name; ?></h1></td>

<td align="right" valign="top"><h1><?php echo $products_price; ?></h1></td>

<?php /*** End Header Tags SEO ***/ ?>

 

NOTE: In any page in which you make the change to the title for Header Tags,

you should also locate the line containing HEADING_TITLE, remove the

pageHeading class and add the h1 tags as above.

 

We have done this, we have also added to stylesheet:

 

/*** Begin Header Tags SEO ***/

h1 {

font-family: Verdana, Arial, sans-serif;

font-size: 20px;

font-weight: bold;

margin-bottom: 0;

padding-bottom: 0;

color: #000;

}

h2 {

font-family: Verdana, Arial, sans-serif;

font-size: 14px;

font-weight: normal;

margin-bottom: 0;

padding-bottom: 0;

color: #000;

}

/*** End Header Tags SEO ***/

 

 

We have edited h1 in stylesheet and there is no change.

I hava tried a number of differant methods to add style, but no luck.

It always show same size & color.

 

Can someone please shed some light in regards to this issue i am having.

 

Thanks again,

Ronnie

Share this post


Link to post
Share on other sites

Ok, I notice that change color works with stlesheet mod on <h1> & <h2>

 

And size change works in <h2> only.

 

Question? can <h3> <h4> <h5> be added to stylesheet and used with metas?

 

Thnaks,

Ronnie

Share this post


Link to post
Share on other sites

I just want to say this is a GREAT Contribution!!!! It works so well for me. I'm next battle is go get URL SEO. I'm scared to install it since a lot of ppl are having problem...

 

THANK YOU JACK

There aren't any major problems I'm aware of in my latest version - 2.2d-5. I install it quite frequently into sites and they run fine. There are a few known small problems, as with any contribution, but they will be fixed with the next version. Plus, as far as I know, my version is the only one that works correctly with Header Tags. And compared to this installation, it is extremely easy to install.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Strange thing happend here.

when I view the source code of my product_info.php pages I noticed that my header tags are in front of the html tags

The placement in the file is determined by STS. You can probably move the headcontent line. If that doesn't do it, you would need to ask in the STS support thread.

Share this post


Link to post
Share on other sites

Question? can <h3> <h4> <h5> be added to stylesheet and used with metas?

Yes, you can add whatever classes you want to the stylesheet. I don't know what you mean about using them with metas, but CSS shouldn't be done in the title and meta tags, if that is what you mean.

Share this post


Link to post
Share on other sites

Yes, you can add whatever classes you want to the stylesheet. I don't know what you mean about using them with metas, but CSS shouldn't be done in the title and meta tags, if that is what you mean.

 

Thanks for the reply Jack,

So you mean that,

 

<h1><?php echo $products_price; ?></h1>

 

can also be <h4><?php echo $products_price; ?></h4>

 

And it dose not necessarily need to be <h1> ???

 

Thanks again,

Ronnie

Share this post


Link to post
Share on other sites

It may not be correct to use H4 in that position, per html specs, but, yes, that will work fine as far as the code is concerned.

Share this post


Link to post
Share on other sites

There aren't any major problems I'm aware of in my latest version - 2.2d-5. I install it quite frequently into sites and they run fine. There are a few known small problems, as with any contribution, but they will be fixed with the next version. Plus, as far as I know, my version is the only one that works correctly with Header Tags. And compared to this installation, it is extremely easy to install.

 

Hey Jack,

Can you give me the link of the SEO URL that you created or used with your Header Tag SEO. Thank you

Share this post


Link to post
Share on other sites

Hey Jack,

Can you give me the link of the SEO URL that you created or used with your Header Tag SEO. Thank you

See My Addons.

Share this post


Link to post
Share on other sites

Hello Jack,

 

First of all, thank you for all your support and Happy new Year!

 

Regarding default logo settings on right column in page control:

 

Can you tell if i've installed something wrong?

 

Or is it a known issue that when activating the category checkbox the effect applies not

only to the actual logo text on every pages, index.php or product_info.php, but also to

title and description meta tags.

 

Parent and sub-catégories are then also added on index.php or product_info.php

to title and description meta tags not only to the logo as the popup explains.

("Include the category name in the Logotext")

 

You say in main config that with "Standard" "Duplicate" etc, the settings only apply

when the category control box is checked in page control. But, there are 2 of those in

page control, 1 for individual pages and 1 in the right column for the logos.

 

I have 3.18 with "Full path" in main config updated a while ago from 2.63.

The only bit of code that I think missed so far in updating is the following:

 

<td valign="middle"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'store_entrance.gif', (tep_not_null($header_tags_array['logo_text']) ? $header_tags_array['logo_text'] : STORE_NAME)) . '</a>'; ?></td>

 

Yet,I want to say that I'am actually very happy with this particular right column Category

checkbox unchecked setting together with Full Path as it does exactly what I need.

 

Just wished to know if "Include the category name in the Logo text" checkbox should act

differently as on my installation.

 

Best regards


david

Share this post


Link to post
Share on other sites

Hi Jack,

Happy New Year!

 

I carefully read through this thread and I think we misunderstood each other. Could I start one last try to make sure that we didn't just miscommunicate?

I originally asked the following question:

I get the following Error Message after I used the header_tags_seo_convert.php:

Warning: main(includes/languages/german/header_tags_seo.php) [function.main]: failed to open stream: No such file or directory in /srv/www/vhosts/myshop.de/httpdocs/shop/admin/header_tags_seo_convert.php on line 171

Fatal error: main() [function.require]: Failed opening required 'includes/languages/german/header_tags_seo.php' (include_path='.:/usr/share/php') in /srv/www/vhosts/myshop.de/httpdocs/shop/admin/header_tags_seo_convert.php on line 171

 

You answered:

The error is saying it can't find the includes/languages/german/header_tags_seo.php. If you look in the includes/languages/german/ directory, is there a header_tags_seo.php file? [No there isn't]

Further you said that this file should be there from the original installation of "HeaderTags_V_2.6.3". It isn't in the zip file.

 

So I still have no idea where this file is :( Do you?

At the moment, all my Titles, Descriptions, etc are just empty!

 

PS: Could you pm me the file that you want translated? Otherwise I'll probably spend hours translating the wrong one. I will translate it, whether you can help me or not, because of the time you already spent on this!

 

Thank you!


Open Source Newsletter: PhPList

Open Source Questionnaire: Lime Survey

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×