Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Hi jack,

 

i installed header tags seo (fresh install)

now afterwards i added dutch language in

catalog/inlcudes/languages/dutch

and the file catalog/includes/languages/dutch.php

but now when i hit the "update" button in admin->header tag

seo->page control->show all files i get a message that i don't

have permissions to access admin/header_ tags_seo.php - however

everything else seems to work, update in index.php update in

page control-show all files right column also, only left column

in header tags seo-page control-show all files not? help?

Share this post


Link to post
Share on other sites

...i get a message that i don't

have permissions to access admin/header_ tags_seo.php...

Please read the instructions, the help on the test function or the many posts on this subject in this thread to fix this.

Share this post


Link to post
Share on other sites

Please read the instructions, the help on the test function or the many posts on this subject in this thread to fix this.

 

i did so, now i renamed my catalog/includes/languages/dutch directory; catalog/includes/languages/dutch.php directory to espanol and now it works,

can you just tell me which file i need to change to get the langauge working with name "dutch"

 

thanx in advance

Share this post


Link to post
Share on other sites

For STS, there will be an includes/sts_templates directory. For BTS, there will be a templates directory.

Thanks for clarifying. It appears our store is neither STS or BTS since our structure is catalog > includes.

Share this post


Link to post
Share on other sites

i did so, now i renamed my catalog/includes/languages/dutch directory; catalog/includes/languages/dutch.php directory to espanol and now it works,

can you just tell me which file i need to change to get the langauge working with name "dutch"

If it is working in one language and not in another, you've either missed a file upload or change somewhere or there is something wrong with your shop with regards to that language. You'll have to figure that one out.

Share this post


Link to post
Share on other sites

Hi,

My shop - oscommerce v2.2 rca2 - is hosted on a shared server. Everything was working fine, however recently I noticed a problem with three add-ons. Since I wasn't modifying anything (either files, or database) I am guessing something changed on the shared server.

 

- Header Tags SEO v3.1.5 - doesn't work on product_info.php and on index.php. When I view page source the tags that are there are global tags, not page specific tags.

 

 

The other two add-ons that don't work (For reference, in case they have some hosting requirement in common with Header Tags SEO):

 

- Ultimate SEO URLS v 5 - example product page url looks like this: www.website.com/product_info.php/product-name-product-model-p-XX

Plus for some odd reason when I go to Configuration -> SEO URLS 5, there is just an empty table (no errors). Tried reinstalling database entries from the provided php script, but the script says the entries already exist. I have no idea what/how to remove manually.

 

- Who's online enhancement v3.6.5 - doesn't show the cart anymore

 

Any idea how to fix/address this issue?

 

-- thanks, ania

Share this post


Link to post
Share on other sites

Header Tags comes with files that have already been altered. Replace yours with those for a quick test. If it works, your files have a mistake. If it fails, the problem is elsewhere or you don't have the tags setup properly in admin.

Share this post


Link to post
Share on other sites

jack,

 

sorry to bother again but header tags seo works in every language, the problem is that as soon as i have more than 3 languages installed i get following problem:Forbidden

You don't have permission to access /admin/header_tags_seo.php on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

this is only after that i did the update in left column at page control->show all files

 

it works fine with english/espanol/dutch or english/dutch/german or dutch/german/espanol; etc... but whenever i have more than 3 the problem occurs

 

??

Share this post


Link to post
Share on other sites

I've been troubleshooting an issue for several hours where the column_right boxes (Shopping Cart, Manufacturer Info, etc.) are all appearing at the bottom of the page directly underneath the left column items. This is somehow related to adding Header Tags SEO, but I know it's something I've done wrong... not the actual code.

 

Here's the page: http://www.wolfftanning.com/product_info.php?products_id=270. Any ideas?

Share this post


Link to post
Share on other sites

I've been troubleshooting an issue for several hours where the column_right boxes (Shopping Cart, Manufacturer Info, etc.) are all appearing at the bottom of the page directly underneath the left column items. This is somehow related to adding Header Tags SEO, but I know it's something I've done wrong... not the actual code.

 

Here's the page: http://www.wolfftanning.com/product_info.php?products_id=270. Any ideas?

Please read the comments in the test section before posting.

Share this post


Link to post
Share on other sites

hello all, i have just installed HT SEO new version, i have an error in categories.php

 

Parse error: syntax error, unexpected $end in /home/USERNAME/public_html/SHOP/admin/categories.php on line 1475

 

not sure how to correct the error?

hope you guys can help. the rest of the install is perfect. just this page.

 

Thanks in advance all.

Edited by Platinum Games

Thanks in advance!

 

Ben

Share this post


Link to post
Share on other sites

hello all, i have just installed HT SEO new version, i have an error in categories.php

 

Parse error: syntax error, unexpected $end in /home/USERNAME/public_html/SHOP/admin/categories.php on line 1475

 

not sure how to correct the error?

hope you guys can help. the rest of the install is perfect. just this page.

 

Thanks in advance all.

 

 

fixed with closing ' } '

 

but now i have an issue with the page being blank?

header, footer & left col load but no page on Categories/Products

 

does anyone know what would cause this?


Thanks in advance!

 

Ben

Share this post


Link to post
Share on other sites

fixed with closing ' } '

 

but now i have an issue with the page being blank?

header, footer & left col load but no page on Categories/Products

 

does anyone know what would cause this?

Please read the troubleshooting section in the install file.

Share this post


Link to post
Share on other sites

Hi

I get this error on my profuct_info page after installing through the install file:

1146 - Table 'U9027791.TABLE_HEADERTAGS_DEFAULT' doesn't exist

 

select * from TABLE_HEADERTAGS_DEFAULT where language_id = '1'

 

[TEP STOP]

 

Any ideas?

 

Also, the instructions say:

1B) ********* FOR BTS USERS ONLY *********

 

Add the code in step 1 to the main_page.tpl.php file then proceed to step 2.

 

======================================================================================================

2) In stylesheet.css, add the following to the end of the file. Set it to the

desired size and color for your shop.

 

Does this mean Step 2 is for everyone or only for BTS users?

Edited by qwertyjjj

Share this post


Link to post
Share on other sites
The original file in the Header Tags Contrib (2.6.3) in the folder \catalog\includes\languages\german is called "header_tags.php" and not "header_tags_seo.php" which is what the error message asks for...

I found no mentioning of that file anywhere in the Update from 2.6.3 to 3.0.0 Textfile.

I triple checked the original Header Tags Contribution and the update instructions but can't find my error. Can't you just pm me the \catalog\includes\languages\german\header_tags_seo.php file? Even it is in english, I don't care by now...

Thank you!


Open Source Newsletter: PhPList

Open Source Questionnaire: Lime Survey

Share this post


Link to post
Share on other sites

Hi

I get this error on my profuct_info page after installing through the install file:

1146 - Table 'U9027791.TABLE_HEADERTAGS_DEFAULT' doesn't exist

 

Also, the instructions say:

1B) ********* FOR BTS USERS ONLY *********

 

Add the code in step 1 to the main_page.tpl.php file then proceed to step 2.

 

======================================================================================================

2) In stylesheet.css, add the following to the end of the file. Set it to the

desired size and color for your shop.

 

Does this mean Step 2 is for everyone or only for BTS users?

The capital letters mean you missed a step in the installation procedure. Search the install files for TABLE_HEADERTAGS_DEFAULT and perform the necessary steps.

 

Yes, step 2 is for everyone.

Share this post


Link to post
Share on other sites

I triple checked the original Header Tags Contribution and the update instructions but can't find my error. Can't you just pm me the \catalog\includes\languages\german\header_tags_seo.php file? Even it is in english, I don't care by now...

Thank you!

There isn't such a file so there isn't anything to send you. As mentioned, I think you've gotten the contributions confused. I can't help with that though since I would just be repeating myself at this point.

Share this post


Link to post
Share on other sites

My shop is not STS or BTS as I have no templated directories at all so not sure what to follow.

Edited by qwertyjjj

Share this post


Link to post
Share on other sites

My shop is not STS or BTS as I have no templated directories at all so not sure what to follow.

Hmm, well let's try this. We will start at step 1 since there aren't any before that.

 

1) ******** NOTE: STS USERS ONLY - Skip to step 1A. *********

You said you don't have STS, so you should not skip to step 1A. You are still in step 1.

******** NOTE: BTS USERS ONLY - Skip to step 1B. *********

You said you don't have BTS, so you should not skip to step 1B. You are still in step 1.

 

So, still reading in step 1, it says:

For Header Tags to work on a page of your site, that page must have the code

change mentioned below installed. At a minimum, the following files should be

changed:

 

index.php

product_info.php

So for the above files, it says to:

FIND:

 

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

And to replace it with

<?php

/*** Begin Header Tags SEO ***/

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

<?php

}

/*** End Header Tags SEO ***/

?>

The next step is Step 1A,

1A) ********* FOR STS USERS ONLY *********
but you said you don't have STS so you would skip that. The next step is Step 1B
1B) ********* FOR BTS USERS ONLY *********
but you said you don't have BTS so you should skip that.

 

I can continue from there if you like but the steps are numbered in order so you just have to go to the next step and then the next until you are done.

 

I hope that cleared it up.

Share this post


Link to post
Share on other sites

Hmm, well let's try this. We will start at step 1 since there aren't any before that.

 

 

You said you don't have STS, so you should not skip to step 1A. You are still in step 1.

 

You said you don't have BTS, so you should not skip to step 1B. You are still in step 1.

 

So, still reading in step 1, it says:

 

So for the above files, it says to:

 

And to replace it with

The next step is Step 1A,but you said you don't have STS so you would skip that. The next step is Step 1Bbut you said you don't have BTS so you should skip that.

 

I can continue from there if you like but the steps are numbered in order so you just have to go to the next step and then the next until you are done.

 

I hope that cleared it up.

 

Ok thanks. Your instructions first made it sound like there are only 2 options STS or BTS.

Share this post


Link to post
Share on other sites

I ran the test and received the following message:

 

Duplicate meta description found:

for English

exists more than once.

 

I checked the source code (view source) and didn't see a duplicate meta description.

Share this post


Link to post
Share on other sites

I ran the test and received the following message:

 

Duplicate meta description found:

for English

exists more than once.

 

I checked the source code (view source) and didn't see a duplicate meta description.

It means for different products or categories. They will be listed. You need to check them to find the problem. It is usually caused by linked or duplicate products but could be other reasons.

Share this post


Link to post
Share on other sites

I noticed the Title tags, generated from the product_info.php file, repeat the name of the category a second time and also contains two hyphens:

 

Category Name - Category Name - - Product Name

 

I checked the product_info.php file and didn't see where anything was duplicated.

 

<head>
<?php
/*** Begin Header Tags SEO ***/
if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {
 require(DIR_WS_INCLUDES . 'header_tags.php');
} else {
?>
 <meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
 <title><?php echo TITLE; ?></title>
<?php
}
/*** End Header Tags SEO ***/
?>
<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">
<link rel="stylesheet" type="text/css" href="stylesheet.css">
<script language="javascript" type="text/javascript"><!--
function popupWindow(url) {
 window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,left=150')
}
//--></script>

<?php // MVS Shipping Estimator Start ?>
<script language="javascript" type="text/javascript"><!--
function estimatorpopupWindow(URL) {
 window.open(URL,'productsshippingestimator','toolbar=0,scrollbars=1,location=0,statusbar=0,menubar=0,resizable=1,width=800,height=600')
}
//--></script>
<?php // MVS Shipping Estimator End ?>
</head>
<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">
<?php /*** Begin Header Tags SEO ***/ ?>
<a name="<?php echo $header_tags_array['title']; ?>"></a>
<?php /*** End Header Tags SEO ***/ ?>
<!-- header //-->
<?php require(DIR_WS_INCLUDES . 'header.php'); ?>
<!-- header_eof //-->

<!-- body //-->

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×