Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

I am using that..

 

I have installed thees contribs only.

 

oscommerce-2.2rc2a.zip

norwegian_2.2_RC2a.zip Language files.

HeaderTags_SEO_V_3.1.8.zip

tinyMCE Anywhere.zip with the updated ibrowser update 20070917.zip (the other ones was for mail/news)

 

What i found out so far is.

In firefox it is working.

In IE 8 it is not working(set site as trusted site dident help.)

 

Any suggestion to what settings i have to change in IE to get it to work.

I don't know what problem you are having but if it is just that the editor isn't showing, then be sure the options in admin for Header Tags are enabled. Otherwise, it's not a Header Tags issue. You will need to ask in the support thread for TinyMCE.

Share this post


Link to post
Share on other sites

Hi Jack,

I have installed Header Tag SEO and is working fine on my site even TEST does not show any error. Everything is fine. But Jack I found alignment of my site is tilted. I also check proper file added correctly. I also use WinMerge to compare site pages, nothing was found. You are requested to help me out of this problem why the alignment is tilted and and header banner just go up above.

You've made some mistake in the installation. Determine what page "is tilted" and re-install the changes or use the one from the archive.

Share this post


Link to post
Share on other sites

Errors:

1. At the top of every Category (and sub-cat) page, 'path Standard' text is displayed above shop logo in top left. Home and info pages are OK. Assume it must be towards the top of index.php but can't see anything obvious.

That is a problem from a previous version. You need to replace all of the files on your server with the ones from the catalog directory.

Share this post


Link to post
Share on other sites

That is a problem from a previous version. You need to replace all of the files on your server with the ones from the catalog directory.

 

Thanks for your fast reply Jack. Too fast!

 

Yep, I just discovered I have 2 downloads of Header Tags - different version - and I was 'mix-and-matching' inadvertantly!!

 

Copied the correct files across and problems resolved. Sorry about that.

 

Last prob to sort out in Admin menu: between Page Control and Fill Tags I now have BOX_HEADER-TAGS_SILO - haven't gone thru' files yet but more human error I suspect.

 

Thanks for your time & effort,

Mike

Share this post


Link to post
Share on other sites

I dont know whether it is right to ask for help as regards this but could i enlist some help with sorting this contribution out on my site as i have a custom index.php and various other files, i could upload the index.php to someoe if needed as sort out a donation of somekind, i am using the greenmania template with altered colours.

 

thanks

Alan SB

Edited by squarebanana

Share this post


Link to post
Share on other sites

Hi Jack, I have previously installed your SEO Header Tags 3.1.1 for RC2. I have now tried to install 3.1.8 but its not clear how to move from 3.1.1 as the file to update the database terminates as it thinks that Header Tags is already installed. I guess if I go ahead and copy the files to my site its going to break it. I have a fully moded backup waiting to be installed. Also I tried to use the header_tags_seo_convert.php but it finds no headr=er file. My site has worked freat with 3.1.1 but now I need the extra features of 3.1.8. whats the process to move from 3.1.1? I dont want to mess up the database. I have only just joined the forum so if I have rambled on too much I will stop right now ...

Share this post


Link to post
Share on other sites

There's several posts in this thread detailing how to upgrade, but in short:

 

- If you don't care that you lose your existing titles and meta tags entries, run the uninstall and install scripts. If you do, run through all of the update files and make the database changes as they are found.

 

- Upload all of the files in the catalog directory.

 

- Make new changes to your shops files as detailed in the update files or in the main installation files.

Share this post


Link to post
Share on other sites

thanks Jack mcs

 

 

In the new edition Header Tags SEO V 3.1.8

 

 

why have to Remove breadcrumb code from index.php in RC2 (found by gemcom)?

 

 

thanks

Edited by zozzoozzz

Share this post


Link to post
Share on other sites

In the new edition Header Tags SEO V 3.1.8

 

why have to Remove breadcrumb code from index.php in RC2 (found by gemcom)?

I somehow mistakenly added that code into the previous version of Header Tags. Some copy/paste mishap, I suppose.

Share this post


Link to post
Share on other sites

After install of Header Tags SEO V 3.1.8 (correct version files this time!) everything now works OK - except...

 

in french language products page, after 'currently viewing:' the breadcrumb trail appears to be lost: the right column is displayed in the centre of the page immediately under 'currently viewing:'.

Subcategories displays seem Ok and everything works fine in English version. Files uploaded to both English and French dirs.

 

I trailed thru' all the updated files and checked for instances of language id, etc., but all seems to be there.

Any idea of what or where I should check for before I go for another install attempt?

 

Thanks

Mike

Share this post


Link to post
Share on other sites

in french language products page, after 'currently viewing:' the breadcrumb trail appears to be lost: the right column is displayed in the centre of the page immediately under 'currently viewing:'.

Subcategories displays seem Ok and everything works fine in English version. Files uploaded to both English and French dirs.

Hmm, strange. There shouldn't be any difference, providing the database is setup correctly for each language. I would remove all of the Header Tags code changes from the product pages and make sure the page works in both languages. Then make the edits to that page one at a time, checking in both languages each time, to isolate the part causing the failure.

Share this post


Link to post
Share on other sites

Hmm, strange. There shouldn't be any difference, providing the database is setup correctly for each language. I would remove all of the Header Tags code changes from the product pages and make sure the page works in both languages. Then make the edits to that page one at a time, checking in both languages each time, to isolate the part causing the failure.

Hi Jack,

Found one bug in the code from the Install_Catalog.txt file:

In the products_info section, FIND around line 240, there is a line:

 

<?php echo '<a title="' . $header_tags_array['title'] . '" href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL') . '"/# ' . $header_tags_array['title'] . '">' . $header_tags_array['title']; ?></a></td>

 

If I move the <a to before <?php as <a> the pages display OK in both languages. BUT... the categories path is still missing from the French version, just the url is shown; english version OK, so still to find that prob.

 

Let you know if I find it.

Mike

Share this post


Link to post
Share on other sites

Hi Jack,

Found one bug in the code from the Install_Catalog.txt file:

In the products_info section, FIND around line 240, there is a line:

 

<?php echo '<a title="' . $header_tags_array['title'] . '" href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL') . '"/# ' . $header_tags_array['title'] . '">' . $header_tags_array['title']; ?></a></td>

 

If I move the <a to before <?php as <a> the pages display OK in both languages. BUT... the categories path is still missing from the French version, just the url is shown; english version OK, so still to find that prob.

 

Let you know if I find it.

Mike

Hi Jack,

 

Please ignore the post above - I tried to edit it but got locked out. 2 mins after the post, I spotted my error.

 

All now resolved - I think!

Schoolboy error (of course) - I hadn't checked all the right boxes in Admin/Page Control. Still, I had a few hours of searching thru' the codes and actually thought I had found a bug for you, but not so.

All the best,

Mike

Share this post


Link to post
Share on other sites

Hi Jack,

 

Please ignore the post above - I tried to edit it but got locked out. 2 mins after the post, I spotted my error.

 

All now resolved - I think!

Schoolboy error (of course) - I hadn't checked all the right boxes in Admin/Page Control. Still, I had a few hours of searching thru' the codes and actually thought I had found a bug for you, but not so.

All the best,

Mike

 

 

Hi Mike

 

I see your post

 

I found also the same as you did in.

 

<?php echo '<a title="' . $header_tags_array['title'] . '" href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL') . '"/# ' . $header_tags_array['title'] . '">' . $header_tags_array['title']; ?></a></td>

 

JUST REMOVE THIS

'"/# ' . $header_tags_array['title'] . '">' .

 

Now the new code will be look like and everything will be fine:

 

<?php echo '<a title="' . $header_tags_array['title'] . '" href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL') . $header_tags_array['title']; ?></a></td>

Share this post


Link to post
Share on other sites

Hi Jack

Everything was working fine and default title, description, keywords for categories and sub-categories for header tag code enabled pages working fine. Now I have the problem on title, description, keywords for categories and sub-categories on are the same as index.php. This problem begins when I again modify and update Metag Tags for index.php in Header Tag Page Controll. Can you tell me how you solved this problem.

Share this post


Link to post
Share on other sites

Regarding my save HT SEO categori description error i am not sure it is tinymce editor error. Because the editor work as expected all other places. In products, in information pages unlimited, ....

If i take this up in Tinymce forum they will only direct me back here, as it is only HT SEO that have the error.

 

I have tryed to make some picture showing the error to you.

 

1. If i go into admin in IE and make this text and save.

chamge%20in%20IE%20and%20save.png

 

2. Then i show in shop.

show%20in%20shop.png

 

3. Show in admin again.

show%20in%20IE%20admin.png

 

4. If i go in IE and delete wast text and save again it will show up with this in shop again.

In edit it show this text. some more..

Share this post


Link to post
Share on other sites

Show%20in%20edit%20again%20IE.png

 

As you can se it is putting in some garbage text from somewhere. And it is only in categori description.

I have the old shop doing it, and i set up a new one from scratch with same problem.

 

I think it have to do somthing about the update function to categori descriptions.

If you want to look more close i can give you the IP adresss and login to check.

 

Sorry for letting this over 2 msg. but pressed the wrong button..

Share this post


Link to post
Share on other sites

Hi Jack

Everything was working fine and default title, description, keywords for categories and sub-categories for header tag code enabled pages working fine. Now I have the problem on title, description, keywords for categories and sub-categories on are the same as index.php. This problem begins when I again modify and update Metag Tags for index.php in Header Tag Page Controll. Can you tell me how you solved this problem.

You may have unchecked the category box for the index.php page in page control. Also check that the tags actually exist by looking at the category edit page.

Share this post


Link to post
Share on other sites

I think it have to do somthing about the update function to categori descriptions.

If you want to look more close i can give you the IP adresss and login to check.

See the troubleshooting section in Install_Admin.txt for problems with the category page.

Share this post


Link to post
Share on other sites

Jack,

 

Quick question please - Does Header Tags SEO change the way that the category path and product name are called into a file?

 

I am having a small issue with PDF DataSheet Maker. If you would take a quick peek at this thread and let me know if you have any suggestions, I would be most grateful. http://forums.oscommerce.com/topic/347916-php3mysql3-php5mysql5-question/

 

Thank you so much for your assistance.


-Dave

Share this post


Link to post
Share on other sites

Quick question please - Does Header Tags SEO change the way that the category path and product name are called into a file?

No. Header Tags doesn't change the url's.

Share this post


Link to post
Share on other sites

No. Header Tags doesn't change the url's.

 

Thank you for the reply Jack. Its not a url issue, its a "cat path" and "product name" not showing up in a on-the-fly creation of a pdf datsheet for a product... but thanks for looking. :)


-Dave

Share this post


Link to post
Share on other sites

hi I am kinda new to this and have tried to install header tags seo 3.1.7 and I keep getting this error

 

1146 - Table 'btfr_osc2.TABLE_HEADERTAGS_DEFAULT' doesn't exist

 

select * from TABLE_HEADERTAGS_DEFAULT where language_id = '1'

 

[TEP STOP]

 

I have checked and it does exist but I still get this error. The admin part of it seems to work fine tho.

 

can you tell me how i can fix it?

Share this post


Link to post
Share on other sites

hi I am kinda new to this and have tried to install header tags seo 3.1.7 and I keep getting this error

 

1146 - Table 'btfr_osc2.TABLE_HEADERTAGS_DEFAULT' doesn't exist

First - download version 3.18 instead of 3.17.

Second - capital letters in an error mean there is a definition missing. So you need to go through the instructions and look for changes to the database_tables.php file to fix that.

Share this post


Link to post
Share on other sites

See the troubleshooting section in Install_Admin.txt for problems with the category page.

 

I have checkt that one out. I have tryed with the categories file from 3.1.8 RC2 folder, i have checked all changes in install admin and compared to the RC2 file in 3.1.8 and there is onlu minor different as empty lines and different commenting...

 

You can se the categories.php file her

 

I still cant enter more than a few character in cat des. it crops at a fixed length as far as i can se. And it is only with categori descriptions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×