Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

The code could be changed in includes/functions/header_tags.php but I'm not sure it is worth the effort. The canonical code will change list the url using index.php and the search engines will note the redirect for that. It's a little extra work for them but they should figure it out. I could be mistaken about that but the only way to know is to see if the index.php link shows up in the listings. If the code was changed, it would have to be specific to shops that use that code. Granted, all shops should use it, but many don't and changing the code in the contribution would break those shops. So, at this point, if you want that change, the code change will have to be made in just your shop.

 

Jack

 

Hi Jack,

I want the canonical link to be http://www.mydomain.com/ at www.mydomain.com and www.mydomain.com/index.php,

 

I dont want the index.php followed because it harms my ranking, now only www.mydomin.com/index.php shows in serps not www.mydomain.com.

 

Please tell me how to modify "includes/functions/header_tags.php" ?

 

Thanks

Share this post


Link to post
Share on other sites
Hi Jack,

I want the canonical link to be http://www.mydomain.com/ at www.mydomain.com and www.mydomain.com/index.php,

 

I dont want the index.php followed because it harms my ranking, now only www.mydomin.com/index.php shows in serps not www.mydomain.com.

 

Please tell me how to modify "includes/functions/header_tags.php" ?

 

Thanks

Try the redirect as recently discussed.

 

Jack

Share this post


Link to post
Share on other sites

Jack,

 

Good morning. Installed 3.1.7 on a new RC2a installation over the weekend. Install went flawless. Thanks for the incredibly accurate and detailed install process. Your contributions are always so well organized. Thanks!

 

Now I spent all last night scanning and searching this thread but could not find a specific answer for the following: see the error

 

Warning: chmod(): Operation not permitted in /var/www/xxxxxx/admin/includes/functions/header_tags.php on line 932
Cannot change the permission on /var/www/xxxxxx/includes/header_tags.php  Permissions settings for the /var/www/xxxxx/includes/header_tags.php file appear to be incorrect. Change to 755. 

 

I focused on resolving the permssions error before worrying about the chmod error. I tried includes/header.php at 777 and 755. nothing seems to matter.

shop is running on Linux 2.4.21-58.EL php4.3.2 and MySQL 3.23.58

 

Could the error be occuriing because the server systems are so outdated? could .htaccesss be preventing the file from being writeable? I am just grasping at straws at this point. Something I missed? any ideas appreciated. And FYI no other errors appear when running Test... flawless :)

Edited by Roaddoctor

-Dave

Share this post


Link to post
Share on other sites

Now I spent all last night scanning and searching this thread but could not find a specific answer for the following: see the error

See the Install_Admin.txt file for that error.

Share this post


Link to post
Share on other sites

See the Install_Admin.txt file for that error.

 

Well, yes I read that last night (several times, trust me :)), and I am doing as you requested, trying to resolve the permissions error before removing the chmod funtion for headers.php. Replacing that code just kills the module to Exit; :(

 

Are you saying the permissions error is un-fixable given my host environment? or because ??? (I am my own host on a box with ThePlanet. I have full webmin access) Are their changes I can make? Could the permissions error have anything to do with ownership of the file? Headers is currently owned by the same user as the database. I hope that makes sense.

Would upgrading php/mysql help?

 

Thank you in advance... much appreciated

 

Dave


-Dave

Share this post


Link to post
Share on other sites

Are you saying the permissions error is un-fixable given my host environment? or because ??? (I am my own host on a box with ThePlanet. I have full webmin access) Are their changes I can make? Could the permissions error have anything to do with ownership of the file? Headers is currently owned by the same user as the database. I hope that makes sense.

Would upgrading php/mysql help?

Setting the permissions to whatever those are on the images directory should work. If you still get the error, it might be something in the server setup that is preventing the code from working. The peremissions message is just a warning in some cases though. If the code still works, you can disable that setting. If you can add some new page, like privacy.php, and change the title for it in Page Control and have that title show up on that page on the site, then everything is working correctly. If you can't, then you need to find the reason. I would start with the chmod code, as mentioned.

Share this post


Link to post
Share on other sites

just a long shot -

 

There is an .htaccess file in catalog/includes. Would this prevent the file from being accessible?

 

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $
#
# This is used with Apache WebServers
# The following blocks direct HTTP requests in this directory recursively
#
# For this to work, you must include the parameter 'Limit' to the AllowOverride configuration
#
# Example:
#
#<Directory "/usr/local/apache/htdocs">
#  AllowOverride Limit
#
# 'All' with also work. (This configuration is in your apache/conf/httpd.conf file)
#
# This does not affect PHP include/require functions
#
# Example: http://server/catalog/includes/application_top.php will not work

<Files *.php>
Order Deny,Allow
Deny from all
</Files>


-Dave

Share this post


Link to post
Share on other sites

There is an .htaccess file in catalog/includes. Would this prevent the file from being accessible?

No, that's not it. That is a standard file and works fine as it is.

Share this post


Link to post
Share on other sites

No, that's not it. That is a standard file and works fine as it is.

 

After some searching, I've determined this is a "File Ownership" issue with the the header.php file.

 

For example, assume:

 

Apache runs as: User Apache Group Apache

The store runs as some other user / group = this contribution will not work.

 

I know this is off-topic to this thread - but it does directly apply to what is a significant problem for some with this contibution.

 

If anyone can provide any guidance how to resolve file ownership... ie obviously my server configuration. any help is greatly appreciated. My linux skills are near nil. a pointer on where to read up would be great as well.

 

Thanks in advance


-Dave

Share this post


Link to post
Share on other sites

Hi all,

 

Not been on here for a while but now have a new project underway so am a bit rusty. I have installed the following contributions:

 

STS

Sid Killer

Headertags SEO

 

All was going fine, except now when i click on a product category i am receiving the following error:

Fatal error: Call to undefined function: last() in c:\program files\easyphp1-8\www\index.php on line 82

 

The lines in question refers to the following code:-

 

<?php /*** Begin Header Tags SEO ***/ ?>

<td><h1><?php echo $category['categories_htc_title_tag']; ?></h1></td>

<td class="pageHeading"><?php echo $breadcrumb->last(); ?>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

<?php if (tep_not_null($category['categories_htc_description'])) { ?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td colspan="2"><h2><?php echo $category['categories_htc_description']; ?></h2></td>

</tr>

<?php }

I have checked through pages of code, but cannot find any relation to the function last(), any ideas?

 

Best regards

 

Donna

Share this post


Link to post
Share on other sites

To find the fix, go to the bottom of this page, type in last() in the search box and click go.

 

Also, I recommend you remove the SID Killer. It is no longer needed and can cause problems.

Share this post


Link to post
Share on other sites

Hi can some one help me here please i get this errors I have added the code to product_info.php but i can't see it in the pagecontrol.

 

Database/File Mismatch Error: explain

The number of file entries in the database (1) does not match the number in the includes/header_tags.php file (6).

Files not in the database:

product_info.php

product_reviews.php

product_reviews_info.php

product_reviews_write.php

specials.php

Edited by rafael-cdkeyhouse

Share this post


Link to post
Share on other sites

Hi can some one help me here please i get this errors I have added the code to product_info.php but i can't see it in the pagecontrol.

 

Database/File Mismatch Error: explain

The number of file entries in the database (1) does not match the number in the includes/header_tags.php file (6).

Files not in the database:

product_info.php

product_reviews.php

product_reviews_info.php

product_reviews_write.php

specials.php

 

I have fixed the problem

 

for those that have the same problem i have just

 

upload the install and un-install database and i have un-installed the database and install again and work now.

Share this post


Link to post
Share on other sites

Hi,

 

I wonder where I can find instructions how to make the settings when installed, i really dont understand how and where to ad all keywords

Share this post


Link to post
Share on other sites

Hi,

 

I wonder where I can find instructions how to make the settings when installed, i really dont understand how and where to ad all keywords

Share this post


Link to post
Share on other sites

Hi,

 

I wonder where I can find instructions how to make the settings when installed, i really dont understand how and where to ad all keywords

Did you follow the instructions in the How To Operate file?

Share this post


Link to post
Share on other sites

It means there are two items with the same information. It could be due to languages. You will have to search them to be sure. Use Fill Tags->Fill Empty wtth Show results set to see if such items show up.

 

Jack

 

Hi Jack, sorry I know you my question immediately in September but I have only just read it and done what you suggested. I am very pleased to say that it worked a treat so basically I am just saying thanks, its much appreciated.

 

Michael

Share this post


Link to post
Share on other sites

Did you follow the instructions in the How To Operate file?

 

 

Yes i have but still dont understand how to write the keywords for each page

 

So I choose on file and the just ad same keywords in all fields?

 

What about all those boxes with Google, Language etc etc...which one should be choosen?

Share this post


Link to post
Share on other sites

Yes i have but still dont understand how to write the keywords for each page

 

So I choose on file and the just ad same keywords in all fields?

 

What about all those boxes with Google, Language etc etc...which one should be choosen?

No, keywords need to be specific to the page they are on. That is what Fill Tags is for. But picking out keywords is beyond the scope of support here. Search the web for SEO and keywords.

 

I'm not familiar with boxes labelled google and lanuage so I can't help with that.

Share this post


Link to post
Share on other sites

Hallo,

 

I hope I am here correct…

 

I have a problem along "Header Tags SEO" and "Seo Urls 5". I installed both. If I"Seo Urls 5" do not activate functioned "Header Tags SEO" no more. As soon as I activate search engines reliably URL, the title is not any longer indicated to the side. What could lie?

 

Unfortunately my English is not good. I hope you can my problem nevertheless understand and possibly a solution communicate.

Thanks Frank

 

"Header Tags SEO" -> http://www.oscommerc...y/contributions,5851/category,all/search,Header+Tags

 

"Seo Urls 5" -> http://www.oscommerc...y/contributions,6768/category,all/search,Seo+Urls+5

 

Hallo,

 

ich habe ein Problem mit "Header Tags SEO" und "Seo Urls 5". Beides habe ich installiert. Wenn ich "Seo Urls 5" aktiviere funktioniert "Header Tags SEO" nicht mehr. Sobald ich Suchmaschinen sicher URL aktiviere, wird der Titel der Seite nicht mehr angezeigt. Woran könnte das liegen?

 

Leider ist mein Englisch nicht gut. Ich hoffe Du kannst mein Problem trotzdem verstehen und eventuell eine Lösung mitteilen.

 

Danke

Frank

Share this post


Link to post
Share on other sites

I have a problem along "Header Tags SEO" and "Seo Urls 5". I installed both. If I"Seo Urls 5" do not activate functioned "Header Tags SEO" no more. As soon as I activate search engines reliably URL, the title is not any longer indicated to the side. What could lie?

I don't use SEO Urls 5 so I can't say for sure what your problem is. But others have posted here that they work together. There is, from what I understand, a setting in that contribution that needs to be set for it to work with Header Tags. You would need to ask in that support thread on how to use that though. If you turn SEO Urls 5 off and the HEader Tags code works correctly, then the problem is with SEO Urls 5.

Share this post


Link to post
Share on other sites

Ok, i have installed it and follow the instructions for filling out the empty fields

 

I cant see any chnage on my site in google or in any other way

 

Is it possible to check the changes in some easy way online?

Share this post


Link to post
Share on other sites

Ok, i have installed it and follow the instructions for filling out the empty fields

 

I cant see any chnage on my site in google or in any other way

 

Is it possible to check the changes in some easy way online?

It sounds like you didn't install it correctly since you are not seeing a title change, as explained in the docs. And since you didn't post the results of the test script, I assume you didn't try that either.

Share this post


Link to post
Share on other sites

Hi Jack

 

I have installed header tags seo 3.1.7 by following the steps you wrote. However,I got stuck immediately after 1st step by uploading the headertags_seo_install.php under index page. The follow error message is what I got.

 

"1060 - Duplicate column name 'categories_htc_title_tag'

ALTER TABLE categories_description ADD categories_htc_title_tag VARCHAR(80) NULL;

[TEP STOP]"

 

Can you guide me how to rectify this issue?

 

I am a beginner for oscommerce. I'm not so sure whether my sitemap version (sitemap_seo.php 1739 2008-12-20 by Jack_mcs) is deemed as previous version where I can upload this sql instead. Can you also let me know what is previous version before 3.1.7? :'(

 

Sorry to ask again if this issue has addressed to you previously. If so, pls just guide me where to find ur post related to this issue.

 

many thanks

 

organicme

Share this post


Link to post
Share on other sites

It sounds like you didn't install it correctly since you are not seeing a title change, as explained in the docs. And since you didn't post the results of the test script, I assume you didn't try that either.

 

 

Very strange, i have done as it says but look at the tags and headlines for www.modevaskor.com

 

All i still the same as before the contrib was installed

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×