Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Hi Jack

 

I have your Header Tags Controller v2.6.3 which I think is the most up-to-date. Am very happy with it but also realised that I needed to check all my SEO contributions to see if they needed up-dating. I also have Chemos Ultimate SEO URLs v2.1c which I will leave as previously suggested by you this is the best version to have.

 

Also your Dynamic sitemap v1.6 if this affects this?

 

I don't update all of my contributions as sometimes they add or change features that I don't want/need. SEO is sometimes different.

 

My question is should I up-date my Header Tags to the latest version of your Header Tags SEO. I feel a little rusty and don't want to break my shop, but I know your instructions are easy to follow. Do I have to follow all the versions up to the latest or can I use the latest instructions to update from my version to your latest?

 

Thanks for your help.

Julie

 

forgot to say I'm running MS2

Edited by warrenerjm

Share this post


Link to post
Share on other sites
Hi Jack

 

I have your Header Tags Controller v2.6.3 which I think is the most up-to-date. Am very happy with it but also realised that I needed to check all my SEO contributions to see if they needed up-dating. I also have Chemos Ultimate SEO URLs v2.1c which I will leave as previously suggested by you this is the best version to have.

 

Also your Dynamic sitemap v1.6 if this affects this?

 

I don't update all of my contributions as sometimes they add or change features that I don't want/need. SEO is sometimes different.

 

My question is should I up-date my Header Tags to the latest version of your Header Tags SEO. I feel a little rusty and don't want to break my shop, but I know your instructions are easy to follow. Do I have to follow all the versions up to the latest or can I use the latest instructions to update from my version to your latest?

 

Thanks for your help.

Julie

 

forgot to say I'm running MS2

If your shop is working and ranking well with those contributions, then you don't need to change anything. But Header Tags Controller had problems in the code and does not handle duplicate content pages, among many other things, so it would be beneficial to upgrade. If you did that, Ultimate SEO should be upgraded to my latest version since the one you have will delete entries from the database. Dynamic Sitemap could be replaced with Sitemap SEO. It is not needed but the latter provides better listings. But those are not trivial changes so if you are not experienced in such matters, you may need to consider the benefits versus the risks.

 

Jack

 

Jack

Share this post


Link to post
Share on other sites
If your shop is working and ranking well with those contributions, then you don't need to change anything. But Header Tags Controller had problems in the code and does not handle duplicate content pages, among many other things, so it would be beneficial to upgrade. If you did that, Ultimate SEO should be upgraded to my latest version since the one you have will delete entries from the database. Dynamic Sitemap could be replaced with Sitemap SEO. It is not needed but the latter provides better listings. But those are not trivial changes so if you are not experienced in such matters, you may need to consider the benefits versus the risks.

 

Jack

 

Jack

Thanks Jack

 

Not after doing un-necessary work! ;o)

How will I know about the duplicate content pages? Is there a way I can check my site please? The only problem I had was when adding a new page, but if I remember rightly you suggested this latest update so that shouldn't be relevant? Been having a play with the settings etc & the keywords etc to try & get the right ones showing, so that may be better than messing with a perfectly good working version.

 

Didn't know about Sitemap SEO so will look at that one.

 

Have added lots of contributions, & if you have written instructions I know it will be easy to follow..just haven't touched it for about a year so thought I'd better have a review. Always nervous even with backing up...just me!

 

Thanks again for your advise. Much appreciated.

Share this post


Link to post
Share on other sites

Sitemap SEO...you have two Jack? Do I do both or one?

 

Google XML Sitemap SEO Does this replace Chemos Google XML Sitemap Feed Documentation that I have installed?

 

Sitemap SEO Does this replace your Dynamic Sitemap?

 

Can I upgrade to these or do I need to un-install (never done that before!)

 

Sorry for extra post.

Share this post


Link to post
Share on other sites
Thanks Jack

 

Not after doing un-necessary work! ;o)

How will I know about the duplicate content pages? Is there a way I can check my site please?

If you have google sitemap account, it will list them there. Otherwise, I'm not aware of a way to check them.

 

Jack

Share this post


Link to post
Share on other sites
Sitemap SEO...you have two Jack? Do I do both or one?

 

Google XML Sitemap SEO Does this replace Chemos Google XML Sitemap Feed Documentation that I have installed?

 

Sitemap SEO Does this replace your Dynamic Sitemap?

 

Can I upgrade to these or do I need to un-install (never done that before!)

 

Sorry for extra post.

They should both be installed. Sitemap SEO replaces Dnamic Sitemap. But please ask any other questions regardnig these in a different thread since this one is only for Header Tags SEO support.

 

Jack

Share this post


Link to post
Share on other sites

Have just upgraded from a very early version of this, and have just two small issues I cannot seem to get to grips with.

 

One is the index title (store name)

It is now showing a blank space where it would be, yet the categories and product titles on those pages show fine. Thinking about it, I would rather remove the title on top of the index as opposed to placing it back on. With the changes within the file(s) that this contribution adds, I am finding it hard just to remove the index title at the top (store name)

 

Is there an easy way of doing this Jack without affecting category titles and product titles on other pages?

 

The other issue is, within admin/Header tags SEO it says at the top:

Found Missing Tags:

Products table has 644 items with missing meta tag information.Categories table has 14 items with missing meta tag information.

Now that would be all products and categories, but yet within the site and checking products in 'View Source' they are all listed there perfect.

I am a little dubious about tweaking settings too much (fill empty tags) as it would mean losing all product keywords.

 

An easy solution?

 

Thanks for your time!

Edited by modulate

Share this post


Link to post
Share on other sites
Have just upgraded from a very early version of this, and have just two small issues I cannot seem to get to grips with.

 

One is the index title (store name)

It is now showing a blank space where it would be, yet the categories and product titles on those pages show fine. Thinking about it, I would rather remove the title on top of the index as opposed to placing it back on. With the changes within the file(s) that this contribution adds, I am finding it hard just to remove the index title at the top (store name)

 

Is there an easy way of doing this Jack without affecting category titles and product titles on other pages?

I'm not clear on where the blank space is displayed. But the title of the index page (both the home and categories) is controlled in page control for index.php. You shouldn't remove the title for the home page, if that is what you mean. But if you mean to remove it from the categories page, then uncheck the root checkbox.
The other issue is, within admin/Header tags SEO it says at the top:

 

Now that would be all products and categories, but yet within the site and checking products in 'View Source' they are all listed there perfect.

When you run fill tags, it will provide links to the missing items. Or you can run the test routine and get to them that way. Many times it is due to an extra language that is installed but not setup.
I am a little dubious about tweaking settings too much (fill empty tags) as it would mean losing all product keywords.

Fill empty tags means fill the ones that don't have entries so you wouldn't lose any information.

 

Jack

Share this post


Link to post
Share on other sites

Wow thanks for your help Jack, really appreciate it.

 

The missing tags were indeed down to unused languages within the store, the message has gone from the top, but now on 'test' it gives this error..

Fatal error: Call to undefined function tep_hide_session_id() in /var/www/../httpdocs/admin/header_tags_test.php on line 519

 

Also, re the missing title, I mean where it normally says the store title at the top on index page under the header..

topindex.th.jpg

The header tags work fine on index, its just a slight cosmetic change its made that I can find out how to alter.

 

Many thanks for your help.

Share this post


Link to post
Share on other sites
Wow thanks for your help Jack, really appreciate it.

 

The missing tags were indeed down to unused languages within the store, the message has gone from the top, but now on 'test' it gives this error..

 

 

Also, re the missing title, I mean where it normally says the store title at the top on index page under the header..

topindex.th.jpg

The header tags work fine on index, its just a slight cosmetic change its made that I can find out how to alter.

 

Many thanks for your help.

The tep_hide_session_id can be fixed by following the install instructions or reading back a page or two where it was discussed here.

 

As for the index, I'm still not clear what you mean by index. The index.php file handles the home page as well as categories and sub-category pages. If you can figure out which one has the problem, it would be easier to find the fix. A link to the site would also be helpful so I can see the problem.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

 

After adding header tags, the subcategory listing order on my site is not alphabetized. Its now listing the latest sub-cateogies at the top, instead of alphabetically like before. Any advice on how I can resolve this?

Share this post


Link to post
Share on other sites
The tep_hide_session_id can be fixed by following the install instructions or reading back a page or two where it was discussed here.

 

As for the index, I'm still not clear what you mean by index. The index.php file handles the home page as well as categories and sub-category pages. If you can figure out which one has the problem, it would be easier to find the fix. A link to the site would also be helpful so I can see the problem.

 

Jack

 

Many thanks on the tep_hide issue, that is now running fine.

 

Have sent site link and you will see what I mean re the home title on the index. I also noticed category text that appears on each category at the top no longer shows, so is definitely something along the lines of that part of each page.

 

Probably something very simple that I've missed, though have checked all the upgrade edits and even compared it to new edits on the latest version and just can't find where it could be missing something.

 

Thanks for your help.

Share this post


Link to post
Share on other sites
Hi Jack,

 

After adding header tags, the subcategory listing order on my site is not alphabetized. Its now listing the latest sub-cateogies at the top, instead of alphabetically like before. Any advice on how I can resolve this?

There's nothing in Header Tags that would change that. You may have altered the code that does handle it in index.php by mistake though. I suggest replacing the index,php file with the original to make sure the sorting is correct. Then add in the changes one at a time, checking after each one.

 

Jack

Share this post


Link to post
Share on other sites
Have sent site link and you will see what I mean re the home title on the index. I also noticed category text that appears on each category at the top no longer shows, so is definitely something along the lines of that part of each page.

 

Probably something very simple that I've missed, though have checked all the upgrade edits and even compared it to new edits on the latest version and just can't find where it could be missing something.

That blank area is in the home section of the index page which Header Tags doesn't change so the problem is elsewhere. It only changes the categories and sub-categories and they are working fine on your shop. If you drag your mouse across that area, you will see there is something being drawn there. You will have to look at your index.php file to see what is causing that.

 

Jack

Share this post


Link to post
Share on other sites

I had a copy of the index saved from last year when the category text worked, so had a look through that and found this code in the earlier file

<td align="right"><?php echo tep_image(DIR_WS_IMAGES . $image, $category['categories_htc_title_tag'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
	  </tr>		   
	  <?php if (tep_not_null($htc['htc_description'])) { ?> 
	  <tr>
	   <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
	  <tr>
	   <td colspan="2"><h2><?php echo $htc['htc_description']; ?></h2></td>
	  </tr>
	  <?php } ?>

After adding that the category descriptions work again, is that older code from an earlier version.

Share this post


Link to post
Share on other sites
I had a copy of the index saved from last year when the category text worked, so had a look through that and found this code in the earlier file

 

After adding that the category descriptions work again, is that older code from an earlier version.

It appears to be the same code in use now. However, it doesn't go in the home section of index.php so if that is where it is located, that is the problem.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

 

I had installed the Header Tags SEO, and other contributions from you, I can find Header Tags SEO at Admin, but I can not find Header Tags SEO at Catalog/Admin/Configuration.

May I missed something?

 

Thanks!

 

Dansino

Share this post


Link to post
Share on other sites
I had installed the Header Tags SEO, and other contributions from you, I can find Header Tags SEO at Admin, but I can not find Header Tags SEO at Catalog/Admin/Configuration.

May I missed something?

Then you've made a mistake in the installation or that was deleted for some reason.

 

Jack

Share this post


Link to post
Share on other sites
It appears to be the same code in use now. However, it doesn't go in the home section of index.php so if that is where it is located, that is the problem.

 

Jack

 

Thanks Jack

 

This is what I saw listed with install (I went over it from fresh in case there was a conflict within the file through upgrades)

 

Index.php

 

FIND (Around line 298)

<td align="right"><?php echo tep_image(DIR_WS_IMAGES . $image, HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
  </tr>

  REPLACE with

	  <?php /*** Begin Header Tags SEO ***/ ?>
	   <td align="right"><?php echo tep_image(DIR_WS_IMAGES . $image, $htc['htc_title'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
	  </tr>
	  <?php if (tep_not_null($htc['htc_description'])) { ?>
	  <tr>
	   <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
	  <tr>
	   <td colspan="2"><h2><?php echo $htc['htc_description']; ?></h2></td>
	  </tr>
	  <?php } 
	  /*** End Header Tags SEO ***/ 
	  ?>

 

Now looking up the file slightly, it seems to appear twice, this is the last part of index.php

 

			<td align="right"><?php echo tep_image(DIR_WS_IMAGES . $image, $category['categories_htc_title_tag'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
	  </tr>		   
	  <?php if (tep_not_null($htc['htc_description'])) { ?> 
	  <tr>
	   <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
	  <tr>
	   <td colspan="2"><h2><?php echo $htc['htc_description']; ?></h2></td>
	  </tr>
	  <?php } ?>
	</table></td>
  </tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
  <tr>
	<td><?php include(DIR_WS_MODULES . FILENAME_PRODUCT_LISTING); ?></td>
  </tr>
  <!--- BEGIN Header Tags SEO Social Bookmarks -->
	  <?php if (HEADER_TAGS_DISPLAY_SOCIAL_BOOKMARKS == 'true')
	   include(DIR_WS_MODULES . 'header_tags_social_bookmarks.php');
	  ?>
	  <!--- END Header Tags SEO Social Bookmarks -->
</table></td>
<?php
 } else { // default page
?>
<td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0">
  <tr>
	<td><table border="0" width="100%" cellspacing="0" cellpadding="0">
	  <tr>
		<td class="pageHeading"><?php /*** Begin Header Tags SEO ***/ ?>
	   <td align="right"><?php echo tep_image(DIR_WS_IMAGES . $image, $htc['htc_title'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
	  </tr>
	  <?php if (tep_not_null($htc['htc_description'])) { ?>
	  <tr>
	   <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
	  <tr>
	   <td colspan="2"><h2><?php echo $htc['htc_description']; ?></h2></td>
	  </tr>
	  <?php } 
	  /*** End Header Tags SEO ***/ 
	  ?>
	</table></td>
  </tr>
  <tr>
	<td><table border="0" width="100%" cellspacing="0" cellpadding="0">
	  <tr>
		<td class="main"><?php echo TEXT_MAIN; ?></td>
	  </tr>
	  <tr>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>

<?php
   include(DIR_WS_MODULES . FILENAME_UPCOMING_PRODUCTS);
?>
	</table></td>
  </tr>
</table></td>
<?php
 }
?>
<!-- body_text_eof //-->
<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->
</table></td>
 </tr>
</table>
<!-- body_eof //-->

<!-- footer //-->
<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>
<!-- footer_eof //-->
<br>
</body>
</html>
<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

 

There is a conflict of code to be there twice, but when I remove the bottom Header tags block, it makes the description (actually on the page) empty on categories.

 

It is definitely a conflict on both code, it's just what to change that is baffling me.

 

Thanks for your help.

Share this post


Link to post
Share on other sites
Then you've made a mistake in the installation or that was deleted for some reason.

 

Jack

 

Hi Jack,

 

I 'd spent one hour to review the installation of Install_Admin.TXT and Install_Catalog.TXT, all steps had been done.

 

and all files had been checked too, there are as same as instruction. any ideal where I did wrong?Possible caused by another contribution?

 

also I found a issue: Please see 3883521897_fd1392ba45_b.jpg.

 

the page title come with "products new home" rather than categories name.

 

 

 

Thanks!

 

Dansino

Share this post


Link to post
Share on other sites
Thanks Jack

 

This is what I saw listed with install (I went over it from fresh in case there was a conflict within the file through upgrades)

 

Index.php

 

FIND (Around line 298)

 

There is a conflict of code to be there twice, but when I remove the bottom Header tags block, it makes the description (actually on the page) empty on categories.

 

It is definitely a conflict on both code, it's just what to change that is baffling me.

 

Thanks for your help.

No, there's no conflict. They both should be there. That's why the approximate line number is given.

 

Jack

Share this post


Link to post
Share on other sites
Hi Jack,

 

I 'd spent one hour to review the installation of Install_Admin.TXT and Install_Catalog.TXT, all steps had been done.

 

and all files had been checked too, there are as same as instruction. any ideal where I did wrong?Possible caused by another contribution?

 

the page title come with "products new home" rather than categories name.

That section is added by the database changes so the problem lies there. If possible, run the uninstall and install files - that will fix it.

 

For the products new home. please run the test routine before asking questions.

 

Jack

Share this post


Link to post
Share on other sites
Hi Jack,

 

I 'd spent one hour to review the installation of Install_Admin.TXT and Install_Catalog.TXT, all steps had been done.

 

and all files had been checked too, there are as same as instruction. any ideal where I did wrong? Possible caused by another contribution?

 

Dansino

 

You are using a version of Ultimate SEO Urls. Jack needs to fix this problem. For now you can simply run the following query in phpMyAdmin found in your Control Panel:

 

INSERT INTO `configuration_group` ( `configuration_group_id` , `configuration_group_title` , `configuration_group_description` , `sort_order` , `visible` )
VALUES ('543', 'Header Tags SEO', 'Header Tags SEO site wide options', '20' , '1');

Share this post


Link to post
Share on other sites

I want to change category page heading.

 

FROM THIS

2h4essw.jpg

 

TO THIS:

31681f9.jpg

 

 

Anyone can give a hint to keep me the right track?

What files should be edited?

 

Thanks in advance for any help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×