Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Fill tags did not work for me. It doesent do a thing.

 

Can plz look at my shop?

 

http://www.mgsl.de/demo/admin

 

(login:admin / pw: test)

Then you've made a mistake in the installation since that is just a script to read and write the database.

 

Jack

Share this post


Link to post
Share on other sites
Then you've made a mistake in the installation since that is just a script to read and write the database.

 

Jack

 

Do you know where the mistake can be? Because i get no error message or something and the "Page Control" Site is working fine!

Share this post


Link to post
Share on other sites
Do you know where the mistake can be? Because i get no error message or something and the "Page Control" Site is working fine!

Other than in admin, no.

 

Jack

Share this post


Link to post
Share on other sites
Yes, for it to work properly, only one installation method can be used. You can just remove the code from one page, like index.php, for a test though.

 

Jack

 

Okay Jack. I changed out all of the Header Tags SEO header info on all pages, but I am still getting no header tags when STS is activated. I am getting the following error on test:

 

Missing Database Error: explain

The Header Tags entry is missing from the configuration group table.

 

Since you uograded me, can you try reinstalling the database on the version you upgraded me to and I'll try again?

 

Thanks

Larry

Share this post


Link to post
Share on other sites
Okay Jack. I changed out all of the Header Tags SEO header info on all pages, but I am still getting no header tags when STS is activated. I am getting the following error on test:

 

Missing Database Error: explain

The Header Tags entry is missing from the configuration group table.

 

Since you uograded me, can you try reinstalling the database on the version you upgraded me to and I'll try again?

 

Thanks

Larry

It means part of the database is missing. You need to run the headertags_seo_uninstall.php and then the headertags_seo_install.php files to reset it to the original condition.

 

Jack

Share this post


Link to post
Share on other sites
I got he fill tags to work

 

http://www.mgsl.de/demo/muster-kategorie-c-32.html

 

But, the Titel of the page stays the same like the index.php

 

<title>Demo Online SHOP neu</title>

You proably haven't set up index.php in page control or you have the default title checked for it.

 

Jack

Share this post


Link to post
Share on other sites

after tinkering a bit with my catalog i finally figured out how to add headers and stuff for the products and categories. i guess i just didnt see it there before.

 

 

awesome contribution!!!!!!

Share this post


Link to post
Share on other sites

Hi, talrasha.

 

I see you also have installed seo urls and in konfiguration you have there two times display Seo urls and both have a error.

I dont not Know what kind of seo urls you have installed, but i had the same problem. I had installed Ultimate seo urls 5 and i had it on standart type. when i changed it to rewrite type it workd. I see you have al ready on rewrite type.

 

Maybe you have installed Header tags correct but is your problem seo urls

you can try to see if you have installed Header tags correct, You have to turn off seo urls.

If you set "ENABLE Seo urls" to false and by both because you have two installed.

 

and then try header tags. When it works your problem is seo urls.

 

 

.

Roy

Share this post


Link to post
Share on other sites
You proably haven't set up index.php in page control or you have the default title checked for it.

 

Jack

 

I installed the package from the beginning. Now it worked, but i get a new error "path Standard" .

 

"path Standard" is shown above the shop logo ...what does this mean?

Share this post


Link to post
Share on other sites
I installed the package from the beginning. Now it worked, but i get a new error "path Standard" .

 

"path Standard" is shown above the shop logo ...what does this mean?

You need to use the latest version.

 

Jack

Share this post


Link to post
Share on other sites
I used HeaderTags_SEO_V_3.1.5

If you updated from a previous version, then you didn't replace the file causing the problem. Otherwise, you used the wrong version. That text was due to some debug code I used and forgot to remove. But it has not been in the code for the last few versions. If you can't find the fix in the files, you can search this thread using the tool below for the fix since it was posted here.

 

Jack

Share this post


Link to post
Share on other sites
The changes to the header.php file only allow the mouseover text to work. It can be ignored and the rest will run fine. I suspect your problem is that you didn't run fill tags yet.

 

Jack

 

Hi Jack,

 

I filled the tags, but the problem remains. Whould that be because I don't have Manufacturers created on my shop?

I really think this is happening because some tag is not filled, but I cannot find which.

Another point is when run the head tag test I am receiving the warnings "duplicated meta description found" for all my products, but I checked on my database the fields the products_head_title_tag, products_head_desc_tag and products_head_keywords_tag and all of these are unique for each product.

Any idea? In which database field the meta description is stored?

Share this post


Link to post
Share on other sites
Hi Jack,

 

I filled the tags, but the problem remains. Whould that be because I don't have Manufacturers created on my shop?

I really think this is happening because some tag is not filled, but I cannot find which.

Another point is when run the head tag test I am receiving the warnings "duplicated meta description found" for all my products, but I checked on my database the fields the products_head_title_tag, products_head_desc_tag and products_head_keywords_tag and all of these are unique for each product.

Any idea? In which database field the meta description is stored?

No, manufacturers are not required. You can check if the tags are set in admin in the categories and products edit pages. It the Header Tags fields are filled in there, then the problem is on your shop side.

 

Jack

Edited by Jack_mcs

Share this post


Link to post
Share on other sites
No, manufacturers are not required. You can check if the tags are set in admin in the categories and products edit pages. It the Header Tags fields are filled in there, then the problem is on your shop side.

 

Jack

 

Hi Jack,

 

The warning message duplicated meta description tag was solved.

The warning message it was appearing on my site when the user was on a specific category "function.implode invalid arguments /home/httpd/htdocs/plixxcbr/loja/includes/functions/header_tags.php on line 66" was solve as well, because I checked the "Category" box on the Page Control, but this had a side effect. Now the page title of a product appear with the name of the category before it. Is there a way to remove the category name of the product page title keeping the category box checked? or Is there a way of leaving the category box unchecked and prevent the warning message mentioned before?

 

Thanks in advance,

Share this post


Link to post
Share on other sites
Hi Jack,

 

The warning message duplicated meta description tag was solved.

The warning message it was appearing on my site when the user was on a specific category "function.implode invalid arguments /home/httpd/htdocs/plixxcbr/loja/includes/functions/header_tags.php on line 66" was solve as well, because I checked the "Category" box on the Page Control, but this had a side effect. Now the page title of a product appear with the name of the category before it. Is there a way to remove the category name of the product page title keeping the category box checked? or Is there a way of leaving the category box unchecked and prevent the warning message mentioned before?

 

Thanks in advance,

I can't follow the problem but in answer to your question, if you uncheck the category box for product_info.php the category won't show up. If you are getting an error, it is due to something set up incorectly on your site. Trying to adjust the code to make it work for something like that is a mistake.

 

Jack

Share this post


Link to post
Share on other sites

FILE CHANGES:

 

1) ******** NOTE: STS USERS ONLY - Skip to step 1A. *********

******** NOTE: BTS USERS ONLY - Skip to step 1B. *********

Your shop is an STS shop if there is an includes/sts_templates/ directory.

Your shop is a BTS shop if there is a templates directroy in the root directory.

 

For Header Tags to work on a page of your site, that page must have the code

change mentioned below installed. At a minimum, the following files should be

changed:

 

index.php

product_info.php

 

Any other file in the root directory (the same location where your index.php

file is located) that you want Header Tags to work with should also be changed.

For example, if you want your privacy page to have its own title and meta tags,

then you should make this change to the privacy.php file. Only files that

contain <title><?php echo TITLE; ?></title> can be altered. Since the <TITLE>

tag is different in popup_image.php and is not handled by Header Tags SEO,

there is no need to modify that file.

 

In each file you want to edit, make the following modification:

FIND:

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo TITLE; ?></title>

REPLACE with the following then continue with Step 2:

<?php
/*** Begin Header Tags SEO ***/
if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {
 require(DIR_WS_INCLUDES . 'header_tags.php');
} else {
?>
 <title><?php echo TITLE; ?></title>
<?php
}
/*** End Header Tags SEO ***/
?>

 

 

I use STS. so this step one is ignored? I did the change for step1. My header tag is now working. should I have to do it in case i disable STS?

Edited by nudylady

Share this post


Link to post
Share on other sites

I anyone using this contribution with the multistore? I have begun to install it, but the queries with the multistore are so crazy. I just want to know if anyone has done it or if it is even possible.

Share this post


Link to post
Share on other sites
I anyone using this contribution with the multistore? I have begun to install it, but the queries with the multistore are so crazy. I just want to know if anyone has done it or if it is even possible.

This contribution will work in any oscommerce shop so, yes, it is possible. But it won't work as intended in a multi-store shop since there is only one set of tags. Someone asked this question, or something very similar some time ago in this thread. I posted a solution that I thought would work and the op said it did. You may want to find that post to see if it will help.

 

Jack

Share this post


Link to post
Share on other sites

Hello Jack , thanks for this useful ADD-ON

I choice the store language to no english , the "corrent review" text in bottom of the product info page don't appears correctly. and how to modify it

 

JUN

Share this post


Link to post
Share on other sites
Hello Jack , thanks for this useful ADD-ON

I choice the store language to no english , the "corrent review" text in bottom of the product info page don't appears correctly. and how to modify it

 

JUN

I'm not sure I understand the problem but if the product page is not showing correctly in a different language than English, then you may have missed the edit in the product_info.php file for the language file of that language.

 

Jack

Share this post


Link to post
Share on other sites

After installing this contribution the layout of my product page got shift to the right and it looks awful. Here is what it looks like. I had lightbox and ultimate images and a few other contributions installed which made changes to the product.php file prior to this install.

 

Can anyone help?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×