Jump to content
Latest News: (loading..)
Jack_mcs

Header Tags SEO

Recommended Posts

Hi! Here you can see!! It works for me with just 1-2 little bugs.

 

Thank you Jack_mcs for this great contrib.

Hi Kornel76,

 

It woks for me too very well.

I was just asking myself if having this "warning" in my admin was not dangerous (security) or...

 

But same as you ---->>>> MANY THANKS JACK!!!!


osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites

Hi Jack,

 

In order to install this contribution, do I have to have either STS or BTS installed? I have neither, and my site is already pretty modded and customized :blush:

 

Thanks!

Justin

Share this post


Link to post
Share on other sites
Hi Jack,

 

In order to install this contribution, do I have to have either STS or BTS installed? I have neither, and my site is already pretty modded and customized :blush:

 

Thanks!

Justin

No. There are just instructions for sites that do have those installed.

 

Jack

Share this post


Link to post
Share on other sites

Why iam i getting this in my page title HEADER_TAGS_SEPARATOR_DESCRIPTION and this in my keywords area this HEADER_TAGS_SEPARATOR_KEYWORD thanks inf

Edited by ackeith

Share this post


Link to post
Share on other sites
Why iam i getting this in my page title HEADER_TAGS_SEPARATOR_DESCRIPTION and this in my keywords area this HEADER_TAGS_SEPARATOR_KEYWORD thanks inf

The database changes weren't added, at least not all of them. Run the uninstall and install scripts to fix it.

 

Jack

Share this post


Link to post
Share on other sites

I think i found another error on <meta name="Description" content= and <meta name="Keywords" content= the 1st letter dont show up like this nice show as ice

Share this post


Link to post
Share on other sites
Hi!

I have a big problem with the contrib Header Tags SEO V3.0.1

This is what happen when i go to edit a product in admin:

 

Fatal error: Call to undefined function tep_get_products_head_title_tag() in /usr/home/web29892/domains/customfit.eu/public_html/admin/categories.php on line 1025

 

 

and here is the line:

<td class="main"><?php echo tep_draw_textarea_field('products_head_title_tag[' . $languages[$i]['id'] . ']', 'soft', '70', '5', (isset($products_head_title_tag[$languages[$i]['id']]) ? stripslashes($products_head_title_tag[$languages[$i]['id']]) : tep_get_products_head_title_tag($pInfo->products_id, $languages[$i]['id']))); ?></td>

 

 

 

 

please can someone help me

 

regards Tony

 

Hi Tony, I'm having the same problem, please can you tell me how you fixed this? Many thanks

Share this post


Link to post
Share on other sites
Hi Tony, I'm having the same problem, please can you tell me how you fixed this? Many thanks

It means the changes were not made to the admin/includes/functions/general.php file. See the install instructions or use the included file to compare against.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

 

Sorry for the late reply was away a few days!

I have done the changes that you said and am now getting the alt text appearing in internet explorer but not in firefox so nearly there :D

 

The source code in firefox and explorer has the alt text!!!

 

<img src="images/Chefs-Recommended2.png" alt="Relief Chef,Temporary Chef, Relief Chef Northern Ireland - Relief Chef,Temporary Chef, Relief Chef Northern Ireland">

 

Just does not appear with mouse over in Firefox must be something really minor!!

 

PS: I changed this code a bit <img border="0" src="images/store_logo.png" alt="$headertags_logotext"></td>

to

<img src="images/Chefs-Recommended2.png" alt="$headertags_logotext"></td>

but still no luck.

 

John

 

That fix is already in the next version. Here are the needed changes to make it work:

 

In includes/modules/sts_inc/general.php,

 

FIND:

if (!isset($sts->template['headertags'])) $sts->template['headertags']= "<title>" . TITLE ."</title>";

 

ADD BENEATH

$sts->template['headertags_logotext'] = tep_not_null($header_tags_array['logo_text']) ? $header_tags_array['logo_text'] : STORE_NAME;

 

In your template file (like includes/sts_templates/test/sts_template.html),

 

REPLACE

<img border="0" src="images/store_logo.png"></td>

 

WITH

 

<img border="0" src="images/store_logo.png" alt="$headertags_logotext"></td>

 

Please test it and let me know of any problems.

 

Jack

Edited by joli1811

To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites
Hi Jack,

 

Sorry for the late reply was away a few days!

I have done the changes that you said and am now getting the alt text appearing in internet explorer but not in firefox so nearly there :D

 

The source code in firefox and explorer has the alt text!!!

 

<img src="images/Chefs-Recommended2.png" alt="Relief Chef,Temporary Chef, Relief Chef Northern Ireland - Relief Chef,Temporary Chef, Relief Chef Northern Ireland">

 

Just does not appear with mouse over in Firefox must be something really minor!!

 

PS: I changed this code a bit <img border="0" src="images/store_logo.png" alt="$headertags_logotext"></td>

to

<img src="images/Chefs-Recommended2.png" alt="$headertags_logotext"></td>

but still no luck.

 

John

FireFox won't display it unless the title tag is used. So change
<img src="images/Chefs-Recommended2.png" alt="$headertags_logotext"></td>

to this

<img src="images/Chefs-Recommended2.png" alt="$headertags_logotext" title="$headertags_logotext"></td>

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

 

Working perfectly now thanks for a fantasic contribution!!

 

Number one in Google here I come :lol:

 

John

 

 

FireFox won't display it unless the title tag is used. So change
<img src="images/Chefs-Recommended2.png" alt="$headertags_logotext"></td>

to this

<img src="images/Chefs-Recommended2.png" alt="$headertags_logotext" title="$headertags_logotext"></td>

 

Jack


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

When I do the test of Header Tags SEO I have this error:

 

Database/File Mismatch Error: explain

The number of file entries in the database (14) does not match the number in the includes/header_tags.php file (28).

Files not in the database:

info_shopping_cart.php

popup_image.php

redirect.php

shipping.php

cookie_usage.php

download.php

contact_us.php

products_new.php

reviews.php

tell_a_friend.php

advanced_search.php

shopping_cart.php

advanced_search_result.php

rss.php

 

I would to fix this error without uninstall and install the database because i have correct other problem and i have already modify the database, but I don't know anithing to resolve this problem.

Bye

Share this post


Link to post
Share on other sites
When I do the test of Header Tags SEO I have this error:

 

Database/File Mismatch Error: explain

The number of file entries in the database (14) does not match the number in the includes/header_tags.php file (28).

Files not in the database:

info_shopping_cart.php

popup_image.php

redirect.php

shipping.php

cookie_usage.php

download.php

contact_us.php

products_new.php

reviews.php

tell_a_friend.php

advanced_search.php

shopping_cart.php

advanced_search_result.php

rss.php

 

I would to fix this error without uninstall and install the database because i have correct other problem and i have already modify the database, but I don't know anithing to resolve this problem.

Bye

Not all of those pages will be added to the database because they are restricted by code in Header Tags. That's because it doesn't help to have Header Tags code in a popup, ofr example, since the search engines will never see it. Those files are listed in admin/includes/functions/header_tags.php so you can see the ones to remove the Header Tags code from. For the others, try going to Page Control and selecting the Add Missing Pages option. That might fix it.

 

Jack

Share this post


Link to post
Share on other sites

Hello,

 

We run this excellent contrib on our shop www.e-modelisme.com,

 

I have this message when I perform the test :

 

Language ID 4 in default Header Tags table does not exist in the shops languages.

Language ID 9 in default Header Tags table does not exist in the shops languages.

 

Any idea from where this error comes from ?

 

Thank you in advance for your support,

 

Best regards

Yves

Share this post


Link to post
Share on other sites
I have this message when I perform the test :

 

Language ID 4 in default Header Tags table does not exist in the shops languages.

Language ID 9 in default Header Tags table does not exist in the shops languages.

 

Any idea from where this error comes from ?

It means that you have lanugages declared in your admin->Localization->Languages section but the actual files for those languages don't exist in the shop. You should delete the extra languages if you are not going to use them. If you are going to use them, then you should add the language files for them.

 

Jack

Share this post


Link to post
Share on other sites
Thank you for your contribution, which we have a different title's and description for the same pages with different addresses.

 

http://site.com/product_info.php?cPath=42_...products_id=513

and

http://watchcopy.com/product_info.php?manu...products_id=513

 

Tell me please, the problem with duplicate content still remains and we must prohibit such overlap?

The first link is invalid so I can't see the problem.

 

Jack

Share this post


Link to post
Share on other sites
The first link is invalid so I can't see the problem.

 

Jack

 

 

This page addresses conditional site: site.com. To the product can go through the manufacturer or through category. It turns out the same page but with different url addresses, title's and description.

 

Tell me please, the problem with duplicate content still remains and we must prohibit such overlap or if we have different title's and description google see this pages as deferent?

Share this post


Link to post
Share on other sites

If the page won't load, it can't be a duplicate page.

 

Jack

Share this post


Link to post
Share on other sites
If the page won't load, it can't be a duplicate page.

 

Jack

 

Sorry, why page will not load, its load. What do you mean? You want to say, if your module exist, site can't have page, that google find as duplicate content ?

Share this post


Link to post
Share on other sites

I mean that if I click on the first link you provided, it is an invalid link. Try clicking on it yourself to see what I mean.

 

Jack

Share this post


Link to post
Share on other sites

 

:blink:

 

The webpage cannot be found HTTP 404

Most likely causes:

  • There might be a typing error in the address.
  • If you clicked on a link, it may be out of date.

What you can try:

  • Retype the address.
  • Go back to the previous page.
  • Go to and look for the information you want.

More information

This error (HTTP 404 Not Found) means that Internet Explorer was able to connect to the website, but the page you wanted was not found. It's possible that the webpage is temporarily unavailable. Alternatively, the website might have changed or removed the webpage.

 

For more information about HTTP errors, see Help.


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites

Sorry Jack but I need your assistance again. :blush:

 

After all the previous updating and editing from version 3.0.1 to 3.1.4 plus the extra little glitches, I can't fix this problem myself.

 

In Admin Panel I added all the meta tag info for such pages as - categories, manufacturers, and products.

 

In version 3.0.1 I had them all properly displaying on the catalog side.

 

Now no matter how I set things up in Admin Panel > Header Tags SEO I can't get the Description content to showup.

 

Catalog side example:

<head>

<title>:: Hande's Hobbies :: - Revell - Revell 1929 Ford Pickup 3in1</title>

<meta name="Description" content="" />

<meta name="Keywords" content="Revell - Revell, 1929, Ford, Pickup, RMX/85-2085, RMX-85-2085, RMX, 85-2085, 2085" />

 

Admin side example:

Product Title Tag: Revell 1929 Ford Pickup 3in1

Product Description Tag: Build a hardtop, convertible, or roadster style pickup - RMX/85-2085

Product Keywords Tag: Revell, 1929, Ford, Pickup, RMX/85-2085, RMX-85-2085, RMX, 85-2085, 2085

 

I have many times now...

 

  • Uploaded includes/header_tags.php
  • Ran - Add missing pages
  • Ran - Fill only empty tags
  • Restored my database and ran all the updates SQL queries

I am at the beginning stage again, above steps, and have not clicked/checked anything yet.

 

All I want is to have my prefilled page tags display as they did before.

<head>

<title>:: Hande's Hobbies :: - Revell 1929 Ford Pickup 3in1</title>

<meta name="Description" content="Build a hardtop, convertible, or roadster style pickup" />

<meta name="Keywords" content="Revell, 1929, Ford, Pickup, RMX/85-2085, RMX-85-2085, RMX, 85-2085, 2085" />

 

Any thoughts or ideas?

 

Also, this may be really stupid and too late...

But exactly what was wrong with version 3.0.1 which required me to make so many updates?


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites
Not all of those pages will be added to the database because they are restricted by code in Header Tags. That's because it doesn't help to have Header Tags code in a popup, ofr example, since the search engines will never see it. Those files are listed in admin/includes/functions/header_tags.php so you can see the ones to remove the Header Tags code from. For the others, try going to Page Control and selecting the Add Missing Pages option. That might fix it.

 

Jack

 

If I go to Page Control and select the Add Missing Pages option, it don't fix anything and during the test I see the same error.

In admin/includes/functions/header_tags.php I can exclude a file from list or add files on $baseFiles array, in this array there are index.php product_info.php product_reviews.php product_reviews_info.php product_reviews_write.php specials.php. If I try in $baseFiles to add for example info_shopping_cart.php, in test the error remains.

Any ideas?

Bye

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×