Jump to content
Jack_mcs

Header Tags SEO

Recommended Posts

Hi Jack,

 

 

 

I read it but it don't really understand it, I mean the way to do it cause as I told you I am under Windows XP and changing chmods can be done but only on a basic way, not like 777 or 6... (I will be able to change it when it will be on the web with the tool of my provider)

 

Can you explain me an easy way to change it on XP please?

Hmm, do you mean like the instructions where it says ignore for windows or in the test routing where it is marked in red to ignore for windows? The purpose of the permissions is to allow the file to be written to. If you find your pages are not working correctly, make sure the file is not read only.

 

Jack

Share this post


Link to post
Share on other sites
The error message is:

 

1060 - Duplicate column name 'categories_htc_title_tag'

 

ALTER TABLE categories_description ADD categories_htc_title_tag VARCHAR(80) NULL;

Upload and run the headertags_seo_uninstall.php and headertags_seo_install.php files.

 

Jack

Share this post


Link to post
Share on other sites
Hmm, do you mean like the instructions where it says ignore for windows or in the test routing where it is marked in red to ignore for windows? The purpose of the permissions is to allow the file to be written to. If you find your pages are not working correctly, make sure the file is not read only.

 

Jack

 

Hi Jack,

 

Do you mean by "Windows serveur", on windows computer (like XP)?! "NOTE: Disregard if on Windows server."

On Windows, my file header_tags.php is not on Read Only.

 

Anyway, I have a Warning on each categories:

Warning: implode() [function.implode]: Invalid arguments passed in C:\wamp\www\catalog\includes\functions\header_tags.php on line 67

 

Do you know what can I do to take it off?

 

And when i click to select a product, I have my right column under the left one!

 

So you know what I have to do please?

 

Thanks


osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites
Anyway, I have a Warning on each categories:

Warning: implode() [function.implode]: Invalid arguments passed in C:\wamp\www\catalog\includes\functions\header_tags.php on line 67

 

Do you know what can I do to take it off?

 

Read back a page. Jack just answered that problem for me.


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites
Upload and run the headertags_seo_uninstall.php and headertags_seo_install.php files.

 

Jack

 

 

Hi Jack, thanks for the reply. I do not know why but I ran the uninstall which returned successfully then I re-ran the install and it returned as "Database successfully updated for HeaderTags SEO!!! "

 

I only ran the same files as I did yesterday so I do not know why it worked this time. I guess the only thing that was different was that I never uploaded the uninstall files yesterday only the install files, perhaps it was looking for these and hence the error.

 

Thanks anyway, I shall move on to the the parts of the install now.

 

Michael

Share this post


Link to post
Share on other sites
Read back a page. Jack just answered that problem for me.

 

 

Oh... silly! I was focussing so much on my personal issues..., that I forgot the basic things as - reading all posts!!! GOOD LESSON ;)

 

Anyway, this problem is solved!

 

I have still an Error:

 

Erreur Permissions settings for the C:/wamp/www/catalog/includes/header_tags.php file appear to be incorrect. Change to 777. NOTE: Disregard if on Windows server.

 

Let me know if you have an idea!?

 

But I think it is cause I am testing it on my localhost (WAMPSERVER with pc under XP Pro).

 

Thanks

Edited by Eric B

osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites
Hmm, do you mean like the instructions where it says ignore for windows or in the test routing where it is marked in red to ignore for windows? The purpose of the permissions is to allow the file to be written to. If you find your pages are not working correctly, make sure the file is not read only.

 

Jack

 

 

Hi Jack,

 

I have left one problem!

I have still an Error:

 

Erreur Permissions settings for the C:/wamp/www/catalog/includes/header_tags.php file appear to be incorrect. Change to 777. NOTE: Disregard if on Windows server.

 

I have tried a lot of things to be sure the file was not on Read Only but as I said it is not easy to be sure on XP.

 

Do you think it is cause I am on localhost with a PC under XP?

 

Thanks

Edited by Eric B

osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites
I have still an Error:

 

Erreur Permissions settings for the C:/wamp/www/catalog/includes/header_tags.php file appear to be incorrect. Change to 777. NOTE: Disregard if on Windows server.

 

I have tried a lot of things to be sure the file was not on Read Only but as I said it is not easy to be sure on XP.

 

Do you think it is cause I am on localhost with a PC under XP?

 

Thanks

 

Eric,

 

Take a closer look at the error message.

Yes the error is because you are on a localhost with a PC under XP (that makes you a Windows server).

 

Personally I preferred XAMPP when I used to test on my PC (localhost) running XP Pro SP/2. I didn't have any file permission issues.


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites
Eric,

 

Take a closer look at the error message.

Yes the error is because you are on a localhost with a PC under XP (that makes you a Windows server).

 

Personally I preferred XAMPP when I used to test on my PC (localhost) running XP Pro SP/2. I didn't have any file permission issues.

 

 

Thanks mate!

 

I was just confused cause "Windows server" didn't mean for me Windows computer cause actually with Wampserver (APACHE, PHP, SQL) I thought it was like not being on Windows server. My mistake!

 

I will try XAMPP on my next project... SOON!

 

Thanks anyway and now I am going to install Header Tags SEO on the web... Hope it will go fine! ;)

 

PS: Jack, sorry if I didn't get it quickly,...maybe cause of all these new words in english (coding and osCommerce)


osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites

Jim - thanks for helping.

 

PS: Jack, sorry if I didn't get it quickly,...maybe cause of all these new words in english (coding and osCommerce)

No need to aplogize. We all go through it.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack, I have just come across 2 possible problems when adding/changing code to admin/categories during the Install_admin.txt section.

 

The first possible problem is the instruction:

 

FIND (a few lines down - around line 72)

  $sql_data_array = array('categories_name' => tep_db_prepare_input($categories_name_array[$language_id]));

REPLACE with

  /*** Begin Header Tags SEO ***/
  $sql_data_array = array('categories_name' => tep_db_prepare_input($categories_name_array[$language_id]),
	   'categories_htc_title_tag' => (tep_not_null($categories_htc_title_array[$language_id]) ? tep_db_prepare_input($categories_htc_title_array[$language_id]) :  tep_db_prepare_input($categories_name_array[$language_id])),
	   'categories_htc_desc_tag' => (tep_not_null($categories_htc_desc_array[$language_id]) ? tep_db_prepare_input($categories_htc_desc_array[$language_id]) :  tep_db_prepare_input($categories_name_array[$language_id])),
	   'categories_htc_keywords_tag' => (tep_not_null($categories_htc_keywords_array[$language_id]) ? tep_db_prepare_input($categories_htc_keywords_array[$language_id]) :  tep_db_prepare_input($categories_name_array[$language_id])),
	   'categories_htc_description' => tep_db_prepare_input($categories_htc_description_array[$language_id]));
  /*** End Header Tags SEO ***/

 

My problem is that I have previously changed this line during the installation of the Categories Images Box contribution, so my line before your change says:

 

// Start Categories images box
	  $categories_description_front_array = $_POST['categories_description_front'];
	  $sql_data_array = array ('categories_name' => tep_db_prepare_input ($categories_name_array[$language_id] ),
							   'categories_description_front' => tep_db_prepare_input ($categories_description_front_array[$language_id] ) );
// End Categories images box

 

I also have another part of the same file which says:

 

Around line 877, find this code in admin/categories.php

  $categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.categories_image, c.parent_id, c.sort_order, c.date_added, c.last_modified from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "' and cd.categories_name like '%" . tep_db_input($search) . "%' order by c.sort_order, cd.categories_name");
} else {
  $categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.categories_image, c.parent_id, c.sort_order, c.date_added, c.last_modified from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '" . (int)$current_category_id . "' and c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "' order by c.sort_order, cd.categories_name");

  and replace it with

/*** Begin Header Tags SEO ***/
  $categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.categories_image, c.parent_id, c.sort_order, c.date_added, c.last_modified, cd.categories_htc_title_tag, cd.categories_htc_desc_tag, cd.categories_htc_keywords_tag, cd.categories_htc_description from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "' and cd.categories_name like '%" . tep_db_input($search) . "%' order by c.sort_order, cd.categories_name");
} else {
  $categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.categories_image, c.parent_id, c.sort_order, c.date_added, c.last_modified, cd.categories_htc_title_tag, cd.categories_htc_desc_tag, cd.categories_htc_keywords_tag, cd.categories_htc_description from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '" . (int)$current_category_id . "' and c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "' order by c.sort_order, cd.categories_name");
/*** End Header Tags SEO ***/

 

I have also changed this section for the Caegories Images Box contribution to:

 

// Categories images box
  $categories_query = tep_db_query("select c.categories_id, cd.categories_name, cd.categories_description_front, c.categories_image, c.categories_image_front, c.parent_id, c.sort_order, c.date_added, c.last_modified from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "' and cd.categories_name like '%" . tep_db_input($search) . "%' order by c.sort_order, cd.categories_name");
} else {
// Categories images box
  $categories_query = tep_db_query("select c.categories_id, cd.categories_name, cd.categories_description_front, c.categories_image, c.categories_image_front, c.parent_id, c.sort_order, c.date_added, c.last_modified from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '" . (int)$current_category_id . "' and c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "' order by c.sort_order, cd.categories_name");

 

Can you please suggest what I should do as this is now the final part of your installation and I have done all the required changes to the other files.

 

Thanks

 

Michael

Share this post


Link to post
Share on other sites
Hi Jack, I have just come across 2 possible problems when adding/changing code to admin/categories during the Install_admin.txt section.

 

Can you please suggest what I should do as this is now the final part of your installation and I have done all the required changes to the other files.

As with any contribution that is being installed into already changed code, you have to merge the code so the resulting code has both changes. The easiest way to do that is to place the new line of code below the original, align the fields and copy/paste the new ones into the old.

 

Jack

Share this post


Link to post
Share on other sites
Jim - thanks for helping.

Jack

 

No problem, you're welcome Jack.

 

I try whenever I can to help and give back to the community.


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites
Thanks mate!

 

I was just confused cause "Windows server" didn't mean for me Windows computer cause actually with Wampserver (APACHE, PHP, SQL) I thought it was like not being on Windows server. My mistake!

 

I will try XAMPP on my next project... SOON!

 

Thanks anyway and now I am going to install Header Tags SEO on the web... Hope it will go fine! ;)

 

PS: Jack, sorry if I didn't get it quickly,...maybe cause of all these new words in english (coding and osCommerce)

 

You're welcome Eric ;)

 

Can I offer a hint as to how I managed my localhost (PC) and web server files?

 

I kept two folders on my PC; one for editing with XAMPP and another for uploading to my web server.

Once everything worked alright after editing I'd copy those files to my upload folder. Yes I would have to write down which files.

Then it was a simple process just to FTP those new files to my server.

 

Hope that might be of some use?


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites
Jim - thanks for helping.

 

 

No need to aplogize. We all go through it.

 

Jack

 

Hello Jack,

 

I have install all, and your contribution seems working very well - just need to learn a bit more how to use it ;) Thanks for it !

 

Anyway, I am now on the Linux server and I have still an ERROR on the ADMIN>Header Tags SEO>Page Control et on my test (only):

 

Erreur Permissions settings for the C:/wamp/www/catalog/includes/header_tags.php file appear to be incorrect. Change to 777. NOTE: Disregard if on Windows server.

 

I have change the chmod via my host control panel but still the same!

 

I have tried too:

 

and you have addressed the file permissions settings as stated above, you may

have to comment out the function. To do that,

OPEN: admin/includes/functions/header_tags.php

 

Around line 201 you find this code:

 

if (!is_writable($filename))

{

if (!chmod($filename, 0666)) {

echo "Cannot change the mode of file ($filename)";

exit;

}

}

 

Replace that with the following code:

 

if (!is_writable($filename))

{

echo "The file isn't writable";

exit;

/* if (!chmod($filename, 0666)) {

echo "Cannot change the mode of file ($filename)";

exit;

} */

}

 

But still nothing!

 

Do you know what I can do please?

 

Thanks

Edited by Eric B

osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites
You're welcome Eric ;)

 

Can I offer a hint as to how I managed my localhost (PC) and web server files?

 

I kept two folders on my PC; one for editing with XAMPP and another for uploading to my web server.

Once everything worked alright after editing I'd copy those files to my upload folder. Yes I would have to write down which files.

Then it was a simple process just to FTP those new files to my server.

 

Hope that might be of some use?

 

Hi jhande!

 

Thanks for your advices... Very kind of you!

I will try that soon I have finished this last step (see above)

It sounds very easy but I found out that things (with me) are never working the same way as the others...;)

 

Will let you know


osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites
Erreur Permissions settings for the C:/wamp/www/catalog/includes/header_tags.php file appear to be incorrect. Change to 777. NOTE: Disregard if on Windows server.

 

I have change the chmod via my host control panel but still the same!

Check what the permissions are on the images directory and set the ones for the file to match those. If it still fails, ask your host to look at it. Or, see if the file includes/header_tags.php can actually be written to (replace with original and run Add Missing Pages in Page Control). If it can, then set the option to ignore the permissions setting and forget abuut it.

 

Jack

Share this post


Link to post
Share on other sites
Check what the permissions are on the images directory and set the ones for the file to match those. If it still fails, ask your host to look at it. Or, see if the file includes/header_tags.php can actually be written to (replace with original and run Add Missing Pages in Page Control). If it can, then set the option to ignore the permissions setting and forget abuut it.

 

Jack

 

Hi Jack,

 

I have tried all again:

 

  • To set the directory /includes/ to writeble chmod (with all files) via FTP, can't be done, same as the test done first via FTP with header_tags.php.
  • I can write change in the file includes/header_tags.php and recorde them via FTP, cause when I open my file again via FTP it has the change that I had done. It means it is writeble (I suppose?)
  • I have read a lot of things in my host website and there are saying that if I want to change a file in 777, I have to change my all website in 777!!! Sounds a bit extreme for me cause even if I can do it, which files will I have to put back on unwriteble???!

Your contribution seems working good actualy with still the error:

Erreur Permissions settings for the D:/www/my-site.fr/htdocs/catalog/includes/header_tags.php file appear to be incorrect. Change to 777. NOTE: Disregard if on Windows server.

 

It sounds like the best (if I can write on the files with my test) to leave it like that and to set the option to ignore the permissions setting and forget about it like you said.

 

What do you think?

Edited by Eric B

osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites

Not all hosts allow setting permissions from external means. You need to contact them to see what the permissions should be and how to set them. If the file changes, then it is OK.

 

Jack

Share this post


Link to post
Share on other sites
Not all hosts allow setting permissions from external means. You need to contact them to see what the permissions should be and how to set them. If the file changes, then it is OK.

 

Jack

 

Actually Jack they just reply to me:

 

Le CHMOD 777 est possible (vous aurez lecture, ecriture, modification, suppression). Pour cela, il est nécessaire de choisir l'option : Mettre les droits en ecriture sur tout votre site.

Impératif pour SPIP,JOOMLA,OSCOMMERCE...

 

Means in English:

 

Chmod 777 is possible (you will have reading, writing, modification, suppression). For it, you need to choice the option : Put rights in writing on all your website

Imperative for SPIP,JOOMLA,OSCOMMERCE...

 

As I told you, it sounds a bit extreme for me cause even if I can do it, which files will I have to put back on unwriteble to have my website safe?


osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites

There's only one file to change for Header Tags. I can't help you with the others.

 

Jack

Share this post


Link to post
Share on other sites
There's only one file to change for Header Tags. I can't help you with the others.

 

Jack

 

OK that's fine!

 

Can I live it like that if Header Tag works properly???

 

Many Thanks anyway

 

 

PS: which file do I have to change back to unwriteble in Header Tags if I can list all the files that I have to change ???

Edited by Eric B

osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites

Hi,

 

I have the latest Header Tags SEO V 3.1.4 and STS 4.5.8 everything is working perfectly except the logo text (alt text)!

It is working with STS disabled but when STS is enabled it reverts to the default store name alt text??


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites
Hi,

 

I have the latest Header Tags SEO V 3.1.4 and STS 4.5.8 everything is working perfectly except the logo text (alt text)!

It is working with STS disabled but when STS is enabled it reverts to the default store name alt text??

That fix is already in the next version. Here are the needed changes to make it work:

 

In includes/modules/sts_inc/general.php,

 

FIND:

if (!isset($sts->template['headertags'])) $sts->template['headertags']= "<title>" . TITLE ."</title>";

 

ADD BENEATH

$sts->template['headertags_logotext'] = tep_not_null($header_tags_array['logo_text']) ? $header_tags_array['logo_text'] : STORE_NAME;

 

In your template file (like includes/sts_templates/test/sts_template.html),

 

REPLACE

<img border="0" src="images/store_logo.png"></td>

 

WITH

 

<img border="0" src="images/store_logo.png" alt="$headertags_logotext"></td>

 

Please test it and let me know of any problems.

 

Jack

Share this post


Link to post
Share on other sites
OK that's fine!

 

Can I live it like that if Header Tag works properly???

 

Many Thanks anyway

 

 

PS: which file do I have to change back to unwriteble in Header Tags if I can list all the files that I have to change ???

 

Hi! Here you can see!! It works for me with just 1-2 little bugs.

 

Thank you Jack_mcs for this great contrib.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×